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Copyright and Disclaimer
Product specifications are subject to change without notice and do not represent a commitment on the part of 
Avid Technology, Inc.

The software described in this document is furnished under a license agreement. You can obtain a copy of that license by 
visiting Avid's Web site at www.avid.com. The terms of that license are also available in the product in the same directory as 
the software. The software may not be reverse assembled and may be used or copied only in accordance with the terms of the 
license agreement. It is against the law to copy the software on any medium except as specifically allowed in the license 
agreement.

Avid products or portions thereof are protected by one or more of the following United States Patents: 4,746,994; 4,970,663; 
5,045,940; 5,267,351; 5,309,528; 5,355,450; 5,396,594; 5,440,348; 5,452,378; 5,467,288; 5,513,375; 5,528,310; 5,557,423; 
5,577,190; 5,583,496; 5,584,006; 5,627,765; 5,640,601; 5,644,364; 5,654,737; 5,715,018; 5,719,570; 5,724,605; 5,726,717; 
5,729,673; 5,745,637; 5,752,029; 5,754,851; 5,799,150; 5,812,216; 5,828,678; 5,842,014; 5,852,435; 5,999,406; 6,038,573; 
6,061,758; 6,141,007; 6,211,869; 6,532,043; 6,546,190; 6,596,031; 6,636,869; 6,747,705; 6,763,523; 6,766,357; 6,813,622; 
6,847,373; D352,278; D372,478; D373,778; D392,267; D392,268; D392,269; D395,291; D396,853; D398,912. 
Other patents are pending.

This document is protected under copyright law.  An authorized licensee of Avid iNEWS Command may reproduce this 
publication for the licensee’s own use in learning how to use the software. This document may not be reproduced or 
distributed, in whole or in part, for commercial purposes, such as selling copies of this document or providing support or 
educational services to others. This document is supplied as a guide for Avid iNEWS Command. Reasonable care has been 
taken in preparing the information it contains. However, this document may contain omissions, technical inaccuracies, or 
typographical errors. Avid Technology, Inc. does not accept responsibility of any kind for customers’ losses due to the use of 
this document. Product specifications are subject to change without notice.

Copyright © 2007 Avid Technology, Inc. and its licensors. All rights reserved. 

The following disclaimer is required by Sam Leffler and Silicon Graphics, Inc. for the use of their TIFF library:
Copyright © 1988–1997 Sam Leffler 
Copyright © 1991–1997 Silicon Graphics, Inc.

Permission to use, copy, modify, distribute, and sell this software [i.e., the TIFF library] and its documentation for any purpose 
is hereby granted without fee, provided that (i) the above copyright notices and this permission notice appear in all copies of 
the software and related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may not be used in any 
advertising or publicity relating to the software without the specific, prior written permission of Sam Leffler and Silicon 
Graphics.

THE SOFTWARE IS PROVIDED “AS-IS” AND WITHOUT WARRANTY OF ANY KIND, EXPRESS, IMPLIED OR 
OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A 
PARTICULAR PURPOSE.

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT 
OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, 
DATA OR PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF 
LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

The following disclaimer is required by the Independent JPEG Group:
Portions of this software are based on work of the Independent JPEG Group.

The following disclaimer is required by Paradigm Matrix:
Portions of this software licensed from Paradigm Matrix.

The following disclaimer is required by Ray Sauers Associates, Inc.:
“Install-It” is licensed from Ray Sauers Associates, Inc. End-User is prohibited from taking any action to derive a source code 
equivalent of “Install-It,” including by reverse assembly or reverse compilation, Ray Sauers Associates, Inc. shall in no event be 
liable for any damages resulting from reseller’s failure to perform reseller’s obligation; or any damages arising from use or 
operation of reseller’s products or the software; or any other damages, including but not limited to, incidental, direct, indirect, 
special or consequential Damages including lost profits, or damages resulting from loss of use or inability to use reseller’s 
products or the software for any reason including copyright or patent infringement, or lost data, even if Ray Sauers Associates 
has been advised, knew or should have known of the possibility of such damages.

The following disclaimer is required by Videomedia, Inc.:
“Videomedia, Inc. makes no warranties whatsoever, either express or implied, regarding this product, including warranties with 
respect to its merchantability or its fitness for any particular purpose.”

http://www.avid.com
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“This software contains V-LAN ver. 3.0 Command Protocols which communicate with V-LAN ver. 3.0 products developed by 
Videomedia, Inc. and V-LAN ver. 3.0 compatible products developed by third parties under license from Videomedia, Inc. Use 
of this software will allow “frame accurate” editing control of applicable videotape recorder decks, videodisc recorders/players 
and the like.” 

The following disclaimer is required by Altura Software, Inc. for the use of its Mac2Win software and Sample 
Source Code:
©1993–1998 Altura Software, Inc.

Attn. Government User(s). Restricted Rights Legend
U.S. GOVERNMENT RESTRICTED RIGHTS. This Software and its documentation are “commercial computer software” or 
“commercial computer software documentation.” In the event that such Software or documentation is acquired by or on behalf 
of a unit or agency of the U.S. Government, all rights with respect to this Software and documentation are subject to the terms 
of the License Agreement, pursuant to FAR §12.212(a) and/or DFARS §227.7202-1(a), as applicable.

Trademarks
888 I/O, Adrenaline, AirPlay, AirSPACE, AirSPACE HD, AirSpeed, AniMatte, AudioSuite, AudioVision, AutoSync, Avid, 
Avid DNA, Avid DNxcel, Avid DNxHD, AVIDdrive, AVIDdrive Towers, Avid ISIS, Avid Learning Excellerator, Avid Liquid, 
Avid Mojo, AvidNet, AvidNetwork, AVIDstripe, Avid Unity, Avid Unity ISIS, Avid Xpress, AVoption, AVX, CamCutter, 
ChromaCurve, ChromaWheel, DAE, Dazzle, Deko, DekoCast, D-Fi, D-fx, DigiDelivery, Digidesign, Digidesign Audio Engine, 
Digidesign Intelligent Noise Reduction, DigiDrive, Digital Nonlinear Accelerator, DigiTranslator, DINR, DNxchange, do more, 
D-Verb, Equinox, ExpertRender, Face Robot, FieldPak, Film Composer, FilmScribe, FluidMotion, HIIP, HyperSPACE, 
HyperSPACE HDCAM, IllusionFX, Image Independence, iNEWS, iNEWS ControlAir, Command, Instinct, Intraframe, iS9, 
iS18, iS23, iS36, LaunchPad, Lightning, Lo-Fi, Magic Mask, make manage move | media, Marquee, Matador, Maxim, 
MCXpress, Media Browse, Media Composer, MediaDock, MediaDock Shuttle, Media Fusion, Media Illusion, MediaLog, 
Media Reader, Media Recorder, MEDIArray, MediaShare, MediaStream, Meridien, MetaSync, MissionControl, NaturalMatch, 
Nearchive, NetReview, NewsCutter, Nitris, OMF, OMF Interchange, OMM, Open Media Framework, 
Open Media Management, PCTV, Pinnacle MediaSuite, Pinnacle Studio, Pinnacle Systems, ProEncode, Pro Tools, 
QuietDrive, Recti-Fi, RetroLoop, rS9, rS18, Sci-Fi, SecureProductionEnvironment, Show Center, Softimage, 
Sound Designer II, SPACE, SPACEShift, SpectraGraph, SpectraMatte, SteadyGlide, Symphony, TARGA, Thunder, Trilligent, 
UnityRAID, Vari-Fi, Video RAID, Video Slave Driver, VideoSPACE, and Xdeck are either registered trademarks or trademarks 
of Avid Technology, Inc. in the United States and/or other countries.

Adobe and Photoshop are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States 
and/or other countries. Apple and Macintosh are trademarks of Apple Computer, Inc., registered in the U.S. and other 
countries. Windows is either a registered trademark or trademark of Microsoft Corporation in the United States and/or other 
countries. All other trademarks contained herein are the property of their respective owners.

Footage
Arizona Images — KNTV Production — Courtesy of Granite Broadcasting, Inc., 
Editor/Producer Bryan Foote.
Canyonlands — Courtesy of the National Park Service/Department of the Interior.
Tornados + Belle Isle footage — Courtesy of KWTV News 9.
WCAU Fire Story — Courtesy of NBC-10, Philadelphia, PA.
Women in Sports – Paragliding — Courtesy of Legendary Entertainment, Inc.

GOT FOOTAGE?

Editors — Filmmakers — Special Effects Artists — Game Developers — Animators — Educators — Broadcasters — Content 
creators of every genre — Just finished an incredible project and want to share it with the world?

Send us your reels and we may use your footage in our show reel or demo!*

For a copy of our release and Avid’s mailing address, go to www.avid.com/footage.

*Note: Avid cannot guarantee the use of materials submitted.

Avid iNEWS Command v1.0 User’s Guide • 0130-07791-01 Rev. A • March 2007

http://www.avid.com/footage
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Using This Guide

Congratulations on your purchase of your Avid iNEWS Command system.

Avid iNEWS Command offers a considerable amount of functionality for the state-of-the-art 
newsroom, including newsroom system integration and playout control. With Command, 
newsroom personnel can easily create and manage playlists.

This publication provides information on how to use the Command system.

n The documentation describes the standard features of a basic system configuration. 
Therefore, your system might contain certain features and hardware that are not covered in 
the documentation.

Who Should Use This Guide

This guide is written for journalists, producers, directors, writers, and various technical 
personnel responsible for using the Command system in a broadcast newsroom. This guide 
is intended for all users, from beginning to advanced.

It is strongly recommended that system users have prior experience in or classroom 
knowledge of Windows-based operating systems.

About This Guide

This guide leads you through even the most complex procedures with task-oriented 
instructions, illustrated for a more realistic presentation of the actual icons and images you 
encounter. The information provides basic user procedures, while adding a complete 
explanation of all the tools and techniques required to create, apply, and adjust various 
settings, including useful tips, shortcuts, and custom options.

The Contents lists all topics included in the book. They are presented with the following 
overall structure:

• The Introduction helps you get oriented with beginning concepts and general workflow 
and provides valuable pointers to keep in the back of your mind as you proceed.
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• The main body of the guide follows the natural flow of your work, with clear and 
comprehensive step-by-step procedures.

• Finally, a detailed Index helps you quickly locate specific topics.

This guide provides instruction for your system in the following areas:

• An overview of system architecture and workflow

• The Command Workstation and iNEWS Workstation

• Various procedures and uses for iNEWS Command

Use this guide for help in using your system after you have installed all components 
according to requirements and specifications. Before installing any equipment, the site must 
already have a configured network.

Symbols and Conventions

Avid documentation uses the following symbols and conventions:

Symbol or Convention Meaning or Action

n A note provides important related information, reminders, 
recommendations, and strong suggestions.

c A caution means that a specific action you take could cause harm to 
your computer or cause you to lose data.

w A warning describes an action that could cause you physical harm. 
Follow the guidelines in this document or on the unit itself when 
handling electrical equipment.

> This symbol indicates menu commands (and subcommands) in the 
order you select them. For example, File > Import means to open the 
File menu and then select the Import command.

t This symbol indicates a single-step procedure. Multiple arrows in a 
list indicate that you perform one of the actions listed.

Italic font Italic font is used to emphasize certain words and to indicate variables.

Courier Bold font Courier Bold font identifies text that you type.

Ctrl+key or mouse action Press and hold the first key while you press the last key or perform the 
mouse action. For example, Ctrl+drag or Ctrl+S. This also applies to 
Alt and Shift keys.
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If You Need Help
If you are having trouble using the Avid iNEWS Command system:

1. Retry the action, carefully following the instructions given for that task in this guide. It 
is especially important to check each step of your workflow.

2. Check for the latest information in one of two locations:

- If release notes are available, they ship with your application.

- If ReadMe files are available, they are supplied in your Avid application folder.

n Release notes and ReadMe files are also available on the Avid Knowledge Base.

3. Check any printed documentation that came with your Avid application or your 
hardware for maintenance or hardware-related issues.

4. Visit the online Knowledge Base at www.avid.com/onlinesupport. Online services are 
available 24 hours per day, 7 days per week. Search this online Knowledge Base to find 
answers, to view error messages, to access troubleshooting tips, to download updates, 
and to read/join online message-board discussions.

5. For Technical Support, call 800-800-AVID (800-800-2843).

For Broadcast On-Air Sites and Call Letter Stations, call
800-NEWSDNG (800-639-7364).

Related Documentation

The following documents provide more information about Command:

• Avid Avid iNEWS Command Installation and Administration Guide

• Avid iNEWS Command ReadMe files (located on the installation CD)

The Online Library that ships with most Avid editing applications includes a Master 
Glossary of all specialized terminology used in the documentation for Avid products.

n For the latest product information, see the Avid Knowledge Base:
www.avid.com/support

How to Order Documentation

To order additional copies of any Avid documentation from within the United States, call 
Avid Sales at 800-949-AVID (800-949-2843). If you are placing an order from outside the 
United States, contact your local Avid representative.

http://www.avid.com/onlinesupport
http://www.avid.com/support
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Avid Educational Services

For information on courses/schedules, training centers, certifications, courseware, and 
books, visit www.avid.com/training or call Avid Sales at 800-949-AVID (800-949-2843).

http://www.avid.com/training


Chapter 1

Introduction to iNEWS Command

Avid iNEWS Command is a device automation system that integrates with any iNEWS or 
MOS-enabled newsroom computer system (NRCS) and provides broadcasters precise 
control over a range of playout devices, including video servers, still stores, and character 
generators in a broadcast news environment. Backup services and mirrored playout make 
this system reliable while the user interface allows you to control multiple production 
devices. Avid iNEWS Command works with Avid Interplay Framework applications and 
services to insure you always have the best system performance.

This chapter contains the following main sections:

• Overview

- Architecture and Workflow

- Features

• Starting the Client Software

• The User Interface

• Support Dialog Box
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Overview

The basic iNEWS Command system is comprised of iNEWS Command Servers, 
workstations that run the client software, and devices, such as Avid AirSpeed video servers, 
Thunder production servers and Deko graphics system. The system is designed to be an 
extension of your current Avid system. It allows you to receive playlists from Avid iNEWS 
(or a MOS-based newsroom computer system) while controlling your video and graphics 
devices, or even create standalone playlists using drag-and-drop functionality from an 
inventory of media items. The iNEWS Command system supports industry standard 
protocols that make it compatible with many other products.

For newscast control your iNEWS Command system provides automated playlists, tracks 
script changes, and automates control of production and playback devices including video 
servers, and character generators. It integrates with the iNEWS rundown—or any other 
MOS-enabled newsroom computer system—allowing a producer to change a show while it 
is on air, and reflecting those changes in their iNEWS Command system. MOS commands 
are provided so that journalists can use MOS plug-ins within the newsroom computer 
system script. Production playout devices, including Avid Deko and Avid Thunder on-air 
graphics solutions and AirSpeed video servers, are triggered based on the events in the 
rundown.

News graphic and text templates for news elements can include logos and station IDs, 
lower-third captions or superimposed graphics, and full-screen backgrounds with text. 
Journalists, using iNEWS newsroom computer system, fill in the templates and insert them 
into their stories in a variety of ways. For instance, machine control commands can be 
entered using Deko Select or Thunder Select plug-ins. They can be entered manually or by 
using a macro. They may also include clips and stills in their script by entering the ID of the 
graphic in the story as a production cue. At air time an iNEWS Command operator triggers 
the graphics playlist, which is synchronized with the iNEWS rundown.

Architecture and Workflow

Avid iNEWS Command is scalable and can adapt to work in traditional newsroom-based 
playlist creation to production-centric workflows where running orders are created inside the 
iNEWS Command playback application. All of the components can run on a single 
computer, or they can be spread out across multiple computers with redundant services 
configured to take control if the primary services should become unavailable.
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An example of a basic Command system architecture is shown in the following illustration:

In the most common news workflow, playlists are created using the iNEWS newsroom 
computer system and the video and graphic assets are referenced in stories using their IDs or 
by dragging and dropping them from an Active-X plugin, such as Deko Select. 

Playlists can be saved to use later, standalone playlists can be created, and multiple playlists 
can be embedded in a single running order. You can set a playlist to playback at a specified 
time, or you can set groups of assets within a playlist to play in follow-on mode.
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A basic workflow is shown in the following illustration.

Features

The Avid iNEWS Command system provides the features described in the following table.

Feature Description

Playlist Functionality You can load a playlist from the newsroom computer system or create the 
playlist manually within Avid iNEWS Command. You can also embed 
within other playlists. This provides the flexibility to control event playout 
locally, at the desktop, or from a rundown. It also allows seamless 
transitions between shows or segments produced by separate editorial teams.

Manual and Automated 
Triggering

Items can be played back manually by the operator, triggered via GPI, linked 
with other clips to block play, or—as in the case of time of day 
playlists—automatically played based on the time of day. This provides total 
integration with the facility, its systems, processes, and staff.

Redundant Failover Mirrored playback allows a single Play command to initiate playback on two 
channels simultaneously for seamless failover. All Command services are 
redundant.

Advanced Playback Feature You can cue items as needed if and when playlists change, and provide 
simultaneous playback while video files are still being transferred, 
saving time.
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Starting the Client Software

Avid iNEWS Command client software requires no password to log in and is easy to start.

To start iNEWS Command at a workstation:

1. Do one of the following:

t Double click the iNEWS Command icon on the desktop.

t Click the Start button and select Programs > Avid > Avid iNEWS Command.

The iNEWS Command window opens as shown in the following illustration:

Frame Accuracy Avid iNEWS Command provides frame accurate video playout for follow-
on items assigned to the same channel.

Flexible Device Configuration Actual device channels can be configured into multiple virtual possibilities 
through channel groups.

Flexible Integration You can configure the Avid iNEWS Command system to control any 
combination of Avid Thunder, Avid AirSpeed, and Avid Deko systems that 
are operating in an Avid iNEWS, ENPS, or other MOS environment. 

User Interface The intuitive user interface provides visual tools, including clocks that show 
time elapsed and time remaining, channel assignments for easy 
identification of transmission paths, and color-coded status indicators that 
illustrate the inventory of assets based on availability and playability on all 
devices. This improves operation, reduces training time, and ensures 
complete synchronization of devices with the playlist

Status Updates The Command user interface reflects playability status of inventory assets; 
display of playout and channel group lock status; and status-based colors 
and fonts for stories and items at a glance. These status updates speed up 
decision-making saving time, while maintaining accuracy.

Feature (Continued) Description (Continued)
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The User Interface

The Avid iNEWS Command window is the graphical user interface that contains panels, a 
menu bar, a status bar, and a workspace area.

Panels

Panels are components that appear in the application and provide information in various 
ways.The iNEWS Command window contains panels that you can dock, undock, move, 
resize, or even hide from view. Each panel is easily identified by the name appearing in its 
title bar.

For more information about the panels, including the Inventory Explorer, used in iNEWS 
Command, see “Panels” on page 31.

Menu Bar

The menu bar for iNEWS Command contains the following:

• File

• Edit

Panels

Menu bar

WorkspacePlaylist Viewer Inventory

Status bar
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• View

• Playlist

• Item

• Tools

• Help

Each menu, its options and descriptions are described in the following tables:

Menu Submenu Menu Option Shortcut Keys Description

File New Playlist Ctrl+Shift+N Opens the Create New Playlist dialog box.

Story Ctrl+N Opens a Create New Story dialog box.

File Import Playlist Imports a playlist to Command.

Export Playlist Exports a playlist from Command.

Exit Closes the Command program.

Edit Cut Ctrl+X Cut selection.

Copy Ctrl+C Copy selection.

Paste Ctrl+V Paste selection.

Delete Delete selection.

View Playlist Explorer Ctrl+Shift+E Displays or closes the Playlist Explorer.

Inventory Ctrl+Shift+I Displays or closes the Inventory.

Clock Displays or closes the Clock.

Media Viewer Ctrl+Shift+M Displays or closes the Media Viewer.

Alerts Ctrl+Shift+A Displays or closes the Alerts.

Playlist View Next Ctrl+Tab Displays next playlist

Previous Ctrl+Shift+Tab Displays previous playlist

Set Focus Ctrl+F Sets the keyboard focus to the active view.

Close Ctrl+W Closes the current playlist.

Close All Ctrl+Shift+W Closes all playlists.

Playlist Select Next item Ctrl+Down Select next item in current playlist.
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Previous Item Ctrl+Up Select previous item in current playlist.

Next Row Alt+Down Select next item in current playlist.

Previous Row Alt+Up Select previous item in current playlist.

Item In 
Following Story

Ctrl+Page Down Select next item after story.

Playlist Properties

Playlist Edit Edit Selection Ctrl+E Edit current selection in playlist.

Edit Channel Ctrl+- (hyphen) Sets focus to current playlist item’s 
Channel column so the user can manually 
assign a channel.

Edit Trigger Ctrl+* (asterisk) Sets focus to current playlist item’s Trigger 
column so the user can select manual or 
follow-on playout. For more information, 
see “Playout Media from Command 
Workstation” on page 97.

Cut Cut selection.

Copy Copy selection.

Paste Paste selection.

Delete Delete selection.

Playlist Insert New Story Ctrl+N Insert new ptory.

New Break Insert new break.

Playlist Channel Assign Ctrl+R Assign channel.

Playlist Playout Cue . (period) Cue media in a playlist.

Play Enter Play media in a playlist.

Pause + (plus) Pause media playing in a playlist.

Stop 0 (zero) Stops media from playing.

Media Play Ctrl+Space Play media.

Go To Mark In Alt+Q Go to the marked In point.

Go To Mark Out Alt+W Go to marked Out point.

Menu Submenu Menu Option Shortcut Keys Description (Continued)
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Support Dialog Box

The Support dialog box is provided for Command users to log information about any issues 
encountered that might require contacting Avid Customer Support. 

To log support information:

1. Select Help > Support.

2. Enter a description of the issue in the Support dialog box. For instance, the following 
example shows a sentence regarding a GPI device:

Set Mark In Alt+I Mark the In point.

Set Mark Out Alt+0 Mark the Out point.

Forward One Frame Alt+. Move forward one frame.

Forward One 
Second

Ctrl+. Move forward one second.

Forward ten 
Seconds

Ctrl+Alt+. Move forward ten seconds.

Backward One 
Frame

Alt+, Move backward one frame.

Backward One 
Second

Ctrl+, Move backward one second.

Backward Ten 
Seconds

Ctrl+Alt+, Move backward ten seconds.

Restart Alt+6 Restart media.

Tools Options Opens the Options dialog box. 

System Settings Opens the System Settings dialog box. 
These options apply to the workstation only 
and are not system-wide settings.

Help About Display information about iNEWS 
Command.

Contents Displays help information for users.

Support Opens the Support dialog box.

Menu Submenu Menu Option Shortcut Keys Description (Continued)
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3. Click Save.

4. Select the name and location where you want the zipped file to be saved. 

5. Click OK.

The system saves your comments inside a zipped file that also contains other vital 
information, such as system settings and software versions, which enable support personnel 
to troubleshoot the issue. This file can then be e-mailed to Avid Technical Support. For more 
information, see “If You Need Help” on page 11.



Chapter 2

Services

The services for iNEWS Command enable it to interface with newsroom computer systems 
as well as providing for playlist control. Some of the services can be defined as Main 
services—those responsible for communicating with newsroom computer systems and for 
playlist control. Other services are known as Device services—those responsible for 
controlling other devices, such as video servers, still stores, and character generators in a 
broadcast news environment.

This chapter contains the following main sections:

• Main Services

• Device Services

• Redundancy/Failover

• Viewing Status of Services

• Starting and Stopping Services
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Main Services

The main services are vital components that enable interfacing with a newsroom system, as 
well as playlist control. 

The two services that pertain to newsroom computer system interfacing are:

• Avid iNEWS Communication Service—An iNEWS Command system uses this 
service as the communication portal to load and unload iNEWS rundowns from an 
iNEWS workstation. The service receives playlist messages from the iNEWS monitor 
server, distributes them to the appropriate Command components, and reports item 
status and inventory messages back to iNEWS. A single iNEWS Command system can 
have multiple iNEWS communication services for redundancy.

• Avid MOS Communication Service—An iNEWS Command system uses this service 
to load and unload rundowns from a MOS-compliant newsroom system, such as ENPS. 
The service receives MOS playlist messages from the newsroom computer system, 
distributes them to the appropriate Command components, and reports item status and 
inventory messages back to the newsroom computer system.

The services related to playout control of playlists are:

• Avid Playlist Controller—The playlist controller drives playout of the media on locked 
channel groups from the playlist it controls. When one or more channel groups are 
locked, a playlist controller is allocated by the Playlist Manager. A single iNEWS 
Command system can have multiple playlist controllers. One playlist controller is 
necessary for each concurrent on-air playlist. Separate controllers are not needed to 
control embedded playlists.

• Avid Playlist Manager—This service assigns a playlist controller (and its backup, if 
any) to a playlist when the first channel group is locked. It also manages the locks on 
other channel groups of the playlist. Playlists that have locked channel groups are 
prevented from being deleted. An iNEWS Command system can only have one primary 
Playlist Manager, but may have others as backups.

• Avid Playlist Store—This service is the data store or respository for all loaded 
(newsroom) playlists and standalone playlists. It communicates playlist changes to other 
Command components.

The services related to inventory are:

• Avid Inventory Manager—This service maintains an inventory of media metadata for 
all physical devices connected to any channel group in an iNEWS Command system. 
This inventory is sent to the Inventory Manager via the individual device services. An 
iNEWS Command system can only have one primary Inventory Manager, but might 
have backups.
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n While an iNEWS Command system can have only one primary service of each Playlist Store, 
Playlist Manager, and Inventory Manager, multiple instances of each service can be 
installed and used as backups.

Device Services

The Device services are those services responsible for controlling other devices, such as 
video servers, still stores, and character generators in a broadcast news environment.

• Avid AirSpeed Device Service—This service provides control of a single AirSpeed 
high resolution video server. One is required for each AirSpeed. It runs on the iNEWS 
Command servers, not on the device like other device services.

• Avid Deko Device Service—This service provides control of a single Deko device. One 
is required for each Deko device. It runs on the device.

• Avid Thunder Device Service—This service provides control of a single Thunder 
device. One is required for each Thunder device. It runs on the device.

• Avid GPI Service—This service interfaces to a GPI input card on the server.

• Avid Maney Panel Service—This service interfaces to a Maney panel.

Redundancy/Failover

Avid iNEWS Command operates on a primary/backup basis. There can be only one primary 
service, but there can be several backup services. It is best to dedicate a computer to be a 
Command Server. Avid does not recommend running the Command services on a 
workstation, Deko, or Thunder. 

When a primary service goes down, Command conducts an election, and changes the 
backup service to primary. The new primary service will remain primary until it goes down. 
When the old primary service comes back up, it becomes the backup service. If the primary 
Command Server were to go down, all of the services on the backup server would become 
primary.

Command determines primary and backup based on the length of time the service has been 
running. The server that has been running longer is the primary. If you were to lose network 
connectivity to the primary Command Server, the services do not actually go down, and so 
their duration remains longer than the backup. After the network connection is restored, 
those services become primary again.
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n If you have an on-air failover on the primary Command Server due to a loss of network 
connectivity, you must stop the services on the primary server. Otherwise, those services will 
once again become primary when the connection is restored, which will interrupt on-air 
playability. After the connection is restored, and at a non-crucial time, you should start 
those services again.

Non-redundant services

There are some services that are not redundant:

• Lookup Service — This Command service acts independently. If a second one is 
running, it is doing the same work; they basically work as two primary services. In a 
failover scenario, the second lookup service is already working, and services would 
continue seamlessly.

• iNEWS Communication Service— This Command service is server specific, meaning 
that services on different computers act independently. In a failover scenario, the 
Command playlist will become disconnected, users can continue playout functions. To 
get an updated playlist, the user can reload the iNEWS rundown to the second 
Command Server and continue.

• Deko & Thunder Device Services— These Command services must run on the Deko 
and Thunder respectively, and you cannot install a second service on a device.

• Service Starter Service, Machine Monitor Service, Time Synchronization— These Avid 
Interplay Framework services are computer specific, so redundancy does not apply.
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Viewing Status of Services

Avid Command uses Avid Interplay Framework as its structure for discovering and 
communicating with services.

To start Interplay Workgroup Properties:

1. Click the Start button and select > All Programs > Avid > Interplay Framework > Avid 
Interplay Workgroup Properties. 

The Avid Interplay Workgroup Properties window opens.

When you start the Interplay Workgroup Properties application, the Services tab appears by 
default displaying the name of the workgroup, to which this computer belongs, in the 
Workgroup text box. Also shown, in the Status text box, is the status of all Avid services 
running on the local computer.

The Interplay Workgroup Properties application uses colored icons—in combination with 
text—on the Services tab to show the status (started and/or enabled) of all Avid services. A 
user can click the Advanced button to see more information about individual services. The 
icons displayed provide fast, easy identification of the current status of an Avid service.
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For more information on viewing Avid services using the Interplay Workgroup Properties 
application, see the Avid Interplay Framework User’s Guide.

Starting and Stopping Services

The Services tab allows you to edit the workgroup to which the computer belongs, view the 
status of all the Avid services running on the local computer, or start, stop, and restart the 
local Avid workgroup services.

The Advance button on the Services tab opens the Avid Interplay Services dialog box. This 
dialog box allows you to stop, start, enable, or disable individual or multiple Avid services 
running on the local computer.

To stop, start, enable, or disable Avid services:

1. From the Services tab in the Avid Interplay Workgroup Properties window, click the 
Advanced button.

The Avid Interplay Services dialog box opens.

Status Icon Status Icon Description

When all of the enabled Avid components are running on the local machine a green 
circle with a check mark in the center is shown next to the Status text box and the 
sentence—All enabled services are running—is displayed.

When some of the enabled Avid components are running on the local machine a 
caution symbol (yellow triangle with an exclamation mark in the center) is shown 
next to the Status text box and the sentence—Some services are enabled 
but not running—is displayed.

When none of the enabled Avid components are running on the local machine a red 
square is shown next to the Status text box and the sentence—No services are 
running—is displayed.
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2. Select a row on which to perform the stop, start, enable, or disable action.

Multiple rows can be selected.The Action buttons are enabled with the Start button 
changing to Restart if all of the services are running.

For more information on starting and stopping services using the Interplay Workgroup 
Properties application see the Avid Interplay Framework User’s Guide.
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Chapter 3

Panels

The iNEWS Command interface is made up of panels, which provide information in various 
ways.

This chapter contains the following main sections:

• Working with Panels

• Playlist Explorer

• Inventory

• Clock

• Alerts

• Media Viewer
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Working with Panels

The iNEWS Command window contains numerous panels that a user can dock, undock, 
move, resize, or even hide from view in the main window. Each panel is easily identified by 
its title bar that bears its name.

The available panels are:

• Playlist Explorer (shown)

• Inventory

• Clock

• Media Viewer

• Alerts

To hide a panel:

t Click the X button on the title bar of the panel you want to hide.

To view a hidden panel:

t Select View > Tools, and then the name of the panel from the submenu.

To dock or undock a panel, do one of the following:

t Click the Restore button located on the panel’s title bar, next to the X button.

t Click on the panel’s title bar and drag it to and from its docked location. 

To resize a panel:

1. Position your mouse pointer on the edge of a panel. The pointer will change to a resize 
indicator.

2. Click and drag to the new size.

Title bar Close button

Restore button
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Playlist Explorer

The Playlist Explorer shows a list of:

• All newsroom playlists that have been loaded to iNEWS Command from an iNEWS 
newsroom computer system.

• All MOS playlists that have been marked ready-to-air from a MOS-enabled newsroom 
computer system, such as ENPS.

• All standalone playlists.

When the green check mark appears, iNEWS Command has received all items and/or stories 
in the rundown. Double-clicking one of the playlists will open it with its stories, media, 
channels, and so forth in preparation of locking channel groups and taking a show to air. 
When a lightbulb appears, the playlist is on air. 

n The green check mark does not apply to standalone playlists created at a Command 
Workstation or newsroom playlists that have been disconnected from the rundown and are 
therefore considered standalone playlists.

The Playlist Explorer can be configured to open a playlist automatically when it’s loaded 
directly from iNEWS or when it’s marked ready-to-air from a MOS-enabled newsroom 
computer system.

Newsroom 
Playlists

Disconnected Newsroom Playlist
Standalone Playlist

Time of Day (Standalone) Playlist
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To configure Playlist Explorer to automatically open loaded playlists:

1. Select Tools > Options. The Options dialog box opens.

2. In Category, select Playlist Explorer.

3. Select Auto-open playlist.

4. Click OK.

Tabs

Whether the same playlist can be opened onto multiple tabs in the Playlist Viewer is a 
configurable setting.

Changing this setting does not affect existing tabs already opened in the current session.
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To turn on or off the multi-tab option for playlists:

1. Select Tools > Options. The Options dialog box opens.

2. In Category, select Playlist Explorer.

3. Do one of the following:

t Select One tab per playlist if you want any playlist opened from the Playlist 
Explorer to appear on only one tab. If its already open, its tab will appear on top of 
other tabs. Avid recommends using this setting.

t Deselect One tab per playlist if you want a playlist to appear on a new tab each time 
it’s opened from the Playlist Explorer.

4. Click OK.

n For more information on the Auto-open playlist option, see “Playlist Explorer” on page 33.
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Inventory

The Inventory panel shows the inventory (media) for a selected channel group in a table or 
spreadsheet-style format. You can see the media’s availability, clip ID, name (slug), 
duration, and the time when it was last modified. For more information about channel 
groups, see “Working with Channel Groups” on page 54.

To view inventory from a different Channel Group:

t Click the down arrow (indicated in the above graphic), and select a different Channel 
Group from the list.

The user can select any column header to sort the table by that column. The user can also 
rearrange the order of columns.

To sort inventory:

t Select the column by which you want to sort, such as Slug.

To rearrange column order:

t Click on a column header and drag it to a new position.

Down Arrow - Select this 
button to choose a different 
channel group.

Resize bar - Select to adjust 
division of list and detail sections 
of the Inventory panel.

Inventory list available 
through the selected 
channel group.

Details on selected media 
in the Inventory list.
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The Inventory panel provides graphical indicators to show status of availability. 

When an item appears unavailable on some, you can view the specific devices by clicking 
the plus (+) to the left of Availability in the Details section of the Inventory panel.

Command users can drag media directly from the Inventory panel to the Playlist Viewer and 
drop it into an open, locked standalone playlist with the same channel group assigned to it.

Clock

The Clock panel displays the current time based on the Command Workstation’s time. It is 
not associated with the clocks featured in the Playlist Viewer.

The Clock can be set to a 12- or 24-hour format. The font, background, and foreground 
colors are also configurable.

Inventory Status Detailed Status

Available on all Available on specific 
device

Unavailable on some Unavailable on 
specific device
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To configure the clock:

1. Select Tools > Options. The Options dialog box opens.

2. In Category, select Clock.

3. Set the clock’s text color and background color.

4. Set the clock to either a 12- or 24-hour format.

5. Click the Change button to set the clock’s font.

6. A sample of your settings is provided as a preview. When done, click OK.

Alerts

The Alerts window provides a list of recent alerts. The alerts contains these properties: 

• Title (mandatory)

• Text (optional-not shown in the list)

• Alert type



Alerts

39

The types of alerts include: 

n The succeeded alert with its check mark icon will only appear as a followup to previously 
reported warnings and critical alerts.

Each alert will appear along with a timestamp for when the alert was issued.

If the alert’s title extends beyond the size of the panel, resize the panel or mouse over the 
alert to view the entire title in a tooltip. A user can also select any alert and view additional 
details as well as clear alerts from the list.

To view details:

t Select an alert.

To clear alerts:

t Right-click and select Clear Alerts.

Critical

Warning

Information

Succeeded
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Media Viewer

The Media Viewer provides Browse controls within the Command user interface that you 
can use to play, stop, and mark in and out points of video on devices, such as an Avid 
AirSpeed video server. 

n A browse channel must be configured in the channel group to browse video, using an 
external video monitor.

The Browse controls are:

The Play button changes to a Stop button when media is playing.

The clock on the bottom left of the Media Viewer displays the timecode of current position 
indicated on the position bar. The clock on the right provides the duration.

n The duration between marked in and out points is shown on the item in the playlist.

Go To In Go To Out

Set 
Mark In

Set 
Mark Out

Set 
Mark In

Set 
Mark Out

Position 
Indicator

Timecode Duration

Play/Stop



Chapter 4

Playlist Viewer

The iNEWS Command interface provides an area known as the Playlist Viewer, with which 
users can view and manage playlists for on-air playout.

This chapter contains the following main sections:

• Types of Playlists

• Overview of Playlist Viewer

- Toolbars

- Customizing the Playlist Viewer

• Locking and Unlocking Playlists

• Working with Channel Groups

• Working with Standalone Playlists

• Working with Embedded Playlists

• Using Time of Day Playlists



 4 Playlist Viewer

42

Types of Playlists

There are different types of playlists. For instance, a playlist created at a Command 
Workstation is considered a standalone playlist. It can be locked and managed from any 
Command Workstation on the Command system.

A playlist created through a newsroom computer system and uploaded to the Command 
system is called a newsroom playlist. When the newsroom rundown is uploaded to 
Command, the resulting playlist can be viewed at the Command Workstation, but the 
newsroom system retains the lock on the playlist.

n Although the newsroom system retains the playlist lock, a user at a Command Workstation 
can still control playout functionality by obtaining the locks on channel groups associated 
with the newsroom playlist. Channel group locks for playout are not the same as playlist 
locks, which prevent altering the structure of the playlist itself.

A user at a Command Workstation can obtain the playlist lock from a newsroom system, in 
which case the newsroom playlist becomes a standalone playlist. For more information, see 
“Locking and Unlocking Playlists” on page 53.
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When a playlist is inserted into another one, the one inserted is called an embedded playlist. 
The one containing the embedded playlist is known as the container playlist. A standalone 
playlist can contain a newsroom playlist or another standalone playlist as its embedded 
playlist. A newsroom playlist can contain a standalone playlist or another newsroom 
playlist.

Overview of Playlist Viewer

Among the many capabilities featured in the Playlist Viewer, a user can:

• View existing playlists—standalone, time-of-day, or newsroom playlists

• Create standalone playlists

• Lock channel groups

• Control a playlist for broadcast

• Embed a playlist into standalone playlists

When you double-click on a playlist in the Playlist Explorer, iNEWS Command will open it 
on a tab to display all the stories with attached media, including character generator graphics 
(CGs), if any. 

The window can also have different playlists open simultaneously. All are accessible 
through tabs located at the top of the Playlist Viewer.

n The workspace cannot be split to view multiple playlists simultaneously; only one tab can be 
viewed at a time.

The appearance and some behavior of the playlist is customizable. For more information, 
see “Customizing the Playlist Viewer” on page 47.
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Toolbars

Below each tab is the Playout toolbar containing two clocks and several buttons for playout 
control. With the toolbar, a user at the Command workstation can play, pause, or stop events.

Cursor

Playout Toolbar

Playlist Toolbar

Left Clock
Control Buttons

Right Clock

Cue Pause 
Play Stop
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Control buttons allow users to control playout of events on locked devices associated with 
the loaded playlist. For more information about the clocks on the Playout toolbar, see 
“Clocks” on page 51. 

A user can choose whether to display the Playout toolbar.

To hide the Playout toolbar:

1. Select Tools > Options. The Options dialog box will appear.

2. In Category, expand the Playlist Viewer and select Playout Toolbar.

Below the Playout toolbar is the Playlist toolbar, which enables users to lock, unlock and add 
channel groups to playlists. It also contains a button used to lock playlists and disconnect 
playlists from rundowns.
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n The buttons that appear on the Playlist toolbar will vary depending on what channel groups, 
if any, are available, whether the playlist is a time of day playlist or standalone playlist, and 
whether its locked.

Channel Group Buttons

Channel Group buttons represent a channel group that is associated with the loaded playlist 
and are used to individually lock channel groups for playout control and unlock them 
afterward. Use the Add/Lock Channel Group button to simultaneously lock or unlock all of 
a playlist’s channel groups.

When playlists are loaded to Command from a newsroom computer system, the Channel 
Group button for the appropriate channel group associated with that playlist will 
automatically appear in the Playlist toolbar. If multiple channel groups are configured for the 
playlist, then more than one button will appear. For standalone playlists created at the 
Command workstation, a channel group must be added to the playlist, using the Add/Lock 
Channel Group button. 

If a user drags an item from the Inventory panel into a standalone playlist, Command will 
prompt the user to automatically add the channel group associated with that item. For more 
information, see “Working with Channel Groups” on page 54.

Add/Lock Channel 
Group Button

Playlist 
Lock 
button

Channel Group Buttons 

Channel Group Button 
(Shows an unlocked 

channel group)

Channel Group Button 
(Shows a channel group locked 
by this playlist and workstation)

Add/Lock Channel 
Group Button

Provides a menu of options, 
shown here, to choose from.

Channel Group Button 
(Shows a channel group 
locked by another playlist 

or workstation)



Overview of Playlist Viewer

47

Customizing the Playlist Viewer

When first installed, Avid iNEWS Command uses default colors and fonts to display 
information about playlist events; however users can customize how that data is displayed on 
the Playlist Viewer tabs. For instance, a user might want an unplayable event to appear in red 
so that it easily stands out on the screen.

To customize the appearance and behavior of the Playlist Viewer:

1. Select Tools > Options. The Options dialog box opens.

2. In Category, expand Playlist Viewer and select Appearance.

3. You can alter the font, as well as the color of text and backgrounds. As you click on each 
entry in the Playlist section, your settings for that entry will appear in the Sample 
section at the bottom of the dialog box. You can select and modify multiple entries 
simultaneously.

4. (Optional) Click Apply to save the settings without closing the dialog box, so further 
modification can continue.

n The Restore Defaults button is used to restore settings to the system’s original default 
settings.
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5. Select Behavior.

6. Select whether to allow use of arrow keys to move the cursor up or down a playlist to the 
nearest media or next adjacent row.

7. Select how many rows should remain displayed above the cursor. This will lock the 
cursor in place—once it reaches the row specified—so that the playlist scrolls up or 
down instead of the cursor moving up or down.

8. Select whether the autoscroll lock applies to the row containing the last-played item, 
instead of cursor position. 

9. Click OK to save the settings.

Cursor

The cursor, as shown on page 44, can appear as a rectangle around a row in the Playlist 
Viewer or as a solid bar in all or specified fields.
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To change the cursor’s appearance:

1. Select Tools > Options. The Options dialog box opens.

2. In Category, expand Playlist Viewer and select Cursor.

3. Set the color of the cursor accordingly. Active represents the color of the cursor when 
the focus is on the Playlist Viewer. Inactive represents the color of the cursor when the 
focus is on a different panel in the iNEWS Command window or on another software 
application.

4. (Optional) Click Apply to save changes without closing the Options dialog box.

5. Select Columns.
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6. Set the Background options per column accordingly. Options include:

Cursor — The cursor’s color will also apply to the field’s background. This makes the 
cursor in that column appear to be a solid bar.

Status — The cursor’s color only applies as an outline on the field. This allows the 
background in that column to reflect status colors, such as playability or transport status.

For instance, if the cursor’s active color is set to black, then the Head frame and Trigger 
columns are set to Cursor, while the rest set to Status, the cursor—located on the video 
item between story lines 04 and 05—would appear as shown:

7. Click OK to save settings and close the Options dialog box.
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Clocks

The clocks on either side of the toolbar can be hidden or customized to provide certain 
timing functions, which include:

• Time elapsed in clip

• Time remaining in clip

• Time remaining in show

Each clock’s background color, as well as the font and color of text, can be altered from the 
defaults, which are: black, 24 pt., bold MS Shell Dlg font on a yellow background. While the 
font setting is shared by both clocks, the colors can be set independently of one another.

To change clock functions:

1. Select Tools > Options. The Options dialog box will appear.

2. In Category, expand Playlist Viewer and select Playout Toolbar.

3. Set each clock’s behavior, text color, and background color.

4. To change the font used for both clocks, click the Change button.

5. When finished modifying the look and behavior of the clocks, click OK.
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Columns

A Command user can rearrange, rename, and hide any column or columns in a playlist.

To rearrange columns:

t Click on the column header and drag it right or left to a new location.

To show, hide, or rename a column:

1. Select Tools > Options. The Options dialog box opens.

2. In Category, expand Playlist Viewer and select Columns.

3. Select or deselect the check box for each column you want to display or hide. 

4. Under Header, double-click the text field corresponding to the column you want to 
rename and type in the new name.

5. Click OK.

n The Story Field option enables the user to display—in the playlist—certain metadata 
obtained from the newsroom computer system related to a story. Options include: Page 
number, Story slug, and Story ID. This data will appear only on a story line in the playlist in 
the specified column.
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The Background column setting pertains to the appearance of the column fields when the 
cursor is on them in the Playlist Viewer. For more information, see “Cursor” on page 48.

Locking and Unlocking Playlists

When a playlist is uploaded from a newsroom computer system, iNEWS Command sends 
that system updates any time changes occur to the playlist at the Command workstation and 
receives updates from the newsroom computer system when changes are made to the 
rundown. The playlist is considered “locked” by the newsroom system. However, should 
that connection be broken, the playlist is considered to be “disconnected” and the Playout 
toolbar will appear red to warn the user at the Command workstation, as shown:

When the Playout toolbar is red, playout on the locked devices can continue from the 
Command workstation that locked the devices; however, any changes to the playlist in 
Command will not be sent to the rundown in the newsroom computer system. Also the 
playlist will not display any modifications that might be made to the rundown. At that point, 
it is equivalent to a stand-alone playlist.

c If a disconnect occurs, reloading the playlist from the newsroom computer system will 
restore the connection and provide the most up-to-date playlist in the Playlist Explorer 
or, if configured to do so, on a new tab in the Playlist Viewer. The channel groups 
(devices) locked to the original (disconnected) playlist must be manually unlocked, and 
then relocked from the reloaded playlist on the new tab.

On the far right side of the Playlist toolbar is the Playlist Lock button. Its appearance varies 
depending on the status of the playlist.
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Working with Channel Groups

A channel group is a group of one or more device channels that might or might not be across 
multiple devices. 

n Avid recommends that each channel group pertains to the same “type” of device. For 
instance, a channel group called AS is a grouping of channels from two or more AirSpeed 
video servers, while a different channel group named CG is a grouping of channels on a 
Deko character generator.

For instance, a station has two AirSpeed video servers, each with two channels that are 
numbered 2 and 3. Let’s call the first AirSpeed AS1 and the second one AS2. With channel 
groups on Command, the station’s system administrator can set up numerous different 
channel groups and call them anything, such as:

This icon indicates that the playlist is locked by a newsroom rundown. Clicking it will 
prompt the user with an Override Lock dialog box. The user must type in the system 
administrator password to override the lock and disconnect the playlist from the newsroom 
rundown. When it is disconnected, the icon will change to indicate the playlist is now 
locked by the user at the Command Workstation.

This icon indicates that the playlist is locked by the user at the Command Workstation. 
When locked, the user can insert, move, or delete items in the playlist. Clicking it will 
unlock the playlist at the workstation. When it is unlocked, the icon will change to indicate 
the playlist is unlocked.

This icon indicates that the playlist is unlocked. Clicking it will lock the playlist at the 
Command Workstation.

This icon indicates that the playlist is locked by a user at a different Command Workstation. 
When locked by another user, only that user can insert, move, or delete items in the playlist. 
Clicking the icon will override the other user’s lock. The user must type in the system 
administrator password to override the lock.

This icon indicates an unusual lock condition, such as when a newsroom system still has the 
lock on a newsroom playlist, but connection to the newsroom computer system is down.

Channel Group Channel Names Actual Device Channels Purpose

AS-Noon A

B

C

AS1 - channel 2

AS1 - channel 3

AS2 - channel 2

Playout

Playout

Browse
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In the Playlist Viewer, users can add new or existing channel groups to standalone playlists, 
as well as lock or unlock channel groups. For more information on assigning channels, see 
“Changing Channels” on page 81.

To add an existing channel group to a standalone playlist:

1. With the playlist open, click the Add/Lock Channel Group button (shown on page 46). 

2. Select Add Existing.

3. Choose one or more of the channel groups from the list. To select multiple channel 
groups, hold the Ctrl key down and click the groups.

4. Click OK. A button or buttons for selected channel groups appears on the Playlist bar.

AS-5PM A

B

C

D

AS1 - channel 2

AS1 - channel 3

AS2 - channel 2

AS2 - channel 3

Playout

Playout

Playout

Playout

AS-10PM A

C

B

D

AS1 - channel 2

AS2 - channel 2

AS1 - channel 3

AS2 - channel 3

Playout

Mirrored

Playout

Mirrored

Channel Group Channel Names Actual Device Channels Purpose
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There is also another way to add an existing channel group to a standalone playlist. When 
dragging and dropping media from the Inventory into a standalone playlist, if the media 
belongs to a channel group not already added to the playlist, an Add Channel Group dialog 
will appear (shown below) asking the user to confirm the addition of the channel group to 
the playlist. Clicking OK adds the channel group.

To add a new channel group:

1. With the playlist open, click the Add/Lock Channel Group button.

2. Select Add New.

3. When prompted for the administrator password, type it in and click OK. 
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The Add New Channel Group to Playlist dialog box opens.

4. Enter the name of the new channel group and any notes you want.

5. Click Add to add a channel to the group.

6. In the Channel Details section, select the Channel Type, Primary, Mirror, and Preview 
options for that channel.

7. Repeat steps 5 and 6 as needed. You can use the Up and Down buttons to rearrange the 
order of channels in the group.

8. Click OK.

To remove a channel group from a playlist:

1. Remove any media in that group from the playlist.

2. Right-click the button for that channel group on the Playlist toolbar.

3. Select Remove from the menu.
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Subtopics

Channel Group Locks

Assigning Channels

Channel Group Locks

Channel group locks are not the same as playlist locks. A channel group lock pertains to 
control of playout on channels in a group. A playlist lock pertains to ability to modify the 
structure of the playlist itself. Users can lock one or more channel groups for a playlist from 
a Command Workstation.

To lock or unlock a specific channel group:

t With the playlist open, click the Channel Group button you want to lock. The icon on 
the button will change to indicate whether it is locked or unlocked. For more 
information, see “Channel Group Buttons” on page 46.

n The keystroke combination for locking an individual channel group is: Ctrl+1 for the first 
channel group, Ctrl+2 for the second, and so forth. To unlock, use the Alt key instead of Ctrl.

To lock or unlock all channel groups for a playlist:

1. With the playlist open, click the Add/Lock Channel Group button (shown on page 46). 

2. Do one of the following:

t Select Lock All to lock all channel groups.

t Select Unlock All to unlock all channel groups.

n The keystroke combination for locking all channel groups is Ctrl+L. Pressing Alt+L will 
unlock all of them.

When a channel group is locked, the status of those locks appears on the status bar at the 
bottom right corner of the window. In the following example, a closeup of the locked status 
for both channels A and B of a channel group named AB is shown.

Assigning Channels

After a channel group is added to a playlist, channels can be assigned to or edited for 
specific items in the playlist.
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For some sites, channels are automatically assigned when the playlist’s channel group is 
locked. Whether this occurs depends on system settings in Avid iNEWS Command. Contact 
your system administrator for more information.

There are other methods for assigning channels at a workstation as well.

To assign channels in Command:

t Do one of the following:

a. Click the field in the Channel column of the playlist opened in the Playlist Viewer 
and type the first character of the channel name, such as A, B, or C.

b. Right-click and select Channel > Assign.

c. Type Ctrl+R.

n Steps b and c will result in the assignment of alternating channels throughout the playlist. 
For instance, if there are two channels, A and B, then Command will automatically assign A 
to the first item, B to the second, A to the third, and so forth. Auto-assignment only applies to 
channels that are locked.

A user can select multiple items in a playlist and assign all of them to a single channel. 

To assign a channel to multiple items:

1. Click the first item to select it.

2. Do one of the following:

t Hold the Shift key down to select all items between your first selection and your 
last.

t Hold the Control key down to select multiple non-sequential items. As shown in the 
following graphic, items for pages 06, 08, and 10 are selected, while 07, 09, and 11 
are not.
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3. Do one of the following:

t Press Ctrl+– (hyphen) to set the focus on the Channel field, then type the first letter 
of the channel you want. (This will change all selected items.)

t With the Shift or Ctrl key still held down, as chosen in the previous step, double-
click in the last item’s cell located in the Channel column. This will give you a drop-
down arrow. Then, click the arrow and select the channel from the list, as shown in 
the previous graphic.

4. Click anywhere else in the playlist. It’s at this point that the channel is reassigned to the 
selected items. In the following graphic, the user clicked on row 11 as indicated by the 
black outline, and the channel assigned to items 06, 08, and 10 is now A.
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Working with Standalone Playlists

A standalone playlist is one that is not directly associated with (or disconnected from) a 
newsroom rundown. Users can create standalone playlists at the Command Workstation.

To create a standalone playlist:

1. Select File > New > Playlist (or use the shortcut keystroke combination, Ctrl+Shift+N).

2. When the Create New Playlist dialog box opens, enter a name for the new playlist.

3. Click OK.

4. Assign a channel group or groups to the new standalone playlist by clicking the 
Add/Lock Channel Group button (shown on page 46).  You can add either a new 
channel group or an existing one. For more information see “Working with Channel 
Groups” on page 54.

5. Drag and drop items (existing machine control events) from the Inventory Explorer into 
your playlist.

6. Repeat step 5 as needed.

After a standalone playlist is created, the items in that list can be modified as needed, such as 
rearranging the order or deleting items.

To edit a standalone playlist:

1. Open the playlist.

2. Do any of the following:

t Add new items to the playlist by dragging them from the Inventory Explorer.

n If the channel group associated with the item is not already assigned to the playlist, then a 
dialog box will appear to confirm the assignment of the channel group to the playlist. Once 
confirmed, the channels are assigned to the playlist and the item added.

t Delete items by selecting the item and pressing the Delete key.

t Rearrange the order by dragging and dropping items into new locations within the 
playlist.

To delete a standalone playlist:

1. Select the playlist in the Playlist Explorer.

2. Press the Delete key.

c To delete a playlist, it must not be on air.
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Working with Embedded Playlists

Avid iNEWS Command supports embedding playlists, which enables users to insert one 
playlist into another one. For instance, a newsroom producer is setting up a newscast in 
which there will be a segment on sports. The ability to embed playlists enables a user to 
work on one rundown without requiring access to another—the person setting up the sports 
segment no longer needs full producer-level access to the newscast rundown. Instead, two 
rundowns can be created: one for the overall newscast and another for the sports segment. 
The newsroom producer can embed the sports rundown inside the news rundown.

Another example of this workflow is a newscast that contains segments produced at different 
locations. The primary rundown could contain one or more embedded rundowns from 
remote sites.

A user can embed playlists from the Command Workstation or from the iNEWS 
Workstation. 

n When using Command Workstation, the playlist can be embedded only into a standalone 
playlist. When using the iNEWS Workstation, the playlist can be embedded only into a 
newsroom rundown, which appears as a newsroom playlist in Command once the monitor 
server is loaded.

To embed a playlist using Command:

1. Open (or create) the container playlist in the Playlist Viewer.

2. Select a playlist you want to embed from the Playlist Explorer.

3. Drag it to the location in container (standalone) playlist. It must be dropped before a 
story, not an item; otherwise, the system will display a warning to that effect.
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When the playlist is successfully embedded, no icon appears, but the color of the top row is 
different, as is a matching bar that continues down the left side to indicate all items included 
as part of the embedded playlist. 

In the previous example, the embedded playlist is called Special and contains four 
items—the first of which is called China Trade and is playing, and the last of which is called 
Closing Bell. The cursor is on the last item in the embedded playlist, as indicated by the 
row’s black rectangular outline. The I-WORLDCUP story is not part of the embedded 
playlist, as indicated by the absence of the bar on the left edge.

To embed a playlist using the Avid iNEWS newsroom computer system:

1. Open the rundown in which you want to embed another rundown.

2. Insert a new story where you want the other rundown embedded.

3. In the Title field (usually named Slug), type EMBED: followed by the pathname of the 
rundown that you want to embed. For instance: EMBED: SHOWS.6PM.RUNDOWN
The EMBED: token is configurable, so check with your system administrator.

n Do not add machine control events to the story.

An icon (shown at left) appears in the container playlist as the system is embedding the 
playlist.

If a problem occurs, another icon (shown at left) might appear to indicate that the system was 
unable to embed the playlist, resulting in an error. Mousing over the row referencing the 
embedded playlist will provide a tooltip with more deatils about the error. An example of an 
error is: This embedded playlist was deleted.
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Editing Embedded Playlists

Embedded playlists are not copies of the original playlist. So, changes made to the actual 
playlist will appear when viewing the embedded playlist. Like stories in an iNEWS 
rundown, embedded playlists can be moved or floated.

Whether editing can be done is determined by the type of playlist regardless of whether that 
playlist is a container for an embedded playlist or the embedded one itself. Users can edit a 
standalone playlist (or a disconnected newsroom playlist) from the Command Workstation. 
Newroom playlists locked by the newsroom computer system must be edited from a 
workstation running the newsroom computer system software.

If the embedded playlist is a standalone playlist, to edit it, you must open the actual playlist 
in the Playlist Viewer at a Command Workstation. Do not try to edit it from its embedded 
location.

Using Time of Day Playlists

In Avid iNEWS Command, playlists can be set to air at specific times. These playlists are 
called time of day playlists.

To set a playlist to air at a certain time of day:

1. Open (or create) a playlist in the Playlist Viewer.

2. Select Playlist > Edit > Properties.

The Playlist Properties dialog box opens.

3. Select the check box and set the time you want Command to automatically begin 
playing the playlist.
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n A minimum thirty second lead time is required when setting up time of day playlists.

4. Click OK.

n You can click on the Time of Day button to open the Playlist Properties dialog at any time, 
such as if you want to change the time setting or remove the scheduled time altogether.

A new button (shown at left) will appear on the Playlist toolbar along with 
the time the playlist is set to begin.
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Chapter 5

iNEWS Integration

The iNEWS Command system is a device automation system for on-air operations, which 
can be integrated into the iNEWS newsroom computer system, or into another MOS-enabled 
newsroom computer system. The interface between Avid iNEWS Command and the Avid 
iNEWS newsroom computer system provides for rundown updates between the products. 
Command can also operate in a standalone environment if the Avid iNEWS connection is 
lost.

This chapter contains the following main sections:

• Overview

• Inserting Machine Control Events into Stories

• Loading Rundowns to Command

• Changing Channels
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Overview

This section provides an overview of the Avid iNEWS workspace and instructions on 
different methods for inserting machine control events into scripts in iNEWS for the iNEWS 
Command system.

The Avid iNEWS workspace consists of three main panels: 

• Directory panel—the portion of the workspace that displays the directory or file 
structure of the Avid iNEWS database.

• Queue panel—the portion of the workspace that displays a list of stories in a queue. 
Stories are added, deleted, moved, and ordered through this panel.

• Story panel—the portion of the workspace that displays the story text; however, the 
panel may be split, as shown in the figure below, into the following three subpanels: 

- Instruction panel—for production cues and machine control instructions. It appears 
on the bottom left side o the Story panel.

- Story Form panel—containing fields for data typically appearing in the queue 
(rundown). It appears across the top of the Story panel.

- Story Text panel—containing the script of a story and production cue markers also 
known as grommets that coincide with production cues and machine control 
instructions in the Instruction panel. It appears on the bottom right side of the Story 
panel.

n The Story Text panel is the only subpanel that always appears; the other two may be 
removed from view by users at iNEWS Workstations.
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Inserting Machine Control Events into Stories

Users cannot add machine control events to a newsroom playlist from a Command 
Workstation. This does not apply to standalone playlists, which could be a disconnected 
newsroom playlist. For more on how to edit standalone playlists, see “Working with 
Standalone Playlists” on page 61.

For newsroom playlists, the iNEWS Workstation provides a scripting function that places 
unformatted stories into a split-screen script format with production cues, in the left column 
(also referred to as the Instruction panel) and story text in the right column (also referred to 
as the Story Text panel).
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To insert a machine control event into an iNEWS story: 

1. From an iNEWS Workstation, open the script into the Story panel. 

2. Click in the Story panel at the location where the production cue is to be placed.

3. Type Alt+Insert. 

An Instruction panel appears to the left of the Story Text panel.The Instruction panel has a 
Production Cue text box where the cursor is placed so that a production cue can be entered.

Production cues might include the following: Take VO, On Camera, Take SOT, Take Live, 
and so forth. When interfacing with iNEWS Command, production cues in the iNEWS 
newsroom computer system might include commands for devices, such as character 
generators (CGs) and high-resolution video servers. 

n By default, Avid iNEWS generally refers to all video playback devices—for instance, Avid 
AirSpeed video servers—as “video” type devices.

A production cue containing a command for a device is known as a machine control event. 
Each command is preceded by an asterisk (*) and should be written in a special format. 

The format for machine control events, following the asterisk, starts with a code for the type 
of device the instruction is for, such as CG for a character generator or Deko for an Avid 
Deko graphics system. For Command, this “code name for the device” is the name of the 
channel group.

A production cue marker (also known as a grommet) is inserted in the script text at the 
cursor position.
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After the command, the format specifies a particular item or template. If additional 
comments or information, such as replaceable text, is required it would follow on 
succeeding lines in the same Production Cue text box.

For example, in iNEWS, a machine control event for a 2-line character generator graphic 
might look like the one shown below.

In the above example, the Story panel is split to show both the Instruction and Story Text 
panels, but not the Story Form panel. The Take VO production cue is information for the 
director; it is not a machine control event. The machine control event for the character 
generator is in the second Production Cue text box. 

n Machine control event formats will vary based on styles set up by your system administrator. 
Check with your system administrator for a list of styles used at your location.

Using Plug-Ins

Deko Select is a plug-in for a newsroom computer system’s interface that allows a user, such 
as a reporter, to drag and drop graphic templates directly into the story, as well as alter 
replaceable text or graphics in the selected template.

Any Deko graphic can be used as a template for Deko Select if the following conditions are 
met:

• Appropriate layers are designated as replaceable.

• Replaceable layers are properly identified, ordered, and named.

• Default playout channel is designated.

For more information, see the Avid Deko Select Installation and User’s Guide.

Production Cue 
Text Box

Machine Control Event
for a Character Generator

Instruction Panel

Story Text Panel
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To access Deko Select at an iNEWS Workstation:

1. Log in to iNEWS. 

2. Select Tools > Options > Deko Select.

The plug-in will open in a new workspace within the iNEWS window. It might appear at 
the top (as shown) or bottom, depending on the user’s preferences.

n Another plug-in available from Avid is Thunder Select. If both the Deko Select and Thunder 
Select plug-ins are installed, the name that will appear in the Tools > Options menu will be 
Avid Graphics Select. When chosen, both plug-ins will open in the workspace, with each 
plug-in available via tabs (shown) in the upper left corner of the workspace.

Preview Graphic 
area

Browser Area 
(showing thumbnails)

Plug-in Tabs 
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Inserting Deko Select Events into iNEWS Stories

Deko Select events can be inserted directly into the body of a news story or inserted into the 
story form as a primary machine control event.

n Dropping events into the story form is available only if the Deko is the primary device, 
which is usually not the case when a video device is also used, such as an AirSpeed video 
server.

To insert a Deko event into the story form:

1. From an iNEWS Workstation, open the story in which you want to insert the Deko 
Select event.

2. With the Deko Select workspace open in the iNEWS window, select a Deko Select event 
from the Preview Graphic area and drag it to the Story Form panel in the iNEWS 
workspace. See “Overview” on page 68 for more information on the Story Form panel.

n You do not have to drop the event onto a specific field in the form.

To insert a Deko event into an iNEWS story using Deko Select:

1. From an iNEWS Workstation, open the story in which you want to insert the Deko 
event.

2. (Optional) Position cursor in the story where you want the production cue marker to be, 
and insert it by typing Alt+Insert.

3. With the Deko Select workspace open in the iNEWS window, double-click on a 
template’s file name or thumbnail. See “Using Plug-Ins” on page 71 for more 
information on accessing the Deko Select plug-in. A preview of the template will appear 
on the bottom right of the workspace.

n When multiple plug-ins are installed, such as Deko Select and Thunder Select, the 
workspace is known as the Avid Graphics Select workspace; the individual plug-ins are then 
accessible by clicking on tabs available in the upper left corner of the workspace.
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4. Above the preview, type information into the replaceable fields as needed. If default text 
was included in the template, it will appear automatically, but can be replaced.

5. (Optional) The selected template displays its default channel assignment, but a different 
channel can be selected from the Channel list.

6. (Optional) To view a larger preview of the currently selected template with the edited 
fields, do one of the following:

t Double-click on the preview graphic.

t Click the Full Preview button.

7. (Optional) Use the Spell Check button to check spelling of text in the replaceable fields.

n If In-line spelling is enabled, Deko Select will underline spelling errors as the user types in 
the fields. The underline will not appear in the graphic output.

8. (Optional) Enter In and Out or Duration settings for a “tagged” event.

d. An example of a tagged event is when a character generated graphic is set to 
automatically go on-air at a specific time and for a specific duration based on the 
first video event of the story. Timecode information specified in the plug-in is 
forwarded to the Command Workstation and appears in the playlist so that the 
operator knows when this automatic event will occur. 

n Administrators at sites that want to take such events to air manually can turn off the 
automatic functionality by modifying a system setting in Avid iNEWS Command. For more 
information, see the Avid iNEWS Command Installation and Configuration Guide.

Browser Area
(showing file names)

Preview Graphic 
area

Replaceable Fields

Channel List

Plug-in Tabs 
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9. When finished editing, drag and drop the preview graphic into the story. A production 
cue marker is inserted in the story’s text and the Deko Select information will appear in 
the Instruction panel on the left side of the Story panel. The font will be blue to indicate 
a machine control event as opposed to a production cue.

When the story is completed and saved, any Deko Select events become part of the story. 
When a rundown’s monitor server is loaded, the playlist, including any Deko Select events 
will be published to iNEWS Command.

To edit the replaceable fields of a Deko Select event in an iNEWS story:

1. Open the story and do one of the following:

t Double-click the Production Cue text box containing the machine control event, 
displayed in the Instruction panel.

t With the cursor in the Production Cue text box, press Enter.

When the Deko Select plug-in opens, an image of the template will appear as a preview 
graphic, above which the current contents of the replaceable fields will be displayed.

2. (Optional) Change the background by pressing Enter and selecting another one.

3. Edit the replaceable fields as needed.

4. (Optional) Edit the In, Out, and Duration time.

5. Set the channel, if needed.

6. Click Apply to save without exiting the plug-in or OK to save and exit the plug-in. The 
edited graphic will replace its previous version in the story.
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Loading Rundowns to Command

This section provides some basic user information about the Avid iNEWS monitor server, 
which is used to load iNEWS rundowns to Command. The monitor server is not an actual 
part of Avid iNEWS Command software, but is a utility program on the iNEWS Server. 

For iNEWS Command, it is used to scan stories in the iNEWS rundown, check that show’s 
event requests for errors, and search for machine control events to build event lists (playlists) 
for the production devices. It continues monitoring the rundown for changes to machine 
control events and sends them to the iNEWS Command system until the show goes off the 
air.

Monitor servers must be set up on iNEWS Servers to ensure proper integration between 
Avid iNEWS Command and an iNEWS newsroom computer system.

The monitor server is turned on when a user at an iNEWS Workstation turns it on. When on, 
monitor server checks its assigned rundown for machine control events, and builds playlists. 
It continues to monitor the rundown for changes and performs as much error checking as it 
can without communicating with any broadcast equipment, including Command. The 
monitor server loads data to the Command system when a user instructs it to do so from an 
iNEWS Workstation. 

n It is recommended that producers or production assistants turn the monitor server on as 
show time approaches so it can check the rundown queue throughout much of the show’s 
development. Monitor server scans through the scripts and builds Event Lists for CG and 
video if these events are present in the scripts. Monitor server will also create a Composite 
list if configured to do so. Instructing the monitor server to load data should be done later, 
such as just before taking the show to air.

Loading and Unloading Playlists from iNEWS

The monitor server is used to monitor playlists before broadcasting, load newsroom playlists 
to Command and unload them.

To load a playlist from Avid iNEWS to Command, using the monitor server:

1. Log in to an iNEWS Workstation.

2. Open the appropriate rundown in the Queue panel.

3. Select Tools > Monitor.

The Monitor dialog box opens. 
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The system displays the current status for and name of all devices available for the 
opened rundown. 

The duration (or automatic quit time, if configured) appears at the bottom of the dialog 
box. For more information, see “Duration” on page 78.

4. Select a monitor mode based on the following options:

If you select Load, specify the device or server to load from the Devices list, or select 
the All Devices checkbox to load all devices associated with the rundown queue. To 
select up to three devices from the list, without selecting all, press the Ctrl key while you 
click on each item. If you select a server, the data will be loaded to all devices associated 
with that server. 

On — Turns the monitor server on and creates an event list for each device in the 
rundown queue.

Load — Instructs the monitor server to load event lists to devices you select. See 
“Monitor LOAD” on page 78 for more information.

Unload — Disconnects from the selected device or server without turning the monitor 
server off. (If all devices/servers are unloaded, the monitor server returns to the 
On mode. See “Monitor Off and Unload” on page 79 for more information.

Off — Turns the monitor server off, overriding the Duration setting. See “Monitor Off 
and Unload” on page 79 for more information.
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Item Status After Load to Command

Duration

Monitor server uses a large amount of system resources. If monitor servers are left on after 
the end of their shows, they could degrade the efficiency of the Avid iNEWS system.

To protect system resources, a quit time or a duration can be set by the system administrator. 
A quit time will automatically switch off the monitor server at the specified time, ensuring 
the integrity of the system. A duration will automatically switch off the monitor server after 
the allotted time is achieved. However, for the best results, Avid recommends that monitor 
servers be manually turned off at the end of each show.

If configured, the quit time or duration time appears at the bottom of the Monitor dialog box. 
The monitor server’s quit time or duration is determined by configuration settings in the 
SYSTEM.MAP story of iNEWS. For more information, see the iNEWS documentation for 
system administration and configuration.

Monitor LOAD

Before Command is able to view the list of machine control events (known as items in 
Command) in an iNEWS rundown and control those events for playback, they must be 
loaded from the rundown in iNEWS. The procedure for using monitor server to load events 
from a newsroom rundown to iNEWS Command is on page 76.



Loading Rundowns to Command

79

Events are loaded from Avid iNEWS to Command and then communicated to appropriate 
devices. After Command receives the entire list, it will notify the user that it has received the 
list by sending a message to the iNEWS Workstation. Confirmation messages might look 
like the following:

LIST RECEIVED “SHOW.5P.Rundown”

SHOW.5P.RUNDOWN: Download Complete

If the monitor server is not on, loading events will automatically switch the monitor server 
on.

Monitor Off and Unload

Monitor Off is used after the show is over. Switching the monitor server off stops the system 
from scanning scripts for updates and sending those updates to Command.

If a user at a Command Workstation disconnects the show, the broadcast can continue with 
playout controlled from that workstation instead of the newsroom computer system; 
however, no updates to the rundown from Avid iNEWS will be received in Command and no 
changes to the disconnected playlist are sent to iNEWS. Turning the monitor server off, back 
on, and loading it will create a new newsroom playlist in the Playlist Explorer, which will 
bear the same name as the original “disconnected” playlist.

Monitor Unload clears the playlist, if Command has not disconnected it from the show, but 
continues to scan the scripts and update the event lists with changes.

Event List Queue

After the monitor server is on for a few seconds, event lists are built. In iNEWS, the Event 
List queues—each one representing a different channel group—are generally built in the 
same folder as the rundown, such as:

Rundown: SHOW.6PM.RUNDOWN

CG Event List: SHOW.6PM.CG

Video Event List: SHOW.6PM.VIDEO

Any script or rundown changes will be picked up automatically by the monitor server, which 
will then make the appropriate changes in the event lists. All changes must be made in the 
rundown queue, not in the event build queues. 
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The following figure shows a CG event queue for a rundown, listing the CGs for that show.

Composite Queue

It is possible to configure Avid iNEWS to also create a Composite List queue. This is a 
single queue that contains a list of all machine control events for all channel groups (for all 
devices associated with a rundown) that are required during the show. This list represents 
what will be seen on the newsroom playlist at a Command Workstation. The Composite List 
Queue is usually found in the same folder as the rundown, such as:

Composite List Queue: SHOW.6PM.COMPOSITE
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Item Status After Load to Command

Playability is shown in Command through a variety of icons. For a quick reference on what 
each icon means, see “Icon and Button Quick Reference” on page 105.

Changing Channels

Channel assignment can be accomplished from either a Command Workstation or an 
iNEWS Workstation. In iNEWS, depending on how a rundown is configured, there are 
multiple locations where channel assignment is displayed and therefore a variety of ways to 
assign channels or change channel assignments.

Channel Column

Channel Field in Story Form
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To assign channels in iNEWS:

t Do one of the following:

a. Type the channel name, such as A, B, or C, in the Channel column of the rundown 
opened in the Queue panel.

b. Type the channel name in the Channel field of story’s Story Form panel.

c. Type Shift-Alt-C and enter the channel in the Assign Channel dialog box (shown), 
then click OK.
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Chapter 6

Working with Stories

In Avid iNEWS Command, when a newsroom playlist is loaded, it presents the machine 
control events grouped by story according to the order of the rundown from which it was 
loaded.

During the final preparations and as a show goes to air, that order might change as producers 
add, remove, or rearrange stories in the rundown to reflect the changing demands of late-
breaking news and production developments.

While a newsroom playlist is locked to the rundown in iNEWS, updates will appear in both 
the rundown and the playlist whenever a change is made at an iNEWS Workstation. While 
the newsroom computer system retains the playlist lock, changes cannot be made to the 
newsroom playlist from a Command Workstation.

However, if a standalone playlist is created at a Command Workstation or if a newsroom 
playlist is disconnected from the rundown and the lock obtained from a Command 
Workstation, then changes to the stories in those playlists can be done from the Command 
Workstation.

This chapter contains the following main sections:

• Inserting New Stories

• Deleting Stories

• Updating Stories

• Rearranging Stories

• Floating & Unfloating Stories
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Inserting New Stories

New stories can be inserted in a standalone or disconnected newsroom playlist at a 
Command Workstation.

To insert a new story in a playlist in Command:

1. Position the cursor in the playlist on a story, not an item.

n If a user attempts to insert a new story before an item, the system will display a warning 
instructing the user to insert the story before another pre-existing story.

2. Do one of the following:

t Press Ctrl+N.

t Select Playlist > Insert > New Story.

The Create New Story dialog box opens.

3. Enter the name for the new story.

4. Click OK or press Enter.

Deleting Stories

Stories can be deleted from a standalone or disconnected newsroom playlist at a Command 
Workstation.

To delete a story from a standalone or disconnected newsroom playlist:

1. At a Command Workstation, select the story you want to remove.

2. Do one of the following:

t Select Playlist > Edit > Delete.

t Press Delete.

c Deleting a story in a standalone playlist will remove all events in that story from the 
playlist.
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Deleting a story from a rundown at an iNEWS Workstation can be accomplished even after 
the show’s newsroom playlist has been loaded to Command.

To delete a story from a rundown:

1. At an iNEWS Workstation, select the story you want to remove by clicking on the 
selector button to the left of the story.

2. Do one of the following:

t Select Edit > Kill. 

t Press Delete.

3. When the confirmation dialog box opens. Click OK.

n Deleting a story from a rundown (and therefore from its newsroom playlist) does not delete 
the story and its machine controls events from the newsroom computer system’s database. It 
only removes the story from appearing in the show’s rundown and newsroom playlist.

Updating Stories

Although a show’s newsroom playlist is loaded to Command, updates to a story in the 
rundown can still occur, such as the need to add or alter a machine control event. For 
newsroom playlists in which the playlist lock is retained by the iNEWS newsroom computer 
system, updating can be accomplished only from an iNEWS Workstation, unless the 
newsroom playlist is disconnected from the newsroom and therefore becomes a standalone 
playlist locked by the Command Workstation.

For more information, see “Inserting Machine Control Events into Stories” on page 69.

n Updating the text in the body of a story must be done from the newsroom computer system 
and not Command.

For more information about editing iNEWS stories, see the Introduction to the iNEWS 
Workstation Training Manual available on the Avid Knowledge Base.

Rearranging Stories

Changing and updating the order in which stories appear in the course of a show is a 
frequent task for a show’s producer. As new stories develop and urgent bulletins come in, a 
producer must decide the sequence in which stories should appear in the course of a news 
program and update the show’s rundown accordingly. 
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The integration between Command and the Avid iNEWS newsroom computer system 
provides for seamless communication regarding the changes that occur in the iNEWS 
rundown and the order of events in the newsroom playlist in Command. When the order of 
stories in a show is altered after the monitor server has loaded its playlist to Command, the 
order of events associated with each story is also rearranged accordingly.

c This updating occurs in newsroom rundowns for which the playlist lock is retained by 
the newsroom system. If the playlist is disconnected from the newsroom rundown, then 
updates will no longer be communicated between Command and iNEWS, or vice versa.

To rearrange stories in a standalone or disconnected newsroom playlist:

t At a Command Workstation, select the story and drag it from its current location to its 
new location within the playlist.

n For standalone playlists, Avid iNEWS Command provides the standard copy and paste 
functionality as options in the Playlist > Edit menu.

To rearrange stories in an iNEWS rundown:

1. From an iNEWS Workstation, select the story in the rundown by clicking the selector 
button to the left of the story. (To select multiple stories, hold the Ctrl key down first.)

2. Drag and drop the story’s button to its new location within the rundown.

Floating & Unfloating Stories

The Avid iNEWS system provides producers with a way to “float” stories when they are 
unsure where they should go in the rundown, if at all. 

Floating stories can only be accomplished from the iNEWS Workstation, not a Command 
Workstation. However, if the rundown’s playlist is already loaded to Command, then 
floating an iNEWS story removes it, including any associated machine control events, from 
the newsroom playlist in Command.

n Floated stories appear in the iNEWS rundown in a different color (usually blue text) than 
other stories, and their times are removed from the rundown’s show timing.

To float an iNEWS story:

1. From an iNEWS Workstation, select the story in the rundown by clicking the selector 
button to the left of the story.

2. Select Story > Float.

To unfloat a story, repeat the above procedure.
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Chapter 7

Playout Control

Playout control through Avid iNEWS Command varies from site to site depending on 
workflow. Some television stations might want to control playout through the software’s 
graphical user interface, while others choose to use USB or GPI keypads.

This chapter contains the following main sections:

• UI Controlled

• USB Keypad Controlled

• GPI Controlled
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UI Controlled

Playout control from a Command Workstation is accomplished through the use of the tabbed 
workspace known as the Playlist Viewer. While some functionality is described in this 
section, for additional information such as customization options, see “Playlist Viewer” on 
page 41.

Command uses various icons, as well as color, to indicate the status of machine control 
events (items) in the playlist. Some of which are shown in the following closeup graphic:

Icon representing a 
“Follow-On Playout” event.

Playout of this event is done.
This event is playing now.

This event is cued.

This event is unavailable.

Cursor location can appear solid 
or as an outline; varies by field.
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Playout Media from Command Workstation

Users can cue, play, pause or stop the playout of media from a Command Workstation, using 
the control buttons on the Playlist toolbar or keys on the numeric keypad. For information on 
the buttons, see “Toolbars” on page 44.

To control playout, using the numeric keypad on a keyboard:

1. Select the event in the playlist.

2. Do one of the following:

t Press the Decimal key (.) to cue the media.

t Press Enter to play the media.

t Press the Plus key (+) to pause the media.

t Press zero (0) to stop playing the media.

n Playout options are also available by right-clicking on the event and selecting the options 
from the Playout submenu.

Users can set playout of an item in a playlist to automatically occur immediately following 
the completion of the previous item. This functionality is called follow-on playout and is 
indicated by an icon in the playlist that looks like a bent blue arrow.

To set follow-on playout for an item(event):

1. At a Command Workstation, in the Playlist Viewer, click the field in the Trigger column 
corresponding with the item that you want set for follow-on playout. (The Trigger 
column is narrow and usually has no label on its column header. Its location in the 
playlist might also vary.)

2. When the menu appears, select Follow-On Playout. (The menu option might appear 
truncated.)

Trigger 
Column

Status 
Column
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3. Do one of the following:

t Click elsewhere on the playlist.

t Press Enter on the main keyboard.

t Move the cursor with keyboard shortcuts.

It’s only at this point that the playout method is saved.

To set an item to manual playout:

1. At a Command Workstation, in the Playlist Viewer, click the field in the Trigger column 
corresponding with the item that you want set for manual playout.

2. When the menu appears, select Manual Playout.

3. Do one of the following:

t Click elsewhere on the playlist.

t Press Enter on the main keyboard.

t Move the cursor with keyboard shortcuts.

It’s only at this point that the playout method is saved. 

Disabling the Keyboard at the Command Workstation

Some sites use alternative devices to control playout from Command, such as a GPI device 
or an X-keys USB keypad, and therefore do not want the computer keyboard at the 
workstation enabled.
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To enable or disable the keyboard:

1. Select Tools > Options.

2. In Category, select Keyboard.

3. Do one of the following:

t Select Enable keyboard.

t Deselect Enable keyboard.

4. Click Apply.

5. Click OK.

n If the keyboard is disabled, the numeric keypad cannot be used to control playout from the 
Command Workstation. Disabling the keyboard does not affect the use of the keyboard for 
software on the workstation PC unrelated to the Command client software.

USB Keypad Controlled

Avid iNEWS Command interfaces with the X-keys® USB keypad for playout control. An 
X-keys USB keypad connects to the USB port the Command Workstation and offers up to 
twenty user-reprogrammable keys for one-button access to playout functionality.
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n X-keys is a third-party hardware solution, so for more information on the X-keys USB 
keypad, see that manufacturer’s documentation on www.xkeys.com.

To program the X-keys from the Command Workstation:

1. Select Tools > Options.

2. In Category, expand Actions and select X-keys.

3. Select Enable X-keys.

4. Set the de-bounce period. Designed to avoid inadvertent repetition, this is the span of 
time (in milliseconds) during which the system should ignore duplicated signals.

5. Click on a gray box that represents (or corresponds to) the key on the keypad.
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n Some sites might use key caps that cover 2 or 4 buttons on the keypad, turning a set of 
buttons into a single key. If that is the case, select the left box to set the “2-button” key. For 
4-button keys, select the upper left box.

6. Assign an action to the key by selecting it from the list of those available in the Choose 
Action dialog box.

7. Click OK.

8. Repeat steps 5-7 as needed.

9. Click Apply.

10. Click OK.

The following graphic shows a closeup of the first row of keys after they were assigned to 
the four playout control options of play, cue, pause, and stop.
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Channel-Specific Actions

Keys can also be assigned to an action associated with a specific channel on a device. An 
example of this would be for a key to initiate a play command on a single channel. 

To assign channel specific actions to a key:

1. Complete steps 1 - 5 of the procedure to program X-keys on page 100.

2. In Category, expand Actions and select Playlist, then Channel.

3. Select the action, such as Play.

4. Select the indice, such as 01, that corresponds to the device channel.

5. Click Apply.

6. Click OK.

n Indices for channel specific actions in the list are pre-configured through system settings at 
the Command Workstation, which requires an administrative password. For more 
information, see the Avid iNEWS Command Installation and Administration Guide.

GPI Controlled

A GPI panel is another alternative keypad device that can be used to control playout through 
Command. The GPI panel, such as a Maney panel (shown below), connects to a GPI card 
installed in the Command Server.

The GPI panel allows a user to select up to four channels, with each channel having its own 
set of Control buttons for play, cue, pause, and stop functionality. 
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To enable a GPI panel to control a playlist:

1. At the Command Workstation, select Tools > Options.

2. In Category, expand Actions and select GPI.

3. Select a GPI panel from the list.

4. Click Apply.

5. Click OK.

n System administrators must configure system settings to provide a list of GPI panels in the 
Options dialog box. For more information see the Avid iNEWS Command Installation and 
Configuration Guide.
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Appendix A

Icon and Button Quick Reference

iNEWS Command has many different tools, icons, and buttons, which are used to alert you 
to information and status as well as making your actions quick and precise. This appendix is 
intended to serve as a quick reference to some of the icons and buttons used throughout your 
Command system. It is not all inclusive.

Playlist Viewer Buttons

This section describes buttons in the user interface, some of which have icons on them that 
will change depending on a certain status, such as whether a channel group is locked.

Playout Channel Groups Playlist 

Cue Add/Lock Channel Groups Playlist Locked by 
Newsroom

Play Locked Channel Group by 
Command Workstation

Playlist Locked by 
Command Workstation

Pause Channel Group Locked by 
Other Workstation

Playlist Locked by Other 
Command Workstation

Stop Unlocked Channel Group Unlocked Playlist

Unknown Time of Day Playlist

Unusual Lock Condition
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Playlist Viewer Icons

Inventory

Playlist Explorer

Alerts

Playout Status Playability Status Miscellaneous

Cued Primary Only On Air

Playing Backup Only Follow On

Paused Unplayable Embedding playlist

Stopped, Done Unknown Embedding error

Warning

Error

Inventory Status Detailed Status

Available on all Available on specific 
device

Unavailable on some Unavailable on 
specifc device

Playlist Status

Ready forAir

Message Type

Information

Critical Error

Caution, Warning
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Unknown

Message Type
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Appendix B

Action Quick Reference

iNEWS Command enables users to assign actions to X-keys, which can speed up frequently 
performed tasks. This appendix is intended to serve as a quick reference to those actions 
available in the Options dialog box—accessible through the Tools > Options menu of your 
Command system—and the Choose Action dialog box (shown below), which opens when 
you select an X-key to assign an action to in the Options dialog box. The reference list here 
is not all inclusive.
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Actions

This list of actions available are shown in a tree-style format that contain categories, 
subcategories, and actions.

Category/Subcategory Subcategory/Action Description 

Alerts ShowDiagnostics Open the Alert Diagnostics dialog box.

Clear Clear alerts.

MediaViewer BackwardOneFrame Navigate back one frame of video.

BackwardOneSecond Navigate back one second.

BackwardTenSeconds Navigate back ten seconds.

ForwardOneFrame Navigate forward one frame of video.

ForwardOneSecond Navigate forward one second.

ForwardTenSeconds Navigate forward ten seconds.

GoToMarkIn Navigate to the marked In point.

GoToMarkOut Navigate to the marked Out point.

Play Play media (in the Media Viewer)

Restart Restart media.

SetMarkIn Set In point at current timecode location.

SetMarkOut Set Out point at current timecode location.

Edit Copy Copy selection. 

Cut Cut selection.

Delete Delete selection.

Paste Paste cut or copied data to current cursor location.

n The Edit actions apply to current focus within the user interface and whether 
editing functionality is supported.

MainWindow Exit Exit the application.

View Help Open the Help system.

About Display information about the application.
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Support Open the Support dialog box.

Versions Display software version.

Alerts Show the Alerts panel.

Clock Show the Clock panel.

Inventory Show the Inventory panel.

PlaylistExplorer Show the Playlist Explorer.

MediaViewer Show the Media Viewer.

SystemSettings Opens the System Settings dialog box.

UIOptions Opens the Options dialog box.

Playlist/ChannelGroup AddExisting Open the Add Channel Group Playlist dialog box.

AddNew Open the Add New Channel Group Playlist dialog box.

AutoAssign Initiate auto-assignment of channels in the playlist.

Playlist/ChannelGroup Lock/1-9 Lock the specified channel group.

LockAll Lock all channel groups.

Remove/1-9 Remove the specified channel group.

Replace/1-9 Replace the specified channel group.

SetChannel/Index/01-16 Changes the channel of all the items to the channel 
specified for the index as configured in the System 
Settings dialog box.

SetChannel/Name/A-Z Changes the channel of all the items to the specified 
channel, whose name is a single character of the 
English alphabet. Won’t work if channel isn’t in group.

SetGroup/1-9 Switches all selected playlist items to the specified 
channel group.

Unlock/1-9 Unlock the specified channel group.

UnlockAll Unlock all channel groups.

n The numeric values correspond to the Channel buttons as they appear from 
left to right on the Playlist toolbar (or from right-to-left depending on your 
locale). For more information, see “Channel Group Buttons” on page 46.
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 (Continued)



 B Action Quick Reference

112

Playlist Copy Copy the selected item(s) in the active playlist.

Cut Cut the selected item(s) in the active playlist.

Delete Delete the selected item(s) in the active playlist.

Playlist/Selection EditChannel Opens the channel list for the topmost selected item. 
This is the same as clicking in the Channel column of a 
playlist.

EditSelection Edit the selected row. (For video items with a browse 
channel, the In and Out points can be set using the 
Media Viewer.)

End Move cursor to end of playlist.

Home Move cursor to top of playlist.

ItemAfterStory Move cursor to the next item after the current story.

NextItem Move cursor to the next item.

NextRow Move cursor to the next row.

PageDown Move down one page in the playlist.

PageUp Move up one page in the playlist.

PreviousItem Move to previous item.

PreviousRow Move to previous row.

Cue Cue selected item.

Pause Pause selected item.

Play Play selected item.

Stop Stop selected item.

Playlist EditProperties Open the Playlist Properties dialog box.

InsertBreak Insert a break before the selected row in the playlist.

InsertStory Create a new story in the playlist.

Lock Obtain the playlist’s lock.

Paste Paste cut or copied rows in the playlist above the cursor 
location.

Category/Subcategory  
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Unlock Release the playlist’s lock.

Export Export the playlist.

Import Import a playlist.

Playlist/View CloseAll Close all playlist views (tabs) in the Playlist Viewer.

Close Close the active playlist (topmost tab) in the Playlist 
Viewer.

Next Switch to the next playlist view—the next tab in the 
Playlist Viewer.

Previous Switch to the previous playlist view—the next tab in 
the Playlist Viewer.

Refresh View Refreshes the view in the Playlist Viewer. This does not 
reload newsroom or system data to the Command 
Workstation from iNEWS or the Command Server. 

SetFocus Sets the keyboard focus to the active view.

PlaylistExplorer DeleteSelectedPlaylists Delete the selected playlist(s) in the Playlist Explorer. 
The system will ask for confirmation.

NewPlaylist Create a new standalone playlist.

PlaylistExplorer/View Refresh Refreshes the view in the Playlist Explorer. This does 
not reload newsroom or system data to the Command 
Workstation from iNEWS or the Command Server.
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A
AirSpeed

channel groups 54
device service 25

Alerts window 38
alerts, types of 39
Avid

documentation 11
educational services 12
Knowledge Base 11

Avid Deko device service 25
Avid Graphics Select 72
Avid iNEWS Communication service 24
Avid Interplay Framework

nonredundant services 26
Workgroup Properties 27

Avid Interplay services 28
Avid MOS Communication service 24
Avid Playlist Controller 24
Avid Playlist Manager 24
Avid Playlist Store 24
Avid Thunder device service 25
Avid Inventory Manager 24

B
Background option 50
Browse controls 40

C
Channel group

add to playlist 55
defined 54
locking and unlocking 58
viewing inventory 36

Channels
assigning in Command 59

assigning in iNEWS 82
Channel-specific actions 102
Clock 37
columns

Status 97
Trigger 97

Command
panels 31
Playlist Viewer 41

Command Workstation
alternative keypad device 102
changing channels 81
deleting a story 90
disabling keyboard 98
menus explained 18
user interface explained 18
using X-keys 99

Composite List queues 80
Container playlist, defined 43
Cursor 48
Customer Support

contact information 11
log support information 21

D
Deko

events 73
plug-in defined 71
spell checking 74

Deko device service 26
Device services 25
Dialog boxes

Add Channel Group to Playlist 55
Avid Interplay Services 28
Choose action 101
Create New Story 90
Monitor 76
Options 34, 35, 38, 45, 47, 49, 51, 52

Index
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Support 21
Directory panel 68
Disconnected playlist 53
Docking and undocking panels 32

E
Embedded playlist 62

defined 43
editing 64

Event List queues 79
Events

follow-on 97
inserting in iNEWS story 70
inserting via DekoMOS 73
tagged 74

F
Failover 25
Float iNEWS stories 92
Follow-on playout 97

G
GPI card 102
GPI panel 102

H
Head frame column 50
Hiding or showing panels 32

I
iNEWS

changing channel assignment 81
deleting a story 91
Directory panel 68
embedded playlists 63
floating a story 92
Instruction panel 68
machine control event 71
monitor server 76
Queue panel 68
rearranging stories in rundown 92

reordering rundowns 91
Story Form panel 68
Story panel 68, 70
Story Text panel 68
training 12
updating stories 91
workspace 68

iNEWS Communication service 26
Instruction panel 68
Interplay Workgroup Properties 27
Inventory panel 36

K
Keyboard

alternative keypad device 102
disabling 98

Knowledge Base 11

L
Loading playlists 76
lock and unlock channel groups 58
Lock and unlock playlists 53
Lookup service 26

M
Machine control event, defined 70
Machine Monitor service 26
Maney panel 102

device service 25
Manual playout 98
Media Viewer 40
Menu bar 18
Monitor Load 76, 78
Monitor modes 77
Monitor Off 79
Monitor server 76
Monitor Unload 76, 79

N
Newsroom playlist, defined 42
Non-redundant services 26
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O
Online support 11

P
Panels

defined 18
in Command 31
in iNEWS 68
working with 32

Playlist
add channel group 55
channel groups 55
embedding 62
icons 96
loading 76
lock channel group 58
lock status 53
locking and unlocking 53
multiple tab option 34
rearranging columns 52
reconnecting to newsroom 53
toolbars explained 44
types of 42
unloading 76

Playlist Explorer 33
configure to auto-open playlists 34
multiple tab option 35

Playlist Lock button 53
Playlist toolbar 45

time of day icon 65
Playlist Viewer

multiple tab option 34
Trigger and Status columns 97

Playout
follow-on 97
manual 98

Playout control 95
services for 24

Playout toolbar 44
Plug-ins 71
Primary machine control event 73
Procedures

accessing DekoMOS in iNEWS 72
add a channel group to a playlist 55
add a new channel group 56

assign channel specific actions to a key 102
assign channels 59
assign channels in iNEWS 82
change clock functions 51
change cursor appearance 49
configure Playlist Explorer to auto-open loaded 

playlists 34
configuring the clock 38
control playout with numeric keypad 97
create a new story in a playlist 90
create a standalone playlist 61
customize Playlist Viewer 47
delete a standalone playlist 61
delete a story 91
docking or undocking a panel 32
edit a Deko event in iNEWS 75
edit a standalone playlist 61
embed a playlist in Avid iNEWS 63
embed a playlist in Command 62
enable a GPI panel to control a playlist 103
enable or disable Avid services 28
enable or disable the keyboard 99
float an iNEWS story 92
hiding a panel 32
insert a DekoMOS event into the story form 73
inserting a DekoMOS event in iNEWS 73
inserting machine control events 70
lock or unlock a channel group 58
lock or unlock all channel groups for playlist 58
log support information 21
programming X-keys 100
rearrange columns in a playlist 52
rearrange Inventory column order 36
rearrange stories in a newsroom playlist 92
rearrange stories in an iNEWS rundown 92
resizing a panel 32
set a playlist to air at a certain time of day 64
set follow-on playout 97
set manual playout 98
sorting inventory 36
start Interplay Workgroup Properties 27
stop or start Avid services 28
using monitor server 76
using MOS plug-ins 71
viewing a hidden panel 32
viewing inventory from a channel group 36

Production cue marker 70
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Production cues 69

Q
Queue panel 68

R
Redundancy 25
Resizing panels 32

S
Service Starter service 26
Services

defined 23
for devices 25
for redundancy 25
non-redundant 26
starting and stopping 28
types of 24
viewing status 27

Standalone playlist 61
defined 42
deleting 61
editing 61
editing embedded 64

Starting
Avid Workgroup Properties 27
services 28

Status column 97
Story

create new one in playlist 90
deleting 91
floating 92
rearranging in iNEWS rundown 92
rearranging in newsroom playlist 92
rearranging stories 91
updating 91

Story Form panel 68
Story panel 68, 70
Story Text panel 68

T
Tabs 34
Tagged event 74

Thunder device service 26
Thunder Select 72
Time of day icon 65
Time of day playlists 64
Time Synchronization 26
Training, ordering courses 12
Trigger column 50, 97
Troubleshooting 11

U
Unloading playlists 76
Updating stories 91
USB keypad 99

W
Workgroup Properties 27

X
X-keys 99

channel-specific actions 102
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