
VENUE Live Recording Guide

Overview and 
Terminology Setups Virtual Soundcheck

Example

Guide Part Number: 9329-66322-00 
01/22

For VENUE | S6L Systems

What is 
Virtual Soundcheck? 

What is Pro Tools AVB?

MADI Setups for
Record/Playback

Pro Tools AVB

VENUE Link

Record the Show

Play Back
the Show

Switch Back to 
Stage Mode

What is 
VENUE Link? 

System Requirements

Assignable IO

I/O Sharing Info

VENUE Metering Options 
in Pro Tools

Toggling Input Source

Snapshot PRE Settings
and Virtual Soundcheck

Using Assignable Inputs

Using Input Mode

About Track Assignments

Importing VENUE 
Channel Names

Pro Tools Markers

Controlling Pro Tools 
from S6L

Examples and step-by-step instructions for live recording, Virtual Soundcheck, integrated playback, 2-track USB, and more.

Introduction Connections and Settings Virtual Soundcheck Additional Recording Features Playback

Events Example
(Record Enable Tracks)

Video Tutorials 
(Setup and Configuration)

2-Trafck USB 
Playback and Recording

Media



Overview
Welcome to the Live Recording Guide for Avid VENUE | S6L systems. 
This guide shows you how to integrate Pro Tools recording and playback with your S6L system and includes the following topics: 
• What is Virtual Soundcheck, VENUE Link, and Pro Tools AVB.
• How to set up Pro Tools AVB, VENUE Link, and Pro Tools Sessions to record and play back up to 128 channels of audio with VENUE.
• How to perform a complete Virtual Soundcheck. 
• How to route and record Mains, audience mics, and submix outputs. 
• How to integrate Pro Tools tracks into your performances. 
• How to toggle individual channels between Stage and Pro Tools input, and how to use Input mode
• How to control the Pro Tools Transport from S6L, how to link Pro Tools Markers to S6L snapshots, and more
• How to record/playback via MADI using MADI-192 MADI Option Cards. 
• How to use Stage 64 MADI outputs to record to a MADI-compatible device.
• How to use 2-Track USB Playback and Recording.

In this guide, instructions for S6L systems are generally applicable to S3L-X systems also. Note that S3L-X systems support Stage 16 I/O units only. 

Overview of VENUE Recording and Playback Features 

S6L S3L-X/S3L Record Playback Virtual Soundcheck VENUE Link

Pro Tools AVB      

MADI-192 MADI Option Cards     

Stage 64/32 MADI Out  

2-Track USB Playback and 

Recording

   



Overview: Terminology
To get the most out of this guide, take a moment to familiarize yourself with the following terms and concepts. 

Recording Outputs
Ethernet AVB or MADI-192 MADI Option Card audio connections carry the following types of output signals from S6L to Pro Tools for recording:

Direct Digital Splits (Pro Tools “Auto-Patch”) Stage inputs assigned to S6L system input channels are automatically sent to Pro Tools as unprocessed 
direct digital splits. A Pro Tools session recorded using direct digital splits are an essential part of the Virtual Soundcheck workflow. 
Assignable Pro Tools Outputs For any system input channels not assigned Stage inputs as their sources, assignable recording outputs are available, 
up to the maximum number of available Pro Tools I/O channels. Assignable outputs can be used to send the Direct Outs of S6L system I/O channels,  
the Main L/R mix and other submixes from sources such as Matrix and Groups, and audience mics to Pro Tools. Assignable outputs also let you 
record pre-fader/post-insert or post-fader S6L signals. Note, however, that recording pre-fader/post-insert of post-fader signals disqualifies the 
recordings of these outputs for use in Virtual Soundcheck, which requires direct “splits” of channels with no S6L processing applied other than input 
gain. 

Playback Inputs
Ethernet AVB or MADI-192 MADI Option Card audio connections carry the following types of input signals to S6L from Pro Tools for playback:

Virtual Soundcheck Inputs Any S6L input channel with a Stage input as its source is automatically assigned a corresponding Pro Tools Virtual 
Soundcheck input. The source for that S6L system input channel can then be toggled between its assigned Stage input and its corresponding Virtual 
Soundcheck input, either globally or individually. When Virtual Soundcheck inputs are active, you can make adjustments to your mix using pre-
recorded Pro Tools tracks derived from direct digital splits of your Stage inputs. All changes carry over when you switch back to live Stage inputs. 
You can also choose to apply any Input Gain changes made to input channels when switching back to Stage inputs. For more information, see
What is Virtual Soundcheck?

Assignable Pro Tools Inputs For any system input channels not assigned Stage inputs as their sources, assignable Pro Tools inputs are available, up 
to the maximum number of available Pro Tools I/O channels. Assignable inputs can be used to monitor your Pro Tools recording on your S6L system, 
or to incorporate pre-recorded audio tracks into your live mix. To learn more, see Using Assignable Inputs. 

Pro Tools Input Mode
In Pro Tools Input mode, audio from Pro Tools via AVB or MADI (if any MADI-192 MADI Option cards are installed) is the main source of audio for your 
S6L system. Stage inputs on your S6L system are replaced with inputs from Pro Tools. Unlike Virtual Soundcheck mode, changes made to Input Gain 
settings while operating in Pro Tools Input mode cannot be applied when switching back to Stage inputs. To learn more, see Using Input Mode. 

VENUE Link
VENUE Link is a communication link between your S6L and Pro Tools systems. Using this link, you can transfer data between systems and control 
Pro Tools from the S6L control surface. VENUE Link is an integral part of the Virtual Soundcheck workflow. Use features such as Create Session from 
VENUE to properly and quickly create a Virtual Soundcheck-compatible  Pro Tools session.  For more information, see What is VENUE Link? 

2-Track USB
The S6L system also provides built-in USB 2-track recording and playback, letting you create basic stereo live recordings and play back stereo music 
tracks and/or sound effects during a production or performance.  For more information, see Media (2-Track USB Playback and Recording).



What is Virtual Soundcheck?

When using Pro Tools with S6L via Pro Tools AVB and VENUE Link you get true Virtual SoundCheck functionality.

Here is an overview of the complete Virtual Soundcheck workflow:  

Record a Show
• After enabling VENUE Link, create a Pro Tools session with 

tracks that are automatically created, named, and routed 
based on your VENUE channels. 

• Record all live stage inputs directly to Pro Tools. The pick-
off point is post A-to-D (analog-to-digital) conversion but 
before all VENUE channel processing, making the 
recorded material the most accurate way to recreate your 
mix during Virtual Soundcheck. While recording, recalling 
a sequential VENUE snapshot can create a Pro Tools 
Marker in the Pro Tools timeline. 

Perform a Virtual Soundcheck
• Play back the previously recorded Pro Tools tracks. Tracks 

play through their matching VENUE Input channels.  
• During playback adjust levels, program and update 

snapshots, experiment with different plug-ins, and more. 
To jump to specific songs or scenes, recall snapshots 
linked to Pro Tools Markers. 

• While in Virtual Soundcheck mode all adjustments are 
applied instantly to the currently loaded Show file. Be 
sure and Overwrite the currently loaded Show file or 
create a new Show file to retain those settings. 

Apply and Update
• Switch the VENUE system back to Stage inputs mode.
• If you’ve made changes to input gain while in playback, you’ll 

be given the option to apply or ignore those changes to the 
Stage Rack pre-amps. For the Virtual Soundcheck work flow 
you’ll most likely choose to apply those changes.

Repeat
• Record the next show. 
• Use those new tracks at the next soundcheck. 
• Apply additional adjustments to further refine your live mix.
• Simultaneously compile a catalog of live recordings.  

Pro Tools

VENUE S6L

(Note: You can also record L/R Mains, “stems” (submixes of any combination of channels), or audience mics as explained in Assignable I/O).



What is VENUE Link? 
VENUE Link is a communication protocol that uses the same Ethernet connection to the Pro Tools computer as Pro Tools AVB. 
Essential to the complete Virtual Soundcheck workflow, VENUE Link lets you take advantage of the following capabilities: 

• Create Session from VENUE Quickly create Pro Tools sessions that automatically populate and name tracks based on your VENUE 
channels, and automatically assign Pro Tools track inputs and outputs to correspond with VENUE I/O 1-for-1.

• Transport Control VENUE Link lets you control the Pro Tools Transport directly from the S6L control surface. 

VENUE Patchbay

Pro Tools Session
created from VENUE

VENUE Input channels generate and name Pro Tools tracks

VENUE patching defines Pro Tools track I/O

With VENUE Link enabled you can also create and link Pro Tools Makers (memory locations) with VENUE Snapshots.  

• Assignable Pro Tools IO To also record L/R Mains, “stems” (submixes of any combination of channels), or audience mics you can use Assignable I/O. 

For a more detailed explanation and specific examples, see About Track Assignments in Pro Tools. 



What is Pro Tools AVB?

VENUE | S6L systems provide direct connection to a computer running Pro Tools software via AVB Ethernet. 
The Ethernet AVB connection between your S6L system and Pro Tools provides up to 128 channels of 
simultaneous Pro Tools I/O. No additional audio hardware is required to connect your S6L system to Pro Tools.

Requirements: 
• The Pro Tools license must be present on the Pro Tools iLok. 
• Beginning with Pro Tools 2018.10, the functionality provided by the Live Sound Production Toolkit is included in Pro Tools and is  

automatically enabled whenever the Pro Tools Playback Engine is set to E6L. For maximum compatibility, transfer the Live Sound 
Production Toolkit to your Pro Tools iLok to enable 64- and 128-channel Pro Tools AVB with Pro Tools 2018.7 or earlier. (If you are renting 
a system, be sure the Pro Tools iLok with both of these licenses is also provided). Without the LiveSound Production Toolkit license, 
Pro Tools recording is limited to 32 tracks. 

• 128-channel AVB requires 2x AVB-192 Network Cards in the E6L Engine. 
• Pro Tools AVB requires an AVB-compatible Mac. Special system requirements for the Pro Tools computer may apply depending on the 

number of channels required. For the latest compatibility information and system requirements, visit this article on our Knowledge Base:    
What are the system requirements for Pro Tools with S6L?

I want to do this, how do I start?  
• See Pro Tools AVB Connections and Settings, then configure VENUE Link.

This single Ethernet connection lets you record multi-track Pro Tools sessions of performances 
using a variety of S6L system audio sources, including digital splits of your Stage inputs, channel 
Direct Outputs, and bus outputs. 
Beginning with VENUE software version 6.1 up to two compatible Pro Tools computers can be 
connected to S6L simultaneously for redundant 128-channel recording.  
You can also play back multi-track audio from Pro Tools through your S6L system to integrate 
pre-recorded tracks with your live mix, or to monitor your Pro Tools recording on your S6L 
system. When VENUE Link is enabled, the same connection also lets you control the Pro Tools 
Transport from the S6L control surface. 
By combining recording and playback features, you can perform a true Virtual Soundcheck. 

What is an iLok? An iLok is a USB device that can hold hundreds of authorizations for all of your iLok-enabled software. When you activate Avid software, licenses 
are deposited in your iLok account at iLok.com. Use the free Ilok License Manager application to transfer your licenses from iLok.com to the appropriate iLok. 

Overview

• If you need more USB ports use a powered USB hub (not a bus-powered or passive hub). 

http://avid.force.com/pkb/articles/compatibility/What-are-the-system-requirements-for-Pro-Tools-with-S6L
https://www.ilok.com/


What is Pro Tools AVB?

Pro Tools AVB Redundant Record
Beginning with VENUE software version 6.1 you can perform redundant recording of 128 channels via Pro Tools AVB to two qualified Pro Tools 
computers. Up to two (2) compatible Pro Tools computers can be connected to a single VENUE S6L system by connecting them to Network 
ports C and D on the S6L control surface.  

I/O Sharing Configurations
When S6L systems are configured for I/O Sharing, up to two Pro Tools computers, total, can be connected. You can connect one Pro Tools 
computer to each system (use Network port C on both S6L control surfaces) or connect both computers to Network ports C and D on either single 
S6L system for redundant recording. 
• When one computer is connected to each separate S6L control surface, either computer can record or play back up to 128 channels.
• When both computers are connected to the same S6L control surface, the same record/playback rules apply as when two computers are 

connected to a single system. 

Redundant Recording

Redundant Recording 
On both Pro Tools systems, enable VENUE Link and use Create Session from VENUE 
to be able to record your performance to both Pro Tools systems simultaneously 
(fully redundant recording of up to 128 tracks) for Virtual Soundcheck and archiving. 
By enabling VENUE Link on both systems, both Pro Tools systems respond as one to 
Transport commands from S6L. 

Virtual Soundcheck 
When you switch the S6L system Input Source to Pro Tools to perform a Virtual 
Soundcheck, playback will be available from the Pro Tools computer that was 
connected to the E6L engine last in AMS. When VENUE Link is enabled on both 
Pro Tools systems they will both play back and cue in response to Transport 
commands from S6L, but audio from the first-connected Pro Tools system will not be 
available (only audio from the last-connected Pro Tools system is recognized by S6L). 

Simultaneous Record/Playback 
If you need to simultaneously record to and play back from Pro Tools to integrate 
backing tracks, count-offs or other material, use a single Pro Tools system connected 
to S6L Network port C, only.  Or if using two Pro Tools systems in a redundant 
recording configuration, the last Pro Tools system connected can provide playback. 

Connections for Pro Tools AVB redundant recording

For additional details and information see Working with Pro Tools in Shared I/O Configurations. 



System Requirements

This guide assumes that you have already done each of the following: 
• Set up your VENUE system and confirmed successful installation of the latest VENUE software
• For Pro Tools AVB – Make sure you have already installed Pro Tools software on an AVB-compatible Mac and confirmed that it is operating correctly (for 

the latest compatibility information, see What Are the System Requirements for Pro Tools with S6L?)

System Requirements and Compatibility  

If you have not completed any of the above tasks, refer to the VENUE S6L Installation Guide.pdf for S6L and Pro Tools installation instructions You can download these 
and all other VENUE documentation, including the VENUE S6L Handbook.pdf, from your Avid account.

Example iLok account shown in iLok License Manager  

Visit iLok.com to sign-in to your iLok account, or create one if necessary (it’s free). Download  and install iLok License Manager on a Mac or PC, then transfer 
the following licenses to the correct iLok as shown below: 

VENUE Plug-in Licenses
The S6L Plug-In Bundle and other 
VENUE plug-in licenses must be 
transferred to your VENUE iLok (the 
licenses must be present on an iLok 
connected to your VENUE system). 

VENUE iLok

Pro Tools iLok

iLok Requirements
• Transfer the Pro Tools license and  LiveSound Production Toolkit to your Pro Tools iLok, and make sure that your Pro Tools iLok is connected to your 

Pro Tools computer. Without the LiveSound Production Toolkit (or Pro Tools 2018.10 or later) recording via Pro Tools AVB is limited to 32 tracks. 

• For Pro Tools AVB and VENUE Link – Make sure you have acquired an Ethernet cable (Cat5-e or better) to connect the S6L system to the Pro Tools computer
• For Pro Tools recording using MADI, make sure you have installed Pro Tools software on a compatible  Mac or Windows computer that is capable of recording 

and/or playing back the desired number of tracks via MADI
Important! Do the following to optimize your Mac for AVB recording and playback:
• Disable Wi-Fi, Airport, and Bluetooth, and turn off Internet Sharing
• Turn off Energy Saving, and disable Notification Center!

Pro Tools License
Must be transferred to your Pro Tools iLok. If you are 
using Pro Tools 2018.7 or earlier, the LiveSound 
Production Toolkit license must also be present on the 
iLok connected to your Pro Tools computer to enable 
recording of more than 32 tracks).

About the Live Sound Production Toolkit   Beginning with Pro Tools 2018.10, the functionality provided by the Live Sound Production Toolkit is included in Pro Tools and 
is automatically enabled when the Pro Tools Playback Engine is set to E6L. For maximum compatibility, transfer the Live Sound Production Toolkit to your Pro Tools iLok 
to enable 64- and 128-channel Pro Tools AVB with Pro Tools 2018.7 or earlier. (If you are renting a system, be sure the Pro Tools iLok with both of these licenses is also 
provided). Without the LiveSound Production Toolkit license, recording to Pro Tools 2018.7 is limited to 32 tracks. 

http://avid.force.com/pkb/articles/en_US/Compatibility/What-are-the-system-requirements-for-Pro-Tools-with-S6L
https://my.avid.com/account/orientation?returnUrl=https://my.avid.com/account
https://www.ilok.com/
http://avid.force.com/pkb/articles/Compatibility/en436391?retURL=/pkb/articles/en_US/Compatibility/en353265&popup=true
http://avid.force.com/pkb/articles/compatibility/en353265


Setups
Connecting and Configuring Systems

Follow these links for Pro Tools AVB then proceed to VENUE Link. 

VENUE Link

Pro Tools AVB

S6L MADI-192 MADI Option Cards S6L Stage 64 MADI Out

For MADI recording and playback, begin by following these links for connection diagrams and configuration instructions.  



Video Tutorials
If you prefer viewing to reading, check out these videos on the Avid Live Sound YouTube channel: 

Live Recording and Virtual Soundcheck Part 2: Perform a Virtual Soundcheck
Learn how to record a show, and how to perform a Virtual Soundcheck.

Live Recording and Virtual Soundcheck Part 1: Setup and Configuration
Learn how to set up and configure S6L and Pro Tools AVB for live recording and Virtual Soundcheck.

https://www.youtube.com/watch?v=7jFUiB4YqNo&list=PLhCR_8aS9jOPLn0DR1OuSKY7oynJH7PaE&index=1
https://youtu.be/Iqjz9ff_SgU?list=PLhCR_8aS9jOPLn0DR1OuSKY7oynJH7PaE
https://youtu.be/lZFrSipqQTA?list=PLhCR_8aS9jOPLn0DR1OuSKY7oynJH7PaE
https://youtu.be/lZFrSipqQTA?list=PLhCR_8aS9jOPLn0DR1OuSKY7oynJH7PaE
https://youtu.be/Iqjz9ff_SgU?list=PLhCR_8aS9jOPLn0DR1OuSKY7oynJH7PaE


Pro Tools AVB Connections and Settings
Before you can record and playback with Pro Tools via AVB, do each of the following: 

• Make sure you have met all the System Requirements described earlier, including Mac optimizations and setting up your iLoks (very important!)
• Connect S6L to Pro Tools (connect AVB), configure the Pro Tools computer (enable AVB), configure Pro Tools (Setup > Playback Engine), then 

enable VENUE Link. 
Connect S6L to Pro Tools
1. To connect a single Pro Tools computer, connect an Ethernet 

cable from Network Port C on the S6L control surface to an 
available Ethernet port on the Pro Tools computer. 

2. If your computer only has Thunderbolt ports: 
• Thunderbolt 2 Use a Thunderbolt-to-Gigabit Ethernet adapter.
• Thunderbolt 3 (USB-C) Two adapters are required at the time of this writing, a USB-C to Thunderbolt 2 adapter, and a Thunderbolt (2)-

to-Gigabit Ethernet adapter. (Be aware that not all USB-C to Ethernet adapters are AVB-compatible.)
3. If using two Mac Minis for redundant recording, do not connect to the built-in Ethernet ports on both computers. Connect one Mac Mini 

using a USB-C to Thunderbolt 2 adapter along with a Thunderbolt (2)-to-Gigabit Ethernet adapter (not all USB-C to Ethernet adapters are 
AVB-compatible.)

4. Proceed to Configure the Pro Tools Computer. 

Cables Connections
Ethernet  (Cat5-e or better) Pro Tools AVB/VENUE Link

Connections for a single Pro Tools AVB computer

Network Connections

Note: A direct connection between the S6L system and Pro Tools is required. Network equipment such as routers, hubs, and switches 
are not supported for S6L network connections to Pro Tools.!

To connect two Pro Tools computers for redundant recording, connect an 
Ethernet cable from Network Port C and D on the S6L control surface to 
an available Ethernet port on each Pro Tools computer. 

Connections for two Pro Tools AVB computers

If multiple S6L systems are configured for I/O Sharing, you can connect one Pro Tools system to each S6L or connect up to two 
Pro Tools systems to either single S6L. For more information, see the VENUE S6L Installation Guide.pdf. 



Pro Tools AVB Connections and Settings
Mac Optimizations

Do all of the following to optimize your Mac(s) for AVB recording and 
playback:
• Turn off Internet Sharing (System Preferences > Sharing)

• Disable Wi-Fi, Airport, and Bluetooth (System Preferences > Network)

• Turn off Energy Saving

• Disable Notification Center (System Preferences > Notifications)

Important!

Internet Sharing disabled in System Preferences > Sharing

Make sure you have already installed Pro Tools software on an AVB-compatible Mac and confirmed that it is operating correctly (for the latest 
compatibility information, see What Are the System Requirements for Pro Tools with S6L?). 

For a complete list of optimizations for your Pro Tools computer, visit: 
Pro Tools Computer Optimization

http://avid.force.com/pkb/articles/en_US/Compatibility/What-are-the-system-requirements-for-Pro-Tools-with-S6L
http://avid.force.com/pkb/articles/troubleshooting/en367983


Pro Tools AVB Connections and Settings

To enable AVB on the Pro Tools computer: 
1. If multiple S6L systems are connected for I/O Sharing, disconnect the 

Ethernet cable between the two E6L engines until after you have enabled 
AVB on the Pro Tools computer(s). For additional recommendations, see 
Working with Pro Tools in Shared I/O Configurations.

2. Make sure your S6L system and Pro Tools computer are powered on. 
3. On the Pro Tools computer, go to Applications > Utilities and launch Audio 

MIDI Setup.
If you have 2x AVB-192 Network Cards installed in your E6L engine and 
your Mac configuration supports 128 channels of AVB, see Enabling 128 
Channel AVB.

4. In Audio MIDI Setup, click the Window menu and choose  
Show Network Device Browser. 
Each currently connected and powered-on E6L appears in the Device list 
as “E6 Engine xxxx.”

5. Click to enable the desired E6L engine. 
(Optional) So that you can differentiate your E6L from any others on the 
network, name your E6L by doing the following: Enabled E6L

Entering a custom name

6. Repeat for any other Pro Tools computers you plan to use. 
7. Proceed to Configure Pro Tools. 

• From the Audio MIDI Setup Network Device Browser Devices list, 
select the E6L Engine so it is highlighted.

• Press Enter, enter a name, then press Enter again to save the name. 
(On laptops without a dedicated Enter key, press fn+Return.) 

Note: If you are connecting two Pro Tools computers to a single S6L 
system, the first computer to connect to that E6L in AMS will be able 
to record only. The second computer to connect to that E6L in AMS 
will be able to record (redundant), and be the Pro Tools AVB Input 
Source when performing a Virtual Soundcheck. 

Tip: After you have enabled AVB and configured Audio MIDI Setup as described above you will not need to repeat these steps in the future if using the 
same VENUE system and the same computer(s). You will only need to repeat the above steps if connecting a different VENUE system or computer(s).

Enable AVB
Configure the Pro Tools Computer
Important! Make sure you have performed all the Mac optimizations described on the previous page. 



Pro Tools AVB Connections and Settings

Enable 128 Channel AVB
You can toggle between 128- and 64-channel AVB using Audio MIDI Setup on your Mac. 128-channel AVB requires 2x AVB-192 Network Cards 
in the E6L Engine, and a compatible Mac (currently only Mac Pro computers).

Current Configuration selector in AVB Audio Entity window

To configure AVB for 128- or 64-channels:
1. On your AVB-compatible Mac, launch Audio MIDI Setup and open the Network 

Devices Browser (Command 3).
2. Make sure there is a check next to the E6L; if not, click to enable it.
3. Open the Audio Devices window (Window > Show Audio Devices) and do the 

following: 
• Select the E6L in the column at the far left.
• From the Options selector (gear icon), choose Configure device. 

4. In the AVB Audio Entity Configuration window, click the Current Configuration 
selector and choose either 64x64 96 kHz or 128x128 96 kHz.

AMS Audio Devices > Configure device

5. Close the AVB Audio Entity Configuration window. 
6. Close AMS.
7. Proceed to Configure Pro Tools.

128-Channel AVB

Note: Exact steps and images will vary depending on the version of macOS being used. 

http://avid.force.com/pkb/articles/compatibility/What-are-the-system-requirements-for-Pro-Tools-with-S6L


Pro Tools AVB Connections and Settings

Confirm Communication
To confirm S6L-to-Pro Tools communication: 
1. On the external VENUE software screen, go to the Options > Devices page. 
2. In the CONNECTED DEVICES column, an icon representing the Pro Tools computer 

is shown to indicate that the connection to Pro Tools is active. 
• When only one Pro Tools computer is connected, it appears in the CONNECTED 

column. 
• When two Pro Tools computers are connected, only the computer that connected 

to the E6L last in AMS appears. This Pro Tools computer can perform recording, and
will be the Pro Tools source for Virtual Soundcheck playback (the first computer to 
connect to the E6L in AMS can only record). 

3. With communication confirmed, proceed to VENUE Link. 

Configure the Pro Tools Playback Engine
After you have enabled AVB, configure the Pro Tools Playback Engine dialog and then confirm  S6L-to-Pro Tools communication.

E6 Engine selected as the Pro Tools Playback Engine

Pro Tools listed in 
CONNECTED DEVICES

To configure Pro Tools:
1. Launch Pro Tools, and if the Dashboard appears click Cancel.
2. Choose Setup > Playback Engine to open the Playback Engine dialog.
3. From the Playback Engine selector, choose your E6L engine. 

The default name for the E6L is <E6L Engine:AVB> unless you entered a custom name 
for it in the Audio MIDI Setup > Network Devices browser.
Tip: For best performance, use the highest available buffer size (in Setup > Playback 
Engine, choose 2048 (for 96 kHz projects) from the H/W Buffer Size pop-up). 

4. Click OK.

Configure Pro Tools



VENUE Link

To connect S6L and the Pro Tools Computer for VENUE Link:
• If you have already connected Pro Tools AVB, no other connection is required. Proceed to Enable VENUE Link in VENUE.

To connect VENUE Link when using MADI-192 MADI Option Card record/playback: 
• Connect an Ethernet cable from Network Port C on the S6L control surface to an available Ethernet port on the Pro Tools computer, then 

proceed to Enable VENUE Link in VENUE.

VENUE Link is a communication link between S6L and Pro Tools, and is an integral part of the Virtual Soundcheck workflow. 
VENUE Link lets you use Pro Tools features such as Create from VENUE to quickly create a Virtual Soundcheck-compatible Pro Tools session, and  to 
be able to control the Pro Tools transport from the S6L control surface, including Play, Stop, and master (Transport) Record. VENUE Link also allows 
Pro Tools Markers (memory locations) to be automatically created that are “linked” to VENUE snapshots; this lets you quickly navigate to different 
songs, scenes, or cues in your Pro Tools recordings simply by recalling the corresponding snapshot. 
You can also use VENUE Link independently of AVB audio when recording to Pro Tools using one or more MADI-192 MADI Option cards. 
VENUE Link must be enabled in both VENUE and in Pro Tools, as shown in the following instructions.  When two Pro Tools computers are connected 
for AVB, you can enable VENUE Link on both Pro Tools systems. 

Important!  The VENUE Link connection and settings are separate from ECx Remote Control Network connections and settings. If you are running ECx, 
be sure to configure ECx separately. VENUE Link is not supported through the ECx port on the S6L control surface (only through Network port C). 

Cables Connections

Ethernet (Cat5-e)
• S6L network
• Pro Tools AVB/VENUE Link

Coax/BNC MADI • MADI-192 MADI Option Card to/from
Pro Tools | HD MADI I/O

Coax/BNC Word Clock

• E6L Engine Word Clock to/from
Pro Tools | HD MADI I/O Word Clock
(See MADI-192 MADI Option Card 
Connections and Settings.) 

DigiLink
• Pro Tools | HD MADI I/O to Pro Tools | 

HDX or HD Native Card

Connections for Pro Tools via MADI-192 MADI Option Card



VENUE Link

Enable VENUE Link in VENUE
To enable VENUE Link in VENUE:
1. Make sure the S6L and Pro Tools are connected as described in 

Connecting to Pro Tools.
2. On the external screen, go to the Options > Interaction page. 
3. Select the Enable VENUE Link button in the Ethernet Control section so it 

is checked.
4. Proceed to Setting the Computer IP Address.

Set the Computer IP Address
Make sure your Pro Tools computer is set so it obtains an IP address 
automatically using DHCP.
To automatically set the IP address on your Mac:
1. On your Pro Tools computer, go to System Preferences > Network. 
2. Required: 

• Make sure you have disabled Wi-Fi, Airport, and Bluetooth. 
• Disable Internet Sharing.

3. Do one of the following:
• If you connected S6L to an Ethernet port on the computer, choose 

Ethernet from the network connections services list.
• If you connected to a Thunderbolt port on the computer, choose 

Thunderbolt Ethernet.
3. Choose Using DHCP from the Configure menu. 

An IP address is automatically assigned to the computer (also known as 
“self-assigned”).

4. Click Apply and close the Network System Preferences window. 
5. Proceed to Enable VENUE Link in Pro Tools.

VENUE Link enabled in Options > Interaction

Mac System Preferences > Network



VENUE Link

Enable VENUE Link in Pro Tools

To enable VENUE Link in Pro Tools:
1. Launch Pro Tools if it is not already launched. If the Dashboard 

appears, click Cancel.
2. Choose Setup > Peripherals to open the Peripherals dialog, then click 

the VENUE tab.
3. In the System Name box, enter a name for the Pro Tools system.
4. Choose your E6L engine from the VENUE System pop-up menu. When 

a connection is established, “connected” is displayed next to the 
name of the connected VENUE system. 

Troubleshooting VENUE Link Connections
If you cannot establish VENUE Link between systems, try the following:
• On your Pro Tools computer, make sure you have turned off Wi-Fi and Bluetooth, and disabled Internet Sharing. 
• In Pro Tools, choose Setup > Peripherals > VENUE. Make sure the IP address in the Interface pop-up under Advanced Network Settings begins 

with “169.254.xxx.xxx” and that it matches the IP address as shown in the IP Address field for the VENUE Link connection on your computer’s 
System Preferences > Network window. If it does not match, click the Interface pop-up and choose that IP address.

If you named the E6L engine in the Options > Devices page of the 
external VENUE software screen, its name appears here. If not, 
choose the IP address of the S6L system VENUE Link connection 
from the pop-up menu (such as 169.254.xx.xxx).

VENUE Link enabled in Pro Tools 
(Setup > Peripherals, VENUE tab)

VENUE Link Interface selector in Pro Tools  (Setup > Peripherals, VENUE tab)

5. Click OK to close the Peripherals dialog. 
6. Repeat on any other Pro Tools computers. 

• Make sure the TCP/UDP port numbers, shown on the Options > Devices page in VENUE and the Peripherals > VENUE window in Pro Tools, 
match between Pro Tools and S6L. If they match and you are still having connection issues, choose a new number between 1024–65535 
(except 5900), and then enter it into the TCP/UDP Port fields on both systems.



Virtual Soundcheck: Example

Example: Channel-by-Channel Virtual Soundcheck
Recordings of auto-patched Pro Tools direct digital splits form the basis of the overall Virtual Soundcheck workflow, and are 
also useful for capturing unprocessed audio files of your Stage inputs for later mixdown and editing.
In this example you will see how to perform a complete Virtual Soundcheck using Pro Tools AVB or MADI-192 MADI cards: 

• Record 48 stage sources to Pro Tools 
• Play back all 48 tracks from Pro Tools through VENUE and adjust the mix 
• Switch back to Stage mode and apply or discard mix adjustments as needed 

Before you continue, make sure you have connected and configured your systems and enabled VENUE Link. 



Record the Show

To enable Stage inputs:
1. Make sure the Stage inputs you are using are patched to the desired S6L system input 

channels in the Patchbay. (See the VENUE S6L System Guide.pdf for more information.)
2. On the external VENUE software screen, go to Options > System.
3. In the System Inputs section, make sure Stage is selected.

If Stage is not selected, do the following:
• Put your S6L system into Config mode.
• Select EDIT.
• Select Stage.
• Select APPLY.

In VENUE, Enable Stage Inputs
To send digital splits of S6L system Stage inputs to Pro Tools, the Stage inputs on your S6L system must simply be active. 
Before creating a Pro Tools Session from VENUE via VENUE Link make sure you have enabled Stage Inputs in VENUE as described below.
The pickoff point for each Stage input split is post-analog input gain, but pre-digital trim and channel processing, including the channel HPF. 
Thus, the gain for any input channel sent to Pro Tools is dependent on the S6L input gain setting for that Stage input channel.

5. Check to make sure the System Outputs section shows the destination appropriate 
for your connection(s):  

Virtual Soundcheck Destination: AVB if using only Pro Tools AVB
Virtual Soundcheck Destination: MADI if using MADI-192 MADI Option cards
Virtual Soundcheck Destination: Both if connected for both Pro Tools AVB and

MADI-192 MADI Option cards 
If the current Virtual Soundcheck Destination does not show the correct destination, 
do the following: 
• Make sure the system is still in Config Mode (if not, enable Config mode).
• Select EDIT.
• In the Virtual Soundcheck Destination selector, choose AVB, MADI, or Both. 
• Select APPLY.

6. Proceed to Record the Show. 

Signals from any Stage inputs assigned to S6L system input channels are auto-patched to the connected Pro Tools computer as direct digital 
splits. The corresponding channels under the Pro Tools tab in the Patchbay are highlighted in purple to indicate they are in use as digital 
split outputs and as Virtual Soundcheck inputs.



Record the Show

In Pro Tools:
1. Make sure you have connected and configured the Pro Tools computer for AVB. 
2. Make sure your VENUE channels are arranged where you need them (do not move fader 

strips to new locations after configuring I/O Setup or creating a session). 
3. Launch Pro Tools. If the Dashboard appears, click Cancel. 
4. Choose Setup > IO, click the Bus tab, then do the following:

• Select all Bus paths listed in the Names column. 
• Click Delete Path. 
• Click Default. 

5. Click the Input tab and do the same steps: 
Select all Input paths, click Delete Path, then click Default. 

6. Click the Output tab and do the same steps: 
Select all Output paths, click Delete Path, then click Default. 

7. Click OK to close the I/O Setup dialog. 

Default button in 
Pro Tools IO Setup

VENUE paths in Pro Tools I/O Setup

Important! It is best to always reset the Pro Tools IO Setup to Default when connecting a Pro Tools computer to an S6L system for the 
first time. 
Do this before opening or creating a Session, so that Pro Tools creates Bus, Input and Output paths that correspond to your VENUE 
channels and patching. 
After resetting the IO Setup tabs to Default for VENUE, I/O settings will follow changes to the Playback Engine selection. For example, 
switching Playback Engine back to Aggregate will also change the  I/O settings, and then switching back to E6L automatically reloads 
VENUE paths and settings.
Tip: If the same Pro Tools system is being connected to the same S6L system and neither system has been changed or reconfigured (such as 
during a tour or multi-night run), you do not have to reset I/O Setup to Default before every performance/recording. However, if you are 
connecting a different Pro Tools computer or a different S6L system, or if ever in doubt, reset the IO Setup tabs as described above. 

Configure Pro Tools I/O Setup
After enabling VENUE Link and enabling Stage inputs, do the following to configure the Pro Tools I/O Setup with VENUE paths. 



Record the Show

Create Session from VENUE
In Pro Tools:

In the new Pro Tools Session:
• Mono and stereo tracks are created for all S6L system mono and stereo input channels that have Stage inputs assigned to them.
• Tracks are named automatically based on their corresponding Stage input channel names. Duplicate track names are appended incrementally 

(such as “.1,” and “.2,”).
• Track input and outputs are automatically assigned in Pro Tools, and are shown in the Track I/O selectors.
• Track outputs follow input assignments one-for-one to facilitate Virtual Soundcheck.
• Track order (top to bottom in the Edit window and left to right in the Mix window) follows the channel order on your S6L system.
(If no tracks are created, check the VENUE Options > System page: Make sure Stage is enabled in the System Inputs section, then try to 
Create Session from VENUE again.) 

1. Choose File > Create New. 
2. In the Dashboard, click the Location button and specify a location on an external drive for 

the session folder (which contains the Session .ptx file, audio files, and other session data). 
3. In the Dashboard, do the following: 

• Choose Create from VENUE from the selector.
• If desired, enter a custom Name for the session. 
• Configure other session parameters such as File Type and Bit Depth as desired. 

Sample Rate is fixed at 96 kHz. (Important: For Bit Depth, do not use 32-bit Float.) 
6. Click Create.  
Pro Tools creates a new Session based on your VENUE configuration. 

Pro Tools Dashboard (File > Create New)

Pro Tools Track I/O assignments after creating a session from VENUE

To also record L/R Mains, “stems” (submixes of any combination of channels), or audience mics you can use VENUE Assignable I/O. 

For additional information and examples, see About Track Assignments in Pro Tools. 



Record the Show

Output Levels to Pro Tools for Recording
Because the direct digital splits of Stage inputs to Pro Tools are post-analog gain and pre-digital trim, output levels to Pro Tools are set by each Stage 
unit’s Master E6L. Any changes made to the input gains of Stage inputs by its Master E6L affect recording output levels to all DAW computers. 
Also, Pro Tools meters can be configured for VENUE Peak or RMS ballistics (see VENUE Metering Options in Pro Tools). 

Record the Show
To start recording: 
1. In Pro Tools, arm the Transport and record enable all tracks. 

Tip: You can arm the Pro Tools Transport directly from the S6L control surface via VENUE Link. With VENUE Link enabled, press the S6L Trans
switch to place F1-5 in Transport mode, then press F5/Record. You can also control Pro Tools track record enable states directly from the S6L 
control surface using custom Events. For an example, see Using Events to Record Enable Tracks. 

2. To start recording: 
• Press Play in the Pro Tools Transport window.
Or on S6L with VENUE Link enabled: 
• First press Trans to enable Transport mode. 

• Then press F4/Play.

Pro Tools Edit, Transport, and Big Counter windows, recording

Tip: After learning the basics of Virtual Soundcheck, see Creating Pro Tools Markers from Snapshots. Markers created by and linked to 
VENUE Snapshots can greatly simplify session navigation later during playback and Virtual Soundcheck. 



Play Back the Show and Perform a Virtual Soundcheck

To playback from Pro Tools and adjust the mix: 
1. On the VENUE system, enable Config mode. 
2. Navigate the external screen to Options > System, then do the following:

• Select EDIT. 
• In the System Inputs section, enable the appropriate Pro Tools Virtual Soundcheck mode 

(Virtual Soundcheck AVB or Virtual Soundcheck MADI).  
• Select APPLY.  

3. In Pro Tools, locate the session to the desired song or location, make sure no tracks are record-
enabled, and begin playback. 

4. On the VENUE system, do any of the following while playing back the Pro Tools tracks: 
• Adjust levels, panning, and Input gain.
• If you adjust gain, update any snapshots in which Input 

is scoped. Edit and create other snapshots as needed. 
• Adjust plug-in settings. 
• Roam the seats to check your house mix at different 

locations; go on-stage to listen to monitor mixes. 

Tip: You can use ECx Ethernet Remote Control to be able to work the 
console remotely using a tablet (see the  ECx Ethernet Control Guide.pdf 
for more information). For simple level and pan control of different Aux-
based mixes you can also use VENUE | On-Stage with a compatible iPad 
or iPhone (see the VENUE On-Stage.pdf for details).

While in Pro Tools Virtual Soundcheck mode all adjustments are 
applied instantly to the currently loaded Show file. Be sure and 
Overwrite (store to disk) the currently loaded Show file, or 
create a new Show file to retain those settings. When ready to 
switch back to Stage input mode, if you made changes to input 
gain while in playback you will be prompted to apply or ignore 
those changes to the Stage Rack pre-amps. For the Virtual 
Soundcheck work flow you will most often apply those changes.

Play Back Tracks from Pro Tools through VENUE and Adjust the Mix
The essential parts of Virtual Soundcheck are switching VENUE to Pro Tools Virtual Soundcheck mode, playing back the pre-recorded tracks 
through your VENUE system and making adjustments, then switching back to Stage mode to be ready for the next performance. 

Pro Tools Edit, Transport, and Big Counter windows, playing

Rehearsing during Playback   After learning how to perform a complete Virtual Soundcheck, see Toggling the Input Source of a Channel to see how you 
can play back a previous performance while allowing one or more performers to rehearse, check their monitor mixes, and more. 



Switch Back to Stage Mode

Switch Back to Stage Mode 
1. On the VENUE system, enable Config mode. 
2. Navigate the external screen to Options > System. 
3. Select EDIT. 
4. In the System Inputs section , click to enable Stage. 

If you made changes to Input gain, you are asked to Apply or Discard them. 

• Select APPLY to update VENUE Input gain settings with the changes you made in Pro Tools Virtual Soundcheck mode. 
• Select DISCARD to ignore any changes to VENUE Input gain (gain settings will be restored to their previous values, prior to entering 

and existing Pro Tools Virtual Soundcheck Input mode). 
The system switches back to Stage mode, ready for the next performance. 

Adjusting Gain When Switching Between Sources
The S6L system uses a hybrid analog/digital gain approach for analog Stage inputs. Input gain is adjusted in 1 dB analog steps, and 0.1 dB digital steps. When switching to a 
Virtual Soundcheck input, the digital component of the gain stage (up to +0.9 dB) is preserved, so the Virtual Soundcheck input plays back at the same level as its corresponding 
Stage input. As a result, input gain settings never vary across Virtual Soundcheck inputs by more than 0.9 dB.
For example, if you set the input gain for a channel to +30.5 dB, then switch to its Virtual Soundcheck input, +0.5 dB of gain is preserved and displayed in the Gain setting on-
screen, resulting in the same apparent input level on that channel (because 0.5 dB of the 30.5 dB setting was digital gain as compared to analog gain).
While in Virtual Soundcheck mode, if you increase the gain on this channel by 6 dB (to a displayed setting of +6.5 dB), and then switch back to Stage mode, you can do one of 
the following:
•   Apply the gain change, yielding a gain increase of 6 dB, or a final setting of +36.5 dB (30+6.5).
– or –
•   Discard the gain change, leaving the original Stage input gain unchanged at +30.5 dB.



Assignable I/O
Record L/R Mains, Stems, Audience Mics, and More 

When using Virtual Soundcheck, all Stage inputs assigned to S6L system input channels become Pro Tools “auto-patched” channels. In the 
Patchbay, their routing to and from Pro Tools is automatically set in a 1-to-1 relationship with their corresponding Stage input. 
All Stage inputs that are not assigned to S6L system input channels in the Patchbay become available as Pro Tools Assignable I/O. The maximum 
number of Assignable I/O channels available for simultaneous recording and playback depends on the current AVB configuration (64 or 128), 
minus the number of Stage inputs that are assigned to S6L system input channels. 

Examples
• On older systems with one AVB-192 Network Card, up to 64 total Pro Tools channels are available. If 48 Stage inputs are assigned to S6L 

system input channels, 16 Assignable Pro Tools output channels and 16 Assignable Pro Tools input channels are available. 
• On systems with two AVB-192 Network Cards, up to 128 total AVB channels are available. If 64 Stage inputs are assigned to S6L system input 

channels, 64 Assignable Pro Tools output channels and 64 Assignable Pro Tools input channels are available. 

Direct Outs and Assignable Output Busses
Pro Tools Assignable I/O can be used in two ways: You can patch input and output channel Direct Outs to Pro Tools for recording, and you can 
also route Mains, Auxes, mono or stereo Groups, and Matrixes to Pro Tools assignable outputs for recording. 
• Direct Outs let you record discrete channels from the pickoff point of your choice, with independent level control over each send to Pro Tools. 

Each S6L system input and output channel provides a Direct Out. Remember, the total number of available Direct Outs to Pro Tools depends 
on the AVB configuration (64 or 128) minus the total number of Stage inputs patched to input channels. Common uses for Direct Outs include 
recording VENUE input channels that are used as FX Returns, and recording audience mics located at FOH. 

• You can also record submixes (aka stems) by multi-assigning outputs such as Mains, Auxes, Groups, and Matrixes to Pro Tools. An output bus 
signal to Pro Tools is always post- fader, and therefore will reflect any processing occurring on the channels assigned to the bus or processing 
on the bus itself. An output bus can be assigned to multiple output destinations.

How to Get Started
Configuring and using assignable outputs involves the following steps, detailed on the next few pages: 
Configure the Patchbay Identify or create available I/O.
Assign Direct Outs in the Patchbay Assign channel Direct Outs to Pro Tools destination channels. 
Enable and Adjust Direct Outs Activate channel Direct Outs and adjust output level, from the control surface or external screen.
Assign Bus Outputs Assign VENUE outputs directly to Pro Tools.



Assignable I/O
Configure the Patchbay

Configuring the Patchbay
1. On the external screen, go to the Patchbay page and select the Inputs tab. 
2. Select a Stage IO device tab that you know has unused hardware input channels. In the image below, Stage 1 is selected. 
3. Unpatch any Stage inputs you are not using to make those channels available for assignable I/O. For more information on the Patchbay 

and how to patch and unpatch channels, see the VENUE S6L System Guide.pdf.
Shown below is an example image of the Patchbay > Inputs tab, showing Stage 1 inputs 41-48 unpatched. We will use these channels
(41-48) as Pro Tools Assignable I/O. 

All Stage inputs that are not assigned to S6L system Input Channels in the Patchbay become available as Pro Tools Assignable I/O. 
Use the Patchbay to identify and, if necessary, create available Assignable I/O.  In the previous Pro Tools AVB Virtual Soundcheck example we 
showed how to record 48 S6L Input channels to Pro Tools. On an S6L system with a single AVB-192 Network Card and a single Stage 64 with 
48 hardware inputs, this leaves 16 channels available to use as Assignable Pro Tools I/O (64 maximum Pro Tools paths minus 48 S6L Stage 
inputs patched to Input Channels. 

Available Stage inputs

Inputs tab of the Patchbay

1

2

4. After identifying and/or creating available channels, proceed to Assignable I/O: Direct Outs. 



Assignable I/O: Direct Outs

To assign channel Direct Outs to Pro Tools:
1. On the external screen, go to the Patchbay page and select the Directs tab.
2. Select the tab at the left of the grid for the channel or output type you are routing.

• “T” (Top of Channel)/Mains/Aux/Group/Matrix 
• “I” (Insert Return); available on Input Channels only
• “p” (Pre-Fader Post-Mute
• “P” (Post-Fader) 

(For Input channels, the Pre-/Post-Fader Direct Output 
Pickoff Point is configured globally on the Options > Pickoffs 
page.)

6.Proceed to Enable and Adjust Direct Outs on the next page. 

Assigning Direct Outs
You can assign Direct Outs on any S6L input or output channels for recording. After assigning, enable the Direct Out(s) and set its output level. 

3.Select the Pro Tools tab at the top right of the grid. 
Available Pro Tools channels are dark grey; outputs 
reserved for use as digital splits (Pro Tools “auto-
patched”) are purple in the channel grid.

4.Touch in the channel grid to assign a channel or bus 
(listed on the left) to a Pro Tools output channel 
(listed across the top). 
When prompted, confirm the assignment. 
In the image to the right, a stereo reverb return 
(Revibe L/R) is patched to  Pro Tools 41 and 42. 

5.Click the Pickoff column in the Patchbay to specify 
one of the following pickoff sources for each Direct 
Output (choices vary for inputs versus outputs):

2

3

4

1

5

Reserved
(purple)

Available
(dark grey)

Pro Tools Assignable channels can be fed in two ways: You can patch input and output channel Direct Outs to Pro Tools for recording, 
and you can also route Mains, Auxes, mono or stereo Groups, and Matrixes to Pro Tools assignable outputs for recording. 



Assignable I/O: Direct Outs

Enable and Adjust Direct Outs
After routing a Direct Out to Pro Tools you must turn each channel’s Direct Out on and set its level. 
You can do this from the external screen or from fader strips. 

To enable a Direct Out and adjust its level from the external screen (see image at right): 
1. Navigate the external screen to the Inputs or Outputs page, and Select (or Attention) 

the desired channel. 
2. Turn the channel’s Direct Out on (so IN and the encoder are lit green. 
3. Rotate the on-screen encoder to set the Direct Out level.  

To enable a Direct Out and adjust its level from a CKM using Channel Control:  
1. Bank the desired output bus to the surface.  
2. Press Select on the strip for the output bus (the CKM enters Channel Control mode). 
3. On the CKM press Input. 
4. To turn on the channel’s Direct Out, press the encoder under the display showing 

Dir Out. The encoder In LED lights green.
5. Rotate the encoder to adjust the Direct Out level of the channel.

Direct Out controls on a CKM

1

2

Direct Out controls on the Inputs page of the external screen

3

Tip: You can define an Event to bring channel Direct Outs to the faders. In the Control > 
Events screen, create a new Event and choose a desired Trigger (such as a Channel Color 
switch). From the Add Action menu, choose “Continuous Control on Fader” and  then 
choose the desired channel > “Direct Out.” 



Assignable I/O: Bus Outputs

2

3

4

1

5

Routing an Output bus to Pro Tools in the Outputs tab of the Patchbay

Assigning VENUE Output Busses to Pro Tools

To assign VENUE Output busses to Pro Tools:
1. On the external screen, go to the Patchbay page and select the Outputs tab.
2. Select the tab at the left of the grid for the output type you are routing (in the example shown below, MAINS is selected).

You can send output busses such as Mains, Auxes, Groups, and Matrixes to Pro Tools to record submixes (“stems”) by assigning them to Pro Tools 
channels. 
Important: Unlike VENUE Direct Outs, an output bus signal assigned to Pro Tools as shown in the following steps is always post- fader, and 
therefore will reflect any processing occurring on the channels assigned to the bus or processing on the bus itself. 

3.Select the Pro Tools tab at the top right of the 
grid. Available Pro Tools outputs are dark grey; 
Pro Tools “auto-patched” outputs (those in use 
as digital splits) are purple in the channel grid.

4.Touch in the channel grid to assign a bus (listed 
on the left) to an available Pro Tools output 
channel (listed across the top). 
When prompted, confirm the assignment. 
In the example shown at right, MAINS LR are 
assigned to Pro Tools 43 and 44, respectively. 

5.Set the levels for the recording by adjusting the 
faders or Global Control encoders for the buses 
you are sending to Pro Tools.

6.Configure Pro Tools for recording.

See also Using Assignable Inputs for Playback. 



VENUE Metering Options in Pro Tools
You can set the metering in Pro Tools to mirror the current Meter setting on your S6L system.  
S6L Metering is configured in the Options > Interaction page. 

Track input meters and the master Output Meter in the Pro Tools Transport can be set to different meter scales.
To set Pro Tools metering to mirror S6L meter settings:
• In Pro Tools, right-click any track meter and/or the master Output Meter and choose either of the following:

VENUE Peak This option mirrors the Peak Ballistics meter setting on your S6L system.
VENUE RMS This options mirrors the RMS Ballistics meter setting on your S6L system.

Setting the Meter mode for the Pro Tools master Output Meter

VENUE Metering settings in Options > Interaction



Controlling Pro Tools from the S6L Control Surface

You can control the Pro Tools Transport(s) using the F1–F5 switches on the MLM of the S6L control surface.

When two Pro Tools systems are connected, and VENUE Link is enabled on both systems, the S6L control surface can control both of their 
Transports simultaneously for redundant recording. 

You must enable VENUE Link on your S6L system and in Pro Tools to use the transport controls. See Enabling VENUE Link for more information.

To control the Pro Tools Transport using the F1–F5 switches:
1. Press the Trans switch so it lights.
2. Press any of the following F1–F5 switches:

• F1 Is reserved for future use.
• F2 Is reserved for future use.
• F3 Stops the Pro Tools Transport.
• F4 Initiates playback in the Pro Tools Transport.
• F5 Arms the Pro Tools transport and initiates recording.

You can also assign the available Pro Tools Transport and recording commands to other S6L controls (including Footswitches) using Events. For 
one specific example, see Using Events to Record Enable Pro Tools Tracks.  



Creating a Pro Tools Marker from a Snapshot
With VENUE Link enabled, you can set individual snapshots to create a new Marker in the Pro Tools Timeline. While Pro Tools is recording, whenever 

that snapshot is recalled, a new Marker is created and named according to the recalled snapshot.
Once the marker is created, subsequent recalls of that snapshot can locate (cue) the Pro Tools playback cursor to the associated Marker while Pro Tools 
is playing back. In performance, this is a great way to precisely control Pro Tools playback for sound effects, beds, or backing tracks. For subsequent 
mixdown or for Virtual Soundcheck, you have a fully archived session in which you can quickly navigate to specific songs or cues.

In VENUE, you can enable or disable individual Snapshots from creating Pro Tools Markers. In Pro Tools, you can edit VENUE-generated Markers to 
rename them, move them to a different location in the Timeline, disable snapshot “chase,” and re- associate a Marker with a different snapshot.

To create a Pro Tools marker from a VENUE snapshot:
1. On the external VENUE software screen, go to the Snapshots page.
2. In the Snapshots list, select the Marker icon to enable that snapshot to create a Pro Tools Marker when that snapshot is recalled during recording.

(If the Marker icon is not displayed, right-Click one of the Snapshots in the list and choose Unhide Marker.)

Lit Marker icons in the Snapshots list

Shift-Click multiple Snapshots and toggle the Marker icon to enable or disable multiple consecutive Snapshots in the Snapshots list. Control-Click 
multiple Snapshots to select multiple non-consecutive Snapshots. Right-Click in the Snapshots list and choose Select All to select all Snapshots.

3. In Pro Tools, locate the Markers ruler. If you do not see it, choose View > Rulers > Markers.
Click the track’s Record Enable button. The Record Enable button flashes when enabled, and lights solid when engaged. 
To record enable all tracks at once, Alt-Click (Windows) or Option-Click (Mac) one track Record Enable button.

4. In the Edit window toolbar, or in the Transport window (Window > Transport) click the Record button to arm the Transport.
5. In Pro Tools, press the Spacebar to start recording.
6. On your S6L system, recall a snapshot.
7. Recall any other Snapshots on your VENUE system as required. Markers appear in the Pro Tools Markers ruler for any recalled VENUE 

Snapshots, and are automatically named to match the corresponding VENUE snapshot.

Pro Tools Markers ruler showing snapshot-generated Markers



Creating a Pro Tools Marker from a Snapshot
To locate to a Pro Tools marker when recalling a snapshot:
1. Make sure Pro Tools is launched and a session is loaded with Markers created from VENUE snapshots.
2. On the external VENUE software screen, go to the Snapshots page.
3. In the Snapshots list, do the following:

• Select a snapshot that is associated with a Pro Tools Marker so the snapshot is highlighted.
• Select its Marker icon so that it lights green.
• Select the Recall Snapshot Command button

If Pro Tools is playing back, playback continues when recalling any snapshot associated with a Pro Tools Marker.

Editing Markers Created from VENUE Snapshots
A Marker linked to a VENUE snapshot can be edited like any other Pro Tools Memory Location. You can rename Markers, move Markers, disable 
snapshot “chase,” and re-associate a Marker with a different VENUE snapshot.

For complete information on Memory Locations, see the Pro Tools Reference Guide.

To rename a Memory Location for a Marker:
1. In the Pro Tools Edit window, double-click the Marker in the Markers ruler to open the Edit Memory Locations dialog.
2. Enter the new name for the Memory Location and Click OK. The edited marker remains linked to the VENUE snapshot.

To move a VENUE snapshot-generated Marker:
• In the Markers ruler in Pro Tools, drag the Marker left or right.

If you move a VENUE snapshot in the Snapshot list, it will still remain linked to the associated Marker.

To disable locating to a VENUE snapshot-generated Marker (snapshot “chase”):
1. In the Pro Tools Edit window, double-click the Marker in the Markers ruler to open the Edit Memory Locations dialog.
2. In the General Properties section, deselect VENUE Snapshot.
3. Click OK.
Recalling the VENUE snapshot does not locate the Pro Tools playback cursor to the disabled Marker. Re-selecting this option restores the locate 
functionality.

To associate a Marker with a different VENUE snapshot:
1. In the Edit window, double-Click the Marker in the Markers ruler to open the Edit Memory Locations dialog.
2. In the General Properties section, next to VENUE snapshot, choose a different VENUE snapshot from the pop-up menu.
3. Click OK. The selected VENUE snapshot locates the Pro Tools playback cursor to the edited Marker.



Snapshot PRE Settings and Virtual Soundcheck
The PRE Data Type Scope button on the Snapshots page lets you recall the preamplifier settings on inputs for all scoped input channels. Go to 
the Options > Snapshots page to set the PRE parameters to be recalled by the PRE data type button.

The data in the table below shows which PRE setting can be stored and recalled with Snapshots when Virtual Soundcheck inputs are enabled.

PRE settings stored and recalled with Snapshots in Virtual Soundcheck mode

PRE Parameter Recall Store

Phase Yes Yes

Gain No No*

Phantom Power No No

Pad No No

* Gain changes made while in Virtual Soundcheck mode can not be stored to Snapshots, but can be applied back to the analog 
settings when switching back to Stage mode.



Importing VENUE Channel Names as Track Names
You can import VENUE channel names as track names into an existing Pro Tools session. You can use this option in the following ways:
• If you have created a session from VENUE, but prior to recording you have changed the names of channels in VENUE, use this feature to 

update track names automatically.
• If you are working from an existing template that includes the VENUE channels plus a variety of other channels (such as effects returns) use 

this feature to update the VENUE-related track names without affecting the other non-VENUE tracks.

If you have added a channel to the currently loaded Show file that does not have a corresponding Pro Tools track, create a new track, set the 
input assignment, then choose Import > VENUE Channel Names as Track Names to import names.

To import VENUE channel names into an existing Pro Tools session:
1. Make sure your S6L system is in Stage mode.
2. In an existing Pro Tools session, from the File menu, choose Import > VENUE Channel Names as Track Names.
Track names are imported the same way as when you create a session from VENUE.  However, I/O routing for all tracks do not change, and no 
new tracks are created.



Working with Pro Tools in Shared I/O Configurations
In shared I/O configurations, one Pro Tools system or other digital audio workstation (DAW) can be paired with one E6L. In most cases you will 
want to pair the Pro Tools computer to the E6L (or S6L) to which the computer is connected. However, any DAW on the network can be paired 
with any E6L on the network. 
After making connections and installing any VENUE software updates on all S6L systems, enable AVB on each computer, set the Pro Tools 
Playback Engine, and enable VENUE Link. Make sure all S6L systems are running the same VENUE software version.

Pair each Pro Tools system to its corresponding E6L before connecting E6L engines for a shared input configuration. Do not make the 
connections between E6L engines until each Pro Tools computer has been paired to the desired E6L.
Also, do not connect the ECx port directly to a LAN such as a corporate network which contains other types of devices. Doing so may disrupt 
the device discovery mechanisms used by some S6L components, including I/O Sharing.

!

Setting Output Levels to Pro Tools for Recording
Because the direct digital splits of Stage inputs to Pro Tools are post-analog gain and pre-digital 
trim, output levels to Pro Tools for splits of Stage inputs to all DAWs in the network are set by 
each Stage I/O unit’s Master E6L. Any changes made to the input gains of Stage inputs by its 
Master E6L affect recording output levels to all DAW computers. 
For a comprehensive presentation of gain in I/O Sharing configurations, including True Gain, 
watch the Input Sharing & Gain Tracking video. 

Using Assignable I/O
Assignable I/O between your E6L and your DAW computer are available, up to the maximum number of available Pro Tools I/O channels and are 
not shared among the other E6Ls in the network. You can use assignables, for example, to assign Direct Outputs of system channels for an 
additional gain stage before Pro Tools.

To make sure Pro Tools Assignable I/O is available, in the Patchbay unassign Stage inputs from any S6L system Input Channels that you are 
not using. See Configure the Patchbay for more information.

Performing Virtual Soundchecks in Shared Input Configurations
Each E6L and its paired DAW computer can perform discrete Virtual Soundchecks. You can engage Virtual Soundcheck mode globally or on a per-
channel basis freely without affecting the other systems, and make adjustments in any mode as if the systems were completely separate, 
including adjusting input gain levels, and have those adjustments carry over to the live Stage inputs.
To ensure proper Stage input gain settings when performing a Virtual Soundcheck in a shared input configuration, do either of the following:
• Make sure the Pro Tools session you are using for Virtual Soundcheck was recorded using the same Stage unit Master/Slave configuration as 

the currently loaded Show file.
• If you make any adjustments to input gain while performing Virtual Soundchecks, be sure to update any snapshots in which Input is scoped.
• Be sure to Overwrite any version of that Show file stored on the control surface to preserve the changes you just made.

Visit www.avid.com/S6Lsupport for important information on playing back Pro Tools tracks recorded from your system.
To learn even more, visit the S6L Workflows series on YouTube. New videos are frequently added that focus on this and other related topics. 

https://youtu.be/q_pvi7y2VGs
http://avid.force.com/pkb/articles/faq/Avid-S6L-Support
http://www.avid.com/S6Lsupport
https://www.youtube.com/watch?v=0RJMeyALltk&list=PLhCR_8aS9jOPiy-yvo4M4GUQVVxkLAmf2
https://youtu.be/q_pvi7y2VGs


About Track Assignments in Pro Tools
This page provides additional details about tracks assignments in Pro Tools when using the Create from VENUE feature of VENUE Link.
After creating a Pro Tools session using the Create from VENUE feature, new tracks appear in the Pro Tools Edit and Mix windows as follows, 
depending on the type of S6L system channel:

Direct Digital Splits (Pro Tools “auto-patched”) In the new Pro Tools session, mono and stereo tracks 
are created for all S6L system mono and stereo input channels that have Stage inputs assigned to 
them. Tracks are named automatically based on their corresponding Stage input channel names. 
Duplicate track names are appended incrementally (such as “.1,” and “.2,”). 

Mono Stage 
input track

Duplicate 
track

Stereo Stage 
input track

Stage input tracks in the 
Pro Tools Edit window

Track I/O selectors showing I/O 
assignments for digital splits

Track output
Track input

Tracks are created for any Stage input channels patched in the VENUE Patchbay. To avoid creating tracks for unneeded inputs, go to Patchbay 
> Inputs in VENUE and deselect any unwanted Stage input channels (click in the patching grid to unassign).

Track input and outputs are automatically assigned in Pro 
Tools, and are shown in the Track I/O selectors.
Track outputs follow input assignments one-for-one to 
facilitate Virtual Soundchecks. Track order (top to bottom 
in the Edit window and left to right in the Mix window) 
follows the channel order on your S6L system.

Assignable Outputs In the Pro Tools session, new mono and stereo tracks are created for any S6L system 
channels patched to Assignable outputs under the Pro Tools tab in the VENUE Patchbay patching grid. 
Tracks are named automatically based on their corresponding channel names in VENUE.
Track names are appended with the corresponding output type as follows:

Stereo 
Direct Out

Stereo Group

Mono Aux

Mono Matrix

Imported track names 
for Assignables

VENUE Channel Type Track Name AppendedWith

Group (Grp)

Aux (Aux)

Matrix (Mtx)

Mains (Left-
Right) 
(Center) 
(Mono)

Monitor (Mon)

Direct Out (Dir)

Plug-in output (PI)

Track output
Track input

Track I/O selectors showing I/O 
S6L Assignable outputs

By default, all track output paths for Assignable outputs are 
assigned to Bus 1-2 in Pro Tools. This routing can be 
changed in Pro Tools. (To monitor Assignables through S6L, 
go to the Patchbay and manually assign them to S6L Input 
Channels as explained in Using Assignable Inputs.)

Track input and outputs are automatically 
assigned in Pro Tools, and are shown in 
the Track I/O selectors.



Using Events to Record Enable Pro Tools Tracks

This example shows how to define an Event to be able to quickly toggle the record enable status of tracks in Pro Tools directly from the S6L 
control surface.  
To create a Soft Key to record enable tracks in Pro Tools: 
1. Navigate the S6L external screen to the Control page. 
2. Select the last Event currently in the Event list, tap NEW, then double-click the default Event name (<Untitled>) and enter a descriptive name 

for the new Event (such as “Track Record Enable”). 
3. In the Triggers section, click the Add menu and select a switch (such as  Function Switch > Function Switch 12). 
4. In the Actions section, click the Add menu and select Pro Tools > Record Enable All VENUE Tracks. 
5. Click the Actions Add menu again and select Light Function Switch > Light Function Switch 12. 
Pressing F12 (Function switch 12) now record enables all VENUE tracks in the connected Pro Tools session. 

1

2

3

4

Creating an Event to record enable all VENUE tracks Adding an Action to the new Event



To toggle the input source for an input channel on the external screen:
1. Select an input channel that has a Stage input assigned to it.
2. From the on-screen Inputs page, Click the Virtual Soundcheck input 

button (indicated by a Pro Tools icon) in the Input section.

The lit button indicates that the Virtual Soundcheck input is now the 
source for the channel. A Pro Tools icon appears in the Patchbay > Inputs 
tab patching grid for the affected channel only.

Toggling the Input Source of a Channel
You can toggle the input source of an individual input channel between the assigned Stage input and its corresponding Virtual Soundcheck input 
from Pro Tools, regardless of the global input source setting on the Options > System page. You can toggle the input source from the S6L control 
surface using the CKM in Channel Control mode, from  the Channel Menu, and from the external screen.
Input toggling can be useful if, for example, you have enabled Virtual Soundcheck inputs globally, and the singer or a new performer arrives 
before the rest of the band to rehearse along with pre-recorded tracks from a previous performance.

To toggle the input source for an input channel in Channel Control mode:
1. Bank the desired channel to the faders.
2. Select the desired channel.
3. Press the INPUT Channel Control Function switch on the associated CKM so it lights. Or, touch the channel’s Input touch zone on the 

associated Channel Touch Module (CTM).
4. Press the encoder under the display showing PT Input. The encoder In switch lights, and the encoder surround in the display fills in to 

indicate the Pro Tools Virtual Soundcheck input is now the input source for the selected channel.

A channel display showing a Stage input source (Left) and a Pro Tools input source (right)

Virtual Soundcheck input button

To toggle the input source for an input channel using the Channel Menu:
1. Bank the desired channels to the control surface’s faders.
2. Press the desired channel’s channel strip Menu switch until Source 

appears in the channel display.
3. To route the Stage input to the channel, press the Left Menu switch so 

it lights. The hardware source is shown in the channel display.
4. To route the Virtual Soundcheck input to the channel, press the Right 

Menu switch so it lights. The Pro Tools source channel is shown in the 
channel display.

The same gain change rules apply when the source for an individual channel is toggled between sources.

A single input channel with a Virtual Soundcheck input in the Patchbay > Inputs page

!



Using Assignable Inputs for Playback
You can route channels from Pro Tools to S6L system Input Channels for playback. You can use this feature to use pre-recorded click tracks or 
other material in a performance, to mix down the Pro Tools session using your S6L system, or for monitoring the Pro Tools recording through 
your S6L system.

To route Pro Tools assignable inputs to Input Channels:
1. On the external screen, go to the Patchbay page and select the Inputs tab.
2. Select the tab at the left of the grid for the channels you want to route.
3. Select the Pro Tools tab at the top right of the grid. Available Pro Tools inputs are dark grey; inputs reserved for use as Virtual Soundcheck 

inputs are purple.
4. Touch in the channel grid to assign a Pro Tools input (listed across the top) to an available Input Channel.
5. After patching, assign the Pro Tools assignable input as needed:

• Assign to the main L/R bus to include Pro Tools audio in the main mix of a performance.
• Assign to a Group, Aux, or Matrix for submixing and monitoring.

To avoid potential feedback loops, make sure no channels are simultaneously routing to and receiving from any record-enabled Pro Tools 
tracks.

Monitoring Pro Tools Recordings
You can monitor a Pro Tools recording through your S6L system while the performance and the recording are in progress. This procedure shows 
how to monitor a stereo mix from Pro Tools on an S6L system stereo input channel.
On the VENUE System
To monitor a Pro Tools Recording:
1. Patch Pro Tools assignable inputs as described above. It is recommended that you use an odd-even pair of inputs (such as 19–20).
2. Make sure that the input channel is not assigned to an output bus such as the Mains or a Group.
3. To monitor the recording, press the Solo switch for the input channel.
To hear panning in Pro Tools, set your VENUE system solo mode to Stereo AFL.

!

Output Path selector

On the Pro Tools System
To monitor a Pro Tools Recording:
1. Launch Pro Tools and, if necessary, create a session, and create and name tracks.
2. In your Pro Tools session, click any Track Output selector.
3. From the menu, select Output and choose the output pair that corresponds to 

the Pro Tools inputs you patched in the VENUE Patchbay.
4. Assign all tracks in the session to the same output pair. 

To auto-assign all tracks to the same output, hold down Option (Mac) or Alt (Windows) on your Pro Tools computer keyboard while assigning any track 
output.

5. While Pro Tools is recording, you can adjust Pro Tools faders and pan without affecting the recording.



Using Input Mode
When Input mode is enabled, Pro Tools (or another Ethernet AVB source) is the main source of audio signals for your S6L system. Audio 
channels from your external device appear one-for-one in place of Stage inputs in the VENUE Patchbay.
In Input mode, changes made to Input Gain cannot be applied to channels when switching back to Stage inputs. Additionally, input channel Gain 
can be stored in Snapshots in Input mode.

To enable Input mode:
1. Put your S6L system into Config mode.
2. On the external screen, go to Options > System.
3. Select Edit.
4. In the SYSTEM INPUTS section, select  Pro Tools.
5. From the pop-up menu, choose Input Mode AVB or Input Mode MADI. 

For complete information on integrating MADI Option cards into Virtual Soundcheck, see the MADI-192 MADI Option Card.pdf.
6. Click Apply. All S6L system input channels with Stage inputs assigned to them are replaced by corresponding inputs from Pro Tools, and Pro 

Tools icons appears in the Patchbay Patching Grid for the affected channels.

Adjusting Input Gain in Input Mode
In Input mode, Input Gain is adjusted using the Gain encoders. Digital gain (-20 dB to +18 dB) is available for all inputs.
When switching from Stage mode to Input mode, the Input Gain settings when Input mode was last enabled are recalled. If Input mode has not 
been previously enabled, Input Gains are set to 0 dB.
When switching from Input mode to Stage mode, the Input Gain settings when Stage inputs were last enabled are recalled.

PRE Parameter Recall Store/Overwrite

HPF freq and state Yes Yes

Phase Yes Yes

Gain Yes Yes

Phantom Power No No

Pad No No

Snapshot PRE Settings in Input Mode
The PRE Data Type Scope button on the Snapshots page lets you recall the preamplifier settings on inputs for all scoped input channels. Go to the 
Options > Snapshots page to set the PRE parameters to be recalled by the PRE data type button.
The data in the table below shows which PRE setting can be stored with Snapshots created in Input mode.
PRE settings stored and recalled with Snapshots in Input mode



MADI Setups for Record/Playback

MADI-192 MADI Option Card
• Requires one or more MADI-192 MADI Option Cards 

(sold separately) installed in the E6L Engine.
• Great for redundant multi-tracking to Pro Tools or other MADI devices.
• Supports digital splits (1-for-1 input splits) and/or sub-mixes/stems.
• Supports 48k recording (via SRC on the receiving MADI device). 
• Requires one or more Pro Tools | HD MADI IO or Pro Tools | MTRX audio 

interfaces, or similar MADI-compatible devices. 
• Because the MADI-192 MADI Option Card provides MADI inputs and 

outputs, Virtual SoundCheck is supported.
• The Pro Tools license must be present on the Pro Tools iLok (if you are 

renting a system, be sure the Pro Tools iLok with these licenses is included).
• Be sure the systems are properly synchronized via Word Clock (for more 

information see the VENUE S6L System Guide.pdf).  

Stage 64 MADI Splits
• Works out-of-the-box (each Stage 64 includes MADI Out connectors for up 

to 64 MADI channels).
• Supports direct digital splits only (1-to-1 split of all Stage inputs; no sub-

mixing or stems, and no patching to these MADI outputs)
• Great for redundant multi-tracking to Pro Tools or other MADI devices (1-

to-1 split of Stage inputs only). 
• Supports 48k recording (via SRC on Stage 64 MADI Outs and/or on receiving 

MADI device).
• Does not support Virtual SoundCheck (no MADI inputs on Stage 64).
• VENUE Link support limited to Transport control.
• Requires one or more Pro Tools | HD MADI IO or Pro Tools | MTRX audio 

interfaces, or similar MADI-compatible devices. 

In addition to Pro Tools AVB, you can also use either (or both) of the following MADI solutions (not all support true Virtual Soundcheck).

I want to do this, how do I start?  
• See Stage 64 MADI to Pro Tools Connections and Settings.

I want to do this, how do I start?  
• See MADI-192 MADI Option Card Connections and Settings, then configure VENUE Link. 
• After making connections and settings, see  Virtual Soundcheck Example. 



MADI-192 MADI Option Card Connections and Settings

To connect MADI-192 MADI Option Cards to Pro Tools | HD MADI:
1. Confirm that Pro Tools and the Pro Tools | HD MADI or Pro Tools | MTRX are installed and operating correctly. 
2. Using a coaxial cable, connect the MADI 1 Out on the MADI-192 MADI Option Card to the MADI Coaxial In 1 port on the 

Pro Tools | HD MADI (if connecting to a Pro Tools | MTRX connect to the built-in MADI In (up to 64 channels) or to connectors on the Dual-
MADI Option Card). Optional:  Repeat for additional MADI channels. 

3. Using another coaxial cable, connect the MADI 1 In on the MADI-192 MADI Option Card to the MADI Coaxial Out 1 port on the 
Pro Tools | HD MADI (if connecting to a Pro Tools | MTRX connect to the built-in MADI Out (up to 64 channels) or to connectors on the 
Dual-MADI Option Card). Optional: Repeat for additional MADI channels. 

4. Make sure Pro Tools is configured to either clock to the incoming MADI signal, or connect a coaxial cable from the E6L engine Word Clock 
Out to the Word Clock In on the Pro Tools HD | MADI and set Pro Tools to clock to Word.  It is also valid to clock the S6L from Pro Tools 
(connect a coaxial cable from the Pro Tools HD | MADI Word Clock Out to the Word Clock In on E6L engine if this is desired. 

5. (Optional) For VENUE Link and Virtual Soundcheck functionality, connect an Ethernet cable from Network Port C on the S6L control surface 
to an Ethernet port on your Pro Tools computer, then  proceed to Enable VENUE Link. 

S6L MADI-192 MADI Option Cards to Pro Tools | HD MADI or MTRX

Each MADI-192 MADI Option card lets you send and receive up to 64 channels of MADI, and supports 48k recording (via SRC on Stage 64 MADI Outs 
and/or on receiving MADI device). You can use any MADI-compatible recording system, but only Pro Tools | HD with Pro Tools | HD MADI or 
Pro Tools | MTRX supports Virtual Soundcheck and VENUE Link.  
See the MADI-192 MADI Option Card.pdf for instructions on installing MADI-192 cards in the E6L engine and connecting to Pro Tools.  
Track count is limited only by the number of hardware MADI channels present, and the capabilities of the Pro Tools computer or other MADI-
compatible recording device. For Pro Tools system requirements, see this article on our Knowledge Base. 

Cables Connections

Ethernet (Cat5-e)
• S6L network
• Pro Tools AVB/VENUE Link

Coax/BNC MADI • MADI-192 MADI Option Card to/from
Pro Tools | HD MADI I/O

Coax/BNC Word Clock • E6L Engine Word Clock to/from
Pro Tools | HD MADI I/O Word Clock

DigiLink
• Pro Tools | HD MADI I/O to Pro Tools | 

HDX or HD Native Card

http://avid.force.com/pkb/articles/Compatibility/Pro-Tools-12-System-Requirements


Stage 64 MADI Out Connections and Settings

To connect Stage 64 MADI Outs to Pro Tools | HD MADI:
1. Confirm that Pro Tools and the Pro Tools | HD MADI are installed and operating correctly. 
2. If necessary, configure the Stage 64 MADI Out sample rate by doing the following: 

• Go to Options > Devices and select the Stage 64 in the CONNECTED DEVICES Devices column, then set its MADI SRC in the Settings panel. 
(You can also set this from the Stage 64 front panel; see the VENUE | S6L System Guide.pdf for instructions.) 

3. Using a coaxial cable, connect the MADI 1 Out on the Stage 64 to the MADI Coaxial In 1 port on the Pro Tools | HD MADI. 
This connection  will carry Stage inputs 1-32 at 96 kHz, or Stage inputs 1-64 at 48 kHz. If connecting to a Pro Tools | MTRX connect to its 
built-in MADI In (up to 64 channels) or to connectors on the Dual-MADI Option Card. 

4. Using another coaxial cable, connect the MADI 2 Out on the Stage 64 to the MADI Coaxial In 2 port on the 
Pro Tools | HD MADI. This connection will carry Stage inputs 33-64 at 96 kHz, or Stage inputs 1-64 at 48 kHz. 

5. (Optional) Repeat for additional Stage 64 I/O Racks. 

Stage 64 MADI Out to Pro Tools | HD MADI

The two MADI Out connectors on the Stage 64 provide fixed one-for-one digital splits 
of up to 64 input channels from the corresponding Stage 64 at a 48 or 96 kHz sample 
rate, letting you connect an external MADI device such as Pro Tools | HD MADI or 
Pro Tools | MTRX without needing to configure the VENUE software Patchbay. You 
can enable and disable the MADI Outs on a per Stage 64 basis. See the table (at right) 
for sampler rate and channel details. 
Recording via Stage 64 MADI Outs does not support Virtual Soundcheck, VENUE Link*, 
or the ability to record mains, submixes or stems. 
* VENUE Link is not prohibited, but is limited to Transport control only which is of 
limited use in a record-only workflow. 

Cables Connections
Ethernet (Cat5-e) S6L network

Coax/BNC Stage 64 MADI Out 1 and MADI Out 2 
to Pro Tools | HD MADI I/O or MTRX

DigiLink Pro Tools | HD MADI I/O or MTRX to 
Pro Tools | HDX or HD Native Card

Sample Rate MADI Out Channel Assignments

48 kHz

Out 1 Stage 64 Inputs 1-64

Out 2 Stage 64 inputs 1-64

96 kHz

Out 1 Stage 64 inputs 1-32

Out 2 Stage 64 inputs 33-64



Media (2-Track USB Playback and Recording)

USB Flash Drive Requirements
USB 2.0 and higher flash drives are required for USB 2-track recording and playback, and must always be connected to the S6L control surface. 
Drives must be formatted to FAT or NTSF file systems. (The built-in USB record and playback engine does not support USB hard disk drives.) 

Multiple flash drives can be connected, up to the maximum number of available USB ports on the S6L control surface. 
•Tracks from multiple connected USB drives can be added to a Playlist for playback. 
•S6L system audio can only be recorded to one drive at a time.
• It is not possible to simultaneously record and playback 2-track audio to/from USB. 
•The maximum file size for a USB recording to HTSF is 4GB. 
• If you need more USB ports use a powered USB hub (not a bus-powered or passive hub). 

Tip: Remember that there is a secure USB port inside the S6L control surface. This port can be ideal for safely connecting a USB flash drive for 
2-track recording or playback in theaters, worship environments, or whenever it is desired to make sure a USB flash drive cannot be damaged or 
removed. To access this port, remove the back cover from the S6L control surface (see the VENUE S6L System Guide.pdf for instructions. 

The S6L system provides built-in USB 2-track recording and playback, letting you record live performances to, and play back pre-recorded tracks 
from USB flash drives connected to the S6L control surface. Use these features to create basic stereo live recordings, and to play back stereo music 
tracks and/or sound effects during a production or performance. 

The CONTROL page provides two tabs (PLAYBACK, and RECORD) with on-screen controls for USB 2-track recording and playback. Additionally, 
snapshots, events, Function switches, and a footswitch can be programmed to control recording and playback functions. 

Note that USB 2-track recording and playback is distinct from the S6L system’s integrated multi-track Pro Tools recording and playback capabilities. 

Overview



Media (2-Track USB Playback and Recording)

The CONTROL page on the external screen provides the PLAYBACK and RECORD tabs. 2-Track USB playback parameters are controlled on the PLAYBACK 
tab, and 2-track USB record parameters are controlled on the RECORD tab. The 2-track USB Transport is shared between the two tabs. 

PLAYBACK and RECORD Tabs

Library
The Library lets you add tracks to the 
Playlist for playback. The Library list 
lets you navigate through connected 
USB drives, create and name folders 
on USB drives, and delete and rename 
files and folders. Icons next to each 
item in the list identify their media 
type (such as a USB drive, audio file, or 
folder). Other data for files such as the 
track length and file format are also 
provided.

Playlist
A Playlist is provided to manage USB 2-track 
playback. You can play back individual 
tracks in the Playlist, or the entire Playlist 
(in either Play Once or Repeat Playback 
mode). You can reorder, remove, and 
preview tracks in the Playlist, as well as add 
tracks to snapshots and events. Total 
Playlist time is also provided. 
The contents of the Playlist is stored as part 
of a Show file. If the USB device containing 
the audio source files for tracks in the 
Playlist is not connected, those tracks 
appear in italics and are unavailable for 
playback until the USB drive is reconnected.

Playback Output Section and Preview
The Playback Output section provides Playback Output selectors (playback 
output signal routing control and indicators), stereo playback output level 
meters, a single stereo-linked output Level control, a Listen button (for 
monitoring the playback track), and a Monitor bus selector. 

Transport
The Record and Playback tabs share the same Transport section, 
with Transport controls, display, and Playback Mode buttons.

Track Playlist Entries  Each track in the Playlist has a number 
(001–999), Preview (audition) button, name, and length 
display. When Play All Tracks mode is enabled, tracks play in 
the order they appear in the Playlist. A total of 999 tracks can 
be added to the Playlist.

Playlist Track Snapshot and Event Icons  Icons are provided 
for each track in the Playlist that let you add track playback 
commands to an existing or new snapshot or event. The icons 
are lit when the track is included in a snapshot or event.

Number
Preview

Name Length
Snapshot

Event

A Track in the Playlist

PLAYBACK



Media (2-Track USB Playback and Recording)
PLAYBACK and RECORD Tabs

Target File Name
The Target File Name section shows 
the name of the targeted recording, 
and lets you name the recording. 
Resulting audio files are 96 kHz 24-bit 
WAV files. File names are 
automatically appended with “.wav,” 
and can be edited before and during 
recording. 

Target Record Folder Section
The Target Record Folder section lets you 
choose the destination drive and/or folder 
for recordings. The Target Record Folder list 
lets you navigate through connected USB 
drives, create and name folders on USB 
drives, and delete and rename existing files 
and folders. Icons next to each item help 
identify the media type of that item (such 
as a USB drive, an audio file, or a folder).

USB Drive Info
This section shows the capacity of and the space available for recording on 
the targeted drive, as well as the maximum possible record length for an 
individual file. Values are shown in hour:minutes:seconds and in bytes.

Transport
The Record and Playback tabs share the same Transport section, 
with Transport controls, display, and Playback Mode buttons.

RECORD

Record Input Section and Listen
The Record Input section provides 
Record Input selectors (record input 
signal routing controls and indicators), 
stereo Record Input Level meters, a 
stereo-linked recording input Level 
encoder, a Listen button (for 
monitoring the recording), and a 
Monitor bus selector. 



Media (2-Track USB Playback and Recording)
Transport and Play Mode Controls

1 - Previous Track  When Play is not engaged, selects the previous track in the Playlist. When Play is engaged immediately skips to and plays the previous track in 
the Playlist.

2 - Next Track  When Play is not engaged, this button selects the next track in the Playlist. When Play is engaged, this button immediately skips to and plays the next track 
in the Playlist.

3 - Stop  Stops playback or recording.

4 - Play/Pause Initiates playback of the cued track in the Playlist. When a track is playing back, pressing the button pauses playback or recording. This button also initiates 
recording when Record Arm is enabled.

5 - Record Arm Toggles Record Arm on/off. The button flashes red when the transport is record-armed. To initiate recording, Play must be engaged, and the Record Arm 
button is lit solid when recording is in progress.

6 - Record Divide  When a recording is in progress, pressing the Record Divide button ends the current recording, writes the audio file to disk, and begins the recording of 
a new audio file. The new file is named based on the previous audio file and appended with an incremented number (such as “Untitled-1”). 

The Record and Playback tabs share the same Transport section, with Transport controls, display, and Playback Mode buttons.

7 - Transport Display  Shows the following data for the currently playing track or in-progress recording: Name of the track or recording, Time elapsed for the current track 
or recording, Time Remaining for a playback track; or for a recording the time remaining on the target drive
The Transport display also provides forward or backward shuttle by dragging the Playhead or clicking in the Timeline.

8 - Playback Mode Buttons  Provide control over how the selected track or Playlist is played back. Options include the following:
Play One Track Toggles between Play All Tracks and Play One Track modes. When unlit, all tracks in the Playlist play back in sequential order. Playback stops when the last 

track in the Playlist has completed. When lit (engaged), only the cued track in the Playlist plays back.
Repeat Playback Toggles between Repeat Playback mode and Play Once mode. When unlit, the cued track (or the entire Playlist depending on the status of the Play One 

Track button) plays back once and stops. When lit (engaged), the cued track or the entire Playlist repeats playback.

1 2 3 4 5 6 7 8
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The S6L system plays back WAV and MP3 files directly from connected USB flash drives. To play back tracks, you must route USB playback 
outputs and then  add tracks to the Playlist. You can then choose the play mode for tracks (to play all, play only one, or repeat) and set the 
playback level.

Playback Examples and Tips
• USB playback is a convenient way to have music playing before, during, and after an event. Copy all the desired audio files to a USB flash drive, add them to 

the VENUE USB Playlist, then set the Play Mode as desired. You can even integrate Public Service Announcements and similar (such as “Please Turn Off 
Your Phone”) and place them within the Playlist. 

• For theater, USB playback can be used for sound effects and even music cues. Playback of specific tracks or an entire playlist can be added to snapshots for 
hands-free playback. 

• For rehearsals and even some performances, USB playback can be a desirable alternative to using a full Pro Tools system to integrate music, sound effects, 
or even click/reference tracks. 

Assigning USB Playback Outputs
You can route USB playback to any input channels on your system. The Patchbay is used to assign USB playback outputs to VENUE system input channels, and 
you can also assign USB  playback outputs as Matrix Mixer inputs in the Outputs > Matrix page. 
To assign USB playback outputs to system input channels:
1. Go to the Patchbay page and click the Inputs tab. (You can also “jump” directly 

to the Patchbay> Inputs page from the Control > Playback window by clicking 
the Playback Output selectors in the Record Input section.)

2. Click the Console hardware tab along the top of the channel grid.
3. To the left of the channel grid, click the tab to display the desired channels in 

the grid.
4. Click in the channel grid to assign USB playback outputs (listed across the top 

under the USB column) to system Input Channels (listed on the left).

Routing USB playback outputs to input channels in the Patchbay

Playback Listen
You can use the on-screen Playback LISTEN button to monitor the currently 
playing track. Playback Listen toggles the playback output onto the Monitor bus. 
Playback Listen is always overridden by other signals on the Monitor bus. If any 
other channel is soloed, or Key Listen is engaged, Playback Listen is always 
overridden. Record Listen defaults to Monitor Bus A but you can choose to use B, 
or A+B. 
To designate a different Monitor bus: 
• Click the MON A button (it changes to MON B). Click again to select MON A+B. 
To monitor the Playback output:
• In the Playback Output section of the Playback tab, press the LISTEN button.
To disengage Playback Listen:
• Click LISTEN again. 
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Adding Tracks to the Playlist
To add tracks to the Playlist:
1. Insert your USB drive(s) into a USB port on the S6L control surface.
2. Go to Control > Playback.
3. Locate the Library section. If one USB drive is connected, that drive appears in the window at the top of the 

section. The contents of that drive appears in the list below it. A speaker icon indicates audio files that can be 
added to the Playlist.
Tip: You can preview an individual audio file by clicking the speaker icon in the Library or in the Playlist. Preview 
audio is sent to the selected Monitor bus (A, B, or A+B) and can be monitored using headphones connected to 
the Headphone Output for the corresponding Monitor bus or buses. Any other signals currently in the Monitor 
bus are overridden by Preview. 

A drive and its contents

5. In the Library list, select one or more tracks. Shift-click to select multiple consecutive items in the list, and Control-click to select multiple non-consecutive items.
6. Click the Add button. The selected track(s) appear in the Playlist.
7. To remove a track from the Playlist, select it in the Playlist and click Remove. 

A Track in the PlaylistSetting the Play Mode
After adding tracks to the Playlist, set the Play Mode. Play Mode can be set on-screen in the Transport. By default, Play Mode is set to play all tracks in the Playlist 
when playback is engaged.
To set the Play Mode on-screen, do any of the following:
• Click the Play One Track button so that it is lit to play only the cued track.
• To play all tracks in the Playlist in sequential order, make sure the Play One Track button is unlit.
• Click the Repeat Playback button so that it is lit to repeat playback of either the cued track or the Playlist.
• To play the track or the Playlist once, make sure the Repeat Playback button is unlit. Enabled Play One Track button (left) and Repeat Playback button (right) 

Engaging Playback
To engage playback:
1. Select a track in the Playlist so that is cued for playback. A track is cued for playback when it is highlighted in yellow 

or green.
2. Press the Play button in the Transport.
3. To stop playback, press the Stop button in the Transport.

To adjust the playback level:
1. On-screen, drag the Level encoder in the Playback Output section.
2. Adjust the faders of the Input Channels that the USB playback outputs are assigned to as desired.

A selected and cued track in the Playlist

To skip to another track in the Playlist:
• To skip to the next track in the Playlist, click the Next button in the Transport, or press the Down arrow on your keyboard.
• To skip to the previous track in the Playlist, click the Previous button in the Transport, or press the Up arrow on your keyboard.

To shuttle forward or backward in the currently playing/paused track, do either of the following In the Transport display:
• Click anywhere in the timeline to move the Playhead to that position.
• Click and drag the Playhead to the left or right to shuttle backward or forward in the track.

The Playhead in the Transport display
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Assigning USB Recording Inputs
The Patchbay is used to assign channels to the USB recording inputs. You can route output busses directly to the USB recording inputs, or you can use input or 
output channel Direct Outputs. 
To assign channels to USB recording inputs:
1. Do either of the following: 
• Click the Record Input Source selectors in the Record Input section to “jump” 

directly to the Patchbay > Directs page.
• Go to the Patchbay page and click the Outputs or the Directs tab.
2. Click the Console hardware tab along the top of the channel grid.
3. To the left of the channel grid, click the tab to display the desired channel type in 

the grid.
4. Click in the channel grid to assign channels or buses (listed on the left) to the USB 

recording inputs (listed across the top under the USB column).

Targeting the Destination for the Recording 
After assigning channels to the USB recording inputs, target the destination for the 
recording. Audio can be recorded to the top (root) level of connected USB drives, or 
you can create a folder or a sub-folder and target the recording to that folder.
To target the destination for the recording:
1. Insert your USB drive(s) into any USB port on the S6L control surface.
2. Go to the Control page and click the Record tab.
3. Locate the Target Record Folder section. If one USB drive is connected, that drive 

appears in the window at the top of the section. The contents of that drive 
appears in the list below it. When the drive is targeted, any subsequent 
recordings are saved to the top-level of the drive indicated in the top window.

4. If two or more drives are connected to the S6L control surface, target the drive 
you want to record to by double-clicking the drive in the list. 

The selected drive appears in the in the window at the top of the section, and any 
subsequent recordings are saved to the top (root) level of the drive indicated in the 
top window.

A drive targeted in the Target Record Folder section

To record audio to USB, you need to assign system channels to the USB recording inputs, target the destination drive (or folder) for the recording, and 
initiate the recording. Audio is recorded to the connected USB drive as 24-bit, 96 kHz WAV files. 

Recording Examples and Tips
• To make a 2-track recording of your mix (“board mix”), assign Mains L/R as the Record Input sources. 
• To record your mix as it sounds in the room, set up a pair of microphones near your mix position. Connect them to a pair of inputs on the back of the control 

surface, assign them to a pair of Input channels, then assign those Input channels as the Record Input sources and use their Direct Outs. 

Routing USB recording inputs in the Patchbay
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Naming a Recording
To name a recording:
1. Click in the Target File Name window, then type in a name for the recording.
2. Press Enter.

To engage Record on-screen:
1. Go to Control > Record.
2. In the Transport section, click the Record Arm button to record arm the 

transport.
3. To start recording, press the Play button in the Transport. The Transport display 

shows the progress of the recording.

To stop recording:
Press the Stop button in the Transport.

Initiating a Recording
After targeting the record destination, set the record level and initiate the recording.
To set the record level:
1. If you are not using Direct Outputs, skip to step 3. 
2. If you are using Direct Outputs, do the following for each channel assigned to the USB recording input:

• Navigate to the Inputs or Outputs page for the channel(s) assigned to the USB record inputs.
• On-screen, click the Direct Outs In button. Adjust the Direct Output level as necessary.

3. Go to Control > Record.
4. Click the Level control in the Record Input section to adjust the record input level. Make sure the input 

level is not clipping the record inputs. Clipping is indicated when red appears on the +15 dB mark in 
the Record Input Level meters. To listen to the record input signals, see Record Listen. 

Record-arming the Transport

Creating and Targeting a Folder for the Recording
You can create a folder on a drive and target it for the recording.
To create a folder and target it for recording:
1. Make sure the desired USB drive is targeted. If necessary, click the Up One Level button to return to the top-level of the drive.
2. Click the New button. A new folder appears in the list.
3. Type in a new name for the folder using your computer keyboard and press Enter.
4. Double-click the new folder. The full file path showing the targeted folder now appears in the window at the top of the Target Record Folder section. Any 

subsequent recordings will be saved to that folder.

An example file targeted in the Target Record Folder section

Channel Direct Output enabled (IN)

As a general rule of thumb, try to set levels so that they peak within -15 dB to -9 dB on the Record Input Level meters. If you are using Direct Outputs, both the channel 
Direct Out level control and the Level control in the Control > Record window affect recording input levels.
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Record Listen
You can use the on-screen Record Listen button to monitor the recording input. Record Listen toggles the recording input onto the Monitor bus. Record does not have 
to be engaged to monitor the recording input.
Record Listen is always overridden by other signals on the Monitor bus, except Mix to Monitors. If any other channel is soloed, or Key Listen is engaged, Record Listen 
is always overridden. Record Listen defaults to Monitor Bus A but you can choose to use B, or A+B. 
To designate a different Monitor bus: 
• Click the MON A button (it changes to MON B). Click again to select MON A+B. 
To monitor the recording input:
• In the Record Input section of the Record tab, click the Listen button. It flashes yellow when engaged. 
To disengage Record Listen:
• Click Listen again. 

Dividing a Recording
You can divide an in-progress recording to create a new audio file for the next song or cue, set, scene, or act during a performance. The previous recording is saved, 
and the new recording continues until the recording is stopped or the Record Divide button is clicked again.
To divide a recording:
1. While a recording is in progress, name the new file by clicking in the Target File Name window, typing in a new name, and pressing Enter.
2. Click the Record Divide button in the Transport. 
If you do not enter a name before clicking Record Divide, the new file inherits the name from the previous file and is appended with a number, such as “Untitled-1,” 
and “Untitled-2.”

Record Divide
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Selecting Tracks
Items in the Playlist, Library and Target Record Folder list can be selected on-screen. Selected items are color-coded to indicate their status. Keyboard shortcuts for 
selecting items are also provided.
To select a single track, file, or folder:
• Click the item. 
To target multiple consecutive tracks, folders, or files:
• Shift-click the items.
To clear a selection of multiple consecutive tracks, folders, or files:
• Click any item in the Playlist, Library, or Target Record Folder list.
To select or de-select non-consecutive tracks:
• Ctrl-click the tracks in the Playlist. 

Color-Coding in the Playlist, Library, and Target Record Folder List
Selected items in the Playlist, Library, and Target Record Folder list are color-coded to indicate their status as follows:
Yellow  Yellow appears only in the Playlist and indicates that the track is both currently cued for playback (or is currently playing back) and currently selected. 

Engaging Play in the Transport initiates playback of the track and clicking Remove removes the track from the Playlist.
Green  Green appears only in the Playlist and indicates that the track is currently cued for playback (or is currently playing back). Engaging Play in the Transport 

initiates playback of the track.
Blue   Blue appears in all three lists and indicates that the item is part of a multiple-item selection. Clicking Delete or Remove deletes or removes all selected items.

Keyboard Shortcuts in the Playlist, Library, and Target Record Folder List
When you click in the Playlist, Library, and Target Record Folder list, you can select items using the following keyboard shortcuts: 

Function Keyboard Shortcut

Select previous/next item Up/Down Arrow keys

Select first item in list Home key

Select last item in list End key 

Select item at top of list Page Up

Select item at bottom of list Page Down

Select multiple consecutive items Shift-click tracks

Select multiple non-consecutive items/Deselect any Ctrl-click tracks
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Managing USB Audio
You can manage tracks by reordering tracks in and removing tracks from the Playlist, previewing tracks, deleting and renaming files on connected USB drives, and 
removing all unavailable files. 

Reordering Tracks in the Playlist
Tracks can be reordered in the Playlist at any time, including during playback. When you reorder one or more tracks, they are automatically renumbered in the list.
To move a track in the Playlist:
1. Select one or more tracks in the Playlist.
2. Do one of the following:

• Drag the currently selected tracks to a new location in the Playlist.
• Double-click the track number in the Playlist or the banner display, type in a new number, and press Enter on the keyboard. 
• Right-click (tap and hold) the time in the Playlist and choose an available Move command. 

Removing Tracks from the Playlist
Tracks can be removed from the Playlist at any time (including during playback).
To remove a track from the Playlist:
1. Select one or more tracks in the Playlist.
2. Click the Remove button. The selected tracks are removed from the Playlist and succeeding tracks are renumbered. Or right-click a selected item and choose 

Remove from Playlist. 

Previewing Tracks 
You can preview tracks in the Target Record Folder list of the Record window, and in the Playlist and the Library lists of the Playback window. When you preview 
a track, the signal is sent only to the Monitor bus. Use this feature to audition tracks in your headphones before playing them back through the sound system.

To audition a track:
1. In the Target Record Folder list, the Library list, or the Playlist, double-click the 

speaker icon next to the track. Or right-click the item and choose Preview. That 
track is sent to the particular Monitor bus chosen on the Playback page.

2. To stop preview, double-click the lit speaker icon. (Initiating playback of a track 
also interrupts preview.)

Previewing a track
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Renaming and Deleting Files and Tracks
You can rename and delete files and tracks in the Target Record Folder list of the Record window. 
To rename and/or delete files from a connected USB drive:
1. Right-Click a file in the Target Record Folder list or the Library list.
2. Select Rename or Delete from the pop-up menu. You can also choose to add the track to the 

Playlist, or create a new Folder. 

Play, Preview, Move, Remove, and Show Commands in the Playlist Right-Click Menu
Right-clicking an item in the Playlist provides a menu with many Playlist management commands.

Play Track  Plays the selected track. 
Preview  Auditions the selected track through the Monitor bus. 
Move Up/Down/To Beginning/To End  Moves the selected track.
Remove from Playlist  Removes the selected track from the Playlist. 
Remove Unavailable Tracks  Removes any unavailable tracks (listed in italics). 
Show in Library  Shows the selected track in the library. 

Track right-click menu in the Library list

Track right-click menu in the Playlist



Media (2-Track USB Playback and Recording)
Using Snapshots to Trigger USB Transport Commands

You can add the track playback command to existing or new snapshots directly from the Playback tab Playlist to initiate playback by recalling a snapshot. 
You can also use snapshots to initiate a recording and to stop the Transport. These commands must be added to already-existing snapshots on the 
Snapshots page. (See the VENUE S6L System Guide.pdf for more information on creating and editing Snapshots.)

Adding Track Playback to an Existing Snapshot
To add a track playback to an already-existing snapshot:
1. Go to Control > Playback.
2. In the Playlist, click the Snapshots icon corresponding to the track you want to add to a snapshot. Snapshot icon in the Playlist

Adding to an existing snapshot

Snapshot

3. From the pop-up menu, choose Add Track Playback to Snapshot and choose the 
existing snapshot from sub-menu.

4. The Play track command for the chosen track is added to the snapshot. 
Any snapshot already containing a USB 2-track Transport command appears in 
italics in the pop-up sub-menu. If you want to change the Transport command on an 
existing snapshot, click Assign in the ensuing dialog to confirm the change.

Editing Snapshots for USB Playback
You can edit the Play Mode for a track added to a snapshot on a per-snapshot basis using the Play 
Mode options in the Media list on the Snapshots page. 
To edit Play Mode and other snapshot parameters: 
1. Navigate to the Snapshots page. 
2. Select the snapshot. 
3. Click the MEDIA subtab, or click the Zoom icon, to see a summary of 2-Track parameters 

associated with the snapshot.
4. Double-click the MEDIA sub-tab to open the Play Mode options view and edit parameters.

Play Mode options in the Snapshots page Media list

Creating a New Snapshot for Track Playback
To create a new snapshot containing a track playback:
1. Go to Control > Playback.
2. In the Playlist, click the Snapshots icon for the track you want to 

add to a snapshot. The icon lights to show that a snapshot 
contains this track.

3. From the pop-up menu, choose Create New Snapshot to Play 
this Track. 

In the Snapshots list on the Snapshots page, a new snapshot 
containing the Play track command is created and added after the 
currently selected snapshot in the Snapshots list. 

Zoom
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Using Events to Trigger USB Transport Commands

The following USB 2-track Transport actions can be triggered using events: 
• Stop USB 2-track Transport.
• Play a specific track in the Playlist.
• Play the currently cued track in the Playlist.
• Engage record in the USB 2-track transport.
• Record divide the current recording.
You add track playback directly from the Playlist or from the Events tab. All other Transport commands (such as Stop and Record) are added from the Events tab. 
(See the VENUE S6L System Guide.pdf for more information on Events.)

Adding Track Playback to an Existing Event
You can add track playback to an existing event or create a new event with track playback directly from 
the Playlist.
To add track playback to an existing event:
1. Go to Control > Playback. 
2. In the Playlist, click the Event icon next to the track you want to trigger.
3. Select Add Track Playback to Event and select the event from the list.
Track playback is added to the selected event, and the track playback command appears in the Events 
tab Actions list for the selected event. Engaging the trigger for that event triggers playback of the 
assigned track.

Adding to an existing Event

Event icon in the Playlist

Event

Play track command added to Events tab Actions list

Creating a New Event for Track Playback
To create a new event for track playback:
1. Go to Control > Playback. 
2. In the Playlist, click the Event icon next to the track you want to trigger using an event.
3. Select Create New Event to Play this Track. The new event is created and added to the Events and Actions Lists on the 

Control > Events page. The new event and action are auto named Play Track - <track name>. 
4. Go to Control > Event and edit the name of the event if desired.
5. Make sure the event is selected (highlighted in blue), and click the ADD pop-up menu in the Triggers list to select a trigger type (such as a Function Switch). The selected 

trigger type is added to the Trigger list for the currently selected event, with its default properties.
You can define event actions to be triggered by nearly any control on the surface, by snapshot recall, and more. See the S6L Event Triggers and Actions.pdf for a listing of all 
available triggers and actions. See the VENUE S6L System Guide.pdf for more information on creating and using Events.

To remove a track playback from an event.
In the Playlist, click the event icon next for the track you want edit.
Choose Remove Track Playback from Event <Event number> “<Event name>”.
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