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Introduction

New Features and Improvements in Sibelius 2021.9
Sibelius 2021.9 provides the following new features, changes, and improvements:

• Keypad improvements:

• Pitch Correction and Chord Input tools

• New Escape icon

• Search Galleries and Plug-ins

• Optimize Page Margins for Tablets option (PDF Export)

• ManuScript access to style commands by Style ID or name (Sibelius | Ultimate only)

New Features and Improvements in Sibelius 2021.2
Sibelius 2021.2 provides the following new features, changes, and improvements:

• The new Command gallery on the Home tab lists all commands in Sibelius and lets you select any command to execute it.

• Command Search lets you search for and find any command in Sibelius and execute it.

• ManuScript updates for creating scriptable plug-ins or plug-in macros (Sibelius | Ultimate only)

System Requirements and Compatibility Information
Avid® can only assure compatibility and provide support for hardware and software it has tested and approved. 

For complete system requirements and a list of qualified computers, operating systems, hard drives, and third-party devices, visit:

www.avid.com/compatibility

Version Compatibility
Sibelius 2019.9 was the last version of Sibelius to support macOS 10.10 “Yosemite” and macOS X 10.11 “El Capitan.” It is rec-
ommended that you upgrade to macOS 10.12 “Sierra” or later to maintain compatibility with current versions of Sibelius.

We recommend that you upgrade to Windows 10 to maintain compatibility with current versions of Sibelius. To find out more 
about migrating to Windows 10, visit https://www.microsoft.com/en-gb/windows/windows-7-end-of-life-support-information.

If you are using an older version of Sibelius and are upgrading to macOS “Catalina” or Windows 10, we recommend that you up-
grade and stay current with the latest version Sibelius as well.
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Conventions Used in Sibelius Documentation
Sibelius documentation uses the following conventions to indicate menu choices, keyboard commands, and mouse commands:
:

The names of Commands, Options, and Settings that appear on-screen are in a different font.

The following symbols are used to highlight important information:

How to Use this PDF Guide
This PDF provides the following useful features:

• The Bookmarks on the left serve as a continuously visible table of contents. Click on a subject heading to jump to that page.

• Click a + symbol to expand that heading to show subheadings. Click the – symbol to collapse a subheading.

• The Table of Contents provides active links to their pages. Select the hand cursor, allow it to hover over the heading until it turns 
into a finger. Then click to locate to that subject and page.

• All cross references in blue are active links. Click to follow the reference.

• Select Find from the Edit menu to search for a subject.

• When viewing this PDF on an iPad, it is recommended that you open the file using iBooks to take advantage of active links within 
the document. When viewing the PDF in Safari, touch the screen, then touch Open in “iBooks”.

Convention Action

File > Save Choose Save from the File tab

Control+N Hold down the Control key and press the N key

Control-click Hold down the Control key and click the mouse but-
ton

Right-click Click with the right mouse button

User Tips are helpful hints for getting the most from Sibelius.

Important Notices include information that could affect data or the performance of Sibelius.

Shortcuts show you useful keyboard or mouse shortcuts.

Cross References point to related sections in this guide and other Avid documentation.
 Introduction
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Resources
The Avid website (www.avid.com) is your best online source for information to help you get the most out of Sibelius. 

Account Activation
Create an Avid Master Account at:

www.avid.com/account

Product Registration
Register your purchase online at:

www.avid.com/register

Product Downloads
Download software, updates, documentation, and other resources from:

my.avid.com/products

Support and Downloads\
Contact Avid Customer Success (technical support), download software updates and the latest online manuals, browse the Compatibil-
ity documents for system requirements, search the online Knowledge Base or join the worldwide Avid user community on the User Con-
ference.

www.avid.com/support

Get Started Fast
Visit the Get Started Fast with Sibelius YouTube channel.

www.youtube.com/playlist?list=PLhCR_8aS9jOPvy871jRUESB0EdgOCD8s1

Training and Education
Study on your own using courses available online, find out how you can learn in a classroom setting at an Avid-certified training center, 
or view video tutorials and webinars.

www.avid.com/education

Products and Developers
Learn about Avid products, download demo software, or learn about our Development Partners and their plug-ins, applications, and 
hardware.

www.avid.com/products
 Introduction
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New Features and Improvements in Sibelius 2021.9

Keypad Improvements

Pitch Correction and Chord Input Tools
The first and second layouts of the Keypad provide two new tools: the Pitch Correction tool and the Chord Input tool. These tools 
make adding and editing notes in chords easier.

The Keypad layout navigation icons appear as part of the new icons for the Pitch Correction tool and Chord Input tool on the first 
two layouts, and are only available using keyboard shortcuts with the first two layouts (not with mouse clicks). 

Pitch Correction Tool

Use the Pitch Correction tool to change the pitch of any selected note, including notes in chords.

To change the pitch of a selected note:

1 Select the note you want to change.

2 Click and hold the Pitch Correction tool, and do any of the following:

• Drag up to raise the pitch.

• Drag down to lower the pitch.

• Drag left to flatten the note.

• Drag right to sharpen the note.

3 Release the mouse when you have the note you want.

Pitch Correction tool

Option-drag (Mac) or Alt-drag (Windows) left or right for quarter tone accidentals.
 New Features and Improvements in Sibelius 2021.9 4



Chord Input Tool

Use the Chord Input tool to add notes to make chords.

To enter notes to make a chord:

1 Enter a note or select an existing note.

2 Click the Chord Input tool to add a note a third above the selected note; or click and hold the Chord Input tool to add another 
pitch, and then do any of the following:

• Drag up to raise the pitch.

• Drag down to lower the pitch.

• Drag left to flatten the note.

• Drag right to sharpen the note.

3 Release the mouse when you have the note you want.

Repeat these steps to add more notes to the chord as desired.

New Escape Key Icon
The Escape key icon has been updated in all Keypad layouts. 

Chord Input tool

Option-drag (Mac) or Alt-drag (Windows) left or right for quarter tone accidentals.

Escape key
 New Features and Improvements in Sibelius 2021.9 5



Search Galleries and Plug-ins

Searching Galleries
Sibelius now lets you search for objects by name in the Lines, Symbols, and Text galleries on the Notations and Text tabs of the 
Ribbon. The search results are organized by category (such as objects currently Used in a score, Common objects, and so on). You 
can navigate search results by scrolling with the mouse or using the Arrow keys.

To search for objects by name in a gallery:

1 Make a selection in the score where you want to add a Lines, Symbols, or Text object.

2 Select the Notations or Text tab in the Ribbon depending on the gallery you want.

3 Click the Open Gallery button for the gallery you want (Lines, Symbols, or Text).

4 In the resulting search field, type the name of the object you want. The search results appear below, grouped by category, as you 
type.

5 Do one of the following to select and add the desired object:

• Scroll through the search results using the mouse and click the object you want.

• Use the Arrow keys to move through the search results and press Enter or Return to add the selected object.

Open Gallery button, Lines gallery on the Notations tab

Lines gallery, search field
 New Features and Improvements in Sibelius 2021.9 6



Searching Plug-ins
Sibelius now lets you search for plug-ins by name.

To search for a plug-in by name:

1 Make a selection in the score where you want to use a plug-in.

2 Select the tab in the Ribbon that has the plug-in you want.

3 Click the Plug-in icon. All relevant Plug-ins are listed below by category.

4 Type the name of the plug-in you want to use in the search field.

5 Do one of the following to use the desired plug-in:

• Scroll through the search results using the mouse and click the plug-in you want.

• Use the Arrow keys to move through the search results and press Enter or Return to use the selected plug-in.

Command Search Improvements
When using Command Search, Sibelius now includes Lines, Symbols, and Text objects in search results.

Optimize Page Margins for Tablets
When exporting to PDF, Sibelius let you optimize page margins for viewing on tablets (such as iPad).

Plug-ins, search field

Export to PDF, Optimize Page Margins for Tablets
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To optimize page margins for tablets:

1 Open the score you want to export to PDF.

2 Click the File tab.

3 Click Export in the left hand column.

4 Select PDF.

5 Under Settings, select Optimize page margins for tablets.

6 Use the default settings or enter new values for Page Margins and Staff Size.

7 If necessary, click Reset to Defaults.

8 Click Export.

ManuScript Access to Style Commands
(Sibelius | Ultimate only)

ManuScript provides access to style commands with Execute() using either the Style Id (these are listed in the ManuScript Lan-
guage Guide) or the actual name of the command as it appears in the Ribbon with StyleCmd(). 

For example, to execute a crescendo on a selection, you can write either of the following:

Style Id

Sibelius.Execute("line.staff.hairpin.crescendo");

Style Command Name

Sibelius.Execute(StyleCmd("Crescendo"));

The argument accepted by StyleCmd() is the name as it appears in the Ribbon's Command Gallery, which can be in any supported 
language.
 New Features and Improvements in Sibelius 2021.9 8



New Features and Improvements in Sibelius 2021.2

Commands Gallery
The new Commands gallery on the Home tab of the Ribbon provides a complete list of commands in Sibelius. Commands are or-
ganized in alphabetical order by category in terms of location (such as commands accessible from the File or Home tab of the Rib-
bon, or from the keypad) or by function (such as Tuplets, Zoom, or Selection). Assigned keyboard shortcuts (if any) are shown to 
the right of the name of commends in the list. You can quickly scroll the list of commands to find the one you want, and then click 
that command in the list to execute it.

List of Commands in the Home tab of the Ribbon
 New Features and Improvements in Sibelius 2021.2 9



Command Search
Command Search lets you search for any command in Sibelius, whether it be in any of the Ribbon menus, the File tab, the Keypad, 
the Inspector, or the Add or Remove Instruments dialog, by typing the name of the command. As you type, matching commands 
are shown below the search field. Results for each command are listed by name and include its keyboard shortcut if any (for ex-
ample, Shift+T), its location (for example, Note Input > Note Input > Transpose), and a description. 

Click the name of the command, or use the Up/Down arrows to select the command from the search results and then press Return 
(Mac) or Enter (Windows) to execute that command.

To run a Command Search and execute the command:

1 Make the appropriate selection in your score for the command you want to apply.

2 Click in the Command Search field or press , (Comma) on the keyboard.

3 Start typing the name of the command you want to use. Matching results are listed below the Command Search field.

4 To execute the command, click it in the list, or select it using the Up and Down Arrow keys and press Enter (Windows) or 
Return (Mac).

Command Search for “Trans”
 New Features and Improvements in Sibelius 2021.2 10



ManuScript Improvements
(Sibelius | Ultimate Only)

Creating Scriptable Plug-ins
ManuScript lets you create scriptable plug-ins using any sequence of any number of Sibelius commands. Use Cmd() in conjunction 
with Execute() to execute any command by name.

Cmd()

Use Cmd() in conjunction with Execute() to look up the CommandID for any command name (as it appears in Sibelius) in any lan-
guage. 

For example, if you write the following line of code in a plug-in:

Cmd("Select all"); 

it will return the name of the associated CommandID, which in this case is: select_all.

The Cmd() function works in whatever language you are using for Sibelius. For example, if you are regularly working in French, 
you could write the command in French:

Cmd("Sélectionner tout"); 

and it will return the name of the associated CommandID: select_all

Note that if you write a scripted plug-in using Cmd() it will only work in the language in which it is written, so use CommandIDs 
to ensure optimal compatibility in all languages.

However, if you only want to write plug-ins in you own language (such as English), write Execute Calls as follows:

Sibelius.Execute(Cmd("Select All")); 

– or –

Sibelius.Execute(Cmd("Repeat")); 

Execute()

Execute() in ManuScript lets you create scriptable plug-ins that can execute any number of commands one after the other. Place 
the CommandID of any command that you want the plug-in to use in straight quotes inside the parenthesis as follows:

Sibelius.Execute("select_all"); 

Any command listed in the Commands gallery on the Home tab can be used with Sibelius.Execute(), but Sibelius features that 
are not in that list cannot be used with this method (such as adding text, symbols, lines, clefs, and so on). Of course, you can use 
other ManuScript methods for features not in the Commands gallery in combination with the Sibelius.Execute() method to create 
plug-ins for almost any workflow.

To create a plug-in using the Execute() method, try the following example:

1 Create a new score with a single staff and add a note (an eighth-note middle C for example).

2 Choose File > Plug-ins > Edit Plug-ins.

3 In the Edit Plug-ins dialog, click New.

For a complete list of CommandIDs, refer to the ManuScript Guide.pdf.
 New Features and Improvements in Sibelius 2021.2 11



4 In the New ManuScript Plug-in dialog, type a Name (for this example, type “Cscale”), Menu (the name of the plug-in as it ap-
pears in the Plug-ins menu, such as “Create C major scale”), and Category (such as “Other”) for the plug-in then click OK.

5 Select the new plug-in (“Other > Create C scale (user copy)”) in the list and click Edit to open the Plug-in editor.

6 Initialize and Run are listed in the Methods section. Double-click Run to open the ManuScript Method dialog.

7 Delete "Sibelius.MessageBox();" before entering the commands you want to use. For this example, enter the following:
Sibelius.Execute(Cmd("Select next object")); 
Sibelius.Execute(Cmd("Create C")); 
Sibelius.Execute(Cmd("Create D")); 
Sibelius.Execute(Cmd("Create E")); 
Sibelius.Execute(Cmd("Create F")); 
Sibelius.Execute(Cmd("Create G")); 
Sibelius.Execute(Cmd("Create A")); 
Sibelius.Execute(Cmd("Create B")); 
Sibelius.Execute(Cmd("Create C")); 

New ManuScript Plug-in dialog

Edit Plug-ins dialog

ManuScript Method dialog
 New Features and Improvements in Sibelius 2021.2 12



8 Click OK to close the ManuScript Method dialog.

9 Click OK to close the Plug-in editor.

10 Click Close to exit the Edit Plug-ins dialog and return to the score.

11 Select the eighth-note middle C in the score.

12 Select Home > Plug-ins > Other > Create C scale.

Sibelius runs the plug-in you just created and generates an ascending C major scale using the rhythm of the selected note (in this 
case, an eighth-note).

Add the following to the end of your plug-in to automatically play back the scale after it is created
Sibelius.Execute(Cmd("Cancel/Stop/Select None"));
Sibelius.Execute(Cmd("Cancel/Stop/Select None"));
Sibelius.Execute(Cmd("Play From Selection"));

Since all commands in the Commands list can be used with the Sibelius.Execute() method, you can create plug-in macros to speed 
up workflows that include multi-step repetitive tasks. For instance, the following example executes 17 steps with a single plug-in 
macro:

Sibelius.Execute(Cmd("Filter Voice 1"));
Sibelius.Execute(Cmd("Copy"));
Sibelius.Execute(Cmd("Triplet"));
Sibelius.Execute(Cmd("Paste"));
Sibelius.Execute(Cmd("Select next object"));
Sibelius.Execute(Cmd("Select previous object"));
Sibelius.Execute(Cmd("Eighth note (quaver)"));
Sibelius.Execute(Cmd("Repeat"));
Sibelius.Execute(Cmd("Quarter note (crotchet)"));
Sibelius.Execute(Cmd("Select previous object"));
Sibelius.Execute(Cmd("Select previous object"));
Sibelius.Execute(Cmd("Select previous object"));
Sibelius.Execute(Cmd("Copy"));
Sibelius.Execute(Cmd("Delete"));
Sibelius.Execute(Cmd("Select next object"));
Sibelius.Execute(Cmd("Paste"));
Sibelius.Execute(Cmd("Select previous object"));

Eighth-note middle C selected

C major scale created by the custom Create C major scale plug-in

"Cancel/Stop/Select None" needs to be executed twice to first stop inputting notes and then again to deselect the top C.

You can further speed up your workflow by assigning a keyboard shortcut to your plug-in.
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Additional New ManuScript Sibelius Objects

The following new Sibelius Object Methods and Variables have been added to ManuScript in support of Execute() and Cmd().

Methods

CommandExists() Returns a boolean to reflect if a given CommandID is available for execution. For example: 
if (Sibelius.CommandAvailable(toggle_review_mode) ) {}

FindCommandId(Command Name) Translates the name of a command (as shown in Sibelius) into a CommandID, and returns that 
CommandID as a string. The Command Name argument is case-insensitive. It is also specific to the current language set inside Si-
belius. If no match is found, an empty string will be returned. For example: 

Sibelius.FindCommandId("ToGGle ReVieW mODe");

Also see, Cmd().

FindCommandName(CommandID) Translates a CommandID into an appropriate Command Name for the current 
language set in Sibelius and returns that Command Name as a string. If no match is found, an empty string will be returned. 
For example:

Sibelius.FindCommandName("toggle_review_mode"); 

GetListOfCommandNamesInCategory(Localized Command Category Name) Returns a sparse array of all External Localized 
Command Names (in alphabetical order). For example:

fileTabCommands = Sibelius.GetListOfCommandNamesInCategory("File Tab")

Variables

AvailableCommands Returns a sparse array of all available CommandIDs in alphabetical order. 

CommandCategories Returns a sparse array of all Command Categories in the local language (in system order). 
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Technical Support (USA)
Visit the Online Support Center 
at www.avid.com/support
Product Information
For company and product information, 
visit us on the web at www.avid.com
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