Avid® Effects Guide

for
Avid Media Composer® Adrenaline™
Avid NewsCutter® Adrenaline™ FX
Avid NewsCutter® XP
Copyright and Disclaimer

Product specifications are subject to change without notice and do not represent a commitment on the part of Avid Technology, Inc.

The software described in this document is furnished under a license agreement. You can obtain a copy of that license by visiting Avid's Web site at www.avid.com. The terms of that license are also available in the product in the same directory as the software. The software may not be reverse assembled and may be used or copied only in accordance with the terms of the license agreement. It is against the law to copy the software on any medium except as specifically allowed in the license agreement.

Avid products or portions thereof are protected by one or more of the following United States patents: 4,746,994; 4,970,663; 5,045,940; 5,267,351; 5,309,528; 5,355,450; 5,396,594; 5,440,348; 5,452,378; 5,467,288; 5,513,375; 5,528,310; 5,557,423; 5,568,275; 5,577,190; 5,584,006; 5,640,601; 5,644,364; 5,654,737; 5,715,018; 5,726,605; 5,726,717; 5,729,673; 5,745,637; 5,752,029; 5,754,851; 5,781,188; 5,799,150; 5,812,216; 5,852,435; 5,905,841; 5,929,836; 5,929,942; 5,930,445; 5,930,797; 5,946,445; 5,987,501; 5,999,190; 6,016,152; 6,018,337; 6,023,531; 6,023,703; 6,031,529; 6,058,236; 6,061,758; 6,091,778; 6,105,083; 6,118,444; 6,128,201; 6,134,607; 6,137,919; 6,141,691; 6,157,929; 6,160,548; 6,167,404; 6,198,477; 6,201,531; 6,223,211; 6,249,280; 6,269,195; 6,317,158; 6,317,515; 6,330,369; 6,351,557; 6,353,862; 6,357,047; 6,392,710; 6,404,435; 6,407,775; 6,417,891; 6,426,778; 6,449,019; 6,473,094; 6,477,271; 6,489,969; 6,512,522; 6,532,043; 6,539,163; D396,853; D398,912. Additional U.S. and foreign patents pending.

No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, including photocopying and recording, for any purpose without the express written permission of Avid Technology, Inc.

Copyright © 2003 Avid Technology, Inc. and its licensors. All rights reserved.

The following disclaimer is required by Apple Computer, Inc.

APPLE COMPUTER, INC. MAKES NO WARRANTIES WHATSOEVER, EITHER EXPRESS OR IMPLIED, REGARDING THIS PRODUCT, INCLUDING WARRANTIES WITH RESPECT TO ITS MERCHANTABILITY OR ITS FITNESS FOR ANY PARTICULAR PURPOSE. THE EXCLUSION OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES. THE ABOVE EXCLUSION MAY NOT APPLY TO YOU. THIS WARRANTY PROVIDES YOU WITH SPECIFIC LEGAL RIGHTS. THERE MAY BE OTHER RIGHTS THAT YOU MAY HAVE WHICH VARY FROM STATE TO STATE.

The following disclaimer is required by Sam Leffler and Silicon Graphics, Inc. for the use of their TIFF library:

Copyright © 1988–1997 Sam Leffler

Permission to use, copy, modify, distribute, and sell this software [i.e., the TIFF library] and its documentation for any purpose is hereby granted without fee, provided that (i) the above copyright notices and this permission notice appear in all copies of the software and related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may not be used in any advertising or publicity relating to the software without the specific, prior written permission of Sam Leffler and Silicon Graphics.

THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND, EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

The following disclaimer is required by the Independent JPEG Group:

Portions of this software are based on work of the Independent JPEG Group.

The following disclaimer is required by Paradigm Matrix:

Portions of this software licensed from Paradigm Matrix.
The following disclaimer is required by Ray Sauers Associates, Inc.:

"Install-It" is licensed from Ray Sauers Associates, Inc. End-User is prohibited from taking any action to derive a source code equivalent of "Install-It," including by reverse assembly or reverse compilation. Ray Sauers Associates, Inc. shall in no event be liable for any damages resulting from reseller's failure to perform reseller's obligation; or any damages arising from use or operation of reseller's products or the software; or any other damages, including but not limited to, incidental, direct, indirect, special or consequential Damages including lost profits, or damages resulting from loss of use or inability to use reseller's products or the software for any reason including copyright or patent infringement, or lost data, even if Ray Sauers Associates has been advised, knew or should have known of the possibility of such damages.

The following disclaimer is required by Videomedia, Inc.:

"Videomedia, Inc. makes no warranties whatsoever, either express or implied, regarding this product, including warranties with respect to its merchantability or its fitness for any particular purpose."

"This software contains V-LAN ver. 3.0 Command Protocols which communicate with V-LAN ver. 3.0 products developed by Videomedia, Inc. and V-LAN ver. 3.0 compatible products developed by third parties under license from Videomedia, Inc. Use of this software will allow "frame accurate" editing control of applicable videotape recorder decks, videodisc recorders/players and the like."

The following disclaimer is required by Altura Software, Inc. for the use of its Mac2Win software and Sample Source Code:


The following disclaimer is required by Ultimatte Corporation:

Certain real-time compositing capabilities are provided under a license of such technology from Ultimatte Corporation and are subject to copyright protection.

The following disclaimer is required by 3Prong.com Inc.:

Certain waveform and vector monitoring capabilities are provided under a license from 3Prong.com Inc.

Attn. Government User(s). Restricted Rights Legend

U.S. GOVERNMENT RESTRICTED RIGHTS. This Software and its documentation are "commercial computer software" or "commercial computer software documentation." In the event that such Software or documentation is acquired by or on behalf of a unit or agency of the U.S. Government, all rights with respect to this Software and documentation are subject to the terms of the License Agreement, pursuant to FAR §12.212(a) and/or DFARS §227.7202-1(a), as applicable.

Trademarks

888 I/O, AirPlay, AirSPACE, AirSPACE HD, AniMatte, AudioSuite, AudioVision, AutoSync, Avid, AVIDdrive, AVIDdrive Towers, AvidNet, AvidNetwork, AVIDstripe, Avid Unity, Avid Xpress, AView, CamCutter, ChromaCurve, ChromaWheel, DAЕ, D-Fi, D-fx, Digidesign, Digidesign Audio Engine, Digidesign Intelligent Noise Reduction, DigiDrive, DigiTranslator, DINA, D-Verb, Equinox, ExpertRender, FieldPak, Film Composer, FilmScribe, FluidMotion, HiIP, HyperSPACE, HyperSPACE HDCAM, IllusionFX, Image Independence, Intraframe, iS9, iS18, iS23, iS36, Lo-Fi, Magic Mask, make manage move | media, Marquee, Matador, Maxim, MCXpress, Media Composer, MediaDock, MediaDock Shuttle, Media Fusion, Media Illusion, MediaLog, Media Reader, Media Recorder, MEDIArray, MediaShare, Meridien, MetaSync, NaturalMatch, Nearview, NetReview, NewsCutter, OMF, OMF Interchange, OMM,
Open Media Framework, Open Media Management, ProEncode, Pro Tools, QuietDrive, Recti-Fi, RetroLoop, rS9, rS18, Sci-Fi, Softimage, Sound Designer II, SPACE, SPACEShift, Symphony, the Avid|DS logo, Trilligent, UnityRAID, Var-Fi, Video Slave Driver, VideoSPACE, and Xdeck are either registered trademarks or trademarks of Avid Technology, Inc. in the United States and/or other countries.

iNEWS, iNEWS ControlAir, and Media Browse are trademarks of iNews, LLC.

Adobe and Photoshop are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries. Betacam SP is a registered trademark of Sony Corporation. Mac OS, TrueType, and QuickTime are trademarks of Apple Computer, Inc., registered in the U.S. and other countries. Ultimatte is a registered trademark of Ultimatte Corporation. Windows is either a registered trademark or trademark of Microsoft Corporation in the United States and/or other countries. All other trademarks contained herein are the property of their respective owners. All other trademarks contained herein are the property of their respective owners.
Footage

Alien Images — Courtesy of Mark J. Norton. All Rights Reserved.

Arri — Courtesy of Arri™/Fauer — John Fauer, Inc.

Bazaar Rugs — Courtesy of Randy Fayan. All Rights Reserved.

Bell South 'Anticipation' — Courtesy of Two Headed Monster — Tucker/Wayne Atlanta/GMS.

Canyonlands — Courtesy of the National Park Service/Department of the Interior.

Eco Challenge British Columbia — Courtesy of Eco Challenge Lifestyles, Inc., All Rights Reserved.

Eco Challenge Morocco — Courtesy of Discovery Communications, Inc.

It's Shuttletime — Courtesy of BCP & Canadian Airlines.

Nestlé Coffee Crisp — Courtesy of MacLaren McCann Canada.

Saturn 'Calvin Egg' — Courtesy of Cossette Communications.

'Tigers: Tracking a Legend' — Courtesy of www.wildlifeworlds.com, Carol Amore, Executive Producer.

WCAU Fire Story — Courtesy of NBC-10, Philadelphia, PA.

Windhorse — Courtesy of Paul Wagner Productions.

GOT FOOTAGE?

Editors — Filmmakers — Special Effects Artists — Game Developers — Animators — Educators — Broadcasters — Content creators of every genre — Just finished an incredible project and want to share it with the world?

Send us your reels and we may use your footage in our show reel or demo!*

For a copy of our release and Avid's mailing address, go to www.avid.com/footage.

*Note: Avid cannot guarantee the use of materials submitted.

Contents

Using This Guide ................................................................. 23
Who Should Use This Guide .................................................. 23
About This Guide ................................................................. 24
Symbols and Conventions ...................................................... 25
If You Need Help ................................................................. 27
If You Have Documentation Comments ................................. 28
How to Order Documentation ................................................. 28
Avid Educational Services ..................................................... 28

Chapter 1 Preparing to Work with Effects ................................... 29
Types of Effects ........................................................................ 30
Overview of Horizontal, Vertical, and Nested Effects .................. 31
Effects Creation Tools ............................................................... 32
Real-Time Effects and Non-Real-Time Effects ............................ 33
Working with Effects in 24p or 25p Projects .............................. 34
Using the Effect Palette ............................................................ 36
  Displaying the Effect Palette .................................................. 37
  Resizing the Effect Palette .................................................... 38
  Understanding Effect Icon Color Coding ............................... 38
  Displaying Effect Templates .................................................. 39
Using Third-Party Plug-in Effects .............................................. 41
  AVX Plug-ins and Memory Usage ......................................... 42
  Installing Plug-in Effects Compatible with Photoshop
    (Macintosh Only) ............................................................ 42
  Installing AVX Plug-ins ....................................................... 43
  Locating the AVX_Plug-Ins Folder (Windows Only) ................. 45
  Upgrading AVX Plug-ins and Effects ..................................... 46
Assigning Multiple Tracks in Plug-in Effects ........................................ 47
Using AVX Plug-in Controls ................................................................. 48
   Accessing an AVX Custom Interface .............................................. 48
   Custom AVX Controls in the Effect Editor ................................. 49
Troubleshooting AVX Plug-Ins ............................................................... 49
   Plug-In Does Not Appear in the Effect Palette ............................. 50
   Plug-In Does Not Load ................................................................. 50
   The Avid Application Cannot Render the Plug-In ....................... 50
   Blank Effect Icons in the Timeline ............................................. 50
   Missing Effect Categories in the Effect Palette ......................... 51
   The Avid System Is Running Out of Free Memory ....................... 51
Changing Timeline View Settings for Effects ....................................... 51
Adjusting Trim Settings for Effects .................................................. 52

Chapter 2 Basics of Effects Editing .................................................. 53
Deconstructing Effects ......................................................................... 54
Applying Effects to a Sequence .......................................................... 56
   Applying an Effect to a Single Transition or Segment ................ 56
   Applying an Effect to Multiple Transitions ................................ 58
   Applying an Effect to Multiple Segments ..................................... 59
Deleting Effects in a Sequence ............................................................. 60
   Deleting a Single Effect ............................................................... 61
   Deleting Multiple Transition Effects ........................................... 62
   Deleting Multiple Segment Effects ............................................ 62
Using the Fade Effect Button ............................................................... 63
Working with Transition Effects .......................................................... 64
   Types of Transition Effects ............................................................ 64
   Applying a Dissolve Effect ............................................................. 64
      Using the Effect Palette ............................................................. 64
      Using the Transition Parameters ............................................ 65
      Using the Quick Transition Button to Create Effects .............. 66
      Using the Quick Transition Button to Apply Effects to Multiple
      Transitions ............................................................................. 70
Chapter 3  Customizing Effects ................................. 81

Understanding the Graphical Display in the Quick Transition
Dialog Box .......................................................... 73
Adding Fades (Dissolves) with the Head Fade and Tail Fade Buttons ........................................... 77
Sizing the Effect to Fit the Media ................................. 78
Trimming a Transition Effect ...................................... 79
Adjusting Transitions in the Timeline ......................... 79

Entering Effect Mode ............................................... 82
Customizing the Effect Display .................................. 83
Understanding the Effect Preview Monitor .................... 83
Using Big Effect Mode ............................................ 85
Mapping User-Selectable Buttons in Effect Mode ........... 85
Understanding the Tracking Information ...................... 86
Displaying the Safe Title and Safe Action Guidelines .... 86
Working with the Effect Grid ..................................... 88
Setting the Effect Grid Options ................................. 89
Displaying the Effect Grid in Effect Mode ..................... 92
Displaying Position Coordinates ............................... 92
Using Local Grid Parameters .................................. 93
Obtaining Position Information in a Film Project ............ 93
Position Information for the Paint and AniMatte Effects ... 94
Position Information for the Blowup Effect .................. 95
Navigating in Effect Mode ........................................ 96
Changing Position ............................................... 96
Using Single-Field Step ......................................... 96
Using the Effect Editor ........................................... 97
Effect Editor Controls ............................................ 98
Moving an Enlarged Image in Effect Mode .................... 102
Selecting a Parameter ........................................... 103
Changing a Parameter with a Slider ......................... 104
Accessing Additional Parameters for an Effect ....... 106
Adjusting the View in a Keyframe Graph .......................... 153
Zooming and Scrolling Keyframe Graphs .......................... 154
Resizing the Keyframe Graph .......................... 156
Moving the Keyframe Graph View Up or Down .................. 156
Resetting the Graph View .................................. 156
Commands for Using Advanced Keyframes ....................... 157
Defining a Motion Path .................................. 161
Moving the Image Directly to Add a Motion Path .............. 161
Using an Effect Template .................................. 164
Saving an Effect Template .................................. 164
Applying an Effect Template .................................. 166

Chapter 4 Playing and Rendering Effects ...................... 169
Playing an Effect .................................. 170
Basic Playback .................................. 170
Playing an Effect in a Continuous Loop ...................... 170
Playing a Preview of an Effect .................................. 171
Understanding Real-Time Effects Processing ...................... 171
Controlling Playback of Real-Time Effects ...................... 172
Prefilling the Video Display Buffer .................................. 173
Limiting the Number of Real-Time Streams ...................... 174
Controlling Video Quality for Playback ....................... 175
Rendering Effects .................................. 176
Creating and Using Render Settings .......................... 178
Creating a New Render Setting .................................. 178
Adjusting Render Settings Parameters .......................... 178
Activating a Render Setting .................................. 182
Rendering a Single Effect .................................. 183
Rendering Effects at Position .................................. 184
Rendering Effects Between IN and OUT Points .................. 185
Displaying Effects On-the-Fly .................................. 186
Interrupting Render On-the-Fly .................................. 186
Rendering HQ (Highest Quality) Effects ....................... 187
Combined Rendering of Real-Time and Non-Real-Time Effects .................................. 188
Chapter 5  Creating and Customizing Motion Effects  211

Understanding Motion Effects  212
Creating Traditional Motion Effects  213

Creating a Rolling Clip That Freezes  222
Creating a Traditional Strobe Motion Effect  226
Working with the Timewarp Effect .............................................. 228
  Speed and Position ................................................................. 230
  Interpolation Options ............................................................. 231
  Rendering Timewarp Effects ..................................................... 231
Creating a Timewarp Effect ......................................................... 233
  Creating a Timewarp Effect from the Effect Palette ......................... 233
  Promoting a Traditional Motion Effect to a Timewarp Effect .............. 233
Opening the Motion Effect Editor ................................................ 235
Understanding the Motion Effect Editor Display ............................ 236
  Selecting the Active Control Graph .......................................... 239
  Setting Input Format and Output Format Options ......................... 240
  Selecting a Rendering Option .................................................. 241
  Speed Graph Display and Position Graph Display .......................... 244
  Changing a Graph Display with the Scale Sliders ....................... 245
  Motion Effect Editor Fast Menu Commands ................................ 247
  Toolbar Buttons for the Active Control Graph ............................. 248
Using the Timewarp Speed Graph ................................................ 249
  Using the Source Anchor Frame ............................................... 251
Using the Timewarp Position Graph .............................................. 252
Setting Up the Motion Effect Editor .......................................... 254
Timewarp Effect Examples ......................................................... 256
  Speed Graph Example: Creating a Rolling Clip That Freezes ............ 256
  Speed Graph Variations: Moving Keyframes ................................ 259
  Strobe Motion Using the Timewarp Effect ................................... 261
  Setting Effect Position with the Position Graph ........................... 262
  Position Graph Example: Reverse Motion .................................... 263
Working with FluidMotion Timewarp Effects ................................. 266
  Opening FluidMotion Edit ....................................................... 267
  Using the Effect Editor with FluidMotion Edit ............................ 268
  Making Corrections with FluidMotion Edit .................................. 268
    Displaying Vectors in FluidMotion Edit .................................. 269
    Defining a Region Around an Artifact .................................... 271
    Applying Corrections to a Region ......................................... 271
Chapter 9  Creating Titles and Graphic Objects  385

Workflow for Creating and Editing Titles  386
Opening the Title Tool  387
Understanding the Title Tool  388
  Understanding the Toolbar  389
  Using the Selection Tool  391
Setting Up the Drawing Environment  392
  Installing Fonts  392
  Previewing Titles  393
  Using Title and Action Guidelines  394
  Using Safe Colors  394
  Selecting a Background  394
    Using a Video Background  395
    Updating the Video Background  395
    Creating a Color Background  396
  Displaying a Grid  396
  Snapping to a Grid  396
  Bringing the Title Tool to the Foreground  397
  Using the 16:9 Display Format for Titles  397
Working with Text  398
  Creating Text  398
  Copying and Pasting Text  399
  Resizing Text Objects  400
  Repositioning Text Objects  400
  Editing a Text String  401
  Formatting the Text  401
    Setting the Default Text Attributes  402
    Selecting a Font  403
    Changing the Point Size  403
    Making Text Bold or Italic  404
    Justifying the Text  404
Adjusting Shadow Softness ........................................... 427
Setting Shadow Softness ............................................. 427
Adjusting Shadow Softness On-the-Fly ......................... 428
Viewing Shadow Softness .......................................... 429
Creating a Glow Effect .............................................. 429
Manipulating Objects ................................................. 429
Basic Object Manipulation ........................................... 430
Layering Text and Objects .......................................... 430
Grouping and Ungrouping Objects ................................. 431
Locking and Unlocking Objects .................................... 432
Aligning Objects ....................................................... 433
Distributing Objects .................................................. 434
Saving Titles and Title Styles ...................................... 435
Matching Resolutions ................................................ 436
Saving a Title and Exiting the Title Tool ....................... 436
Saving Multiple Titles in a Session ............................... 437
Using a Keyboard Shortcut to Save a Title .................... 438
Using the Fast Save Option ......................................... 439
Saving a Title with Fast Save ....................................... 439
Viewing Fast-Saved Titles in a Bin ............................... 440
Revising a Title in a Bin ............................................ 440
Creating and Using Title Templates .............................. 441
Creating Title Templates ............................................ 441
Using Title Templates ............................................... 442
Working with Titles on Systems with 24p or 25p Support .... 443
Creating Titles on Systems with 24p or 25p Support .......... 444
Saving Titles on Systems with 24p or 25p Support .......... 444
Saving and Recalling Title Styles ................................. 446
Saving a Title Style .................................................. 446
Title Style Sheet Options ........................................... 448
Recalling a Title Style ............................................... 449
Confirming Function Key Mapping of Title Styles ............. 449
Applying Title Styles to Text Objects ........................... 450
Managing Title Styles ............................................... 450
Exporting a Title as a Graphics File .............................. 451
### Chapter 10: Editing with Titles

- **Workflow for Editing with Titles** .................................................. 454
- **Before You Begin** ................................................................. 454
  - Restrictions on the Complexity of Titles .................................. 454
  - Playback Restrictions for Rolling Titles .................................... 455
  - Title Effect Clips in the Bin ...................................................... 456
- **Displaying Title Frames in the Bin** ........................................... 457
- **Editing a Title into a Sequence** ................................................ 457
  - Setting Marks in a Rolling Title or a Crawling Title .................... 458
  - Splicing or Overwriting a Title into a Sequence ......................... 458
  - Dragging a Marked Title into a Sequence .................................. 460
  - Dragging an Unmarked Title into a Sequence .............................. 462
  - Trimming the Duration of Rolling and Crawling Titles ................. 463
- **Removing a Title** ................................................................. 464
- **Replacing a Title** ................................................................. 464
- **Fading a Title** .................................................................... 465
- **Adjusting Title Effect Parameters** .......................................... 465
- **Revising a Title in a Sequence** ............................................... 467
- **Working with Existing Multiformat Titles** .................................. 469
- **Replacing Fill Tracks** ............................................................ 469
- **Rendering Titles** ................................................................. 470
  - Re-creating Title Media ......................................................... 470
    - Re-creating Title Media from the Timeline .............................. 471
    - Creating Media for Unrendered Titles in a Bin ........................ 472
    - Re-creating Title Media on Systems with 24p or 25p Support ..... 473
- **Promoting a 2D Title to 3D** .................................................... 474
- **Troubleshooting Titles** .......................................................... 474
  - Title Error Messages .............................................................. 474
  - Wrong Title Format ............................................................... 475

### Chapter 11: Intraframe Editing

- **Understanding the Intraframe Effects** ....................................... 478
- **Rendering Intraframe Effects** ................................................. 480
  - Rendering Paint Effects ....................................................... 480
  - Rendering AniMatte Effects .................................................... 480
Getting Started with the Paint and AniMatte Effects. 481
Applying the Paint or AniMatte Effect to a Sequence 482
Using the Effect Editor with the Paint Effect 483
Using the Effect Editor with the AniMatte Effect 485
Editing with Single-Field Step 486
Using Effect Templates with the Intraframe Effects 486
Using the Intraframe Drawing Tools 486
Understanding Intraframe Modes 487
Using an Optional Pen Tool 487
Using the Brush Tool 488
Selecting a Color 488
Shortcut for Selecting a Color with the Brush Tool 488
Painting with the Brush 489
Creating a Custom Brush Head from a Template 489
Saving a Brush Template 491
Using Path to Create a Signature Effect 491
Using the Selection Tool 492
Creating Rectangular Shapes 493
Creating Oval Shapes 494
Drawing Polygons 495
Creating Polygons with Straight-Line Segments 496
Creating Polygons with Curved Segments 498
Creating a Straight Line Following a Curve 499
Creating Curved Objects 501
Changing the Parameters of a Painted Object 501
Working with Vector-Based Objects 503
The Elements of Vector-Based Objects 503
Getting Started with Bézier Curves 505
Transforming a Rectangle into a Circle 505
Experimenting with Direction Handles 507
Creating a Corner Join 509
Modifying Lines and Curves Summarized 511
Painting a New Object with Bézier Curves 512
Adding a Control Point 513
Removing a Control Point 514
## Tables

<table>
<thead>
<tr>
<th>Table</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table 1</td>
<td>Effect Preview Monitor Toolbar Buttons</td>
<td>84</td>
</tr>
<tr>
<td>Table 2</td>
<td>Grid Settings Options</td>
<td>89</td>
</tr>
<tr>
<td>Table 3</td>
<td>Effect Editor Controls</td>
<td>100</td>
</tr>
<tr>
<td>Table 4</td>
<td>Promotion Paths for Advanced Keyframes</td>
<td>117</td>
</tr>
<tr>
<td>Table 5</td>
<td>Effect Editor Toolbar for Advanced Keyframes</td>
<td>119</td>
</tr>
<tr>
<td>Table 6</td>
<td>Shortcut Menu Controls for Keyframe Graphs and the Motion Effect Editor</td>
<td>121</td>
</tr>
<tr>
<td>Table 7</td>
<td>Effect Editor Commands</td>
<td>158</td>
</tr>
<tr>
<td>Table 8</td>
<td>Render Setting Options</td>
<td>179</td>
</tr>
<tr>
<td>Table 9</td>
<td>Playback Capabilities of Motion Effects</td>
<td>215</td>
</tr>
<tr>
<td>Table 10</td>
<td>Motion Effect Editor Components</td>
<td>237</td>
</tr>
<tr>
<td>Table 11</td>
<td>Motion Effect Editor Toolbar Buttons</td>
<td>239</td>
</tr>
<tr>
<td>Table 12</td>
<td>Timewarp Effect Input Format and Output Format Options</td>
<td>240</td>
</tr>
<tr>
<td>Table 13</td>
<td>Timewarp Effect Rendering Options</td>
<td>241</td>
</tr>
<tr>
<td>Table 14</td>
<td>Active Control Graph Toolbar Buttons</td>
<td>248</td>
</tr>
<tr>
<td>Table 15</td>
<td>Speed Graph Components</td>
<td>250</td>
</tr>
<tr>
<td>Table 16</td>
<td>Position Graph Components</td>
<td>253</td>
</tr>
<tr>
<td>Table 17</td>
<td>Title Toolbar Elements</td>
<td>389</td>
</tr>
<tr>
<td>Table 18</td>
<td>Title Style Sheet Dialog Box Components</td>
<td>448</td>
</tr>
<tr>
<td>Table 19</td>
<td>Effect Editor Components for the Paint Effect</td>
<td>484</td>
</tr>
<tr>
<td>Table 20</td>
<td>Methods of Modifying Lines and Curves</td>
<td>511</td>
</tr>
</tbody>
</table>
Using This Guide

This guide is your introduction to the wealth of effects and design options available for use in your projects. Along with the standard editing features included with this latest release, you have at your fingertips all the sophisticated effects capabilities of a high-end post-production suite, combined with the versatility of a digital nonlinear system.

You can use the tools and techniques described in this guide to create and incorporate into your sequence titles and effects with a wide variety of attributes. This guide also describes how to apply third-party plug-in effects for stunning effects formerly available only on high-end graphics workstations.

A companion volume, Avid Effects Reference for Avid Media Composer Adrenaline, Avid NewsCutter Adrenaline FX, Avid NewsCutter XP, contains reference material for all 2D effects and 3D effects. It is available as part of the Help and on the online library CD-ROM that came with your application.

Who Should Use This Guide

This guide is intended for all Avid users, from beginning to advanced.
Using This Guide

About This Guide

This guide is designed to keep pace with current advances in your Avid editing application’s effects capabilities by consolidating the information you will need to take advantage of the many options available to you. This guide will lead you through even the most complex procedures with task-oriented instructions. The information provided here builds on editing procedures described in the tutorial and the rest of your Avid application’s documentation, while adding a complete explanation of all the tools and techniques required to create, apply, and adjust various effects and graphics, including useful tips, shortcuts, and custom options.

The Contents lists all topics included in the book. They cover the following general areas:

- **Effects editing**: The first seven chapters of this book describe various beginning and advanced techniques for incorporating literally hundreds of digital video effects (DVEs), third-party effects, keys, and layering options.

- **Working with 3D effects**: Chapter 8 provides examples of effects you can re-create to become familiar with the 3D parameters and shapes.

- **Creating and editing titles and graphic objects**: Chapter 9 and Chapter 10 cover real-time titling and use of the tools to create and control the attributes of on-screen text, backgrounds, lines, boxes, ovals, and other graphics objects. You can create multiple titles without exiting the Title tool and apply shadows, color, transparency, layers, and alignment to both objects and text.

- **Intraframe™ editing**: Chapter 11 covers tools and techniques for creating Paint and AniMatte™ effects on individual or multiple frames of footage, including methods for removing scratches and other flaws.

- A detailed Index helps you quickly locate specific topics.

- A companion volume, *Avid Effects Reference for Avid Media Composer Adrenaline, Avid NewsCutter Adrenaline FX, Avid NewsCutter XP*, contains reference material for all 2D effects and 3D effects. It is available as part of the Help and on the online library CD-ROM that came with your application.
Symbols and Conventions

Unless noted otherwise, the material in this document applies to the Windows XP and Mac OS X operating systems. When the text applies to a specific operating system, it is marked as follows:

- (Windows) or (Windows only) means the information applies to the Windows XP operating system.
- (Macintosh) or (Macintosh only) means the information applies to the Mac OS X operating system.

The majority of screen shots in this document were captured on a Windows XP system, but the information applies to both Windows XP and Mac OS X systems. Where differences exist, both Windows XP and Mac OS X screen shots are shown.

Avid documentation uses the following symbols and conventions:

<table>
<thead>
<tr>
<th>Symbol or Convention</th>
<th>Meaning or Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Note Icon]</td>
<td>A note provides important related information, reminders, recommendations, and strong suggestions.</td>
</tr>
<tr>
<td>![Caution Icon]</td>
<td>A caution means that a specific action you take could cause harm to your computer or cause you to lose data.</td>
</tr>
<tr>
<td>![Warning Icon]</td>
<td>A warning describes an action that could cause you physical harm. Follow the guidelines in this document or on the unit itself when handling electrical equipment.</td>
</tr>
<tr>
<td>![Menu Command Icon]</td>
<td>This symbol indicates menu commands (and subcommands) in the order you select them. For example, File &gt; Import means to open the File menu and then select the Import command.</td>
</tr>
</tbody>
</table>
Using This Guide

<table>
<thead>
<tr>
<th>Symbol or Convention</th>
<th>Meaning or Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>▶️</td>
<td>This symbol indicates a single-step procedure. Multiple arrows in a list indicate that you perform one of the actions listed.</td>
</tr>
<tr>
<td>⌨️</td>
<td>This symbol represents the Apple or Command key. Press and hold the Command key and another key to perform a keyboard shortcut.</td>
</tr>
<tr>
<td>Margin tips</td>
<td>In the margin, you will find tips that help you perform tasks more easily and efficiently.</td>
</tr>
<tr>
<td>Italic font</td>
<td>Italic font is used to emphasize certain words and to indicate variables.</td>
</tr>
<tr>
<td>Courier Bold font</td>
<td>Courier Bold font identifies text that you type.</td>
</tr>
<tr>
<td>Click</td>
<td>Quickly click and release the left mouse button (Windows) or the mouse button (Macintosh).</td>
</tr>
<tr>
<td>Double-click</td>
<td>Click the left mouse button (Windows) or the mouse button (Macintosh) twice rapidly.</td>
</tr>
<tr>
<td>Right-click</td>
<td>Quickly click and release the right mouse button (Windows only).</td>
</tr>
<tr>
<td>Drag</td>
<td>Click and hold the left mouse button (Windows) or the mouse button (Macintosh) while you move the mouse.</td>
</tr>
<tr>
<td>Ctrl+key</td>
<td>Press and hold the first key while you press the second key.</td>
</tr>
<tr>
<td>⌨️+key</td>
<td>Press and hold the Apple or Command key while you press the second key.</td>
</tr>
</tbody>
</table>
If You Need Help

If you are having trouble using your Avid editing application:

1. Retry the action, carefully following the instructions given for that task in this guide. It is especially important to check each step of your workflow.

2. Check in one of two locations for the latest information that might have become available after the documentation was published:
   - If release notes are available, they ship with your application.
   - If ReadMe files are available, they are supplied in your Avid application folder. ReadMe files are also available from Help.

   Release notes and ReadMe files are also available on the Avid Knowledge Center.

3. Check the documentation that came with your Avid application or your hardware for maintenance or hardware-related issues.

4. Visit the online Knowledge Center at www.avid.com/support. Online services are available 24 hours per day, 7 days per week. Search this online Knowledge Center to find answers, to view error messages, to access troubleshooting tips, to download updates, and to read/join online message-board discussions.

5. For Technical Support, please call 800-800-AVID (800-800-2843).
   For Broadcast On-Air Sites and Call Letter Stations, call 800-NEWSDNG (800-639-7364).
Using This Guide

If You Have Documentation Comments

We’d appreciate any comments or suggestions you may have about this document or any other piece of documentation. Please restrict your comments to documentation issues.

Please e-mail your documentation comments to:

    TechPubs@avid.com

Include the title of the document, its part number, and the specific section you are commenting on in all correspondence.

How to Order Documentation

To order additional copies of this documentation from within the United States, call Avid Sales at 800-949-AVID (800-949-2843). If you are placing an order from outside the United States, contact your local Avid representative.

Avid Educational Services

For information on courses/schedules, training centers, certifications, courseware, and books, please visit www.avid.com/training or call Avid Sales at 800-949-AVID (800-949-2843).
Your Avid application offers many effects that you can apply to your sequences. This chapter describes some of the concepts with which you must become familiar before you begin creating and editing effects into sequences.

- Types of Effects
- Overview of Horizontal, Vertical, and Nested Effects
- Effects Creation Tools
- Real-Time Effects and Non-Real-Time Effects
- Working with Effects in 24p or 25p Projects
- Using the Effect Palette
- Using Third-Party Plug-in Effects
- Changing Timeline View Settings for Effects
- Adjusting Trim Settings for Effects
Chapter 1  Preparing to Work with Effects

Types of Effects

Much overlapping occurs between the various types of effects you can create, as well as the methods used to create them. Roughly speaking, there are four basic types of effects:

- **Transition effects** (dissolves, wipes, and so forth) are applied at the cut point between two video clips that are on the same video track (that is, the same video layer).

  Chapter 2 and Chapter 3 describe techniques for creating transition effects.

- **Segment effects** (both single-layer and multilayer) are applied to an entire clip or group of clips. There are two types of segment effects:
  - A single-layer segment effect, such as the Mask effect, is applied to a segment on one video track. Single-layer segment effects use one stream of video.

    Chapter 2 and Chapter 3 describe techniques for creating single-layer segment effects.

  - A multilayer segment effect, such as the Picture-in-Picture (PIP) effect, is applied to the top layer or a middle layer of segments that contain two or more video tracks that will be played simultaneously.

    Chapter 6 describes techniques for creating multilayer effects.

- **Title effects** are created with the Title tool and are edited onto their own layers in a sequence.

  Chapter 9 and Chapter 10 describe techniques for creating and editing title effects.

- **Motion effects** (Freeze Frame, Variable Speed, Strobe Motion, and Timewarp) are created by manipulating specific motion characteristics in a clip.

  Chapter 5 contains detailed information about motion effects.

A number of effects have both 2D (two-dimensional) and 3D (three-dimensional) versions. Chapter 8 describes techniques for creating 3D effects.
You can break down effect designs into two different types:

- **Horizontal** refers to effects that you apply across an individual video track. Horizontal effects include:
  - Transition effects between two video clips (dissolves, wipes)
  - Segment effects and motion effects that modify the appearance of a single clip (color effects, flops)

- **Vertical** refers to effects that you apply by adding video elements on more than one track to create a composite.

Vertical effects include picture-in-pictures, titles, and superimpositions. Individual elements in a vertical effect can also contain horizontal effects.

You might need to change a single element in a vertical effect sequence. For example, you might want to apply a color effect within an existing Picture-in-Picture effect. To do this, you can nest an effect inside another effect. Instead of one video layer being physically above another video layer, a nested effect is contained within another effect on the same video layer. For more information, see “Nesting Effects” on page 294.
Chapter 1  Preparing to Work with Effects

Effects Creation Tools

The following illustration presents the basic tools used to create effects.

Sources of effects:

Effect Palette
Motion Effect dialog box
Title tool

Apply transition and segment effects directly to tracks.

Effects editing:
Edit effect clips into the Timeline.

Effects adjustment in Effect mode:
Title and motion effects appear first as clips in the bin.

Effect Editor:
Effect Preview monitor:
Allows you to adjust effect parameters.
Allows you to preview an effect, manipulate keyframes, and manipulate wire-frame representations of the effect.
Real-Time Effects and Non-Real-Time Effects

A real-time effect is an effect that you can apply to a sequence and play without having to render it first (rendering takes time and drive space). Non-real-time effects must be rendered before you can play them back. Without rendering, non-real-time effects can be previewed or played as an outline.

A real-time effect has a small orange dot within the effect icon in the Timeline. Effects that must be rendered have a small blue dot within the effect icon in the Timeline. Effects that might need to be rendered have a small green dot within the effect icon in the Timeline. For more information, see “Understanding Effect Icon Color Coding” on page 38.

Your Avid application has a mix of real-time and non-real-time effects. For a complete list of effects and their real-time status, see the Knowledge Center section of the Avid Web site at www.avid.com.

You can create a sequence that has any number of real-time and non-real-time effects. However, there are limits on how many real-time effects your Avid editing application can play at once without rendering or otherwise reducing the amount of processing necessary during playback. For more information, see Chapter 4.

Real-time effects might cause dropped frames during a digital cut. You can have the Avid editing application select and render real-time effects that might cause dropped frames. For more information, see “Recording a Digital Cut to Tape (Remote Mode) and Recording a Digital Cut to Tape (Local Mode)” in the Help.
Chapter 1  Preparing to Work with Effects

Working with Effects in 24p or 25p Projects

Since effects in 24p or 25p projects are frame based rather than field based, their normal behavior is slightly different from effects in interlaced projects. In particular, temporal artifacts might appear in some effects under certain circumstances. This section explains when temporal artifacts might appear and suggests ways to create effects that do not show perceptible temporal artifacts.

Effects that do not involve any movement across the screen — for example, masks, Color Effects, and dissolves — look the same in 24p or 25p projects as in interlaced projects.

Effects that involve movement across the screen — for example, wipes, 3D shapes, or moving titles — might look different from their equivalents in interlaced projects for the following reasons:

• Since the effect is created using 24 or 25 progressive frames per second (24p or 25p), motion across the screen is interpolated in 24 or 25 increments per second. (Contrast the 50 increments per second for a PAL interlaced project or the 60 increments per second for an NTSC interlaced project.) For example, the edge of a 1-second Horizontal Edge Wipe effect will appear in 24 or 25 different positions across the screen. For effects of short duration in particular, this difference might be perceptible to the viewer.

• When the 24p or 25p media is output (to the interlaced Client monitor or as a digital cut), it is re-interlaced and pulldown is inserted to achieve 60 fields per second (NTSC). The Avid application inserts pulldown by duplicating some of the existing frames to create the correct number of fields per second. Temporal artifacts created by this duplication process might be perceptible to the viewer. This behavior is a normal result of the pulldown insertion process and is often perceptible in conventional transfers of films to video formats.

PAL output with pulldown also duplicates certain frames but is less likely to exhibit perceptible temporal artifacts since fewer frames require duplication.
Motion effects created in 24p or 25p projects, such as Variable Speed effects, might also look different from motion effects created in interlaced projects. For more information on 24p or 25p motion effects, see “About Motion Effects in 24p or 25p Projects” on page 219.

For more information on how the Avid application handles 24p or 25p material, see “Working with 24p Media” and “Working with 25p Media” in the Help.

If an effect in a 24p or 25p project does not look completely smooth, do one or more of the following:

• Slow down the effect.
  For example, a 2-second Horizontal Edge Wipe effect, while it is still performing at the same rate (24 increments per second), moves across the screen in 48 steps. These smaller movements make the wipe appear smoother to the viewer.

• Soften the edges of the effect.
  The more the edges of the effect are blurred, the less noticeable the movements between the increments of the effect will be.

• When working with moving titles, avoid small font sizes and sharp edges.
  In a moving title such as a roll, lines of small text might move less smoothly than lines of larger text.
Chapter 1  Preparing to Work with Effects

Using the Effect Palette

The Effect Palette is a window that lists all the available effects. The effects that are available depend on the model and options that you purchased and on what third-party plug-ins you might have installed.

For the list of effects available for your Avid application, see the Knowledge Center section of the Avid Web site at www.avid.com.

You select transition and segment effects from the Effect Palette. The effects in the Effect Palette are grouped by category:

- Blend
- Box Wipe
- Conceal
- Edge Wipe
- Film
- Illusion FX
- Image
- Key
- L-Conceal
- Matrix Wipe
- Peel
- Push
- Reformat
- Sawtooth Wipe
- Shape Wipe
- Spin
- Squeeze
- Timewarp
- Xpress 3D Effect
If you have effect templates saved in an open bin, or if you have third-party plug-in effects installed, additional effect categories appear in the Effect Palette.

The Illusion FX category appears in the Effect Palette and contains the IllusionFX™ Pack plug-ins that are standard with the Avid application. For information on IllusionFX Pack effects, see “Illusion FX” in the Help.

Each effect category contains multiple effects. Use the following procedure to display the Effect Palette.

### Displaying the Effect Palette

**To display the Effect Palette:**

1. Do one of the following:
   - Select Tools > Effect Palette.
   - Select Toolset > Effects Editing.
   - In the Project window, click the Effects tab.
   - Press Ctrl+8 (Windows) or ⌘+8 (Macintosh).

The Effect Palette opens.

The left side of the Effect Palette displays a scrollable list of effect categories. The right side shows the various effects that are available for the currently selected effect category.
2. Click an effect category to select it and display effects in the category.

*Not all effects are available with all Avid editing applications. For example, the Blur and Mosaic effects are available with some editing applications that don’t have the AniMatte effect and the Paint Effect.*

**Resizing the Effect Palette**

You can resize the Effect Palette to display more effects when a particular category includes a long list of icons.

**To resize the Effect Palette:**

- Click the lower right corner of the palette, drag the palette to the size you want, and release the mouse button.

**Understanding Effect Icon Color Coding**

Effect icons in the Effect Palette and in the Timeline display color-coded dots to help you determine whether an effect is real-time or non-real-time. After opening the Effect Palette, you will notice that:

- Real-time effects are preceded by an *orange dot*. These effects take advantage of fast rendering.
- Real-time effects that *might not* be playable in real time due to their position in a sequence or the options available on your Avid application are preceded by a *green dot*. These effects take advantage of fast rendering.
- Non-real-time effects have *no dot* in the Effect Palette. In the Timeline, the effect icon contains a *blue dot* until the effect is rendered.

*When you edit a non-real-time effect into a sequence, the effect icon appears with a blue dot in the Timeline, which indicates that you must render the effect to play it in real time. After you render the effect, the effect icon appears in the Timeline without a dot.*
Using the Effect Palette

All color-coded dots disappear in the Timeline when you render effects.

A real-time effect might not be playable in real time for a variety of reasons involving the complexity of the sequence and the real-time effects capabilities of the Avid application. For more information, see “Real-Time Effects and Non-Real-Time Effects” on page 33.

Displaying Effect Templates

Effect templates allow you to save the parameters of an effect to a bin and to use them again to create or modify other effects. To learn more about applying templates, see “Using an Effect Template” on page 164.

In addition to allowing you to view all the standard effects, the Effect Palette allows you to view and access effect templates that are stored in open bins. The names of open bins containing effects appear in a list below the effect categories.
Chapter 1  Preparing to Work with Effects

To view the effect template:

1. Open the bin containing the effect templates.

   For more information, see “Displaying the Effect Palette” on page 37.

2. Select Tools > Effect Palette.

   The Effect Palette opens.

3. Click the bin name below the effect category list to view the effect templates in the bin.

   For example, in the illustration in step 1, the bin named Effects contains a series of effect templates using the Paint Effect, Picture-in-Picture, and Timewarp effects.
In the previous illustration, notice that the Effect Palette also displays other effect files, such as titles and matte key clips.

Whenever you open or close a bin or drop an effect into a bin, the application automatically updates both lists. Once a template appears on the right side of the Effect Palette, you can apply it as you would any other effect.

Using Third-Party Plug-in Effects

You can use third-party plug-in effects to add new effects or to update existing effects. Third-party plug-in effects are compatible with the Avid Visual Extensions (AVX™) standard. AVX is a cross-platform software architecture designed to allow software effect modules to be dynamically linked with a host application such as an Avid application.

The Illusion FX category appears in the Effect Palette and contains the IllusionFX Pack plug-ins that are standard with your Avid application. For information on IllusionFX Pack effects, see “Illusion FX” in the Help.

For a complete, up-to-date list of AVX plug-in vendors and other information on AVX, visit the AVX Web site:

www.avid.com/partners/avx/displayPartners.html

After you install third-party plug-ins, the effects appear in the Effect Palette in their own category (usually the name of the plug-in vendor). Individual effects all have a plug-in icon. The plug-in icon also appears in the Timeline when you have applied a third-party plug-in effect. After you create an effect, you can save it as an effect template and reapply the template to other transitions or segments in your sequence. Effect templates also appear in a special section at the bottom of the Effect Palette.

The Avid application also supports Digidesign® AudioSuite™ plug-ins. These plug-ins apply only to audio clips and do not appear in the Effect Palette. For more information, see “Working with Audio” in the Help.
If you are transferring from another system a project that includes sequences with AVX plug-in effects, you must install matching AVX plug-ins in order to see the effects.

AVX Plug-ins and Memory Usage

Each time you apply an AVX plug-in to a sequence, the Avid application keeps the effect resident in memory. When you close the bin containing the sequence, the application also closes the AVX plug-ins, freeing the memory. If you have applied many plug-ins and you find your Avid application running out of memory, use the following procedure to free the memory being used by the plug-ins.

To close all the AVX plug-ins:
1. Select Tools > Console.
2. Type the command `closeallavxplugins` and press Enter (Windows) or Return (Macintosh).

   The application closes all open AVX plug-ins. The AVX plug-ins will automatically open again as needed.

Installing Plug-in Effects Compatible with Photoshop (Macintosh Only)

Avid applications running on a Macintosh platform can use many plug-in effects that are compatible with Adobe® Photoshop®. You purchase these plug-ins directly from a third-party vendor.

To install plug-ins that are compatible with Photoshop:

1. Exit the Avid application.

   Do not add or remove plug-ins while the Avid application is running.
Using Third-Party Plug-in Effects

2. Copy the plug-in files from the software vendor’s folder to the 3rd Party Plug-Ins folder located on your Macintosh HD drive. The 3rd Party Plug-Ins folder is located within the Avid file structure:

Macintosh HD:Applications:Product Name:SupportingFiles:

3rd Party Plug-Ins

where Product Name is the name of your Avid editing application.

3. Restart the Avid application.


The plug-in effects will appear in the Effect Palette, usually in their own effect category.

⚠️ You must place the plug-ins directly in the 3rd Party Plug-Ins folder. They cannot be inside another folder within this folder or elsewhere on the Avid system. If they are, the Avid application will not recognize them.

Installing AVX Plug-ins

AVX plug-ins usually come complete with any necessary documentation. This section describes how to install the plug-ins and how to access them from your Avid application.

Most AVX plug-ins have their own installation program. This program locates the AVX_Plugin-Ins folder and installs the plug-ins automatically when you follow the installation instructions.

⚠️ If an AVX plug-in has an installation program, always use the program to install the plug-ins. For more information, see the documentation for the plug-in.

Some AVX plug-ins do not have an installation program and must be installed manually.
To install AVX plug-ins manually:

1. Exit the Avid application.

Do not add or remove plug-ins while the Avid application is running.

2. Copy the plug-in files from the software vendor’s folder to the AVX_Plug-Ins folder located on your Avid system.

You must place the plug-ins directly in the AVX_Plug-Ins folder. They cannot be inside another folder within this folder or elsewhere on the Avid system. If they are, the Avid application will not recognize them.

   (Windows) The default location for the AVX_Plug-Ins folder is:
   
   C:\Program Files\Avid\AVX_Plug-Ins

   However, the AVX_Plug-Ins folder might be in a different location on your system.

   (Macintosh) The AVX_Plug-Ins folder is located within the Avid file structure:
   
   Macintosh HD:Applications:Product Name:SupportingFiles:AVX_Plug-Ins

   where Product Name is the name of your Avid editing application.

3. Restart the Avid application.


   The AVX plug-in effects appear in the Effect Palette, usually in their own category under the name of the vendor.

   (Windows only) If the plug-in effects do not appear in the Effect Palette after installation, see “Troubleshooting AVX Plug-Ins” on page 49.
Using Third-Party Plug-in Effects

Locating the AVX_Plug-Ins Folder (Windows Only)

When the Avid application is first installed, it asks the administrator to select a location for the AVX_Plug-Ins folder. The default path is:

C:\Program Files\Avid\AVX_Plug-Ins

If the administrator accepts the default location for the AVX_Plug-Ins folder, you can install AVX plug-ins here.

If the AVX_Plug-Ins folder is not in the default location, or if the effects are not appearing in the Effect Palette after you install them, you can use the Regedit application that comes with your Windows system to locate the AVX_Plug-Ins folder.

Use the following procedure only to obtain information on the location of the AVX_Plug-Ins folder. Do not change any of the information in the Windows Registry. Changing values in the Windows Registry might affect the performance of your system.

To locate the AVX_Plug-Ins folder by using Regedit:

1. Click the Start button, and then click Run.
   The Run dialog box opens. You enter commands in the command line.
2. Type `regedit` in the command line, and click OK.
   The Registry Editor window opens.
3. In the left pane of the window, navigate to the following path:
   HKEY_LOCAL_MACHINE\SOFTWARE\Avid Technology\AVX Plug-Ins
4. Click the AVX Plug-Ins folder in the left pane, and then check the entry for “Directory” in the right pane.
Chapter 1 Preparing to Work with Effects

The value of this entry is the path that contains the AVX_Plug-Ins folder. For example, if the AVX_Plug-Ins folder is in its default location, the Directory entry will be “C:\Program Files\Avid.” If you navigate to C:\Program Files\Avid using My Computer or Windows Explorer, you will find the AVX_Plug-Ins folder in that location.

AVX plug-ins must be installed in the AVX_Plug-Ins folder itself, not elsewhere in the path that contains that folder. If AVX plug-ins are not in the folder, the Avid application will not recognize them.

Upgrading AVX Plug-ins and Effects

You can upgrade an AVX plug-in simply by uninstalling the old version of the plug-in and installing the new version in your AVX_Plug-Ins folder.

Once you have installed a new version of an AVX plug-in, your Avid application upgrades existing effects in sequences to be compatible with the new version. The existing parameter values for the effect appear in the Effect Editor or in the plug-in’s own user interface.
If the new version of the plug-in has new or redesigned parameter controls, the Avid application sets these controls to their default settings for existing effects. Controls that are unchanged from the older version of the plug-in retain the values previously set by the user.

⚠️ **Once a plug-in effect or transition has been upgraded, you should not reinstall the older version of the plug-in.** The Avid application cannot use an older version of a plug-in to process effects that have been created with a newer version. Similarly, if you transfer projects between systems, an effect created with a newer version of a plug-in will not work on a system that has an older version installed.

### Assigning Multiple Tracks in Plug-in Effects

Some plug-in effects take an arbitrary number of tracks as input. The Avid application allows you to select the number of video inputs from the AVX Optional Inputs dialog box.

> For more information on the multiple track capabilities of a plug-in, see the documentation for that plug-in.

**To assign multiple tracks to a plug-in effect by using the AVX Optional Inputs dialog box:**

1. Drag the plug-in icon to the Timeline.
   
   If the plug-in supports a variable number of input tracks, the AVX Optional Inputs dialog box opens.

2. Click the Number of Tracks pop-up menu, select the number of video inputs, and then click OK.

For more information on nested effects, see “Nesting Effects” on page 294.
Chapter 1  Preparing to Work with Effects

Using AVX Plug-in Controls

This section provides general guidance for controlling and adjusting AVX plug-in effects. For more information on the adjustments available for a specific effect, see the documentation for the plug-in.

AVX plug-ins use a variety of interfaces that give you control over the effects. Plug-in vendors have the following styles for controls:

- Standard buttons and parameter controls
  
  The Effect Editor for a specific plug-in might include only Avid standard buttons and parameter controls, or it might include additional custom controls presented in the Effect Editor using an Avid-like interface.

- Custom dialog box only

  In this case, when you enter Effect mode the Effect Editor is empty except for the Other Options button in the upper left corner. Click the Other Options button to see the additional dialog box.

- Direct manipulation controls in the Effect Preview monitor

  In this case, when you click the Outline/Path button in the Effect Editor, custom controls appear over the image in the monitor.

Accessing an AVX Custom Interface

If an AVX plug-in has a custom interface, you access that interface from the Effect Editor.

**To access an AVX plug-in’s custom interface:**

- In the Effect Editor, click the Other Options button.

  The AVX plug-in’s custom interface appears.

*Dialog boxes that open as part of an AVX plug-in’s custom interface are modal dialog boxes. If you move one of these dialog boxes, the screen behind the dialog box will not redraw. To restore your screen, close the dialog box.*
Custom AVX Controls in the Effect Editor

This section introduces some of the custom controls that might appear in the Effect Editor for an AVX plug-in effect. For more information on using these controls, and other controls specific to individual effects, see the documentation for the plug-in.

Some plug-in effects allow you to adjust an image by using controls that appear as overlays, such as handles and wire frames, in the Effect Preview monitor. You access these overlays by clicking the Outline/Path button at the bottom of the Effect Editor. In some cases, you can then access further controls by clicking buttons on the right side of the Effect Editor that are similar to the buttons available in standard Avid 3D effects.

The Angle control is an Effect Editor parameter that is not available in standard Avid effects but appears in some AVX plug-in effects. The Angle allows you to manipulate an effect’s angle or direction by dragging within a graphic representation of a circle to alter the angle or direction value. Values can be positive or negative and are not limited to a single 360º rotation.

Troubleshooting AVX Plug-Ins

This section describes problems that you might encounter with AVX plug-ins and suggests possible solutions or sources for more information.

If a plug-in does not work as expected and these suggestions do not solve the problem, contact the plug-in vendor.
Plug-In Does Not Appear in the Effect Palette

AVX plug-ins have a plug-in icon in the Effect Palette and in the Timeline. If the plug-in icon does not appear in the Effect Palette after installation, the plug-in might be in the wrong folder. See “Locating the AVX Plug-Ins Folder (Windows Only)” on page 45, or for Macintosh systems, see “Installing AVX Plug-ins” on page 43.

Plug-In Does Not Load

AVX plug-ins might not load correctly for a variety of reasons. In particular, even though it is located correctly in the AVX_Plug-Ins folder, a plug-in might require supporting files — for example, .dll files — that are missing from your system or are installed in the wrong location.

If a correctly located plug-in does not load, check the plug-in documentation for information on required supporting files.

The Avid Application Cannot Render the Plug-In

If the application cannot render the plug-in, the plug-in might have expired or the plug-in’s system application key (dongle) might be missing or damaged.

If you have problems rendering a plug-in effect, check the Console window. Some plug-ins write more information about the failure to the Console window. Also, some plug-ins might report the problem as a message in the Bin or in the Edit monitor.

Blank Effect Icons in the Timeline

AVX plug-ins have a plug-in icon in the Effect Palette and in the Timeline. If the effect icon in the Timeline is blank, the application could not find the plug-in.

To identify the plug-in that is missing or misplaced:

- Open the Console window (select Tools > Console), and look for the message “Can’t find effect.”
The message identifies the plug-in that cannot be located. You can then reinstall the plug-in in your AVX_Plug-Ins folder and restart the Avid application.

**Missing Effect Categories in the Effect Palette**

If plug-in effect categories are not visible in the Effect Palette, either they are not installed correctly or you might have an incorrect version of the AVXLibrary. Check the Console window for a message that states that AVX was disabled.

- If AVX was not disabled, quit the Avid application, reinstall the plug-ins, and restart the application.
- If AVX was disabled, contact Avid Technical Support to determine whether you need a new version of the AVXLibrary. See “If You Need Help” on page 27.

**The Avid System Is Running Out of Free Memory**

Each time you apply an AVX plug-in to a sequence, the Avid application keeps the effect resident in memory. When you close the bin containing the sequence, the application also closes the AVX plug-ins, freeing the memory. To close the AVX plug-ins, see “AVX Plug-ins and Memory Usage” on page 42.

**Changing Timeline View Settings for Effects**

All effect icons are displayed in the Timeline by default. You can change the Timeline settings to display all effect icons, all effect icons except Dissolve Effect icons, or no effect icons. If you have changed the setting to display no effect icons, you have to reset it before you begin applying effects. The fewer effect icons you display, the faster the Avid application refreshes the screen.
Chapter 1  Preparing to Work with Effects

To change the Timeline settings:

- In the Timeline window, click the Fast Menu button.
  The Timeline Settings Fast menu appears.
  - To display all effect icons in the Timeline, select Effect Icons.
  - To display all effect icons except Dissolve icons, select Effect Icons and deselect Dissolve Icons.
  - To display no effect icons, deselect Effect Icons. Dissolve Icons appears dimmed and is now unavailable.
  - To save your Timeline settings, click the Timeline View Name button, select Save As, and type a view name.

Adjusting Trim Settings for Effects

In Trim mode, you can control whether or not the effects you apply are computed immediately on the screen (that is, on-the-fly) or appear later when you render them. For example, viewing transitions as cuts (without rendering on-the-fly) can facilitate the trimming process. This setting is defined in the Trim Settings dialog box.

To change the Trim settings for Render On-the-Fly:

1. In the Project window, click the Settings tab.
   The Settings scroll list appears.
2. Double-click Trim.
   The Trim Settings dialog box opens.
3. Click the Features tab, and then select or deselect Render On-The-Fly.

For information on changing the Trim settings, see “Working in Trim Mode” in the Help.
Chapter 2
Basics of Effects Editing

This chapter explains how to create basic transition and single-layer segment effects.

• Deconstructing Effects
• Applying Effects to a Sequence
• Deleting Effects in a Sequence
• Using the Fade Effect Button
• Working with Transition Effects
Deconstructing Effects

One good way to understand how effects are built in your Avid application is to break down existing effects into their basic elements. By learning how the various pieces fit together, and how to manipulate them, you can begin to construct new effects from these building blocks.

The sequence depicted in the following screen image contains a series of effects that cover all the basic techniques — from simple dissolves to 3D nested layers — described throughout this guide.
The following figure shows the Timeline for this sequence. The Timeline includes both transition and segment effects applied horizontally, vertically, and nested within video tracks. The callouts summarize deconstructed elements and list the sections of this guide that describe them in more detail.

**Imported graphic promoted to a 3D Slat Wipe:**
See "Using Matte Keys with 3D Effects" on page 351.

**Effect template applied repeatedly to crop and position foreground images on V2:**

**Nested segments add more layers to the foreground track:**
See "Nesting Effects" on page 294.

**Submaster segment, created from collapsed layers, forms the background on V1:**
See "Submaster Editing" on page 301.

**Dissolve sequence forms the foreground on V2:**
See "Applying an Effect to Multiple Transitions" on page 58 and "Working with Transition Effects" on page 64.

**Keyed titles are faded in and out:**
See "Using the Fade Effect Button" on page 63.

**Titles "stamped" in place with 3D Warp:**
See "Creating a Stamp" on page 378.

**Various effect parameters are adjusted throughout to soften, distort, or position images:**
See "Using the Effect Editor" on page 97.
Applying Effects to a Sequence

This section explains how to apply an effect to a sequence in the Timeline. You can apply an effect to:

- One transition or segment on a single video layer
- Multiple transitions or segments on a single video layer
- Multiple transitions or segments on multiple video layers

The effect type (transition or segment) determines where you can place the effect in the sequence. For an explanation of the effect types, see “Types of Effects” on page 30.

After you apply an effect, the next step is to adjust the effect’s parameters. To understand how to adjust the effect parameters, see “Using the Effect Editor” on page 97.

Applying an Effect to a Single Transition or Segment

Use the following procedure to apply an effect to one transition or segment on a single video layer.

To apply an effect to a single transition or segment:

1. Create a sequence in the Record monitor using standard Avid editing procedures. For information about editing a sequence, see “Editing in Source/Record Mode” in the Help.
2. Enter Effect mode by selecting Toolset > Effects Editing.

For more information, see “Entering Effect Mode” on page 82.
3. Apply an effect by doing one of the following:
   - Click the effect icon in the Effect Palette, drag it to the segment or transition in the Timeline, and release the mouse button.
   - Click the transition or segment in the Timeline where you want to apply the effect, and double-click the effect’s icon in the Effect Palette.

The effect icon appears in the Timeline, as shown in the following example.

If the effect is a segment effect, one segment at a time is highlighted as you drag the effect within the Timeline. If the effect is a transition effect, one transition at a time is highlighted as you drag the effect within the Timeline. Some effects can be both a transition and a segment effect; when you drag an effect within the Timeline, both transitions and segments are highlighted.
Applying an Effect to Multiple Transitions

To apply an effect to multiple transitions:

1. Enter Effect mode by selecting Toolset > Effects Editing.
2. Click the first or last transition to which you would like to apply the effect.
3. Click above the Timeline and begin dragging to activate a selection box. Continue to drag down and either to the left or right to include additional transitions in the selection.
4. Release the mouse button when you have lassoed all the transitions you want.

The Avid application highlights the transitions that you selected, and the position indicator moves to the first transition.

5. If the transitions where you want to apply the effect are not contiguous, Shift+click any transition to deselect it.
6. In the Effect Palette, double-click the effect’s icon that you want to apply to the transitions.
Applying Effects to a Sequence

The application applies the effect to the highlighted transitions in the Timeline.

![Timeline with highlighted transitions](image)

If there is not enough incoming or outgoing media to apply the transition effect, a dialog box opens. For more information, see “Sizing the Effect to Fit the Media” on page 78.

You can also apply the effects available in the Quick Transition dialog box to multiple transitions by marking IN and OUT points. For more information, see “Using the Quick Transition Button to Apply Effects to Multiple Transitions” on page 70.

Applying an Effect to Multiple Segments

You can apply an effect to multiple segments on the same video layer or on multiple video layers in a single step. The following procedure describes selecting multiple segments in the same video layer. You can also use this procedure to select segments on multiple layers.

To apply an effect to multiple segments on the same video layer:

1. In Source/Record mode or Effect mode, click above the Timeline and to the left of the leftmost segment that you want to select and begin dragging to the right and down to activate a selection box.

2. Continue to drag the selection box to the right until you lasso the rightmost segment that you want to select.
3. Release the mouse button.

The segments that you selected are highlighted.

4. If the segments where you want to apply the effect are not contiguous, Shift+click a segment to deselect it.

5. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.

6. In the Effect Palette, double-click the effect’s icon that you want to apply to the segments.

The effect is applied to the highlighted segments in the Timeline.

Deleting Effects in a Sequence

Transition effects can be deleted from a sequence in Source/Record mode, Trim mode, or Effect mode. Segment effects can be deleted in Source/Record mode or Effect mode. Use the following procedures to either delete a single effect from a sequence or delete effects in multiple segments.
Deleting a Single Effect

To delete a single effect:

1. Move the position indicator to the Timeline segment containing the effect’s icon.

2. If there are multiple tracks that contain effects at the same position in the Timeline, select only the track where the effect to be deleted resides.

   In this example, only track V3 is selected.

   ![Timeline](record-track-button.png)

   If you are deleting a segment effect and the segment contains a transition effect, the transition effect will be deleted also, because the transition effect resides “on top of” the segment effect. If necessary, you will have to reapply the transition effect.

3. Use one of the following methods to delete the effect:

   - When the Effect Editor is not active, click the Remove Effect button on the Tool palette. For more information, see “Using the Tool Palette” in the Help.
   - When the Effect Editor is active, select the effect and press the Delete key.
   - In Trim mode (for transition effects only), either press the Delete key or click the Remove Effect button.

   When you delete an effect from a sequence, the associated media file is not deleted. To delete the effect’s media file, you must manually remove it from the drive. Your Avid application operates this way so that you will be able
to undo the deletion of an effect or undo the change you made to an effect. To delete an effect’s media file, see “Managing Effect Media Files” on page 205.

Deleting Multiple Transition Effects

To delete multiple transition effects:

1. Shift+click each transition effect you want to delete.

2. Do one of the following:
   - On the Tool palette, click the Remove Effect button. For more information, see “Using the Tool Palette” in the Help.
   - Press the Delete key.

Deleting Multiple Segment Effects

To delete multiple segment effects:

1. Click one of the Segment Mode buttons (the Extract/Splice-in button or the Lift/Overwrite button) below the Timeline.

2. Shift+click each segment that contains a segment effect to be deleted.

3. Do one of the following:
   - On the Tool palette, click the Remove Effect button.
   - Press the Delete key.
Using the Fade Effect Button

You can use the Fade Effect button to fade segment effects quickly and easily. A dialog box opens that allows you to enter the number of frames to fade up and fade down.

The Fade Effect feature automatically creates keyframes for the effect. You can access the keyframes in the Effect Editor.

**To fade one or more segment effects in a sequence:**

1. Select the segment effects in the Timeline:
   - To fade a single segment effect, move the position indicator to the segment.
   - To fade multiple segment effects, click either the Extract/Splice-in button or the Lift/Overwrite button below the Timeline; then Shift+click the segments.

2. Click the Fade Effect button.

The Fade Effect button appears on the Tool palette and in the Timeline top toolbar. In addition, you can map the Fade Effect button to the monitor toolbar or to the keyboard. For more information, see “Mapping User-Selectable Buttons” in the Help.

The Fade Effect dialog box opens.

3. In the Fade Effect dialog box, type the number of frames to fade up and fade down, and click OK.

You can immediately view the Fade effect by playing the segment or segments.
Working with Transition Effects

You apply a transition effect to the cut point between two clips on the same video track. You can adjust the alignment and duration of a transition effect. Depending on the specific effect, other effect parameters might also be available.

Types of Transition Effects

Transition effects are included in all effect categories on the Effect Palette, except the Image effect category. For an explanation of the transition effects in each effect category, see “2D Effects Reference” and “3D Effects Reference” in the Help.

Applying a Dissolve Effect

One of the most common transition effects is a dissolve. The Avid application has the following methods you can use to apply the Dissolve effect:

- Select the Dissolve effect from the Effect Palette.
- Type a duration in the Transition parameters in Trim mode or in the Effect Editor.
- Click the Quick Transition button.
- Use the Head Fade button or the Tail Fade button.

The following sections describe each of these methods.

Using the Effect Palette

To apply a Dissolve effect by using the Effect Palette:

1. Create a sequence in the Record monitor using the standard Avid editing procedures. For information about editing a sequence, see “Editing in Source/Record Mode” in the Help.
2. Enter Effect mode by selecting Toolset > Effects Editing.
3. In the Effect Palette, click the Blend category.

4. Drag the Dissolve Effect icon to the transition in the Timeline, and release the mouse button.

   The Dissolve Effect icon appears in the Timeline.

If the sequence does not have enough incoming or outgoing media to apply a transition effect, a dialog box opens. See “Sizing the Effect to Fit the Media” on page 78.

Using the Transition Parameters

You can create a Dissolve effect by using the Transition parameters displayed in Trim mode and in the Effect Editor. Simply enter the duration for which the effect will play, and the application adds the Dissolve effect to the sequence.

To create a Dissolve effect by using the Transition parameters:

1. Click a transition in the Timeline while in Trim mode or Effect mode.
2. In the Transition Effect Duration box in the Effect Editor, type the dissolve’s duration.

   The duration format is determined by the Duration setting above the Record monitor — for example, seconds:frames.

The application adds the Dissolve effect at the transition, and the Dissolve Effect icon appears in the Timeline.

3. Click the Transition Effect Alignment button, and select the effect’s position relative to the cut point.

   For an explanation of the Transition Effect Alignment menu selections, see “Transition Parameters” in the Help.
Using the Quick Transition Button to Create Effects

Another way to create a transition effect is to click the Quick Transition button. This button allows you to apply a Dissolve effect or any of the following transition effects without using the Effect Palette:

- Dissolve
- Film Dissolve
- Film Fade
- Fade to Color
- Fade from Color
- Dip to Color

You can add the same Dissolve effect to multiple transitions by marking IN and OUT points in your sequence that select all the transitions to which you want to apply the effect. When you click the Quick Transition button, the Quick Transition dialog box will contain a check box for Apply to All Transitions (IN -> OUT). See “Using the Quick Transition Button to Apply Effects to Multiple Transitions” on page 70.

To create an effect by using the Quick Transition button:

1. Move the position indicator to the transition in the Timeline.
2. Click the Quick Transition button.

The Quick Transition button appears on the Tool palette, in the Timeline top toolbar, and on the Command palette. For more information, see the following topics in the Help: “Using the Tool Palette,” “Displaying the Timeline Top Toolbar,” and “Using the Command Palette.”
The Quick Transition dialog box opens.

The dialog box shows a graphical display of the outgoing media (A) and incoming media (B), with the Dissolve Effect icon applied to the transition.

The application scales the graphical display to show the relative size of the Dissolve effect and the media available for the effect.

3. Click the Add pop-up menu, and select a transition effect:
   - Dissolve
   - Film Dissolve
   - Film Fade
   - Fade to Color
   - Fade from Color
   - Dip to Color

For an explanation of individual effects shown in the menu, see “Blend Effects” in the Help.
When you save a Dissolve effect template into a bin named Quick Transitions, the effect template appears in the Add pop-up menu. See “Using an Effect Template” on page 164.

When you select a color transition with Quick Transition, the default color is black. You must enter Effect mode to select another color. For more information, see “Using the Effect Editor” on page 97.

4. Set the transition duration by doing one of the following:
   - Type the duration in frames in the Duration text box.
   - Click either the left edge or right edge of the Dissolve Effect icon and drag it to change the duration. For more information, see “Understanding the Graphical Display in the Quick Transition Dialog Box” on page 73.

   The graphical display changes — the size of the effect icon increases or decreases, and the numbers in the Duration and Start text boxes change — to reflect the new duration.

5. Adjust the effect’s position relative to the cut point in one of the following ways:
   - Click the Position pop-up menu, and select a command to have the effect end at the cut point, center on the cut point, or start at the cut point.
   - Click the Position pop-up menu, select Custom, and then type a number in the Start text box to specify how many frames before the cut point you want the effect to begin.
   - Click the Dissolve Effect icon and drag it to position the effect with respect to the cut point. For more information, see “Understanding the Graphical Display in the Quick Transition Dialog Box” on page 73.
   - Click one of the alignment buttons below the graphical display.
These buttons appear when you select Custom from the Position pop-up menu or click in the graphical display. For more information on the graphical display options, see “Understanding the Graphical Display in the Quick Transition Dialog Box” on page 73.

The application positions the effect, updates the graphical display to show the new position of the effect, and updates the value in the Start text box.

If you select an alignment for which there is not enough media, the application comes as close as it can to the alignment you requested.

6. If you click the Dissolve Effect icon and drag it, the Position pop-up menu changes to Custom. Indicate where the effect is to start — that is, how many frames before the cut you want to include in the Dissolve. Do one of the following:

- Click near the middle of the Dissolve Effect icon and drag it to dynamically change the number of frames.
- Click one of the alignment buttons below the graphical display to specify the effect as ending at cut, centered on cut, or starting at cut.
- Type the number of frames in the Start text box.

The graphical display changes to show the relative amount of media available and the relative position of the effect, and the new value appears in the Start text box.
7. Click the Target Drive pop-up menu, and select a drive on which to store the effect if you choose to render it.

The Effect Source Drive is the drive where the media on the outgoing shot of a transition resides.

8. (Option) If you have IN and OUT points marked in your sequence, the Quick Transition dialog box contains a check box for Apply to All Transitions (IN -> OUT). Select this option to apply the same effect to all transitions between the IN and OUT points. Deselect this option to apply the effect only to the transition at which you have placed the position indicator.

9. If you selected a real-time effect, select Skip Real-Time Effects to prevent real-time effects from being rendered.

10. Do one of the following:

   ▶ To add the effect without rendering it, click Add.
   ▶ To add the effect and render it, click Add and Render.

   The Avid application adds the effect to the selected transition in the sequence, or, if you selected Apply to All Transitions (IN -> OUT), the application adds the effect to all transitions between the IN and OUT points.

**Using the Quick Transition Button to Apply Effects to Multiple Transitions**

You can select multiple transitions by marking IN and OUT points. Then apply an effect from the Quick Transition dialog box to all the selected transitions at once.

**To apply an effect to multiple transitions by using the Quick Transition button:**

1. Mark IN and OUT points around the transitions to which you want to add the effect.

2. Make sure that the Record Track buttons in the Track Selector panel are selected for the tracks to which you want to add the effect.

3. (Option) If you want to see a particular transition in the graphical display of the Quick Transition dialog box, move the position indicator to that transition.
The graphical display in the Quick Transition dialog box always shows the transition closest to the position indicator. When you define an effect to apply to multiple transitions, the positioning details of any one transition might not be useful since you need to create an effect that will fit all the transitions. However, you might want to select one transition as a model. For example, you might use the transition with the least amount of handle as a model. If your effect fits that transition, it should fit all the others you have selected.

4. Click the Quick Transition button.

The Quick Transition button appears on the Tool palette, in the Timeline top toolbar, and on the Command palette. For more information, see the following topics in the Help: “Using the Tool Palette,” “Displaying the Timeline Top Toolbar,” and “Using the Command Palette.”

The Quick Transition dialog box opens.

5. Click the Add pop-up menu, and select a transition effect:
   - Dissolve
   - Film Dissolve
   - Film Fade
   - Fade to Color
   - Fade from Color
   - Dip to Color

For an explanation of individual effects shown in the menu, see “Blend Effects” in the Help.

When you save a Dissolve effect template into a bin named Quick Transitions, the effect template appears in the Add pop-up menu. See “Using an Effect Template” on page 164.

When you select a color transition with Quick Transition, the default color is black. You must enter Effect mode to select another color. For more information, see “Using the Effect Editor” on page 97.
Chapter 2  Basics of Effects Editing

6. Select the transition duration by doing one of the following:
   - Type the duration in frames in the Duration text box.
   - Click either the left edge or right edge of the Dissolve Effect icon and drag it to change the duration. For more information, see “Understanding the Graphical Display in the Quick Transition Dialog Box” on page 73.

   The graphical display changes — the size of the effect icon increases or decreases, and the numbers in the Duration and Start text boxes change — to reflect the new duration.

7. Adjust the effect’s position relative to the cut point in one of the following ways:
   - Click the Position pop-up menu, and select an option to have the effect end at the cut point, center on the cut point, or start at the cut point.
   - Click the Position pop-up menu, select Custom, and then type a number in the Start text box to specify how many frames before the cut point you want the effect to begin.
   - Click the Dissolve Effect icon and drag it to position the effect with respect to the cut point.
   - Click one of the alignment buttons below the graphical display.

These buttons appear when you select Custom from the Position pop-up menu or click in the graphical display. For more information on the graphical display options, see “Understanding the Graphical Display in the Quick Transition Dialog Box” on page 73.
The application positions the effect, updates the graphical display to show the new position of the effect, and updates the value in the Start text box.

If you select an alignment for which there is not enough media, the application comes as close as it can to the alignment you requested.

8. Click the Target Drive pop-up menu, and select a drive on which to store the effect if you choose to render it.

The Effect Source Drive is the drive where the media on the outgoing shot of a transition resides.

9. (Option) If you selected a real-time effect, select Skip Real-Time Effects to prevent real-time effects from being rendered.

10. Select Apply to All Transitions (IN -> OUT).

11. Do one of the following:

   ▶ To add the effect without rendering it, click Add.
   ▶ To add the effect and render it, click Add and Render.

   The application adds the selected effect to all the transitions between the marked IN and OUT points on the selected tracks in the sequence.

If there is not enough incoming or outgoing media material to apply the effect to a transition, a dialog box opens. For more information, see “Sizing the Effect to Fit the Media” on page 78.

Understanding the Graphical Display in the Quick Transition Dialog Box

The graphical display of the transition effect that appears in the Quick Transition dialog box allows you to control the length and position of the effect with frame accuracy simply by dragging. You can also quickly reset the position of the effect by using the three alignment buttons.
Chapter 2  Basics of Effects Editing

Features of the Graphical Display

The following illustration shows the graphical display in the Quick Transition dialog box.

The graphical display shows the following:

- The outgoing (A) and incoming (B) media for the transition to which you are applying the effect.

  The amount of handle available for each piece of media is indicated both as a darker area on the graphic itself and as a number of frames.

- The transition effect that you are applying.

  The display shows the effect icon and indicates the length and position of the effect in relation to the media.

- Three alignment buttons.

  These buttons appear when you select Custom from the Position pop-up menu or click in the graphical display. They allow you to quickly reposition the effect so that it either ends at the cut point, is centered on the cut point, or starts at the cut point.

The Avid application draws and scales the graphical display so that it represents the relative size and position of the transition effect in relation to the media. For example, in the preceding illustration, the effect is 30 frames long while the incoming handle is 46 frames long. The effect is therefore shown about two-thirds the size of the incoming handle.
**Adjusting the Effect by Dragging**

You can control the length or position of the transition effect by dragging in the graphical display.

**To adjust the length of the effect:**

1. Do one of the following:
   - To adjust the length of the effect without changing its start point, move the pointer over the right edge of the effect.
   - To adjust the length of the effect without changing its end point, move the pointer over the left edge of the effect.

   The pointer changes to a resizing arrow.

   ![Resizing arrow](image)

2. Do one of the following:
   - To lengthen the effect, drag away from the effect icon in the center.
   - To shorten the effect, drag toward the effect icon in the center.

   The graphical display and the Duration text box update to reflect your adjustment. If you are dragging the left edge of the effect, the Start text box also updates to reflect the changed start point.

**To adjust the position of the effect:**

1. Move the pointer inside the effect.

   The pointer changes to a hand.

   ![Hand](image)
Chapter 2  Basics of Effects Editing

2. Drag the effect to adjust its position with respect to the cut point.

The graphical display updates to show the new effect position, and the Start text box updates to show the new number of frames before the cut point.

You cannot drag an effect beyond the ends of the handles on the media because you cannot create a transition unless both incoming and outgoing media are available for every frame of the transition. You also cannot drag an effect beyond the cut point.

Repositioning the Effect with the Alignment Buttons

You can use the alignment buttons to quickly reposition the effect so that it either ends at the cut, is centered on the cut, or starts at the cut. The buttons have the same effect as the Ending at Cut, Centered on Cut, and Starting at Cut commands in the Position pop-up menu.

To reposition the effect with an alignment button:

- Click one of the following buttons:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ending at Cut</td>
<td>Aligns the effect so it ends at the cut point.</td>
</tr>
<tr>
<td>Centered on Cut</td>
<td>Aligns the effect so it is centered on the cut point.</td>
</tr>
<tr>
<td>Starting at Cut</td>
<td>Aligns the effect so it starts at the cut point.</td>
</tr>
</tbody>
</table>
Adding Fades (Dissolves) with the Head Fade and Tail Fade Buttons

You can use the Head Fade button and Tail Fade button to add a fade (or dissolve) for audio and video tracks.

When you use the Head Fade button and Tail Fade button this way, all the selected tracks, including layered tracks, receive the effect.

To add a fade (dissolve):

1. Move the position indicator to a clip where you want to end or begin the fade (dissolve).
   
   The Avid application uses the location of the position indicator to begin or end the fade.

2. Select the tracks on which you want the fade (dissolve) to appear.
   
   This procedure works on video and audio tracks.


4. Click the FX tab, and then click Active Palette.

5. Click the Head Fade button or the Tail Fade button.
   
   The rendered fade (dissolve) appears in the Timeline.

   If two clips are edited together, the fade (dissolve) crosses between the two.

If there is not enough source material to create the effect at the position indicator, a dialog box opens. If there is enough material to create a shorter version of the effect, the dialog box contains a Size To Fit button. See “Sizing the Effect to Fit the Media” on page 78. You also have the option to skip individual tracks that do not have enough source material or to cancel the entire effect.

Using the Head Fade Button and Tail Fade Button with Filler

When you use the Head Fade button and Tail Fade button with filler, the Avid application treats the filler like another video clip.
To fade from filler to the start of a video clip:

1. Place the position indicator on the filler clip at the point where you want the fade to begin.

2. Select Tools > Command Palette.

3. Click the FX tab, and then click Active Palette.

4. Click the Tail Fade button.

The application creates a rendered dissolve that starts at the position indicator and ends at the beginning of the video clip.

Conversely, if you want to create a fade from a video clip into filler, place the position indicator in the filler clip and then click the Head Fade button.

Sizing the Effect to Fit the Media

When you apply a transition effect from the Effect Palette and there is not enough source media for the effect to use, a dialog box opens describing whether the source that has insufficient material is Media A (outgoing footage) or Media B (incoming footage).

**To automatically size the effect to fit the media:**

- Click Size To Fit in the dialog box.

  The application sets the duration of the effect to fit the available media. If you have selected an alignment, the application attempts to preserve it.

To change the alignment or duration of the transition effect, see “Using the Transition Parameters” on page 65.
Trimming a Transition Effect

You can trim a transition effect by using the standard transition trim procedures. For more information, see “Working in Trim Mode” in the Help.

Adjusting Transitions in the Timeline

You can change the duration of Dissolve effects just by dragging them in the Timeline. To use this feature, you open the Transition Corner Display in Trim mode.

To adjust a transition by using the Transition Corner Display:

1. Click the transition in the Timeline.
2. Click the Trim Mode button below the Timeline to enter Trim mode.
3. Click the Transition Corner Display button.

   The button changes to bright green, and the display is enabled. As you position the pointer over the transition, it changes to look like a film clip that has been cut for a splice.

4. Lengthen or shorten the transition effect by dragging the transition to the length you want.
   - To shorten a transition, drag toward the transition point.
   - To lengthen a transition, drag away from the transition point.

   The pointer changes to a hand that moves as you drag. You can adjust either the outgoing or the incoming video.

5. To review your edit, click the Play Loop button.

To customize transition effect parameters, see “Transition Parameters” in the Help.
Chapter 3

Customizing Effects

After you have created an effect and applied it to a transition or segment in your sequence, you can adjust its appearance and operation by changing its effect parameters in Effect mode. This chapter explains how to use the Effect Preview monitor and the Effect Editor to adjust effect parameters.

- Entering Effect Mode
- Customizing the Effect Display
- Navigating in Effect Mode
- Using the Effect Editor
- Understanding Keyframes
- Using Standard Keyframes
- Working with Advanced Keyframes
- Defining a Motion Path
- Using an Effect Template
Chapter 3  Customizing Effects

Entering Effect Mode

After you add an effect to a sequence, you must enter Effect mode to change the parameters of the effect. Entering Effect mode transforms the Record monitor into the Effect Preview monitor and opens the Effect Editor.

To enter Effect mode:

1. Move the position indicator to the effect’s icon in the Timeline.
2. Do one of the following:
   - Click the Effect Mode button below the Timeline.
   - Select Toolset > Effects editing.

The Avid application opens the Effect Editor and displays the values for the current effect in the window. At the same time, the Record monitor becomes the Effect Preview monitor.

Both the Effect Editor and the Effect Preview Monitor toolbar display buttons for controlling and adjusting the effect. For more information, see “Effect Editor Controls” on page 98 and “Understanding the Effect Preview Monitor” on page 83.

If the Effect Editor is blank, click an effect icon in the Timeline and then click in the Effect Editor.
Customizing the Effect Display

You can adjust the appearance and function of various aspects of Effect mode by resizing windows, mapping buttons, displaying tracking information, or displaying a variety of grids to provide guidelines, as described in this section.

Understanding the Effect Preview Monitor

The Effect Preview monitor displays the selected effect in the sequence where the position indicator is located in the Timeline. The effect’s position bar, located directly below the Effect Preview monitor, represents only the selected effect, not the entire sequence.
If the effect you expect does not appear in the Effect Preview monitor, make sure that you have selected the Record Track Monitor button in the Track Selector panel. If a black frame appears in the Effect Preview monitor, the position indicator might be at a location in the Timeline where an effect has not been applied to the sequence.

The Effect Preview Monitor toolbar has buttons for controlling effect position and adjustment. Table 1 describes the buttons in the toolbar that you use to play and adjust the effect.

### Table 1  Effect Preview Monitor Toolbar Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rewind</td>
<td>Places the position indicator at the first frame or field of the sequence.</td>
</tr>
<tr>
<td>Fast Forward</td>
<td>Places the position indicator at the last frame or field of the sequence.</td>
</tr>
<tr>
<td>Step Backward</td>
<td>Moves the position indicator one frame or field back.</td>
</tr>
<tr>
<td>Step Forward One Field</td>
<td>Moves the position indicator one frame or field forward.</td>
</tr>
<tr>
<td>Play Loop</td>
<td>Plays back the current effect repeatedly in a loop. Click again or press the space bar to stop play. Real-time and rendered effects play at full speed; unrendered effects play at single-frame rate.</td>
</tr>
<tr>
<td>Play</td>
<td>Plays the effect from the current position in the effect’s position bar. Click again or press the space bar to stop play. Real-time and rendered effects play at full speed; unrendered effects play at single-frame rate.</td>
</tr>
<tr>
<td>Play Preview</td>
<td>Plays back a wire-frame preview of an unrendered effect.</td>
</tr>
<tr>
<td>Dual Split</td>
<td>Click to divide the Effect Preview monitor in half, showing the image with and without the effect applied. Click again to remove.</td>
</tr>
<tr>
<td>Add Keyframe</td>
<td>Creates a keyframe at the current position of the position indicator in the effect’s position bar. Alt+click (Windows) or Option+click (Macintosh) to delete the selected keyframe.</td>
</tr>
</tbody>
</table>
Customizing the Effect Display

The Effect Editor also contains controls that you use to adjust and preview effects. For more information, see “Effect Editor Controls” on page 98.

Using Big Effect Mode

Big Effect mode lets you work on an enlarged Effect Preview monitor if you have a high-resolution monitor. The Source monitor disappears, and the Effect Preview monitor becomes a larger working space that makes it easier to create effects and make changes to them.

You must be using a high-resolution monitor (a monitor capable of 1024 x 768 pixel display or greater) as the Edit monitor to enter Big Effect mode.

To enter or leave Big Effect mode:

1. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.

2. Alt+click (Windows) or Option+click (Macintosh) the Effect Mode button.

   - If the application was in the default Effect mode, it enters Big Effect mode. You can click the Effect Editor and drag it to the left of the enlarged Effect Preview monitor.
   - If the application was in Big Effect mode, it returns to the default Effect mode.

Once you enter Big Effect mode, it remains enabled until you Alt+click (Windows) or Option+click (Macintosh) the Effect Mode button again.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reduce</td>
<td>Reduces the size of the image in the Effect Preview monitor.</td>
</tr>
<tr>
<td>Enlarge</td>
<td>Enlarges the size of the image in the Effect Preview monitor.</td>
</tr>
</tbody>
</table>

The Effect Editor also contains controls that you use to adjust and preview effects. For more information, see “Effect Editor Controls” on page 98.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reduce</td>
<td>Reduces the size of the image in the Effect Preview monitor.</td>
</tr>
<tr>
<td>Enlarge</td>
<td>Enlarges the size of the image in the Effect Preview monitor.</td>
</tr>
</tbody>
</table>
Chapter 3  Customizing Effects

Mapping User-Selectable Buttons in Effect Mode

You can customize the buttons that are available in Effect mode by mapping user-selectable buttons directly from the Command palette to the Tool palette or to the area below the Effect Preview monitor.

When you customize the display of buttons in Effect mode, the new configuration appears in Effect mode only. The default editing mode buttons reappear when you exit Effect mode.

To remap user-selectable buttons, enter Effect mode and use the procedure in “Mapping User-Selectable Buttons” in the Help.

Understanding the Tracking Information

The two boxes above the Effect Preview monitor display the length of the effect in seconds and frames and the current position in the effect’s position bar.

If you are working with two-field media, the current position display indicates the field that appears in the monitor. The current position display ends with .1 for the first field of a frame and with .2 for the second field. These boxes replace the name of the sequence that appears in this position in the Record monitor.

If the position information boxes do not appear above the Effect Preview monitor, increase the size of the window.

Displaying the Safe Title and Safe Action Guidelines

Many effects can utilize the outer edges of the viewing screen area. If you are editing material that will be viewed on screens with more limited viewing areas, such as standard televisions, you can use the Safe Title and Safe Action options to provide visual guidelines in the Effect Preview monitor that replicate the actual viewable area on a standard television screen.
Customizing the Effect Display

For example, you can use the Safe Title option as a template for the area in which you want the effect to operate. In this way, you can avoid the appearance of the effect floating off into a nonviewable area of a standard television screen.

To display the Safe Title and Safe Action guidelines in Source/Record mode or Effect mode:

- In the Effect Editor, click the Grid button.

You can customize the type of grid displayed by the Grid button. For more information, see “Working with the Effect Grid” on page 88.

Two outlined boxes appear in the Effect Preview monitor. The inner box is the safe title area. All text and objects should remain within the inner box. The outer box is the safe action area for video display.
Chapter 3  Customizing Effects

Working with the Effect Grid

The Effect Grid provides a variety of ways for you to position effects with accuracy and previsualize them in the Effect Preview monitor. The grid coordinates can be expressed in traditional fields or X–Y pixels in any resolution.

The following illustration shows a 12-field grid displayed in a video project.

You can use the Effect Grid to:

- Display the aspect ratios for film categories such as standard film, Academy, Super 35 mm, and Anamorphic, as well as the 4:3 safety area for the 16:9 aspect ratio.
- Show coordinate information to track the exact location of an effect in the frame.
- Use the snap-to-grid feature to easily position effects.
In film projects, you can also use the Effect Grid to:

- Create position information for the following effects: Paint, AniMatte, Blowup. You can include this information in an optical list created using Avid FilmScribe™.
- Create position information for an effect you previsualize using the Previsualization Marker tool. You can include this information in an optical list created using Avid FilmScribe. For more information, see “Previsualization Marker Tool for Film Projects” on page 516.

### Setting the Effect Grid Options

The Grid Settings dialog box allows you to define the grid to use when you create effects.

**To set the default grid values, do one of the following:**

- In the Settings scroll list of the Project window, double-click Grid.
- In the Grid parameter group in the Effect Editor, click the Other Options button.

The Grid Settings dialog box opens.

Table 2 describes the Grid settings.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinates</td>
<td>Scale Mode</td>
<td>This setting allows you to work with a grid that indicates boundaries for a format other than the one in which you are working. This is useful when you are creating graphics (like titles) that must remain safe in other formats. Select the appropriate option for the current and target formats you need. When you do not specifically need a grid that represents another format, use the Normal option, which is the default.</td>
</tr>
<tr>
<td></td>
<td>Normal</td>
<td></td>
</tr>
<tr>
<td></td>
<td>4:3 Inside 16:9 Monitor</td>
<td></td>
</tr>
<tr>
<td></td>
<td>4:3 Outside 16:9 Monitor</td>
<td></td>
</tr>
<tr>
<td></td>
<td>1.66 Inside 4:3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>1.77 Inside 4:3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>1.85 Inside 4:3</td>
<td></td>
</tr>
</tbody>
</table>
### Table 2  Grid Settings Options (Continued)

<table>
<thead>
<tr>
<th>Tab</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinates</td>
<td>Increments</td>
<td>Sets the number of tick marks along the grid axes as well as the number of visible grid points. The default value is 12.</td>
</tr>
<tr>
<td></td>
<td>• Fields</td>
<td>Sets the number of divisions between visible grid points for the snap-to-grid feature. Setting Sub Fields to 1 snaps objects to visible points only. A value of 2 provides 1/2-field jumps. A value of 4 (the default value) provides 1/4-field jumps, and so on. Setting Sub Fields to 0 turns off the snap-to-grid feature.</td>
</tr>
<tr>
<td></td>
<td>• Sub Fields</td>
<td>For film projects, where an optical house scans film for the addition of visual effects.</td>
</tr>
<tr>
<td>Coordinates</td>
<td>Source Scan Size</td>
<td>The default values are 720 x 486 pixels.</td>
</tr>
<tr>
<td></td>
<td>• Hor. Size</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Vert. Size</td>
<td></td>
</tr>
<tr>
<td>Coordinates</td>
<td>Source Grid Adjustments</td>
<td>Moves the grid on the image. These values are intended mainly for film projects.</td>
</tr>
<tr>
<td></td>
<td>• Hor. Offset</td>
<td>Shrinks the grid proportionally.</td>
</tr>
<tr>
<td></td>
<td>• Vert. Offset</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Inset</td>
<td></td>
</tr>
<tr>
<td>Display Type</td>
<td></td>
<td>Selects a different grid for each standard film type. For video projects, use the Square grid type. The grid for the Academy option includes a safety margin on the left that is used for adding the optical sound track.</td>
</tr>
<tr>
<td></td>
<td>• Square</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Standard Film</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Academy</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Super 35</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Anamorphic</td>
<td></td>
</tr>
</tbody>
</table>
### Table 2  Grid Settings Options (Continued)

<table>
<thead>
<tr>
<th>Tab</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display</td>
<td>Color</td>
<td>Sets a color for the grid axes and the grid points.</td>
</tr>
<tr>
<td>Display</td>
<td>Show Safe Title</td>
<td>Displays the safe title area. Create video titles within this area to ensure that they are viewable on a regular television screen.</td>
</tr>
<tr>
<td>Display</td>
<td>Show Safe Action</td>
<td>Displays the safe action area for video display. This box is self-adjusting for PAL and NTSC projects.</td>
</tr>
<tr>
<td>Display</td>
<td>Show 14x9 Zone</td>
<td>Select one or more of these options to display the grid you want.</td>
</tr>
<tr>
<td></td>
<td>Show 1.66 Aspect</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Show 1.85 Aspect</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Show 1.77 Aspect</td>
<td></td>
</tr>
<tr>
<td>Display</td>
<td>Show Axes</td>
<td>Displays the grid axes.</td>
</tr>
<tr>
<td>Display</td>
<td>Show Tick Marks</td>
<td>Shows tick marks along the axes. Use the Fields parameter to set the number of tick marks.</td>
</tr>
<tr>
<td>Display</td>
<td>Show Thirds</td>
<td>Divides the screen into three sections. This is especially useful if you are creating titles for the lower third of the screen.</td>
</tr>
<tr>
<td>Display</td>
<td>Show Points</td>
<td>Shows the grid points. Use the Fields parameter to set the number of grid points.</td>
</tr>
<tr>
<td>Display</td>
<td>Show Position Info</td>
<td>Displays the position coordinates of any point in the Effect Preview or Record monitor. The application uses compass coordinates and X, Y coordinates. For compass coordinates, the point (0, 0) is the center of the axes. For X, Y coordinates, the point (0, 0) is the top left corner of the monitor. X values increase to the right, and Y values increase as you move down. For more information, see “Displaying Position Coordinates” on page 92.</td>
</tr>
</tbody>
</table>
Chapter 3  Customizing Effects

Displaying the Effect Grid in Effect Mode

As with the Safe Title/Safe Action guidelines, you use the Grid button in the Effect Editor to display the Effect Grid.

To display the Effect Grid rather than the Safe Title/Safe Action guidelines:

- Press the Alt key (Windows) or Option key (Macintosh), and click the Grid button.

To switch between the Effect Grid and the Safe Title/Safe Action guidelines:

- Press the Alt key (Windows) or Option key (Macintosh), and click the Grid button until the appropriate grid is displayed.

To remove the display of either the Effect Grid or the Safe Title/Safe Action guidelines:

- Click the Grid button without pressing the Alt key (Windows) or Option key (Macintosh).

Displaying Position Coordinates

Your Avid application uses compass coordinates and X, Y coordinates to describe the position of an effect. To view the coordinates, you must select the option Show Position Info in the Grid Settings dialog box and enable the Effect Grid. For compass coordinates, the point (0, 0) is the center of the axes. For X, Y coordinates, the point (0, 0) is the upper left corner of the monitor. X values increase to the right, and Y values increase as you move down.

The compass coordinates describe the effect’s position in terms of film optical house standards. Each compass coordinate begins with a direction (N, S, E, or W, the abbreviations for North, South, East, or West) followed by a numerical value. This numerical component reflects the Fields and Sub Fields parameters you select in the Grid Settings dialog box or the Grid parameter group.

The X, Y coordinates describe position in terms of the Source Scan Size parameters you select in the Grid Settings dialog box or the Grid parameter group.
Customizing the Effect Display

To display position coordinates in Source/Record mode:

- Move the pointer to the Record monitor, press and hold the mouse button, and move the mouse.

To display position coordinates in Effect mode:

1. Deselect all tools in the Effect Editor (including the Outline/Path button and the Selection tool for Intraframe effects).
2. Press and hold the mouse button, and drag the pointer in the Effect Preview monitor.

Using Local Grid Parameters

The Grid parameter category in the Effect Editor allows you to customize the grid display for an individual effect. The Grid parameter category appears in the Pan and Scan effect for all projects and in other effects for film and 24p or 25p projects. Grid parameters set in the Effect Editor apply only to that effect and temporarily override the current settings in the Grid Settings dialog box. For more information on the parameters available with the Grid parameter category, see “Grid” in the section “2D Effects Parameters” in the Help.

Obtaining Position Information in a Film Project

You can use the Effect Grid to include position information in a cut list for the Paint and AniMatte effects on a keyframe-by-keyframe basis. Additionally, you can display the position information for the first keyframe of a Blowup effect in a cut list.

- You generate film cut lists and change lists with Avid FilmScribe. For general information on using Avid FilmScribe, see the Avid FilmScribe User’s Guide.
- You can also generate effect information in a cut list by using the Previsualization Marker Tool in the Paint Effect. For more information, see “Previsualization Marker Tool for Film Projects” on page 516.
Position Information for the Paint and AniMatte Effects

The Avid application can include both compass coordinate and X, Y coordinate information in a cut list for each corner of a Paint or AniMatte effect. For example, a rectangle you create with the Paint Effect shows four compass and four X, Y coordinates for each keyframe.

To include coordinate information in a cut list:

1. Enable the Effect Grid before you generate the list. For more information, see “Displaying the Effect Grid in Effect Mode” on page 92.

2. In the Cut List tool within Avid FilmScribe, select the Key Frames check box in the Options pane for the optical list.

The following illustration shows the presentation of Paint Effect information for a rectangular object in a cut list.
Position Information for the Blowup Effect

The event section of the cut list displays the compass coordinates of the effect at the first keyframe in the segment and the Fields parameter you have selected for the effect. You must enable the Effect Grid before you generate the cut list to display this information in the list.

The following illustration shows the presentation of Blowup effect information in a cut list.

<table>
<thead>
<tr>
<th>Grid information</th>
<th>Field parameter value</th>
<th>Compass coordinates</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keyframe number</td>
<td>Key Frame Information</td>
<td></td>
</tr>
<tr>
<td></td>
<td>KF Footage</td>
<td>&amp; Key #</td>
</tr>
<tr>
<td>(1)</td>
<td>106</td>
<td>5701-03</td>
</tr>
<tr>
<td>(NO EDGE NUMBERS)</td>
<td>Blowup Field: 5 East:3南:3</td>
<td></td>
</tr>
</tbody>
</table>

Transfer: Full Aperture
Grid: Standard Film
Fields: 12
Subfields: 0
Scan Size: (X: 720, Y: 243)
Navigating in Effect Mode

The following sections describe helpful techniques for moving through footage in Effect mode.

Changing Position

You can change your position in an effect either by dragging the position indicator in the effect’s position bar or by typing and entering the timecode in the numeric keypad for a location, just as you do in Source/Record mode. The type of timecode you enter (master timecode or absolute timecode) depends on the top row of tracking information you are displaying.

The position information boxes above the Effect Preview monitor update as you change position. For more information on entering timecode to change the current position, see “Viewing and Marking Footage” in the Help.

Using Single-Field Step

When stepping through two-field media such as 2:1 or uncompressed, the application displays field 1 of each frame by default. Single-field step enables you to view field 1 and field 2 of each frame of video. This feature is especially useful when you require field-by-field control during Intraframe editing. For more information on Intraframe editing, see Chapter 11.

To step through the footage one field at a time:

- In the Effect Preview Monitor toolbar, click the Step Forward One Field button or the Step Backward One Field button.

As you step, the number “2” appears in the upper right corner of the Record monitor whenever field 2 of the media is displayed. The number disappears during the display of field 1 (the default display).
Using the Effect Editor

Use the Effect Editor to adjust the parameters for an effect.

**To display an effect's parameters in the Effect Editor:**

1. Move the position indicator to the effect’s icon in the Timeline.
2. Enter Effect mode by selecting Toolset > Effects Editing.
   The Effect Editor opens.

This example shows the Picture-in-Picture effect parameters.

If the Effect Editor is already open and active, select the segment or transition effect to display the effect’s parameters in the Effect Editor.
Not all effect parameters apply to all effects. Parameters that do not apply to an effect do not appear in the Effect Editor for that effect. To determine which parameters pertain to an effect, refer to the effect’s description in the Help.

*If the position indicator is not on an effect’s icon in the Timeline, or if the track that contains the effect is not selected, then the Effect Editor is blank.*

A number of parameters are common to many effects, such as parameters affecting size, position, or foreground level (transparency). You can adjust these parameters once for the entire effect, or you can use the Effect Editor along with keyframes to change the effect parameter over time. Other parameters can be adjusted only once for the entire effect, regardless of keyframe selection.

*For reference information on all effect parameters, see “2D Effects Parameter” and “3D Effects Parameters” in the Help.*

**Effect Editor Controls**

This section describes the controls in the Effect Editor. Not all controls apply to each effect. If a control is not applicable, it does not appear in the Effect Editor for that effect.

The following illustration shows the location of controls and buttons within the Effect Editor.

*Table 3 on page 100 describes in detail the buttons that all effects have in common. Additional buttons appear in the Effect Editor, depending on the effect used. For example, if you are working with a 3D effect, a set of 3D-specific buttons appears along the right side of the Effect Editor. For more information on 3D-specific Effect Editor buttons, see Chapter 8.*
The Effect Preview Monitor toolbar also contains buttons that you use to adjust and preview effects. For more information, see “Understanding the Effect Preview Monitor” on page 83.
## Table 3  Effect Editor Controls

<table>
<thead>
<tr>
<th>Button or Control</th>
<th>Location in Effect Editor</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Triangular opener</td>
<td>Left side*</td>
<td>Opens or closes the parameter group. A downward-pointing triangle displays the parameter group; a right-pointing triangle displays the parameter name.</td>
</tr>
<tr>
<td>Other Options</td>
<td>Inside some parameter categories</td>
<td>Opens additional parameters for some effects, including the Macintosh Color Picker or the Windows Color dialog box for color selection. For more information, see “Accessing Additional Parameters for an Effect” on page 106.</td>
</tr>
<tr>
<td>Reduce</td>
<td>Right side</td>
<td>Reduces the image in the Effect Preview monitor.</td>
</tr>
<tr>
<td>Enlarge</td>
<td>Right side</td>
<td>Enlarges the image in the Effect Preview monitor.</td>
</tr>
<tr>
<td>Dual Split</td>
<td>Right side</td>
<td>Splits the Effect Preview monitor in half to show the image with and without effects applied to it.</td>
</tr>
<tr>
<td>Play Loop</td>
<td>Right side</td>
<td>Plays back a transition or segment effect in a loop.</td>
</tr>
<tr>
<td>Play</td>
<td>Right side</td>
<td>Plays the effect from the current position in the effect’s position bar for most 2D and 3D effects.</td>
</tr>
<tr>
<td>HQ</td>
<td>Right side</td>
<td>Appears when the effect has an HQ (Highest Quality) rendering option. Click to select the HQ implementation or the standard implementation with which to render the effect. The button is green when the HQ implementation is selected. For more information, see “Rendering HQ (Highest Quality) Effects” on page 187.</td>
</tr>
<tr>
<td>Render Effect</td>
<td>Bottom</td>
<td>Renders the current effect.</td>
</tr>
<tr>
<td>Outline/Path</td>
<td>Bottom</td>
<td>Displays a wire-frame path to illustrate the movement of an effect from the first keyframe through the last keyframe.</td>
</tr>
</tbody>
</table>
Using the Effect Editor

Table 3  Effect Editor Controls (Continued)

<table>
<thead>
<tr>
<th>Button or Control</th>
<th>Location in Effect Editor</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transition Effect Alignment</td>
<td>Bottom</td>
<td>Selects the alignment of a transition effect relative to the cut point. For a detailed explanation of the Transition Effect Alignment menu and the Transition Effect Duration box, see “Using the Transition Parameters” on page 65. The Transition Effect Alignment button shows the alignment of the transition effect applied at the cut point. If the cut point does not have a transition effect, the Transition Effect Alignment button appears as a vertical bar. If the cut point has an existing transition effect, the button indicates the alignment of the transition effect.</td>
</tr>
<tr>
<td>Transition Effect Duration box</td>
<td>Bottom</td>
<td>Sets a duration for the transition effect other than the duration displayed.</td>
</tr>
<tr>
<td>Promote to Advanced Keyframes</td>
<td>Bottom</td>
<td>Available only for effects that support advanced keyframes. Promotes the effect to advanced keyframes. See “Working with Advanced Keyframes” on page 115.</td>
</tr>
<tr>
<td>3D Promote</td>
<td>Bottom right corner</td>
<td>Available for some effects, including titles, Picture-in-Picture, and imported matte keys. Promotes the effect to a 3D effect.</td>
</tr>
</tbody>
</table>

---

a. Triangular openers also appear to the left of keyframe graphs when you use advanced keyframes. For more information, see “Opening Keyframe Tracks” on page 117.
Moving an Enlarged Image in Effect Mode

When you use the Enlarge button to increase the size of the image in the Effect Preview monitor, you cannot view the entire frame all at once. When you are creating an effect that requires great detail, you can reposition the enlarged frame in the monitor to view the sections that need your attention.

This feature applies only to an enlarged image in the Effect Preview monitor, not to a standard-size or reduced image.

To move the image within the Effect Preview monitor:

1. Click within the boundaries of the Effect Preview monitor.
2. Press and hold Ctrl+Alt (Windows) or ⌘+Option (Macintosh).
   The pointer changes to a hand.
3. Drag the hand in any direction to reposition the image within the Effect Preview monitor.

Similarly, you can enlarge the frame in the Source monitor when you are working in Source/Record mode and move the frame around by pressing and holding Ctrl+Alt (Windows) or ⌘+Option (Macintosh). To access the Enlarge and Reduce buttons in Source/Record mode, you must map the buttons to your keyboard or to the user-selectable palettes. You can also use Ctrl+L (Windows) or ⌘+L (Macintosh) to enlarge the frame and Ctrl+K (Windows) or ⌘+K (Macintosh) to reduce the frame.

Selecting a Parameter

Some effects have additional parameters that you select from the current parameter’s Fast menu. For example, border types for 3D effects are in the same Fast menu.
Chapter 3  Customizing Effects

Changing a Parameter with a Slider

Many parameters have sliders for controlling the parameter value.

The thumbwheel is a specialized slider that provides a window on a wide range of values and allows precise control over increments.

- When you edit an effect that has advanced keyframes, you can choose to display parameters with either sliders or thumbwheels. See “Commands for Using Advanced Keyframes” on page 157.

- Some parameters display a blank slider track until you click an Effect Editor tool that activates the control.
To display an adjustable parameter slider:
- Click an Effect Editor tool that pertains to the slider.
  The slider appears on the track.

![Adjustable sliders](image)

To activate a parameter that has a slider:
- Click the parameter’s slider.
  The slider changes to pink.

To change the value of a parameter that has a slider, use any of the following methods:
- Move the slider with the mouse.
- Use the Left Arrow or Right Arrow key to change the value by –1 or +1.
- Press the Shift key, and use the Left Arrow key or Right Arrow key to change the value by –10 or +10.
  The parameter’s numeric value changes as you move the slider.
- Use the numeric keypad to type a new value, and, if you entered fewer than three digits, press Enter (Windows) or Return (Macintosh).

To move from one slider to the next:
- Use the Tab key.
Accessing Additional Parameters for an Effect

Some effects have additional parameters that control their operation. For example, the Grid effect has additional parameters in which you set the number of columns and rows in the wipe. When an effect has additional parameters, the Other Options button appears next to the effect name in the Effect Editor. The Other Options button also appears in a parameter group in the Effect Editor if the category can access additional parameters.

To access an effect’s additional parameters

- Next to the effect name or in a parameter group, click the Other Options button.

A dialog box opens in which you set the additional parameters.

You also use the Other Options button to access the parameters for third-party plug-in effects and for the Windows Color dialog box or Macintosh Color Picker in effects that allow you to change color parameters.

Adjusting a Color Parameter

In addition to using the Hue, Sat (saturation), and Lum (luminance) sliders, you can change a color parameter or select a key color with the following methods:

- Select a color with the eyedropper.
- Specify a color in the Windows Color dialog box or Macintosh Color Picker.
Using the Eyedropper to Select a Color

To select a color using the eyedropper:

1. Position the pointer over the Color Preview window to activate the eyedropper.
2. Click the eyedropper, drag it to the Effect Preview monitor, and release the mouse button on the color you want to select from the video image.

The parameter’s numeric values are updated, and the selected color appears in the Color Preview window.

Using the Windows Color Dialog Box

The Windows Color dialog box is part of the Windows XP operating system.

To open the Windows Color dialog box:

- Click the Other Options button next to a color parameter.

The Windows Color dialog box opens.
To use the Windows Color dialog box:

1. To select a color from the Basic colors palette, click the color you want.

2. To specify a custom color, do one of the following:
   - Click in the color matrix to select a color, and then drag the color slider to adjust the amount of white and black in the color.
   - Type numeric values for each color component in the color selection text boxes.

   The new color is displayed on the left side of the Color|Solid box. The right side of this box displays the solid color closest to the color you have specified. You can select the displayed solid color by double-clicking the right side of the box.

3. When you are satisfied with the color, click Add to Custom Colors to add it to the Custom Colors palette.

4. To select a custom color from the Windows Color dialog box, click the color you want.

5. Click OK.

   The Windows Color dialog box closes, and the application applies the color to the parameter in the Effect Editor.

Using the Macintosh Color Picker

The Macintosh Color Picker is a standard application that ships with Macintosh systems. You can access the Macintosh Color Picker through the Other Options button.

To open the Macintosh Color Picker dialog box:

- Click the Other Options button next to a color parameter.

  The Macintosh Color Picker dialog box opens.
The Macintosh Color Picker provides several methods for specifying colors. Select the appropriate icon on the left side of the Color Picker dialog box to display the method you want. The preceding illustration shows the CMYK (cyan, magenta, yellow, and black) sliders. You can also select a crayon box, an HSV (hue, saturation, luminance) color wheel, a Web-safe color picker (Name), or RGB (red, green, blue) sliders. For a complete description of how to use the Macintosh Color Picker, see the documentation that ships with your Macintosh.

To choose a color with the CMYK sliders, use the following methods:

- Drag the sliders to increase or decrease the color component.
- Type values in the percentage text boxes on the right side of the dialog box.

The color in the New color window updates as you change values.
Replacing an Effect with the Effect Editor

While in Effect mode, you can replace an existing effect.

To replace an effect:

1. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.

2. In the Effect Palette, select an effect category.

3. Use one of the following methods to replace the effect:
   - Drag the new effect’s icon to the Timeline. To replace an existing effect, move the new effect’s icon on top of the existing effect’s icon.
   - Drag the new effect’s icon to the Effect Preview monitor.
   - Select the effect in the Timeline, and double-click the new effect’s icon in the Effect Palette.

4. Set the applicable effect parameters in the Effect Editor.

Some effects cannot replace other effects. For example, some segment effects, such as the Mask effect, cannot replace transition effects. In addition, two-track effects, such as wipes, cannot replace three-track effects, such as matte keys.
Understanding Keyframes

A keyframe is a point in the effect at which you can set parameters. Modifying an effect’s parameters at various points causes the effect’s appearance to vary as it plays. For example, you can add keyframes to a Title effect and change the position parameters for each keyframe to add movement to the effect.

Standard keyframe indicators appear as triangles in the position bar of the Effect Preview monitor when an effect is selected and the Effect Editor is active. You adjust keyframe parameters by using the Effect Editor.

With some effects, you can use advanced keyframes to increase your control of the way effect parameters change over time. With this capability, each keyframeable effect parameter has a separate timeline track — a keyframe track that opens to display a keyframe graph — where you set and customize keyframes that are independent of other parameters’ keyframes. Advanced keyframes are available for Resize, PIP, 3D PIP, and 3D Warp. For more information, see “Working with Advanced Keyframes” on page 115.

You can still select standard keyframes, in which each keyframe affects all parameters. You can also use advanced keyframes as if they were standard keyframes.

Using Standard Keyframes

With standard keyframes, your Avid application always provides the starting and ending keyframes of an effect. These keyframes are selected by default, and thus any parameter changes are constant throughout the effect. Using techniques for adding, deleting, moving, selecting, and
deselecting keyframes, you can begin to change the appearance and operation of the effect over time by applying parameter changes to specific keyframes.

**Adding a Standard Keyframe**

You can create a standard keyframe at any point in the effect’s position bar.

**To create a standard keyframe:**

1. Click in the position bar below the Effect Preview monitor at the point in the effect where you want to add the keyframe. The position indicator moves to that frame.

2. Do one of the following to add a keyframe:
   - In the Effect Preview Monitor toolbar, click the Add Keyframe button.
   - Manually adjust a parameter in the Effect Preview monitor (segment effects only). For example, when you click a handle on an effect outline and drag to resize or reposition it, the application automatically creates a new keyframe.

**Selecting a Standard Keyframe**

You can select a single standard keyframe or multiple standard keyframes. A keyframe indicator changes to pink when selected.

**To select one keyframe:**

- In the position bar below the Effect Preview monitor, click the keyframe indicator.

**To select multiple keyframes:**

- Press and hold the Shift key, and click the keyframe indicators that you want in the effect’s position bar.
To select all keyframes in the effect's position bar, do one of the following:

- Press Ctrl+A (Windows) or ⌘+A (Macintosh).
- Press and hold Ctrl+Alt (Windows) or the ⌘ key (Macintosh), and click one keyframe indicator.

For a quick way to jump to the next or previous keyframe indicator, you can use the Fast Forward and Rewind buttons in the Effect Preview Monitor toolbar.

Moving a Standard Keyframe

After you have created a standard keyframe, you can move it to another position in the position bar below the Effect Preview monitor.

With standard keyframes, you cannot move the starting and ending keyframes.

To move a standard keyframe, do one of the following:

- Alt+click (Windows) or Option+click (Macintosh) the keyframe indicator, and drag it to its new position.
- Select a keyframe indicator, and click the Trim Left 1 Frame or Trim Right 1 Frame button, or the Trim Left 10 Frames or Trim Right 10 Frames button.

The four buttons for trimming are available on the Command palette and can be mapped to the Effect Preview Monitor toolbar. For more information, see “Mapping User-Selectable Buttons” in the Help.

Changing a Standard Keyframe’s Parameters

When you work with standard keyframes, with certain parameter categories, such as Foreground and Acceleration, you adjust parameters globally (over all keyframes in the effect). You can also change many parameters for individual standard keyframes. For information on the
scope of adjustments (global or keyframeable) for each parameter category, see “2D Effects Reference” and “3D Effects Reference” in the Help.

To change a standard keyframe’s parameters:

1. In the position bar below the Effect Preview monitor, click the keyframe indicator.
   
   The keyframe indicator changes to pink when selected.

2. Adjust any of the applicable parameters in the Effect Editor.

Copying and Pasting Standard Keyframe Parameters

You can copy and paste parameters from one standard keyframe and apply them to another keyframe. You can also copy standard keyframe parameters from one effect to another effect.

To copy and paste standard keyframe parameters:

1. Click one keyframe indicator in the position bar below the Effect Preview monitor whose parameters you want to copy.

2. Select Edit > Copy.

3. Select one or more standard keyframes:

   ▶ To copy the parameters to one keyframe, click the keyframe indicator.

   ▶ To copy the parameters to multiple keyframes, Ctrl+click (Windows) or Shift+click (Macintosh) multiple keyframes.

   ▶ To copy the parameters to all keyframes, select Edit > Select All.

4. Select Edit > Paste.

   The parameters that you copied from one standard keyframe are pasted to the keyframe, or frames, you selected.
Deleting a Standard Keyframe

You can delete any standard keyframe you create. You cannot delete the starting and ending keyframes created by the Avid application.

To delete a standard keyframe:

1. In the position bar below the Effect Preview monitor, click the keyframe indicator.
   
   The keyframe indicator changes to pink when selected.

2. Press the Delete key.

Alternatively, you can Alt+click (Windows) or Option+click (Macintosh) the Add Keyframe button to delete a keyframe.

Working with Advanced Keyframes

With standard keyframes, every keyframe affects every parameter. This section describes how to use advanced keyframes, where a separate timeline track — a keyframe track — appears in the Effect Editor for each keyframeable parameter in an effect.

The keyframe track opens to display a keyframe graph. When you work with effects that have advanced keyframes, you customize a parameter’s actions by using keyframes in the keyframe track. Each parameter’s keyframes are independent of any other parameter’s keyframes.

Advanced keyframes are available for PIP, 3D PIP, 3D Warp, and Resize. The Motion Effect Editor also uses advanced keyframes in the Speed graph and Position graph.

You do not have to use advanced keyframes in the Effect Editor. You can work using standard keyframes, in which each keyframe affects all parameters. In addition, advanced keyframe functions are available even when a keyframe graph is closed to show only the keyframe track.
Using advanced keyframes, you can change the order of nested effects by manipulating the Nesting Priority icons that appear in the Effect Editor. See “Changing the Order of Nested Effects” on page 298.

The following sections describe setting and customizing advanced keyframes.

**Promoting Effects to Advanced Keyframes**

You can promote Picture-in-Picture (PIP), 3D PIP, 3D Warp, and Resize effects to advanced keyframes. You can promote other effects to advanced keyframes if they are effects that can be promoted to 3D Warp.

You can choose whether or not a newly promoted effect first appears with no keyframes or with two keyframes, one at the start and one at the end of each parameter. You set this option in the Effect Editor entry of the Settings scroll list. For more information, see “Commands for Using Advanced Keyframes” on page 157.

Once you promote an effect to advanced keyframes, the Acceleration parameter category no longer appears. You manipulate acceleration (ease-in and ease-out) of the effect by using the spline or Bézier interpolation options, which give you more control than the standard Acceleration parameter category. See “Parameter Changes at Keyframes” on page 138.

**To promote a PIP effect or a Resize effect to advanced keyframes:**

- In the Effect Editor toolbar, click the Promote to Advanced Keyframes button.

  The Effect Editor displays the effect with keyframe tracks. Picture-in-Picture becomes Picture-in-Picture v2. Resize becomes Resize v2.

**To promote other effects to advanced keyframes:**

1. Promote the effect to 3D Warp.

   The Effect Editor displays a 3D Warp effect.

   The Promote to Advanced Keyframes button appears in the Effect Editor toolbar.
2. In the Effect Editor toolbar, click the Promote to Advanced Keyframes button.

The Effect Editor displays the promoted effect with keyframe tracks as a 3D Warp v2 effect.

Table 4 describes the promotion paths for advanced keyframes.

<table>
<thead>
<tr>
<th>Effect</th>
<th>Promoted to 3D</th>
<th>Promoted (from 3D) to Advanced Keyframes</th>
</tr>
</thead>
<tbody>
<tr>
<td>PIP or Resize</td>
<td>3D Warp</td>
<td>3D Warp v2</td>
</tr>
<tr>
<td>PIP promoted directly to advanced keyframes</td>
<td></td>
<td>PIP v2</td>
</tr>
<tr>
<td>Resize promoted directly to advanced keyframes</td>
<td></td>
<td>Resize v2</td>
</tr>
<tr>
<td>PIP v2 or Resize v2</td>
<td>3D Warp</td>
<td>3D Warp v2</td>
</tr>
</tbody>
</table>

Opening Keyframe Tracks

Effects using advanced keyframes appear with keyframe tracks at the right side of the Effect Editor. Next to each keyframe track is a triangular opener. The parameter group name appears in a title track at the top of the keyframe tracks.

You do not have to open a keyframe track to set and manipulate advanced keyframes. You can add and delete keyframes, customize keyframe interpolation options, and use the standard controls for each parameter to set the values for its keyframes, while a keyframe track is closed.
To open a keyframe track and display the keyframe graph:

- Click the triangular opener.

The keyframe track opens into a keyframe graph.

Depending on how you have the keyframe graph zoomed and scaled, the lines representing the keyframe graph boundaries — start and end of effect, maximum and minimum parameter values — might not be visible. See “Adjusting the View in a Keyframe Graph” on page 153.

**Effect Editor Controls for Advanced Keyframes**

You use the Effect Editor toolbar and the keyframe graph shortcut menu to create, delete, and customize advanced keyframes.
Table 5 describes the components of the Effect Editor toolbar for advanced keyframes.

Table 5  Effect Editor Toolbar for Advanced Keyframes

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rewind button</td>
<td>Moves the position indicator one keyframe to the left and activates the keyframe. If there is no keyframe to the left, the position indicator does not move. That is, the position indicator does not move to the beginning of the effect unless you have a keyframe there.</td>
</tr>
<tr>
<td>Fast Forward button</td>
<td>Moves the position indicator one keyframe to the right and activates the keyframe. If there is no keyframe to the right, the position indicator does not move. That is, the position indicator does not move to the end of the effect unless you have a keyframe there.</td>
</tr>
<tr>
<td>Add Keyframe button</td>
<td>Creates a keyframe at the current position. Alt+click (Windows) or Option+click (Macintosh) this button to delete a keyframe. When you add or delete a keyframe, a pop-up menu gives you additional selections. See “Adding and Deleting Keyframes in Keyframe Graphs” on page 122.</td>
</tr>
<tr>
<td>Zoom slider</td>
<td>Use the zoom slider in the scale bar, and the adjacent scroll thumbwheel, to zoom and scroll the view in the keyframe graph. See “Adjusting the View in a Keyframe Graph” on page 153.</td>
</tr>
<tr>
<td>3D Promote button</td>
<td>Click to promote the effect to a 3D effect.</td>
</tr>
</tbody>
</table>

Other controls appear in a pop-up menu when you click the Add Keyframe button, and in the shortcut menu that appears when you right-click (Windows) or Ctrl+Shift+click (Macintosh) a keyframe graph or keyframe track. The following sections describe the menu selections.

In addition to the controls in Table 5, a Nesting Priority icon appears in line with the effect name at the top of the Effect Editor. For more information, see “Changing the Order of Nested Effects” on page 298.
Shortcut Menus for the Motion Effect Editor and Keyframe Graphs

Advanced keyframes use two shortcut menus. You invoke the keyframe graph shortcut menu from the area of the Effect Editor that displays keyframe graphs. You invoke the Effect Editor shortcut menu from the part of the Effect Editor that does not display the keyframe graphs. For more information about the Effect Editor shortcut menu, see “Commands for Using Advanced Keyframes” on page 157.

Because the Motion Effect Editor uses advanced keyframes, the shortcut menu for the Motion Effect Editor and the shortcut menu for keyframe graphs are nearly identical. The differences stem from the multiple tracks available in the Effect Editor. The footnotes in Table 6 identify where each option is found.

To display the shortcut menu for a keyframe graph:

- Right-click (Windows) or Ctrl+Shift+click (Macintosh) a keyframe track, a keyframe graph, a parameter group title track, or the effect title track.

To display the shortcut menu for the Motion Effect Editor:

- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the active control graph.
### Table 6  Shortcut Menu Controls for Keyframe Graphs and the Motion Effect Editor

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Keyframe&lt;sup&gt;a&lt;/sup&gt;</td>
<td>Adds a keyframe at the position indicator. See “Adding and Deleting Keyframes in Keyframe Graphs” on page 122.</td>
</tr>
<tr>
<td>Delete Keyframe&lt;sup&gt;a&lt;/sup&gt;</td>
<td>Deletes the selected keyframe. See “Adding and Deleting Keyframes in Keyframe Graphs” on page 122.</td>
</tr>
<tr>
<td>Select All Keyframes&lt;sup&gt;a&lt;/sup&gt;</td>
<td>For the Effect Editor, selects all keyframes in the section of the editor where you click to display the shortcut menu. See “Selecting and Deselecting Advanced Keyframes” on page 133. For the Motion Effect Editor, selects all keyframes in the active graph.</td>
</tr>
<tr>
<td>Align Keyframe&lt;sup&gt;b&lt;/sup&gt;</td>
<td>Moves the selected keyframe to the position indicator. See “Using the Align Keyframes and Slip Keyframes Commands” on page 145.</td>
</tr>
<tr>
<td>Align Keyframes&lt;sup&gt;c&lt;/sup&gt;</td>
<td>Moves the selected keyframe in one or more keyframe graphs to the position indicator, depending on which keyframes you select and on where you click to display the shortcut menu. See “Using the Align Keyframes and Slip Keyframes Commands” on page 145.</td>
</tr>
<tr>
<td>Slip Keyframes&lt;sup&gt;a&lt;/sup&gt;</td>
<td>Moves all the keyframes of the parameter so the active keyframe aligns with the position indicator, and the rest of the keyframes maintain their relative location. See “Using the Align Keyframes and Slip Keyframes Commands” on page 145.</td>
</tr>
<tr>
<td>Shelf&lt;sup&gt;a&lt;/sup&gt;</td>
<td>The keyframe interpolation options set the way parameter changes occur at keyframes. See “Parameter Changes at Keyframes” on page 138.</td>
</tr>
<tr>
<td>Linear</td>
<td></td>
</tr>
<tr>
<td>Spline</td>
<td></td>
</tr>
<tr>
<td>Bézier</td>
<td></td>
</tr>
<tr>
<td>Fixed Keyframes&lt;sup&gt;a&lt;/sup&gt;</td>
<td>Sets how the application moves keyframes when an effect is trimmed in or trimmed out. Elastic keyframes change the time at which they occur when you trim an effect, in proportion to the new effect length. Fixed keyframes do not change. See “Elastic Keyframes and Fixed Keyframes” on page 135.</td>
</tr>
<tr>
<td>Elastic Keyframes</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 3  Customizing Effects

Adding and Deleting Keyframes in Keyframe Graphs

You can add a keyframe by using the Add Keyframe button in the Effect Editor toolbar, or you can use the keyframe graph shortcut menu. The first panel of the shortcut menu has commands for adding and deleting keyframes.

To add a keyframe to a keyframe graph by using the Add Keyframe button:

1. Move the position indicator to the point where you want to add a keyframe.

2. In the Effect Editor toolbar, click the Add Keyframe button.

   The Add Keyframe Mode menu appears.

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extrapolate&lt;sup&gt;c&lt;/sup&gt;</td>
<td>Determines how the application sets parameter values before the first keyframe and after the last keyframe. See “Extrapolate and Hold” on page 150.</td>
</tr>
<tr>
<td>Hold</td>
<td></td>
</tr>
<tr>
<td>Reset Graph View&lt;sup&gt;a&lt;/sup&gt;</td>
<td>Vertically recenters the graph view. See “Resetting the Graph View” on page 156.</td>
</tr>
</tbody>
</table>

   *a. The control appears in both the Effect Editor keyframe graph shortcut menu and the Motion Effect Editor shortcut menu.
   *b. The control appears only in the Motion Effect Editor shortcut menu.
   *c. The control appears only in the Effect Editor keyframe graph shortcut menu.
Working with Advanced Keyframes

If the Add Keyframe Mode menu does not appear, it is deselected in the Effect Editor shortcut menu, or in the Effect Editor entry in the Settings scroll list. See “Commands for Using Advanced Keyframes” on page 157.

For more information on the command selections, see “Using the Add Keyframe Mode Menu and the Delete Keyframe Mode Menu” on page 124.

3. Click the Add Keyframe button a second time to select the command that has a check mark next to it, or select another command from the Add Keyframe Mode menu.

An active keyframe indicator appears at the position indicator. If you selected a command that results in multiple keyframes, other keyframe indicators appear at the proper places.

If you changed the command, the Delete Keyframe mode also changes.

You can use the Effect Editor shortcut menu to set a default command. For more information, see “Commands for Using Advanced Keyframes” on page 157.

To add a keyframe to a keyframe graph by using the shortcut menu:

1. Move the position indicator to the point where you want to add a keyframe.

2. Right-click (Windows) or Ctrl+Shift+click (Macintosh) the keyframe graph or keyframe track, and select Add Keyframe.

An active keyframe indicator appears at the position indicator.

To delete a keyframe from a keyframe graph:

1. Click a keyframe indicator to activate it.

2. Do one of the following:

   ▶ Press the Delete key.

   ▶ Right-click (Windows) or Ctrl+Shift+click (Macintosh) the keyframe graph or keyframe track, and select Delete Keyframe.
In the Effect Editor toolbar, Alt+click (Windows) or Option+click (Macintosh) the Add Keyframe button.

The Delete Keyframe Mode menu appears. For more information on the commands, see “Using the Add Keyframe Mode Menu and the Delete Keyframe Mode Menu” on page 124.

If you select a new command from the Delete Keyframe Mode menu, the Add Keyframe mode also changes.

If the Delete Keyframe Mode menu does not appear, Show Add Keyframe Mode Menu is deselected in the Effect Editor shortcut menu, or in the Effect Editor entry in the Settings scroll list. For more information, see “Commands for Using Advanced Keyframes” on page 157.

Using the Add Keyframe Mode Menu and the Delete Keyframe Mode Menu

Before you begin adding keyframes, it is important to understand the terms the Avid application uses to refer to parameters and parameter groups. These terms are on the menu that appears when you add or delete a keyframe using the Add Keyframe button in the Effect Editor toolbar. The terms are also in the Effect Editor entry of the Settings scroll list.

If the Add Keyframe Mode menu or the Delete Keyframe Mode menu does not appear, it is deselected in the Effect Editor shortcut menu, or in the Effect Editor entry in the Settings scroll list. See “Commands for Using Advanced Keyframes” on page 157.

Use the Effect Editor shortcut menu or the Effect Editor entry of the Settings scroll list to set a default command. See “Commands for Using Advanced Keyframes” on page 157.

The selection you make for the Add Keyframe mode is mirrored in the Delete Keyframe Mode menu, and vice versa. That is, when you change one, you change both.
In the following descriptions, *group* refers to the parameter category. Each
description first defines the term that appears in the Add Keyframe Mode
menu and the Delete Keyframe Mode menu, and then illustrates the result
of using that command when adding or deleting a keyframe.

The following illustration shows an example of the Effect Editor with a 3D
PIP effect promoted to advanced keyframes, as it would look before
selecting a command from the Add Keyframe Mode menu.
• **Active Parameter** — The parameter that is currently active. For example, a slider that you clicked is pink.

- **Add To Active Parameter** — The keyframe appears in the keyframe track or keyframe graph for the active parameter only.

- **Delete From Active Parameter** — The application removes selected keyframes in the keyframe track or keyframe graph for the active parameter only.
• **Active Group** — The group to which the active parameter belongs.
  
  - **Add To Active Group** — Keyframes appear in the keyframe tracks or keyframe graphs of all parameters that are in the same group as the active parameter. If the active group is part of a larger group (for example, Color is a subgroup or subcategory of Border), keyframes appear only in the active group and not in the larger group. The parameter group does not have to be enabled.
  
  - **Delete From Active Group** — The application deletes selected keyframes from the keyframe tracks or keyframe graphs of all parameters that are in the same group as the active parameter. The parameter group does not have to be enabled.
• **Open Groups** — Groups that you opened by clicking the triangular opener next to the group name.

  - Add To Open Groups — Keyframes appear in the keyframe tracks or keyframe graphs of all parameters in groups that are currently open, whether the group is enabled or disabled.

  - Delete From Open Groups — The application deletes selected keyframes from keyframe tracks or keyframe graphs of all parameters in groups that are currently open, whether the group is enabled or disabled.
Working with Advanced Keyframes

- **Enabled Groups** — Groups that you enabled by clicking the Enable button next to the group name.
  - Add To Enabled Groups — Keyframes appear in the keyframe tracks or keyframe graphs of all parameters in groups that are currently enabled, whether the group is open or not.
  - Delete From Enabled Groups — The application deletes selected keyframes from the keyframe tracks or keyframe graphs of all parameters in groups that are currently enabled, whether the group is open or not.
Chapter 3  Customizing Effects

- *Open Graphs* — Keyframe tracks that you opened by clicking the triangular opener next to the keyframe track.

  - Add To Open Graphs — Keyframes appear in the keyframe graphs of all parameters with open graphs.
  
  - Delete From Open Graphs — The application deletes selected keyframes from the keyframe graphs of all parameters with open graphs.
• *All Parameters* — Every parameter represented in the Effect Editor that has a keyframe track and is therefore keyframeable.
  - *Add To All Parameters* — Keyframes appear in all keyframe tracks.
  - *Delete From All Parameters* — The application deletes selected keyframes from all keyframe tracks.

**Moving a Keyframe in a Keyframe Graph**

Once you create an advanced keyframe, you can move it to another location in the keyframe graph. The methods described here use the mouse to move a keyframe. You can also use commands in the keyframe graph shortcut menu. For more information, see “Using the Align Keyframes and Slip Keyframes Commands” on page 145.

**To move a keyframe vertically, changing its value:**

- With the keyframe graph open, click the keyframe indicator, and drag it to its new position.

  The time at which the keyframe occurs does not change.

**To move a keyframe horizontally, changing its time, do one of the following:**

- With the keyframe graph open, Alt+Shift+click (Windows) or Option+Shift+click (Macintosh) the keyframe indicator, and drag it to its new position.

  When you move a keyframe with the keyframe graph open, the Shift key constrains the movement to the horizontal (time) axis.

- With the keyframe graph closed, Alt+click (Windows) or Option+click (Macintosh) the keyframe indicator, and drag it to its new position.

  Alternatively, you can select keyframes and click the Trim Left 1 Frame and Trim Right 1 Frame buttons or the Trim Left 10 Frames and Trim Right 10 Frames buttons.

  The keyframe’s value does not change.
To move a keyframe in any direction:

- With the keyframe graph open, Alt+click (Windows) or Option+click (Macintosh) the keyframe indicator, and drag it to its new position.

  You can change both the keyframe’s value and the time at which the keyframe occurs.

  *You cannot move a keyframe past another keyframe. That is, keyframe movement is bounded by neighboring keyframes.*

You can use these methods to move a keyframe outside the time boundaries of the keyframe graph. That is, you can make the effect behave as if parameter values are changing before the beginning or after the end of the effect. This works only for the time at which a keyframe occurs. You cannot set a keyframe value outside the maximum or minimum value for the parameter.

The following illustration shows an example of moving a keyframe before the beginning of an effect.

You can also move keyframes outside the time boundaries by using the Align Keyframes and Slip Keyframes commands. See “Using the Align Keyframes and Slip Keyframes Commands” on page 145.
Working with Advanced Keyframes

Copying and Pasting Advanced Keyframe Parameters

You can copy and paste parameters from one advanced keyframe and apply them to another advanced keyframe. You can also copy advanced keyframe parameters from one effect to another effect.

**To copy and paste advanced keyframe parameters:**

1. Click one keyframe indicator in the parameter’s keyframe graph whose parameters you want to copy.
2. Select Edit > Copy.
3. Select one or more keyframes:
   - To copy the parameters to one keyframe, click the keyframe indicator.
   - To copy the parameters to multiple frames, Ctrl+click (Windows) or Shift+click (Macintosh) multiple keyframe indicators.
   - To copy the parameters to all keyframes, select Edit > Select All.
4. Select Edit > Paste.

The parameters that you copied from one keyframe are pasted to the keyframes you selected.

Selecting and Deselecting Advanced Keyframes

A keyframe graph does not have to be open when you select a keyframe. You can select keyframes in closed keyframe graphs.

**To select a keyframe:**

- Click the keyframe indicator.
  
  The keyframe indicator changes to pink (activated).

When you select more than one keyframe in a single keyframe track, the Avid application uses the most recently selected one as the reference keyframe for aligning and slipping keyframes. In addition, there are special considerations when you align keyframes in a track with both selected keyframes and deselected keyframes. See “Aligning Keyframes” on page 146.
To select more than one keyframe in a keyframe track:
1. Click the first keyframe indicator that you want to select.
   The keyframe indicator changes to pink (activated).
2. Press and hold the Ctrl key (Windows) or Shift key (Macintosh), and
   click each additional keyframe indicator.
   Each keyframe indicator changes to pink (activated).

To select keyframes in more than one keyframe track:
1. Click the first keyframe indicator that you want to select.
   The keyframe indicator changes to pink (activated).
2. In each keyframe track that you want to add to your selection, click the
   keyframe indicator.
3. (Option) If you want to select multiple keyframes in a keyframe track,
   Ctrl+click (Windows) or Shift+click (Macintosh) each additional
   keyframe indicator.

The following illustration shows the location of various components of
keyframe graphs in the Effect Editor.

To select all keyframes in a keyframe track:
- Right-click (Windows) or Ctrl+Shift+click (Macintosh) a keyframe
  track, and select Select All Keyframes.

To select all keyframes in a parameter group:
- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the parameter
  group title track, and select Select All Keyframes.
To select all keyframes in the effect:

- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the effect title track, and select Select All Keyframes.

To deselect a keyframe:

- Shift+click the keyframe indicator.

Occasionally, you might want to deselect all but one keyframe in a keyframe graph.

To deselect all keyframes but one in a track:

- Click the keyframe indicator of the keyframe that you want to remain selected.

  The keyframe indicator you click changes to pink (activated). All other keyframe indicators in the track appear gray and are deselected.

Elastic Keyframes and Fixed Keyframes

In previous releases, all keyframes were *elastic*. When you trimmed an effect, the Avid application scaled the keyframes to fit the new duration. For example, suppose you want to have a PIP effect appear, be visible for 16 frames, and then pop off the screen. If the original clip is 2 seconds long and you trim out the clip to 3 seconds, each event takes proportionally longer. After the trim, the PIP effect remains visible for 24 frames.
Chapter 3  Customizing Effects

With fixed keyframes, when you trim out a clip, the application extends the first or last keyframe value by duplicating parameters in the trimmed-out area. When you trim out a clip, the keyframes remain fixed at their original timecodes. Fixed keyframes allow you to “pin” a parameter change to a particular timecode. Using the previous example, if before the trim the PIP appears for 16 frames at 02:18, after the trim the PIP appears for 16 frames at 02:18.

<table>
<thead>
<tr>
<th>Event</th>
<th>Source Timecode Before Trim</th>
<th>Source Timecode After Trim</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start of clip</td>
<td>02:00</td>
<td>01:00</td>
</tr>
<tr>
<td>PIP effect on</td>
<td>02:18</td>
<td>01:27</td>
</tr>
<tr>
<td>PIP effect off</td>
<td>03:04</td>
<td>02:21</td>
</tr>
<tr>
<td>End of clip</td>
<td>3:29</td>
<td>3:29</td>
</tr>
</tbody>
</table>

2-second clip with fixed keyframes

Same clip trimmed out to add 1 second at the head:
timing of events does not change.

New material
Effect parameters default to elastic keyframes. You select elastic keyframes or fixed keyframes from the shortcut menu for a parameter.

- **All keyframes for a parameter are either elastic or fixed. You cannot mix elastic keyframes and fixed keyframes within a single parameter.**

- **Except for the Timewarp effect, you can select elastic keyframes or fixed keyframes for each parameter of an effect. That is, some parameters can have elastic keyframes and other parameters can have fixed keyframes.**

- **All keyframes for a Timewarp effect are either elastic or fixed. You cannot mix elastic and fixed keyframes within a Timewarp effect.**

**To select elastic keyframes or fixed keyframes for a parameter:**

- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the keyframe graph or keyframe track for the parameter with which you are working, and select Fixed or Elastic.

  The keyframes for the parameter change to the selected keyframe type and the keyframe indicators for the parameter display the selected keyframe type.

  All subsequent keyframes you add to this parameter appear as the selected keyframe type.
To select elastic keyframes or fixed keyframes for a parameter group:

- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the parameter group title track, and select Fixed or Elastic.

  The keyframes for all parameters in the parameter group change to the selected keyframe type. The keyframe indicators display the selected keyframe type.

  All subsequent keyframes you add to this parameter group appear as the selected keyframe type.

Parameter Changes at Keyframes

How an effect parameter changes at a keyframe is governed by which keyframe interpolation option you select. Interpolation refers to the method the Avid application uses to calculate the rate of change and the relative smoothness of change.

To select an interpolation option:

- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the keyframe graph or keyframe track for the parameter with which you are working, and select one of the following:
  - Shelf
  - Linear
  - Spline
  - Bézier

  Each option is described fully in the next section.
Options for Controlling Parameter Changes at Keyframes

You can select from the following options for controlling parameter changes at keyframes:

- **Shelf** — The parameter value does not change between keyframes and then changes abruptly to the new value. Some applications call this *Hold*.

  Use Shelf to hold a parameter value for a fixed length of time. For example, you can use Shelf with the Position parameters to create a PIP that appears to “pop” to a new location at each keyframe.

- **Linear** — The parameter value ramps smoothly between keyframes but then changes abruptly at each keyframe. The change in parameter value at a keyframe happens with no ease-in or ease-out.

  Effects with standard keyframes make linear parameter changes (with the exception of Spline for motion paths and Acceleration for other parameters). With advanced keyframes, you can use the Linear interpolation option for some parameters and not for others, depending on the effect you want to achieve.
Chapter 3  Customizing Effects

Using the Linear interpolation option, the PIP effect moves across the image for the entire effect.

Using the Shelf interpolation option, the PIP effect “pops” to a new location at each keyframe.

- **Spline** — The parameter value changes smoothly at each keyframe, creating a simple ease-in or ease-out effect. Spline is sometimes called *Natural Spline* or *Cardinal Spline* because the line representing the parameter value always goes precisely through each keyframe.
With two keyframes, the application changes the parameter value slowly at the beginning of the effect, speeds up the rate of change, and then slows down to come to rest gently at the end of the effect. Use three keyframes to create an arc.

Use the Spline interpolation option (or the Bézier interpolation option) for any parameter for which you want to avoid abrupt changes, such as Scaling or Border width.

- **Bézier** — The Bézier interpolation option is similar to the Spline interpolation option, in that the parameter value changes smoothly at each keyframe. In addition, the Bézier interpolation option provides direction handles at each keyframe. You adjust the rate at which the parameter value changes by manipulating the direction handles.

When you click a direction handle and drag it, you change the height and angle of the curve. The curve responds as if you were gently tugging it like a piece of string. The curve remains anchored to the keyframes on either side of the active keyframe.

Use the Bézier interpolation option (or the Spline interpolation option) for any parameter for which you want to avoid abrupt changes.
You can use the Bézier interpolation option to create abrupt changes. “Break” the direction handles using modifier keys and adjust each side of the curve independently. For more information, see “Adjusting Parameter Values with the Bézier Interpolation Option” on page 142.

The adjustment methods for Bézier curves are described in the next section.

### Adjusting Parameter Values with the Bézier Interpolation Option

You can adjust Bézier curves in the following ways:

- **Symmetrically** — Dragging a direction handle changes the length and rotation of both direction handles symmetrically.

**Adjusting Bézier curves symmetrically**

**Before**

![Before symmetrically](image1)

**After**

![After symmetrically](image2)

Dragging the left handle up and to the left causes both sides to rotate and increase in length.

- **Asymmetrically** — Dragging a direction handle changes the length of the selected handle, but not the opposite handle. The rotation of both handles changes as you drag the selected handle.

**Adjusting Bézier curves asymmetrically**

**Before**

![Before asymmetrically](image3)

**After**

![After asymmetrically](image4)

Dragging the left handle up and to the left causes the left side to rotate and increase in length. The right side rotates but does not change in length.
• **Independently** — Dragging a direction handle changes both the length and rotation of the selected handle. The opposite handle does not change. You do this by “breaking” the handle.

The default adjustment method is symmetrical. You change the adjustment method by using the Alt key (Windows) or Option key (Macintosh). See “Changing the Adjustment Method for the Bézier Interpolation Option” on page 144.

**To use the Bézier interpolation option for adjusting a parameter value:**

1. Select the Bézier interpolation option.
   
   For more information, see “Parameter Changes at Keyframes” on page 138.

2. Click a keyframe indicator to activate it.
   
   The keyframe indicator changes to pink, and a direction bar with direction handles appears.
3. Position the pointer over one of the direction handles.
   The pointer changes to a hand pointer.

4. (Option) Alt+click (Windows) or Option+click (Macintosh) the direction handle to select an adjustment method.
   Each time you do, the adjustment method cycles to the next adjustment method: symmetrical, asymmetrical, or independent. For more information, see “Changing the Adjustment Method for the Bézier Interpolation Option” on page 144.

5. Drag the mouse to move the direction handle.
   The direction bar and the curve change to show the new interpolation motion.

6. Continue adjusting the direction handles to achieve the effect you want.

When you make an adjustment to a direction handle, the application remembers which adjustment method you used. If you do not want to change the adjustment method, do not Alt+click (Windows) or Option+click (Macintosh) the direction handle before making another adjustment to the same handle. Instead, just click the direction handle, and drag it to its new location.

Changing the Adjustment Method for the Bézier Interpolation Option

To change the adjustment method for the Bézier interpolation option:

- Alt+click (Windows) or Option+click (Macintosh) the direction handle.
   Each time you do, the adjustment method cycles to the next adjustment method: symmetrical, asymmetrical, and independent.

For example, suppose you make an adjustment using independent direction handles, and then move the cursor away from the keyframe. To continue using independent direction handles, click the direction handle and make further adjustments. To change the adjustment method from independent to symmetrical, Alt+click (Windows) or Option+click (Macintosh) the direction handle.
Using the Align Keyframes and Slip Keyframes Commands

The Align Keyframes and Slip Keyframes commands give you another way to adjust the position of advanced keyframes.

- Align Keyframes moves the selected keyframe to the position indicator. The other keyframes in the keyframe track do not move.
- Slip Keyframes moves all the keyframes of the parameter so the active keyframe aligns with the position indicator, and the rest of the keyframes maintain their relative location.

You do not have to select a keyframe from an open keyframe graph to use Align Keyframes and Slip Keyframes. You can select keyframes in any keyframe track.

Disabling Set Position To Keyframe can make it easier for you to use Align Keyframes and Slip Keyframes. See “Commands for Using Advanced Keyframes” on page 157.

You can use Align Keyframes and Slip Keyframes within a single keyframe track by selecting a single active keyframe. You can also use Align Keyframes and Slip Keyframes to bring several parameters into alignment by selecting an active keyframe in more than one parameter and then choosing where you invoke the shortcut menu. See “Selecting and Deselecting Advanced Keyframes” on page 133.

When you select more than one keyframe in a single keyframe track, the application uses the most recently selected one as the reference keyframe for aligning and slipping keyframes. In addition, there are special considerations when you align keyframes in a track with both selected keyframes and deselected keyframes. See “Aligning Keyframes” on page 146.

Both Align Keyframes and Slip Keyframes can move keyframes outside the time boundaries of the keyframe graph. That is, you can make the effect behave as if parameter values are changing before the beginning or after the end of the effect.
In each of the following procedures, the *reference keyframe* of any keyframe graph is the keyframe you activated most recently in that keyframe graph.

**To align the reference keyframe to the position indicator, in one keyframe track:**
- Right-click (Windows) or Ctrl+Shift+click (Macintosh) a keyframe track, and select Align Keyframes.

**To align the reference keyframes to the position indicator, in one parameter group:**
- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the parameter group title track, and select Align Keyframes.

  The reference keyframes move to the position indicator.

**To align the reference keyframes to the position indicator, in the entire effect:**
- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the effect's title track, and select Align Keyframes.

  The reference keyframes of the entire effect move to the position indicator.

> In each keyframe track, Align Keyframes will not move the reference keyframe beyond an intervening keyframe; that is, a keyframe between the reference keyframe and the position indicator. If there is an intervening keyframe, the reference keyframe moves to within one frame or field of it.
Align Keyframes exhibits more complex behavior when you have multiple keyframes selected in one keyframe graph.

If you select all keyframes in one keyframe graph, Align Keyframes is equivalent to Slip Keyframes. The reference keyframe moves to the position indicator, and all other keyframes maintain their position relative to the reference keyframe.

Deselected (gray) keyframes do not move. All selected keyframes do move, as close to the target position as possible, unless a deselected keyframe intervenes.
The following illustration shows several examples.

Slipping Keyframes

In each of the following procedures, the reference keyframe of any keyframe graph is the keyframe you activated most recently in that keyframe graph.

To slip keyframes to the position indicator, in one keyframe track:

- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the keyframe track, and select Slip Keyframes.

All the keyframes move so that the reference keyframe aligns with the position indicator, and the other keyframes maintain their position relative to the reference keyframe.
To slip keyframes to the position indicator, in one parameter group:

- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the parameter group title track, and select Slip Keyframes.

In the parameter group, in each keyframe track with a reference keyframe, all the keyframes move so that the reference keyframe aligns with the position indicator, and the other keyframes maintain their position relative to the reference keyframe.

If a keyframe track has no selected keyframes, no keyframes move.

To slip keyframes to the position indicator, in the entire effect:

- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the effect’s title track, and select Slip Keyframes.

In the effect, in all keyframe tracks with a reference keyframe, all the keyframes move so that the reference keyframe aligns with the position indicator, and the other keyframes maintain their position relative to the reference keyframe.
Extrapolate and Hold

When you use standard keyframes, you always have a starting keyframe and an ending keyframe that are fixed at the start of the effect and the end of the effect. You cannot move or delete the starting keyframe and the ending keyframe. With advanced keyframes, you do not need to set a starting keyframe or an ending keyframe, and you can move or delete them.

To keep the application from creating starting and ending keyframes when you promote an effect, deselect Automatic Start and End Keyframes in the Effect Editor entry in the Settings scroll list.

In a keyframe graph, the first keyframe and the last keyframe are the bracketing keyframes for the parameter. The application uses either Extrapolate or Hold to determine parameter values beyond the bracketing keyframes.

Extrapolate and Hold are available only for keyframe graphs. The Motion Effect Editor does not use Extrapolate and Hold.

With Extrapolate enabled, the application extrapolates — that is, estimates more values for — the parameter values at the start and end of an effect by using the values at the bracketing keyframes. Parameter values continue to change over time. The application calculates new values using the interpolation option in effect for that parameter.
In the preceding illustration, the blue lines represent the parameter value before and after the bracketing keyframes and show the extrapolation of the parameter value.

If you are reading a hardcopy version of this document, you might find it useful to view the color images in the Help or in the online version of this document on the online library CD-ROM.

For example, if the parameter value between the last two keyframes increases as the end of the effect approaches, the parameter value continues to increase until the end of the effect. Similarly, if the first keyframe is not at the very beginning of the clip, the application extrapolates the parameter value from the start of the effect up to the first keyframe.

With Hold enabled, the application uses only the parameter values at the bracketing keyframes to set values at the start and end of the effect. The parameter values hold steady — that is, are the same — from the start of the effect to the first keyframe, and again from the last keyframe to the end of the effect.

In the preceding illustration, the horizontal blue lines represent the parameter value before the first keyframe and after the last keyframe.

Extrapolate and Hold are useful any time you slip keyframes or align keyframes in such a way that a bracketing keyframe falls within the effect, or if you are using fixed keyframes for a parameter and you trim in or trim out the effect so that a bracketing keyframe falls within the effect.

The Extrapolate or Hold setting remains in effect if you trim in or trim out the effect.
Chapter 3  Customizing Effects

In either case, you do not have an explicitly defined value outside the bracketing keyframes. Extrapolate and Hold can save you the trouble of individually setting new values for each parameter whenever you make changes to the position of keyframes or the length of the effect.

When you select Extrapolate, the application estimates more values for the parameter before and after the bracketing keyframes by using the values at the bracketing keyframes. Parameter values continue to change over time. The application calculates new values by using the interpolation option in effect for that parameter.

When you select Hold, the application uses only the parameter values at the bracketing keyframes to set values before and after the bracketing keyframes. The parameter values are the same from the start of the effect to the first keyframe, and again from the last keyframe to the end of the effect.
As a result of slipping the keyframes in the previous examples, the last keyframe indicator has moved out of the keyframe graph view but is still present and is still the bracketing keyframe. The keyframe indicator visible at the right edge of the keyframe graph (the third keyframe indicator) is not a bracketing keyframe. Therefore, the parameter values in effect from the third keyframe to the end of the effect are calculated along the curve between the third keyframe and the last (bracketing) keyframe.

You set Extrapolate and Hold independently for each parameter in an effect. The default condition is Hold.

To set Extrapolate or Hold for a parameter:
- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the keyframe track, and select Extrapolate or Hold.
  The display changes to reflect the new setting.

### Adjusting the View in a Keyframe Graph

You adjust the view in a keyframe graph in the following ways:
- Zoom and scroll the view in a keyframe graph by using the zoom slider and the scroll thumbwheel at the bottom of the Effect Editor.
- Resize a keyframe graph by manipulating the size of the Effect Editor and by expanding or contracting the vertical size of the keyframe graph.
- Scroll the view vertically in a keyframe graph by dragging the view.
Zooming and Scrolling Keyframe Graphs

You zoom and scroll the view in a keyframe graph by using the zoom slider and the scroll thumbwheel at the bottom of the Effect Editor.

The zoom slider in the scale bar stretches and contracts the view in a keyframe graph centered around the position indicator. This allows you to either zoom in to focus on a specific area of your keyframe graph or zoom out to display the entire keyframe graph.

To zoom in on a section of a keyframe graph at the position indicator and then zoom out:

1. Click the zoom slider, and drag it to the right.
   The view in the keyframe graph expands horizontally and shows more detail.
2. Click the zoom slider, and drag it to the left.
   The view in the keyframe graph shrinks to its original size.

The scroll thumbwheel scrolls the view in a keyframe graph left or right.

**To scroll the view in a keyframe graph left or right:**
1. Click the scroll thumbwheel, and drag it to the left.
   The view in the keyframe graph scrolls to the right; that is, as part of the view disappears on the right, more comes into view on the left.

![Keyframe Graph](image)

2. Click the scroll thumbwheel, and drag it to the right.
   The view in the keyframe graph scrolls to the left; that is, as part of the view disappears on the left, more comes into view on the right.

![Keyframe Graph](image)
Chapter 3  Customizing Effects

Resizing the Keyframe Graph

Resize the keyframe graph by manipulating the size of the Effect Editor and by expanding or contracting the vertical size of the keyframe graph.

To change the width of a keyframe graph:
- Click a corner of the Effect Editor, and drag it to resize the window.

To change the height of a keyframe graph:
1. Position the pointer over the lower edge of the keyframe graph that you want to change.
   The pointer changes to a vertical resizing pointer.
2. Click the edge of the graph, and drag it up or down.
   The height of the keyframe graph gets smaller or larger.

Moving the Keyframe Graph View Up or Down

Scroll the view in a keyframe graph up or down by dragging the view.

Use the scroll thumbwheel to move the view left or right.

To scroll the view in a keyframe graph up or down:
1. Alt+click (Windows) or Option+click (Macintosh) the keyframe graph.
   The pointer changes to a hand.
2. Drag the hand up or down to reposition the view within the keyframe graph.

Resetting the Graph View

If you move the view in a keyframe graph or in the active graph of the Motion Effect Editor so that you can no longer see the keyframes, you can use the shortcut menu to vertically recenter the keyframes in the keyframe graph.
To reset the view vertically in a keyframe graph:

- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the keyframe graph, and select Reset Graph View.
  The keyframes appear centered vertically in the keyframe graph.

Depending on how you have scaled and zoomed your keyframe graph, you might not see any keyframes even after resetting the graph view. Try scrolling the keyframe graph left or right, or zoom out until keyframes appear.

Commands for Using Advanced Keyframes

The Effect Editor shortcut menu gives you commands for adjusting the Effect Editor display, for controlling the playback of effects with advanced keyframes, and for setting a default command for the Add Keyframe button.

The Effect Editor shortcut menu appears only in effects with advanced keyframes.

To display the Effect Editor shortcut menu:

- Right-click (Windows) or Ctrl+Shift+click (Macintosh) the Effect Editor outside the keyframe track area.
  The Effect Editor shortcut menu appears.

Table 7 describes the shortcut menu commands for the Effect Editor and the Effect Editor commands in the Settings scroll list.

The commands in the Effect Editor entry of the Settings scroll list and the commands in the Effect Editor shortcut menu are similar but not identical. The footnotes identify where each command is found.
Table 7  Effect Editor Commands

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Indent Rows</td>
<td>When selected, parameter rows are indented from the parameter group row, and any parameter subgroups are indented again. When deselected, the left edges of parameter rows line up with the parameter group row.</td>
</tr>
<tr>
<td>Large Text</td>
<td>When selected, text in the Effect Editor appears in 12-point size. When deselected, text in the Effect Editor appears in the default size, 10 points (Windows) or 9 points (Macintosh).</td>
</tr>
<tr>
<td>Thumbwheels</td>
<td>When deselected, variable controls in the Effect Editor appear as the default sliders. When selected, variable controls appear as thumbwheels. For information on using thumbwheels, see “Changing a Parameter with a Slider” on page 104.</td>
</tr>
</tbody>
</table>
### Table 7  Effect Editor Commands (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Real Time Update(^a)</td>
<td>When selected, the application updates the rendered effect image in real time. Because the update can be slow for complex effects, you have the option to deselect updating in real time.</td>
</tr>
<tr>
<td>Set Position To Keyframe(^a)</td>
<td>With Set Position To Keyframe selected, when you click a keyframe indicator, the application moves the position indicator to the keyframe. With Set Position To Keyframe deselected, when you click a keyframe indicator, the position indicator does not move. Deselecting Set Position To Keyframe allows you to align a keyframe to the position indicator. See “Using the Align Keyframes and Slip Keyframes Commands” on page 145.</td>
</tr>
<tr>
<td>Update Position While Playing(^a)</td>
<td>When selected, the position indicator in the Effect Editor moves while you play the effect. Because using Update Position While Playing can cause video underrun problems in complex real-time effects, the option is deselected by default.</td>
</tr>
<tr>
<td>Show Add Keyframe Mode Menu(^a)</td>
<td>When selected, the Add Keyframe Mode menu (or the Delete Keyframe Mode menu) appears when you use the Add Keyframe button to add (or delete) keyframes. See “Using the Add Keyframe Mode Menu and the Delete Keyframe Mode Menu” on page 124.</td>
</tr>
<tr>
<td></td>
<td>With Show Add Keyframe Mode Menu deselected, using the Add Keyframe button performs the default command from the following list (Add Keyframe button commands), without displaying the Add Keyframe Mode menu or the Delete Keyframe Mode menu.</td>
</tr>
</tbody>
</table>
Chapter 3  Customizing Effects

Table 7  Effect Editor Commands (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Keyframe button commands(^b)</td>
<td>Select one as the default command for the Add Keyframe button.</td>
</tr>
<tr>
<td>• Add Keyframe To Active Parameter</td>
<td>• When you deselect Show Add Keyframe Mode Menu, clicking the Add Keyframe button once performs the default command.</td>
</tr>
<tr>
<td>• Add Keyframes To Active Group</td>
<td>• When you select Show Add Keyframe Mode Menu, clicking the Add Keyframe button twice performs the default command. (The first click displays the Add Keyframe Mode menu, at which point you can select another command.)</td>
</tr>
<tr>
<td>• Add Keyframes To Open Groups</td>
<td></td>
</tr>
<tr>
<td>• Add Keyframes To Enabled Groups</td>
<td>The selection you make for the Add Keyframe mode is mirrored in the Delete Keyframe Mode menu, and vice versa. That is, when you change one, you change both.</td>
</tr>
<tr>
<td>• Add Keyframes To Open Graphs</td>
<td>For a description of each command, see “Using the Add Keyframe Mode Menu and the Delete Keyframe Mode Menu” on page 124.</td>
</tr>
<tr>
<td>• Add Keyframes To All Parameters</td>
<td></td>
</tr>
<tr>
<td>Automatic Start and End Keyframes(^c)</td>
<td>With Automatic Start and End Keyframes selected, when you promote an effect to advanced keyframes, all keyframe tracks initially appear with a start keyframe and an end keyframe. With Automatic Start and End Keyframes deselected, newly promoted effects initially appear with no keyframes.</td>
</tr>
</tbody>
</table>

---

\(^a\) The command appears both in the Effect Editor shortcut menu and in the Settings scroll list.

\(^b\) The command appears only in the Effect Editor shortcut menu.

\(^c\) The command appears only in the Settings scroll list.

---

160
Defining a Motion Path

You can define how the foreground image of a multilayer effect will move across the background video by building a motion path, or string of keyframes. You can define a motion path on multilayer video effects such as Picture-in-Picture effects. Use the wire-frame preview feature when you want to see the path an image takes on the screen.

When you are creating a motion path that moves beyond the viewing screen, you can use the Reduce button to view an outline of the image at a reduced scale. The reduced scale view shows the area outside the background image and allows you to extend the motion path into that area. The Enlarge button returns the screen to full view.

To define a motion path for the foreground image, use one of the following methods:

- Move the image directly and automatically add keyframes.
- Add keyframes and adjust the parameter sliders.

Moving the Image Directly to Add a Motion Path

You can use the wire-frame feature and keyframes to add a motion path to a multilayer effect. The Outline/Path button on the Effect Editor window places a wire frame around the foreground image in the Effect Preview monitor. You can then drag the wire frame to new locations and add keyframes at each location to add movement to the effect.

You can also resize the foreground image by clicking the wire-frame handles and dragging them to a new location. The top center handle adjusts the image’s height and the right center handle adjusts the image’s width. You can use the top right corner handle to equally change the image’s height and width.
To add a motion path to the foreground image by using the wire frame and keyframes:

1. Create a sequence with two video layers (foreground video on track V2, background video on track V1). For information about creating a sequence, see “Editing in Source/Record Mode” in the Help.

2. Apply a multilayer effect to the foreground segment on track V2.

3. Select the foreground effect segment on track V2.

4. Enter Effect mode by selecting Toolset > Effects Editing.

   By default, the wire frame is active. The foreground image is outlined, and both the starting and ending keyframe indicators are highlighted (pink) in the effect’s position bar.

5. Drag the wire frame to the start point of the motion path you are creating. The starting keyframe indicator represents the start point.
6. Click the ending keyframe indicator to select it. Make sure the ending keyframe indicator is the only indicator selected (pink).

7. Drag the wire frame to the end point of the motion path. A path line from the center of the starting position to the center of the ending position appears.

8. Drag the position indicator in the effect’s position bar to a new location. The wire frame moves with the position indicator; notice the path line does not change.

9. Click inside the wire frame, and drag or stretch the wire frame to add a keyframe at the new location. A handle appears in the center of the wire frame, indicating the path position of the new keyframe.

10. Drag the wire frame to change the effect’s path.

11. Repeat steps 8 to 10 to add more variation to the path.
Using an Effect Template

The parameters for an effect are called the effect template. You can reuse an effect template in multiple places in a sequence by saving the template in a bin and later applying the template to other effects or video clips in the sequence.

Saving an Effect Template

You can save the parameters from an effect in the Effect Editor and reuse them for another effect.

**To save an effect template:**

- Drag the effect icon from the Effect Editor to a bin.

A new effect template appears in the bin, containing the parameter setting information for the effect. The new effect template is identified in the bin by its effect icon.
Effect icons for open bins are also displayed in the Effect Palette.

You can save a segment effect with its source media, which is useful when you want to save an imported PICT file or Matte Key clip for future editing into a sequence. Press and hold the Alt key (Windows) or Option key (Macintosh) while you drag the effect icon from the Effect Editor to a bin.

Title effects are saved with the source media by default. If you press and hold the Alt key (Windows) or Option key (Macintosh) while dragging the icon, you create a keyframe-only template. This template will retain the movement of the title without the source media.

To rename an effect template:

- In the bin, click the template name below the icon and type a new name.
Applying an Effect Template

You can take an effect template that has been saved in a bin and apply the template and its parameters to other transitions or segments in your sequence.

You can apply an effect template with all its parameters directly to segments or transitions as you would any other effect. You can also apply specific parameters from the template.

To apply a specific parameter from an effect template:
1. In the Timeline, select an effect transition or segment.
2. Select Tools > Effect Editor.
3. Open the parameter group you want to change.

For example, the following illustration shows the Position parameter group.
4. Click the effect template icon in the bin or in the Effect Palette, and drag it to the specific parameter group in the Effect Editor.

⚠️ Do not drag the effect template through the Timeline because this deselects the effect.

The application applies the effect template only to the effect parameter group you selected.
Chapter 4

Playing and Rendering Effects

This chapter explains how to play and render effects and how the Avid application behaves under various rendering conditions.

- Playing an Effect
- Understanding Real-Time Effects Processing
- Rendering Effects
- Saving a Partially Completed Render
- ExpertRender
- Rendering Effects for the Media Station XL
- Managing Effect Media Files
Chapter 4 Playing and Rendering Effects

Playing an Effect

The following sections describe the variety of ways in which you can play back an effect. Depending on the capabilities of your Avid application, various effects might require rendering before you can play them back in real time. For more information, see “Real-Time Effects and Non-Real-Time Effects” on page 33 and “Understanding Real-Time Effects Processing” on page 171.

Basic Playback

To play an effect:

1. In the Timeline, drag the position indicator to the effect you want to play.
2. Click the Play button.

To stop playing an effect, do one of the following:

- Click the Play button.
- Press the space bar.

Playing an Effect in a Continuous Loop

For information on entering Effect mode, see “Entering Effect Mode” on page 82.

To play the effect in a continuous loop while in Effect mode:

1. In the Timeline, drag the position indicator to the effect you want to play.
2. In the Effect Preview Monitor toolbar, click the Play Loop button.

To stop playing an effect, do one of the following:

- Click the Play Loop button.
- Press the space bar.
Playing a Preview of an Effect

You might want to play an effect or its outline to check its appearance and operation. An effect’s *outline* is a wire-frame representation of the effect’s position, scale, and path of motion.

**To play an effect’s outline:**
- In the Effect Preview Monitor toolbar, click the Play Preview button.
  The effect’s outline plays from the current position.

**To stop playing the effect preview, do one of the following:**
- Click the mouse button.
- Press the space bar.
- Click the Play Preview button a second time.

Understanding Real-Time Effects Processing

To display a frame from a sequence that has a video effect applied, the Avid editing application must calculate the result of the effect at that frame. For example, to display the midpoint frame from a dissolve between two clips, the application must calculate, for each pixel in the frame, a 50 percent blend between the color and luminance values in the outgoing clip and those in the incoming clip. To display frames in real time, the application must be able to perform enough of these effect calculations per second to maintain the appropriate display rate for your project, for example 30 frames per second (fps) for NTSC video.

Because your computer’s processor and memory capabilities are finite, your Avid editing application’s ability to play back effects in real time is limited. Effect calculations are more complex for some effects than for others, and still more complex when many effect options have been adjusted or when multiple effects apply to the same frame in a sequence. Even the fastest and most powerful system might eventually reach a point where it can no longer maintain real-time playback.
When the Avid editing application is unable to maintain real-time playback, it continues to play at the correct rate but does not display frames that it cannot process quickly enough. If the application is having only a small amount of difficulty with the complexity of the sequence, you will probably perceive a short stutter in the video playback, but you might still be able to get a useful sense of how your effects will look once they are rendered. If the application is having more difficulty, it is less likely that you will be able to judge the look of the effects.

You have a number of options for controlling how real-time effects preview operates, including the ability to selectively render effects and the ability to change the resolution at which the application displays video. These options are discussed in the following sections.

**Controlling Playback of Real-Time Effects**

When the Avid editing application is unable to maintain real-time playback of an effects sequence, there are a number of ways you can attempt to ensure that the sequence plays back successfully in real time.

- If possible, start playback earlier in the sequence, before the effects that are causing difficulties begin.
  
  This allows the Avid editing application to begin processing some of the effects frames before it must display them, decreasing the chance of difficulties with playback.

- In the Video Display Settings dialog box, increase the number of seconds of video to prefill.
  
  For more information, see “Prefilling the Video Display Buffer” on page 173.

- Render some or all of the effects.
  
  You can use ExpertRender™ to identify those effects in a sequence that must be rendered to achieve successful playback. The Avid editing application marks these parts of the sequence in the Timeline. For more information, see “ExpertRender” on page 192.

Consider rendering transition effects such as the Dissolve effect or wipe effects first, because they take less time to render than titles or segment effects.
• Reduce the image resolution that the application uses for display during playback or rendering.

This increases the application’s ability to process effects at the expense of image quality. For more information, see “Controlling Video Quality for Playback” on page 175.

• Use the Submaster effect to reduce the amount of rendering.

For more information, see “Submaster Editing” on page 301.

• Perform a mixdown of video tracks.

For more information, see “Performing a Video Mixdown” on page 306.

• Reduce the number of real-time streams.

In some circumstances, reducing the number of real-time streams that the application uses for playback will improve system performance. For more information, see “Limiting the Number of Real-Time Streams” on page 174.

• Optimize your drive striping.

Proper drive striping increases the speed at which the application retrieves media. For more information, see the ReadMe for your Avid editing application and the online Knowledge Center at www.avid.com/support.

Prefilling the Video Display Buffer

In the Video Display Settings dialog box, you can specify the number of seconds that the Avid editing application delays before it begins playback. During this time, the application processes frames in advance and stores them in the video display buffer. When playback begins, the application starts to display the preprocessed frames while it continues to process new ones. The application will continue to play back the sequence successfully in real time unless it exhausts its supply of preprocessed frames. By accepting a delay at the beginning of playback, you increase the likelihood that the application will play the material successfully. The maximum delay you can specify is 10 seconds.
If the memory in your Avid system is limited, the Avid editing application might not be able to prefill the full number of seconds that you specify. As a result, the delay you experience before playback begins might be less than the number of seconds you specify. It cannot be more than that number.

To set the number of seconds of video to prefill:

1. In the Project window, click the Settings tab.
   The Settings scroll list appears.
2. Double-click Video Display.
   The Video Display Settings dialog box opens.
3. In the Seconds of Video to Pre-Fill text box, type the number of seconds by which you want the application to delay playback.
4. Click OK.

Limiting the Number of Real-Time Streams

Your Avid editing application supports up to eight real-time streams. If the system on which the application plays does not have the capacity to run that many real-time streams, you can experience a degradation of system performance. Processor speed, system memory, and disk speed all affect system performance.

You can also experience performance degradation in an Avid Unity™ workgroup environment when the demands on the system exceed the capacity of the Unity to respond.

In either case, you can improve system performance by decreasing the number of real-time streams that the application uses during playback. Use the Video Display Settings dialog box to change the number of real-time streams.
To set the number of real-time streams:

1. In the Project window, click the Settings tab.
   The Settings scroll list appears.
2. Double-click Video Display.
   The Video Display Settings dialog box opens.
3. In the Stream Limit text box, type the number of real-time streams you want the application to use for playback.
   The application supports a minimum of one and a maximum of eight real-time streams.
4. Click OK.

Controlling Video Quality for Playback

The Video Quality Menu button in the Timeline bottom toolbar allows you to switch display resolution between Full Quality and Draft Quality.

Display resolution during playback has two states:

- **Full Quality** (green) uses full-image 1:1 resolution, but handles limited effect complexity before the Avid application begins to have difficulties with real-time playback.

  *If you notice missing frames or choppy video during real-time playback, switch to Draft Quality.*
Chapter 4  Playing and Rendering Effects

- **Draft Quality** (half green, half yellow) uses 1/4 resolution and reduces the quality of the image so you can view greater effect complexity in real time.

Once you are satisfied with your sequence using Draft Quality, render the sequence and switch to Full Quality to see the final result.

**To select video quality for playback:**

- In the Timeline bottom toolbar, click the Video Quality Menu button and select a video quality.

When you change video quality, immediate changes appear in the quality and sharpness of the media displayed in the Source/Record monitor.

**Rendering Effects**

*Rendering is the merging of effect layers to create one stream of digital video for playback in real time.*

You must render a non-real-time effect (an effect whose icon displays a blue dot) before it can be played. In addition, you must render some or all effects that exceed the real-time playback capabilities of the Avid application in order to view them during playback. Occasionally, you might also need to render an effect that displays a green dot in the Timeline, depending on the complexity of the sequence. See “Understanding Effect Icon Color Coding” on page 38.

For more information on real-time effects playback capabilities, see “Controlling Playback of Real-Time Effects” on page 172.

When an effect renders, the application stores the effect and its media file as a precomputed master clip (often referred to as a precompute). The application uses the precompute the next time to play the effect at its normal speed.

If IN and OUT points are not marked in the Timeline, the Render at Position command is available for rendering a single effect or for rendering multiple effects at the same position in the Timeline. If IN and OUT points are marked in the Timeline, the Render IN to OUT command is available for rendering all effects on selected tracks between the marked IN and OUT points. For more information, see “Rendering Effects Between IN and OUT Points” on page 185.
You can also click the Render Effect button to render effects at position. The Render Effect button ignores any marked IN and OUT points and allows you to render the effects at the current position in the Timeline.

The Render Effect button appears in the Effect Editor, on the Tool palette, and in the Timeline top toolbar. You can also map the Render Effect button from the Command palette to another button or the keyboard. For more information, see the following topics in the Help: “Using the Tool Palette,” “Displaying the Timeline Top Toolbar,” and “Using the Command Palette.”

You can also use ExpertRender to determine which effects need to be rendered. If IN and OUT points are not marked in the Timeline, the ExpertRender at Position command is available for determining which effects at the current position in the Timeline require rendering. If IN and OUT points are marked in the Timeline, the ExpertRender IN to OUT command is available for determining which effects on the selected tracks between the marked IN and OUT points require rendering.

For more information, see “ExpertRender” on page 192.

The key to rendering quickly is to render only those effects that require it. With vertical and nested effects, for example, you do not have to render every layer to play the effect in real time. If the top track covers the entire duration of the tracks below, the application renders the composite result of all tracks into the top track.

Two useful ways to minimize rendering time are:

- Use the ExpertRender feature to determine which effects to render for successful playback. See “ExpertRender” on page 192.
- Use the Submaster effect by applying it to a track above layered effects and rendering only the Submaster effect. See “Submaster Editing” on page 301.
Creating and Using Render Settings

You can create one or more sets of parameters to customize rendering, and save them as a custom Render setting. For example, you can create one setting especially for rendering single-field motion effects and another for rendering two-field or uncompressed motion effects. You can then activate the setting that you need at each stage of your project.

Creating a New Render Setting

To create a new Render setting:

1. In the Project window, click the Settings tab.
   The Settings scroll list appears.
2. Click Render.
3. Select Edit > Duplicate.
4. Name the setting.
   a. Click the custom name column (in between the setting name and the setting type identifier).
   b. Type a name, and press Enter (Windows) or Return (Macintosh).
5. Adjust the options for the setting as described in the following procedure.

Adjusting Render Settings Parameters

To adjust the parameters in the Render Setting dialog box:

1. In the Settings scroll list of the Project window, double-click a Render setting.
   The Render Setting dialog box opens.
2. Select the appropriate options based on the descriptions in Table 8.
3. Click OK to apply the Render settings.
### Table 8  Render Setting Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Render Completion Sound</strong></td>
<td>Sets a sound for the application to activate once the rendering process is complete. This is useful when you are rendering multiple effects.</td>
</tr>
<tr>
<td>• None</td>
<td>Disables the rendering completion sound. This is the default.</td>
</tr>
<tr>
<td>• System Beep</td>
<td>Sets the rendering completion sound to match the sound set for your operating system.</td>
</tr>
<tr>
<td>• Avid Sound</td>
<td>Sets the rendering completion sound to a customized Avid sound.</td>
</tr>
<tr>
<td><strong>Motion Effects Render Using</strong></td>
<td>Select an option to determine the processing method when existing motion effects, other than Timewarp effects, are rendered or rerendered.</td>
</tr>
<tr>
<td>• Original Preference</td>
<td>Causes effects to be rendered as whatever type they were when originally created.</td>
</tr>
<tr>
<td>• Duplicated Field</td>
<td>Displays a single field in the effect. For two-field media, this reduces the information stored by half because it drops one field of the image, resulting in a lower quality image. For single-field media, this is usually the best choice because of its speed. (The other options do not improve effect quality for single-field media.) With JFIF resolutions, selecting this option causes effects to render in the shortest amount of time. With DV and MPEG resolutions, effects render approximately as quickly as they would if you selected Both Fields as the rendering option.</td>
</tr>
<tr>
<td>• Both Fields</td>
<td>Displays both fields in the effect. For example, the first two frames of a half-speed (50%) slow-motion effect repeat the original Frame 1 (both fields) twice. This option is good for shots without inter-field motion, NTSC or PAL film-to-tape transfers, and still shots. With footage that includes inter-field motion, this method might result in minor shifting or bumping of the image because it disturbs the original order of fields: a Field 1 will appear both before and after the corresponding Field 2. The effect renders relatively quickly. For best results, you should use evenly divisible frame rates with this option.</td>
</tr>
</tbody>
</table>

*If an option is grayed out it is not available for the current project.*
Chapter 4  Playing and Rendering Effects

### Table 8  Render Setting Options (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interpolated Field</td>
<td>Creates a second field for the effect by combining scan line pairs from the first field in the original media. This option calculates the motion effect at the field level rather than the frame level. Using this method results in the smoothest effect because the application considers all fields and does not disturb the original order of fields. This method is best for video-originated material or film-originated material transferred at 24 fps. Effects created using this option render in the longest amount of time.</td>
</tr>
<tr>
<td>VTR-Style</td>
<td>Creates a second field for the effect by shifting selected video fields of the original media by a full scan line. This technique is similar to that used by high-quality professional video decks when playing footage at less than normal speed. This option also creates the motion effect at the field level rather than the frame level; however, because pixels are not filtered, the final image is sharper than that created by the Interpolated Field option. The image might display some slight jitter at certain speeds. The time needed to render effects created with this option is longer than the time for effects created using either Duplicated Field or Both Fields but similar to the time needed for Interpolated Field.</td>
</tr>
</tbody>
</table>

**Timewarps Render Using**

Select an option to determine the processing method when Timewarp effects are rendered or rerendered.

*If an option is grayed out it is not available for the current project.*

- Original Preference
- Duplicated Field
- Both Fields
- Interpolated Field
- VTR-Style

These rendering options are the same as those for Motion Effects Render Using. See the preceding descriptions.
The application blends, or averages, pixels from the original frames or fields to create intermediate frames or fields. For example, at 25% speed, the system creates three blended images between outgoing Image A and incoming Image B. The first blended image weights the pixels from Image A at 75% and Image B at 25%. The second blended image weights the pixels from Image A at 50% and Image B at 50%. The third blended image weights the pixels from Image A at 25% and Image B at 75%. Objects in motion from Image A to Image B appear to fade out of Image A and fade in to Image B.

Timewarp effects created using Blended Interpolated or Blended VTR render less quickly than Interpolated Field or VTR-Style.

The application first creates a second field for the effect by shifting selected video fields of the original media by a full scan line. Then it blends, or averages, pixels from the original frames or fields to create intermediate frames or fields. For example, at 25% speed, the system creates three blended images between outgoing Image A and incoming Image B. The first blended image weights the pixels from Image A at 75% and Image B at 25%. The second blended image weights the pixels from Image A at 50% and Image B at 50%. The third blended image weights the pixels from Image A at 25% and Image B at 75%. Objects in motion from Image A to Image B appear to fade out of Image A and fade in to Image B.

Timewarp effects created using Blended Interpolated or Blended VTR render less quickly than Interpolated Field or VTR-Style.

The application analyzes the motion between outgoing Image A and incoming Image B, and interpolates intermediate frames pixel-by-pixel. The motion generated by FluidMotion is the smoothest of all the rendering options.

Timewarp effects created using FluidMotion are the slowest to render.

To save time while rendering the Timewarp effect, select one of the other rendering options to rough out your sequence and use FluidMotion only when you are satisfied with the overall sequence.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blended Interpolated</td>
<td>The application blends, or averages, pixels from the original frames or fields to create intermediate frames or fields. For example, at 25% speed, the system creates three blended images between outgoing Image A and incoming Image B. The first blended image weights the pixels from Image A at 75% and Image B at 25%. The second blended image weights the pixels from Image A at 50% and Image B at 50%. The third blended image weights the pixels from Image A at 25% and Image B at 75%. Objects in motion from Image A to Image B appear to fade out of Image A and fade in to Image B. Timewarp effects created using Blended Interpolated or Blended VTR render less quickly than Interpolated Field or VTR-Style.</td>
</tr>
<tr>
<td>Blended VTR</td>
<td>The application first creates a second field for the effect by shifting selected video fields of the original media by a full scan line. Then it blends, or averages, pixels from the original frames or fields to create intermediate frames or fields. For example, at 25% speed, the system creates three blended images between outgoing Image A and incoming Image B. The first blended image weights the pixels from Image A at 75% and Image B at 25%. The second blended image weights the pixels from Image A at 50% and Image B at 50%. The third blended image weights the pixels from Image A at 25% and Image B at 75%. Objects in motion from Image A to Image B appear to fade out of Image A and fade in to Image B. Timewarp effects created using Blended Interpolated or Blended VTR render less quickly than Interpolated Field or VTR-Style.</td>
</tr>
<tr>
<td>FluidMotion</td>
<td>The application analyzes the motion between outgoing Image A and incoming Image B, and interpolates intermediate frames pixel-by-pixel. The motion generated by FluidMotion is the smoothest of all the rendering options. Timewarp effects created using FluidMotion are the slowest to render. To save time while rendering the Timewarp effect, select one of the other rendering options to rough out your sequence and use FluidMotion only when you are satisfied with the overall sequence.</td>
</tr>
</tbody>
</table>
Chapter 4  Playing and Rendering Effects

Table 8  Render Setting Options (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Effects Quality Render Using</td>
<td>Sets a global override for effects that have HQ (Highest Quality) rendering options. You select HQ rendering or standard rendering for individual effects by clicking the HQ button in the Effect Editor. For more information, see “Rendering HQ (Highest Quality) Effects” on page 187. Once the application begins rendering, it changes all affected HQ settings to the Effects Quality Render Using value in the active Render setting. If you cancel the render, HQ settings do not revert to their previous values.</td>
</tr>
</tbody>
</table>

- Quality Set in Each Effect  Causes effects to render at the quality determined by the HQ selection in the individual effects. This is the default.
- Standard Quality            Causes all effects to use standard rendering, without regard for the HQ setting in individual effects.
- Highest Quality             Causes effects that have HQ rendering to render with it, without regard for the HQ setting in individual effects. If HQ rendering does not exist for a given effect, the effect uses standard rendering.

Activating a Render Setting

To activate a Render setting:

- Click in the column to the left of the setting name in the Settings scroll list of the Project window.

A check mark appears beside the setting that is currently active.
Rendering a Single Effect

After you have adjusted an effect’s parameters, you can render the effect.

To render a single effect:

1. Move the position indicator to the effect in the Timeline. Make sure the track containing the effect is selected.

2. Do one of the following:
   - In the Effect Editor, click the Render Effect button.
   - Select Clip > Render at Position.

   The Render Effect dialog box opens.

3. Click the Drive pop-up menu, and select a drive for the rendered media.

   The Effect Source Drive is the drive where the media on the outgoing shot of a transition resides.

4. Click OK.

   If there is not enough room on the drive, a message box opens.
   - Click Stop to stop the rendering process and return to the Render Effects dialog box, and then select another target drive before continuing.
   - Click Continue to attempt to render the effect anyway, in case there might be enough room on the drive.

   The Avid application renders the effect, and stores a precompute master clip on the drive you selected.

   To display the estimated rendering time, press the T key on the keyboard. Press the T key again to clear the display. Press the P key to view percent rendered.
When you have more than one effect at a particular point in the Timeline (for example, effects on several stacked video tracks), you can render them as a group.

**To render multiple effects at position:**
1. Move the position indicator to the effects in the Timeline.
2. Select all tracks that contain effects you want to render.
3. Do one of the following:
   - In the Effect Editor, click the Render Effect button.
   - Select Clip > Render at Position.
   
   The Render Effects dialog box opens.
4. Click the Drive pop-up menu, and select a drive for the rendered media.
   
   The *Effect Source Drive* is the drive where the media on the outgoing shot of a transition resides.
5. (Option) If you do not want to render the real-time effects in the selected group of effects, select Skip Real-Time Effects.
6. Click OK.

If there is not enough room on the drive, a message box opens.

- Click Stop to stop the rendering process and return to the Render Effects dialog box, and then select another target drive before continuing.
- Click Continue to attempt to render the effect anyway, in case there might be enough room on the drive.

The Avid application renders all effects at the position in the Timeline.

*To display the estimated rendering time, press the T key on the keyboard. Press the T key again to clear the display. Press the P key to view percent rendered.*
Rendering Effects Between IN and OUT Points

When you have multiple effects to render for a whole sequence or a portion of a sequence, you can render them as a group by marking IN and OUT points.

Save your sequence before you use this feature. Depending on the number, type, and complexity of the effects, the batch process can take a long time.

To render multiple effects between IN and OUT points:

1. Select all tracks that contain effects you want to render.

2. In Source/Record mode, mark an IN point before the start of the first effect to be rendered in your sequence, and mark an OUT point after the last effect to be rendered.

3. Select Clip > Render In/Out.

   The Render Effects dialog box opens.

4. Click the Drive pop-up menu, and select a drive for the rendered media.

   The Effect Source Drive is the drive where the media on the outgoing shot of a transition resides.

5. (Option) If you do not want to render the real-time effects in the selected group of effects, select Skip Real-Time Effects.

6. Click OK.

   If there is not enough room on the drive, a message box opens.
   
   ▸ Click Stop to stop the rendering process and return to the Render Effects dialog box, and then select another target drive before continuing.
   
   ▸ Click Continue to attempt to render the effect anyway, in case there might be enough room on the drive.

The Avid application renders all effects between the IN and OUT points.
To display the estimated rendering time, press the T key on the keyboard. Press the T key again to clear the display. Press the P key to view percent rendered.

Another way to speed up rendering is to use the Submaster effect. See “Submaster Editing” on page 301.

Displaying Effects On-the-Fly

The Render On-the-Fly option allows you to play back real-time effects and preview non-real-time effects frame by frame, immediately after applying them.

**To display effects immediately during effects editing:**

- Select Special > Render On-the-Fly.

A separate setting for Render On-the-Fly exists for Trim mode. See “Adjusting Trim Settings for Effects” on page 52.

Interrupting Render On-the-Fly

Using Render On-the-Fly can slow down your editing of a sequence. If you are compositing and then change the frame you are monitoring, you must wait for the application to render the single frame.

Instead of waiting for the application to finish rendering, you can interrupt Render On-the-Fly. Interrupting Render On-the-Fly interrupts the rendering of only non-real-time effects.

**To interrupt Render On-the-Fly, do one of the following:**

- Drag the position indicator in the Timeline.
  
  While you are dragging, the sequence appears in the Record monitor as it would if Render On-the-Fly were not selected in the Special menu.

- If you click in the Timeline and the application begins to render, quickly move to another location in the Timeline.

  This cancels the rendering process.
Rendering HQ (Highest Quality) Effects

Some effects have two rendering options, the standard hardware-assisted render and the HQ (Highest Quality) software-based render. HQ rendering produces a superior image, but it takes longer than standard rendering.

The HQ button appears in the Effect Editor for effects that have an HQ rendering option. Use the HQ button to select HQ rendering for an individual effect in your sequence.

Not all effects have an HQ rendering option.

To select HQ rendering for an individual effect:

1. In Effect mode, move the position indicator to the effect you want to select.
   
   If HQ rendering exists for the effect, the HQ button appears in the Effect Editor.
   
2. Click the HQ button.
   
   The button turns green.

To select standard rendering for an individual effect:

- Click the HQ button again.
   
   The button turns black.

The HQ button has a global setting in the Render Settings dialog box. Effects Quality Render Using lets you override the selection you made in the Effect Editor for individual effects. You can easily change from standard rendering to HQ rendering for your entire sequence, once you are satisfied with your draft version, by using the Render Settings selection. You can also choose to set all effect rendering to standard if you want to decrease rendering time. For more information, see “Creating and Using Render Settings” on page 178.

Once the application begins rendering, it changes all affected HQ settings to the Effects Quality Render Using value in the active Render setting. If you cancel the render, HQ settings for individual effects do not revert to their previous values.
Chapter 4 Playing and Rendering Effects

For example, suppose you apply several effects to a sequence and use the HQ button in the Effect Editor to select HQ rendering for some but not all the effects. In the active Render setting, you set Effects Quality Render Using to Highest Quality. You set an IN point and an OUT point, and select Clip > Render In/Out.

When you start the render, the application immediately changes all the effects between the IN point and the OUT point to HQ rendering, if the HQ render is available for a given effect. If you cancel the render, the HQ settings that were changed will not be changed back. You must reset the HQ settings individually.

Combined Rendering of Real-Time and Non-Real-Time Effects

The combination of real-time and non-real-time effects on the same video track can show different results, depending on when you render the non-real-time effects:

• If you render non-real-time segment effects after you apply a real-time transition effect, the sequence will play in real time.
• If you render non-real-time segment effects and then apply a real-time transition effect, the transition effect will play as a cut.

Saving a Partially Completed Render

If you interrupt the rendering of an effect before it finishes, the application allows you to save the part of the rendered effect that was completed when you interrupted the process. You can finish rendering later by resubmitting the effect for rendering. The application will then render only the part of the effect that has not been rendered previously and will save that part as a separate precompute. This feature is especially useful if you have to interrupt the long rendering of a single effect, such as a Submaster effect.

You can also use the Render Ranges command in the Timeline Fast menu to customize the Timeline so that it indicates which parts of an effect have been rendered.
Partial Completed Rendering Example

The following example describes a typical interrupted rendering process for a group of five effects.

The five effects are submitted for rendering, and the process is interrupted while rendering the second effect. Precomputes are saved for the fully rendered first effect and for the part of the second effect that has been rendered.

When the same group of effects is submitted for rendering again, the application:

- Does not rerender the fully rendered first effect
- Renders only that portion of the second effect that has not been rendered previously
- Renders the remaining three effects

The result is six precompute files for five effects, since the second effect was rendered in two parts at two different times.
Interrupting Rendering

To interrupt rendering:

1. Press Ctrl+period (Windows) or ⌘+period (Macintosh).
   A message box opens.
2. Do one of the following:
   - Click Keep to save the material already rendered.
   - Click Discard to stop rendering without saving the material already rendered.

Customizing Render Range Display

To customize the display of render ranges in the Timeline:

1. Click the Timeline Fast Menu button, and select Render Ranges.
2. Select one of the following:
   - None — Turns off the display of render ranges
   - Partial Only — Displays a red line on the portion of any partially rendered effect that is currently unrendered (but does not mark completely unrendered effects)
   - All — Displays a red line on the portion of any partially rendered effect that is currently unrendered and on all completely unrendered effects

The following illustrations show how the Timeline displays render range information. The Picture-in-Picture effect on track V2 has been partially rendered; effects on track V1 are not rendered.
Render Ranges indicator lines do not display if Show Effect Contents is selected in the Timeline Settings dialog box.

The All option of the Render Ranges display provides a simple visual indication of which effects are unrendered. It is not an indication of which effects might need to be rendered to achieve successful playback.

In Effect mode, the playback behavior of a partially rendered effect depends on the frame at which playback begins. If playback begins at a rendered frame, the application attempts to play the entire effect in real time. You see the rendered portion in real time but cannot see the portion that has not been rendered. If playback begins at a frame outside the rendered portion, the application uses Render On-the-Fly to play the entire effect.
ExpertRender

When you use the Render at Position or the Render In/Out command to render effects, all effects in the selected material render — all effects on the enabled tracks at the position or all effects on the enabled tracks between the marked IN and OUT points. In most cases, some effects are rendered that do not require rendering for successful playback, resulting in a longer rendering time than necessary and the creation of more precomputes than necessary.

The ExpertRender option helps to solve this problem by analyzing all the effects in selected material and then determining which ones need to be rendered to achieve successful playback. You can then choose to render the effects identified by ExpertRender or to modify the selections before submitting them for rendering.

ExpertRender attempts to generate a minimum set of effects to render for successful playback. If you render the effects recommended by ExpertRender, your material will always play successfully in real time.

In most circumstances, ExpertRender enables you to render material quickly, easily, and with a high degree of storage efficiency. However, experienced Avid users might achieve an even quicker rendering of a complex sequence than that offered by ExpertRender — for example, using Submaster editing. For more information, see “Examples of ExpertRender Behavior” on page 196 and “Submaster Editing” on page 301.

Using ExpertRender to Render Effects

To use ExpertRender to render effects:

1. Select all tracks in the Timeline that contain effects you want ExpertRender to analyze.

2. Do one of the following:
   - To render at position, move the position indicator to the effects in the Timeline.
   - To render between IN and OUT points, mark IN and OUT points around the effects.
3. Do one of the following:
   - Select Clip > ExpertRender at Position.
   - Select Clip > ExpertRender In/Out.

   ExpertRender analyzes the selected effects and highlights the effects that require rendering in the Timeline. The following illustration, in which four effects are selected for rendering, shows how the application highlights both transition and segment effects.

   ![Illustration showing highlighted effects]

   The Render Effects dialog box opens and indicates how many of the effects submitted to ExpertRender require rendering.

4. Do one of the following:
   - Click Cancel.
     The application removes all ExpertRender highlighting and cancels the ExpertRender process without rendering any effects.
   - Click Modify Selection.
     The effects identified for rendering remain highlighted, and you can modify the set of effects to render. For more information, see “Modifying ExpertRender Results” on page 194.
   - Click OK.

5. If there is not enough room on the drive, a message box opens.
   - Click Stop to stop the rendering process and return to the Render Effects dialog box, and then select another drive before continuing.
   - Click Continue to attempt to render the effects anyway, in case there might be enough room on the drive.

   The Avid application renders the highlighted effects.

   To display the estimated rendering time, press the T key on the keyboard. Press the T key again to clear the display. Press the P key to view percent rendered.
Modifying ExpertRender Results

To modify the results of an ExpertRender analysis:

1. Perform an ExpertRender by following steps 1 to 3 in “Using ExpertRender to Render Effects” on page 192.

2. In the Render Effects dialog box, click Modify Selection.

3. Shift+click effects in the Timeline to add them or remove them from the set of effects to render.

   Effects currently selected are highlighted.

4. When you are satisfied with your selections, click the Render Effect button.

   The Render Effect button appears in the Effect Editor, on the Tool palette, and in the Timeline top toolbar. You can also map the Render Effect button from the Command palette to another button or the keyboard. For more information, see the following topics in the Help: “Using the Tool Palette,” “Displaying the Timeline Top Toolbar,” and “Using the Command Palette.”

   The Render Effects dialog box opens.

5. Click the Drive pop-up menu, and select a drive for the rendered media.

   The Effect Source Drive is the drive where the media on the outgoing shot of a transition resides.

6. Click OK.

   If there is not enough room on the drive, a message box opens.

   ▶ Click Stop to stop the rendering process and return to the Render Effects dialog box, and then select another drive before continuing.

   ▶ Click Continue to attempt to render the effects anyway, in case there might be enough room on the drive.

   The selected effects render.
To display the estimated rendering time, press the T key on the keyboard. Press the T key again to clear the display. Press the P key to view percent rendered.

To cancel ExpertRender during the modification process, do one of the following:

- Click in the timecode (TC) track to move the position indicator.
- Double-click one of the Segment Mode buttons (the Extract/Splice-in button or the Lift/Overwrite button) below the timeline.
- Select Clip > ExpertRender at Position, and then click Cancel in the Render Effect dialog box.
- Select Clip > ExpertRender In/Out, and then click Cancel in the Render Effect dialog box.

The application removes all ExpertRender highlighting and cancels the ExpertRender process without rendering any effects.

Some Considerations When Using ExpertRender

When you work with ExpertRender, you should be aware of the following aspects of its operation:

- ExpertRender operates on all selected tracks in the Timeline, including any enabled tracks that might be above the currently monitored track. To view the material that you are submitting to ExpertRender accurately in the Record monitor, make sure that you are monitoring the topmost selected track in the sequence.

- ExpertRender takes account of all tracks at or below the topmost selected track when determining what to render on the selected tracks to achieve successful playback. For example, if you have a sequence with tracks V1 to V4, and select tracks V3 and V4 when using ExpertRender, the application considers tracks V1 and V2 when determining playback possibilities but highlights effects to render only from tracks V3 and V4.

- If the material you submit to ExpertRender includes an effect in a segment that also contains nested effects, ExpertRender always renders the effect on the top (outside) track rather than the effect inside the nest. In certain circumstances, this might limit your workflow...
flexibility. For example, you might anticipate the need to readjust the parameters of the effect outside the nest and the effect would then require rerendering. You can use the procedure described in “Modifying ExpertRender Results” on page 194 to select the effect within the nest for rendering and deselect the effect outside the nest.

Examples of ExpertRender Behavior

The following examples illustrate how ExpertRender functions in a variety of circumstances. The examples will help you to understand the value of ExpertRender and will alert you to certain situations where you might want to modify the results of an ExpertRender analysis before you render a sequence.

Example 1: Nested Effect with Dissolves

In this example, two segment effects are applied to a segment by nesting the effects, and Dissolve effects are applied to the beginning and end of the segment. In the Timeline, the Dissolve effects appear with green dots.

Although the Dissolve effects have green dots to indicate that they might need to be rendered under some circumstances, this example will play successfully in real time without rendering. When the sequence is submitted to ExpertRender, it correctly indicates that no effects require rendering.
In this example, ExpertRender saves time for the editor who might assume that the sequence cannot play in real time without rendering at least the Dissolve effects.

**Example 2: Multilayer Sequence with a 3D Effect**

In this example, a Mask effect is applied to the segment on track V1, and a 3D Picture-in-Picture effect is created by applying the 3D Warp effect to the segment on track V2. Dissolves are applied to the beginning and end of the segments on both tracks. The final effect has masked video in the background and a 3D Picture-in-Picture effect using the same footage in the foreground. Additional segments containing Mask effects follow the first segment on track V1. The sequence has eight effects.

Dissolve effects appear with green dots.

3D Warp effect appears with a green dot.

Mask effects appear with orange dots.
In the Timeline, the 3D segment effect and all four transition effects appear with a green dot.

When this sequence is submitted to ExpertRender, only three effects are recommended for rendering — the 3D effect on track V2 and the two dissolves on track V1. After you render these three effects, the sequence plays successfully in real time.

In this case, ExpertRender saves time for the editor who might assume that the sequence cannot play in real time without rendering all five green dot effects or even all the effects in the sequence.
Example 3: Titles with a Dissolve Effect

In this example of a situation that is common when working with titles, a Dissolve effect is applied between two Title Effect clips. In the Timeline, the Dissolve effect appears with a green dot.

When this sequence is submitted to ExpertRender, it recommends rendering the two Title Effect clips.
In this case, ExpertRender makes a recommendation for rendering that is not ideal. This sequence will play back successfully if the Dissolve effect alone is rendered.

This example shows that ExpertRender sometimes recommends the rendering of longer segment effects (including Title Effect clips) when a quicker rendering of transition effects is sufficient to enable successful playback. You should check for these kinds of recommendations and consider modifying them by using the procedures described in “Modifying ExpertRender Results” on page 194. Accepting these recommendations might slow down your workflow.
When your workflow includes a Media Station XL system for off-loading the rendering process, you can use the Render to Media Station XL command. Because Media Station XL cannot render all types of effects, this command determines which effects in the selected area require rendering on your Avid application before you send the sequence to the Media Station XL system.

For example, the Media Station XL system is not configured with 3D hardware, so you must render any 3D effects before you send the sequence to the Media Station XL system.

You can choose to render the effects identified by the Render to Media Station XL command or to modify the selections before submitting them for rendering. For more information, see “Modifying the Render to Media Station XL Results” on page 203.

For a multiple-track sequence, Render to Media Station XL begins analyzing the effects from the top track down. When the Avid application finds an effect that cannot be rendered by Media Station XL, it selects the effect for rendering. Any lower-track effects entirely covered by an upper-track clip that contains a selected effect will not be rendered. If you want to render these effects, deselect the tracks above the track with the effects that you want to render. Then use Render to Media Station XL again.

**To use the Render to Media Station XL command:**

1. Select all tracks in the Timeline that contain effects you want the Render to Media Station XL command to analyze.

2. Do one of the following:
   - To render at position, move the position indicator to the effects in the Timeline.
   - To render between IN and OUT points, mark IN and OUT points around the effects.
Chapter 4  Playing and Rendering Effects

3. Select Clip > Render to Media Station XL.

The Render to Media Station XL dialog box opens.

![Render to Media Station XL dialog box](image)

4. Select one of the following options:

- Entire Sequence — Selects any effects in the sequence that require rendering on the Avid application.

- In/Out — Selects any effects between the IN and OUT points that require rendering on the Avid application. This option is available only when IN and OUT points are marked.

- Position — Selects any effects located at the position indicator that require rendering on the Avid application. This option is not available when IN and OUT points are marked in the sequence.

5. (Option) Select Render AVX Effects if you want your Avid application to render the AVX effects.

6. Click OK.

The Render to Media Station XL command analyzes the selected effects and highlights the effects that require rendering by your Avid application.

The Render Effects for Media Station XL dialog box opens and indicates how many of the effects submitted require rendering.
7. Click the Drive pop-up menu, and select a drive for the rendered media.

The *Effect Source Drive* is the location of the media for the outgoing shot of a transition.

8. Do one of the following:
   - Click OK to render the selected effects that Media Station XL cannot render.
   - Click Modify Selection if you want to modify the set of effects selected to render. For more information, see “Modifying the Render to Media Station XL Results” on page 203.
   - Click Cancel to remove all Render to Media Station XL highlighting and to cancel the Render to Media Station XL process without rendering any effects.

**Modifying the Render to Media Station XL Results**

**To modify the results of a Render to Media Station XL analysis:**

1. Perform the Render to Media Station XL analysis by following steps 1 to 6 in “Rendering Effects for the Media Station XL” on page 201.

2. In the Render Effects for Media Station XL dialog box, click Modify Selection.

3. Shift+click effects in the Timeline to add them or remove them from the set of effects to render.

   Selected effects are highlighted.

4. When you are satisfied with your selection, do the following:
   a. Select Tools > Command Palette.
   b. Click the FX tab.
   c. If Active Palette is not selected (pink), click the Active Palette radio button.
   d. Click the Render Effect button.

   The Render Effect dialog box opens.
5. Click the Drive pop-up menu, and select a drive for the rendered media.

The *Effect Source Drive* is the location of the media for the outgoing shot of a transition.

6. Click OK.

If there is not enough room on the drive, a message box opens.

- Click Stop to stop the rendering process and return to the Render Effects dialog box, and then select another drive before continuing.
- Click Continue to attempt to render the effects anyway, in case there might be enough room on the drive.

The selected effects render.

*To display the estimated rendering time, press the T key on the keyboard. Press the T key again to clear the display. Press the P key to view the percent rendered.*

**Canceling a Render to Media Station XL Command During Modification**

To cancel a Render to Media Station XL command during the modification process, do one of the following:

- Click in the timecode (TC) track to move the position indicator.
- Double-click one of the Segment Mode buttons (the Extract/Splice-in button or the Lift/Overwrite button) below the Timeline.
- Select Clip > Render to Media Station XL, and then click Cancel in the Render to Media Station XL dialog box.

The application removes all Render to Media Station XL highlighting and cancels the Render to Media Station XL process without rendering any effects.
Managing Effect Media Files

The Avid application allows you to view effect media files and select them for deletion. You can quickly find or delete an effect media file from a bin, or you can use the Media tool to view all the files that relate to your project and then select those you want to delete.

For complete information on media management features and on the use of the Media tool, see “Managing Media Files” in the Help.

If you are using your Avid application in an Avid Unity workgroup environment, you can use Avid Unity MediaManager to manage your media. For information on using the MediaManager application, see the Avid Unity MediaManager Setup and User’s Guide.

Understanding Effect Media Files

When you render an effect, the Avid application creates two elements: a rendered effect clip (also known as a precompute clip) and an associated media file. When you create a title or an imported matte key clip, the Avid application creates several elements: an effect clip, a precompute clip, and associated media files.

The Avid application overwrites or automatically deletes a media file from your drive only if you do both of the following:

- Render an effect two or more times with the Render Effect button.
- Close the project before either an Auto Save or a manual save occurs.

In this case, the application automatically saves the last-rendered effect and deletes the earlier, unreferenced versions. This autodeletion applies only to effects rendered since the last time you saved or closed a project.

This prevents you from deleting media that may be necessary to play other versions of the sequence. If you want to remove media files from your drive to save space, you will have to manually delete the files.
Chapter 4  Playing and Rendering Effects

Revealing Effect Media Files

You can reveal the media files that are associated with effect clips (titles and matte keys), rendered effect clips (precompute clips), and motion effects so that they are visible in their folders on the desktop. You can then verify information about the media files, delete them directly from the folder, or perform other standard file management operations.

To reveal effect clip, rendered effect clip, or motion effect media (Windows):

1. (Option) If you want to reveal effect media for rendered effect clips (precompute clips), display those clips in the bin by doing the following:
   a. Select Bin > Set Bin Display.
      The Set Bin Display dialog box opens.
   b. Select Rendered Effects and “Show reference clips,” and then click OK.

      Any rendered effect clips appear in the bin.
2. Select an effect item in the bin.
   In this example, a Title Effect clip is selected.

   ![Effects](image)

   **You can reveal media files for only one item in a bin at a time.**

   The application searches all available drives, opens the folder in Windows Explorer, and highlights a related media file.

   ![OMFI MediaFiles](image)
4. (Option) If more than one media file is associated with the clip, a message box opens prompting you to reveal the next file. Do one of the following:
   ▶ Click OK to reveal the next file.
      If the Explorer window disappears from view, bring it forward by pressing and holding the Alt key and pressing the Tab key until you select the Explorer window containing the OMFI MediaFiles folder information.
   ▶ Click Cancel to end the Reveal File operation.

To reveal effect clip, rendered effect clip, or motion effect media (Macintosh):

1. (Option) If you want to reveal effect media for rendered effect clips (precompute clips), display those clips in the bin by doing the following:
   a. Select Bin > Set Bin Display.
      The Set Bin Display dialog box opens.
   b. Select Rendered Effects and “Show reference clips,” and then click OK.
      Any rendered effect clips appear in the bin.
2. Select an effect item in the bin.
   In this example, a Title Effect clip is selected.

You can reveal media files for only one item in a bin at a time.
Managing Effect Media Files


The application searches all available drives, opens the folder, and highlights related media files.

Deleting Effect Media Files from a Bin

You can use the Delete dialog box to delete effect media files (for titles, matte key clips, and rendered effects) and motion effect media from a bin.

To delete effect media files and motion effect media:

1. (Option) If you want to delete effect media for rendered effect clips (precompute clips), display those clips in the bin by doing the following:
   a. Select Bin > Set Bin Display.
      The Set Bin Display dialog box opens.
   b. Select Rendered Effects and “Show reference clips,” and then click OK.
      Any rendered effect clips appear in the bin.
2. In the bin, select the clip or clips whose media you want to delete.

   In this example, two items are selected: a motion effect and a rolling title.

3. Press the Delete key.

   The Delete dialog box opens.

4. Select the appropriate check boxes for the material you want to delete, and then click OK.

   For example, to delete only effect media files, select “delete n associated media file(s)” beneath each of the appropriate effect clip types and deselect all other check boxes. Make sure that you select only those file types you want to delete.
Chapter 5
Creating and Customizing Motion Effects

This chapter describes how to create and customize effects that alter motion in a clip either by changing a clip’s speed or by creating a Strobe Motion effect.

- Understanding Motion Effects
- Creating Traditional Motion Effects
- Working with the Timewarp Effect
- Creating a Timewarp Effect
- Opening the Motion Effect Editor
- Understanding the Motion Effect Editor Display
- Using the Timewarp Speed Graph
- Using the Timewarp Position Graph
- Setting Up the Motion Effect Editor
- Timewarp Effect Examples
- Working with FluidMotion Timewarp Effects
Understanding Motion Effects

Motion effects can be divided into two main categories:

- **Traditional motion effects.** You create a traditional Freeze Frame, Variable Speed, or Strobe Motion effect by generating a new clip with specific motion characteristics from an original clip that you open in the Source monitor. You then edit the motion effect clip into your sequence.

  For example, if you begin with a 3-second clip and create a Variable Speed motion effect from that clip with the speed set to 50%, the result is a new 6-second clip in which movement takes place at half the speed of the original clip.

  The advantage of traditional motion effects is that they are simple to create. The disadvantage of traditional motion effects is that they limit flexibility when editing and they allow only one speed for the duration of the clip. You cannot change the speed of a Variable Speed effect without creating a new motion effect clip, and you cannot achieve an effect where a clip moves slowly for part of its duration and then suddenly speeds up.

- **Timewarp effects.** You create Timewarp effects by applying the Timewarp effect from the Effect Palette to a clip that you have already edited into a sequence. You modify the effect by using the Motion Effect Editor. You can also promote a traditional motion effect to a Timewarp effect once you have edited it into the sequence.

  With the Timewarp effect, you can use keyframes to make multiple changes to the speed and position of any image in the effect. You can employ several different rates of speed, including reverse speed, in the same clip. You can also freely edit the effect, changing your speed settings as often as you need until you achieve the look you want.

  In a Timewarp effect, the variations in speed are independent of the length of the clip in the sequence, so you can trim the clip without affecting your speed adjustments.

  For more detailed information on Timewarp effects and how they differ from traditional motion effects, see “Working with the Timewarp Effect” on page 228.
Creating Traditional Motion Effects

A motion effect, applied to a clip in the Source monitor, allows you to alter the playback characteristics of the clip. Motion effects include Freeze Frame, Variable Speed (such as slow motion or fast motion), and Strobe Motion effects. You can also combine Variable Speed and Strobe Motion effects in a single clip.

Your Avid application creates a traditional motion effect by creating a new clip in a bin. You then use standard editing techniques to edit the clip into your sequence.

You create a traditional Variable Speed or Strobe Motion effect by using the Motion Effect dialog box.

To open the Motion Effect dialog box:

1. Select Tools > Command Palette.
2. Click the FX tab.
3. If Active Palette is not selected (pink), click the Active Palette radio button.
4. On the Command palette, click the Motion Effect button.

If you map the Motion Effect button from the Command palette to the button palettes on the interface or to the keyboard, it opens the Motion Effect Editor for Timewarp effects. You must use the Motion Effect button on the Command palette (with Active Palette selected) to create traditional Variable Speed or Strobe Motion effects. For information on using the Command palette, see “Activating Commands from the Command Palette” in the Help.
Chapter 5  Creating and Customizing Motion Effects

Playing and Rendering Motion Effects

Some motion effect clips play in real time when edited into a sequence; others must be rendered before they can be played.

Playback capabilities for motion effects depend on the type of effect, the options you select when creating the effect, and how you work with the effect after you first create it.

Rendering Considerations When Creating Motion Effects

When you first create a motion effect that requires rendering, you can either render it immediately or create an unrendered version that you can render later in your workflow.

The Avid application creates traditional motion effects using one of four different types:

• Duplicated Field
• Both Fields
• Interpolated Field
• VTR-Style

Some of these types enable some motion effects to play in real time, while other types always require rendering. You select motion effect types based on the quality you need for the final motion effect, the rendering time that each type requires, and the media with which you are working (some types are useful only when you are working with two-field media).

For more information on motion effect types, including their relative quality and their compatibility with different types of media, see “Motion Effect Parameters” in the Help.

You can preview some kinds of unrendered motion effects in real time even if they require rendering for final playback. The application cannot preview other kinds of unrendered motion effects; these effects will play as filler until they are rendered.
Table 9 provides a summary of playback capabilities for motion effects.

<table>
<thead>
<tr>
<th>Effect</th>
<th>Playback Capability</th>
<th>Preview Capability</th>
</tr>
</thead>
<tbody>
<tr>
<td>Freeze Frame (all types)</td>
<td>Real-time</td>
<td>Real-time</td>
</tr>
<tr>
<td>Variable Speed effects — forward slow motion — created using the Duplicated Field or Both Fields type. (Use a value between 0 and 100 in the % Speed text box of the Motion Effects dialog box.)</td>
<td>Real-time</td>
<td>Real-time</td>
</tr>
<tr>
<td>Variable Speed effects — forward slow motion — created using the Interpolated Field or VTR-Style type. (Use a value between 0 and 100 in the % Speed text box of the Motion Effects dialog box.)</td>
<td>Non-real-time</td>
<td>Play in real time as Duplicated Field motion effects until rendered</td>
</tr>
<tr>
<td>Variable Speed effects — fast motion and reverse motion (all types). (Use a value over 100 or a negative value in the % Speed text box of the Motion Effects dialog box.)</td>
<td>Non-real-time</td>
<td>Play back as filler (black image) until rendered</td>
</tr>
<tr>
<td>Strobe Motion effects (all types)</td>
<td>Non-real-time</td>
<td>Play back as filler (black image) until rendered</td>
</tr>
<tr>
<td>Strobe Motion effects combined with Variable Speed effects (all types)</td>
<td>Non-real-time</td>
<td>Play back as filler (black image) until rendered</td>
</tr>
</tbody>
</table>
Rendering and Rerendering Existing Motion Effects

In certain situations, you might need to render or rerender existing motion effects. To do this, follow one of the procedures described in “Rendering Effects” on page 176.

Information about the type and rendering status of motion effects appears in the Timeline in the same form as that used for other effects. Each motion effect type has a distinct effect icon:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Duplicated Field Motion Effect</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Both Fields Motion Effect</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Interpolated Field Motion Effect</td>
</tr>
<tr>
<td>![Icon]</td>
<td>VTR-Style Motion Effect</td>
</tr>
</tbody>
</table>

Color-coded dots appear on Motion Effect icons to indicate whether they require rendering. The following illustration shows several examples of Motion Effect icons in the Timeline.

![Illustration of Motion Effect icons]

ExpertRender correctly identifies motion effects that require rendering.

When you render existing motion effects, the application checks the Motion Effects Render Using option or the Timewarp Effects Render Using option in the active Render setting. If the option is set to Original
Creating Traditional Motion Effects

Preference (the default setting), the application makes no change to the type of motion effects when it renders them. If the option is set to a specific motion effect type, the application changes all motion effects to that type when it renders them. Using the same type for all motion effects is particularly important for controlling the look of motion effects when you are working with two-field media.

Whenever the application changes the motion effect type during a rendering operation, a message appears in the Console window, providing information about the change. For more information, see “Creating a New Render Setting” on page 178 and “Understanding Motion Effect Type Changes” on page 218.

The following is a list of the circumstances in which you might need to render or rerender motion effects.

- You need to render any motion effect that requires rendering for successful playback if you did not render that effect at the time you created it. This kind of effect appears with a blue dot in the Timeline until it is rendered.

- You might need to render a motion effect so that it will play successfully in a complex sequence even if that effect would not normally require rendering. (Motion effects that display a green dot in the Timeline might not play back in real time under some circumstances.)

For more information on overall real-time playback capabilities, see “Real-Time Effects and Non-Real-Time Effects” on page 33.

- You might need to render or rerender motion effects when you edit them into a sequence and perform trims or apply transition effects. If an effect that was previously rendered (no colored dot in the Timeline) or that previously played in real time (orange dot in the Timeline) changes in such a way that it requires rendering, it will appear with a blue dot in the Timeline. With the Partial Render feature, only those parts of the Motion Effect clip that have been changed by your editing require rendering. Using the Render Ranges command in the Timeline Fast menu, you can see which parts of the motion effect require rendering. For more information, see “Some Considerations When Using ExpertRender” on page 195.
Chapter 5 Creating and Customizing Motion Effects

- You need to rerender motion effects when you recapture media at a different resolution. For example, if you edit a sequence using a single-field resolution and then recapture at a two-field resolution, you will need to rerender all motion effects before they will play back correctly. In this circumstance, it is important to manage the quality of the finished effects using the most appropriate Render Settings options. For more information, see the following section and “Creating and Using Render Settings” on page 178.

Understanding Motion Effect Type Changes

Whenever motion effects in the Timeline are rendered or rerendered, the application uses the Motion Effects Render Using option or the Timewarp Effects Render Using option in the active Render setting to define the motion effect type for the new versions of the motion effects. For example, you might start a project using single-field media and the Duplicated Field type for motion effects. Later, you might recapture the media at a two-field resolution, set the rendering option in the active Render setting to VTR-Style, and submit the whole sequence for rendering. By doing this, you create new motion effects that are higher quality and that can play with the two-field media.

Changes to motion effect types are permanent changes to both the Motion Effect clip and its associated media. You can return to the old motion effect type only by rerendering. To avoid unnecessary rerendering, make sure that the Motion Effects Render Using option and the Timewarp Effects Render Using option in the active Render setting are set to the motion effect type you need.

The application writes a message in the Console window whenever it changes the type of motion effect during rendering. You can check these messages to verify the changes that the application has made to your motion effects. Motion Effect icons in the Timeline also change to reflect the new motion effect type.
Creating Traditional Motion Effects

To display information about motion effect type changes in the Console window:

1. Select Tools > Console.
   
   The Console window opens.

2. Render one or more motion effects, using one of the procedures described in “Rendering Effects” on page 176.
   
   For each motion effect whose type is changed by rendering, a message appears in the Console window.

   The following illustration shows a typical message. In this example, the Motion Effects Render Using option in the active Render setting is set to Interpolated Field.

   ![Console Window](image)

   3. (Option) If the new motion effect type is not the one you want, change the Motion Effects Render Using option in the active Render setting, and then rerender the motion effects.

About Motion Effects in 24p or 25p Projects

Motion effects created in 24p or 25p projects behave somewhat differently from the same effects created in interlaced projects. You should be aware of the following issues when you are working with motion effects in 24p or 25p projects.

- The application always uses complete progressive frames to create 24p or 25p motion effects since there are no fields in 24p or 25p material. There are no two-field rendering options available in the Motion Effect dialog box when you are working in a 24p or 25p project.
• The application creates motion effects by duplicating or eliminating frames to speed up or slow down the motion. Since 24p or 25p motion effects use only 24 frames per second, if you use speed ratios that are not integer values, you might notice minor stuttering due to unusual patterns of duplication. Select simple ratios such as 2:1 (50%), 3:1 (33%), or 4:1 (25%).

• 24p or 25p motion effects might look slightly different from interlaced motion effects because of the way the application handles 24p or 25p material. For more information, see “Working with Effects in 24p or 25p Projects” on page 34.

Freeze Frame Effects

A Freeze Frame effect is a still image, based on a selected frame from a clip, that continues to display for the duration that you select. When combined with the original clip, the footage plays and then “freezes” and holds on the frame that you specified.

You can create a traditional Freeze Frame effect in the Source monitor by selecting Clip > Freeze Frame, or you can use the Timewarp effect to freeze a single frame or create a rolling clip that freezes. See “Speed Graph Example: Creating a Rolling Clip That Freezes” on page 256.

To create a traditional Freeze Frame effect:

1. Load a clip into the Source monitor. For more information, see “Editing in Source/Record Mode” in the Help.
2. Cue the clip to the frame that you want to freeze.
3. Select Clip > Freeze Frame.
   A submenu appears.
4. If you are using two-field or uncompressed media, select an option from the Two Field Freeze Frames submenu:
   - Using Duplicated Field — The application uses a single field to create the effect. While this reduces the vertical resolution of the image by one-half, it is often the best option if the source footage contains rapid motion.
Creating Traditional Motion Effects

- Using Both Fields — The application uses both fields to create the effect. This option is especially useful when there is little or no motion in the footage since it preserves all vertical resolution.

- Using Interpolated Field — The application creates a second field for the effect by combining scan line pairs from the first field in the original media. This might result in a slightly softer look to the freeze frame.

For more information on these options, see “Motion Effect Parameters” in the Help.

The selected option becomes the default until you select another option.

5. Select a duration:
   - Select a preconfigured duration from the list.
   - Select Other and type a custom duration in the dialog box; then click OK to enter the new duration.

A dialog box opens, prompting you to select a target drive for the freeze frame media.

6. Click the Drive pop-up menu, select a drive, and then click OK.

A new clip appears in the Source monitor and in the current bin preceded by a Motion Effect icon. The new clip has the original clip name followed by the letters FF.
Chapter 5  Creating and Customizing Motion Effects

Creating a Rolling Clip That Freezes

One common use for freeze frames is to create a segment that plays normally and then freezes, either to superimpose text information or to add emphasis to the end of a sequence before fading.

The procedure in this section uses a traditional Freeze Frame effect. For an example using the Timewarp effect, see “Speed Graph Example: Creating a Rolling Clip That Freezes” on page 256.

**To create a rolling clip that freezes:**

1. Edit the clip into the sequence.
2. Mark an IN point in the sequence at the frame where you want the freeze frame to occur.
3. Click the Match Frame button to load and cue the source clip to the matching frame.
   
   For more information on matchframing, see “Using Match Frame” in the Help.
4. Create the Freeze Frame effect from the source footage as described in “Freeze Frame Effects” on page 220.
5. Click the Extract/Splice-in button or the Lift/Overwrite button to edit the freeze frame into the sequence at the previously marked IN point.

When you play the sequence, the footage plays full-motion and then freezes at the selected frame.

Creating a Traditional Variable Speed Effect

Variable Speed effects involve changing the rate of playback to achieve fast-motion or slow-motion effects. The Avid application creates slow-motion effects by duplicating frames in the original media. It creates fast-motion effects by eliminating frames from the original media.

For information on using the Timewarp effect to create a Variable Speed effect, see “Using the Timewarp Speed Graph” on page 249 and “Position Graph Example: Reverse Motion” on page 263.
To create a Variable Speed effect:

1. (Option) If you require a fixed duration for the clip based on a segment in the sequence, mark the segment in the Timeline with IN and OUT points.

You can use the Fit to Fill button, on the Edit tab of the Command palette, to create a motion effect of fixed duration. See “Using the Fit to Fill Button” on page 225.

2. (Option) If you want to use only part of the source clip for the motion effect, mark IN and OUT points in the Source monitor.

3. Click in the Source monitor to activate it.

If you do not activate the Source monitor, the Motion Effect dialog box will not open when you click the Motion Effect button.

4. Do the following:
   a. Select Tools > Command Palette.
   b. Click the FX tab.
   c. Select Active Palette.
   d. On the Command palette, click the Motion Effect button.

   If you map the Motion Effect button from the Command palette to the button palettes on the interface or to the keyboard, it opens the Motion Effect Editor for Timewarp effects. You must use the Motion Effect button on the Command palette (with Active Palette selected) to create traditional Variable Speed or Strobe Motion effects. For information on using the Command palette, see “Activating Commands from the Command Palette” in the Help.

   The Motion Effect dialog box opens.

   The selections for Render 2-Field Motion Effect Using are available for two-field media in interlaced projects only. See step 7 and step 8.

5. Select the Variable Speed option.
Chapter 5  Creating and Customizing Motion Effects

6. Specify the play speed for the Variable Speed motion effect in one of the following ways:
   ▶ Type a number of frames in the frames text box.
   ▶ Type a frame rate in the FPS text box. To indicate reverse motion, enter a negative number for the play rate.
   ▶ Type a percentage of the current play rate in the % Speed text box. To indicate reverse motion, enter a negative number for the percentage.
   ▶ Select the Fit To Fill option to automatically set the variable speed parameters so that the duration of the motion effect will match the IN to OUT duration marked in the Record monitor.

When one of these is set, all values change to reflect the specified play rate.

7. (Option) If you are using two-field or uncompressed interlaced media, select one of the Render 2-Field Motion Effect options:
   - Duplicated Field — A single field is displayed in the effect.
   - Both Fields — Both fields are displayed in the effect.
   - Interpolated Field — A second field is created for the effect by combining scan line pairs from the first field in the original media. The interpolation causes a slight softening of the final image.
   - VTR-Style — The Avid application creates a second field for the effect by shifting selected video fields of the original media by a full scan line. This technique is similar to that used by high-quality professional video decks when playing footage at less than normal speed.

For more information on these options, see “Motion Effect Parameters” in the Help.

8. (Option) If you are using two-field media, and a specific motion effect type is set as the Motion Effects Render Using option in the active Render setting, the application automatically selects that type in the Motion Effect dialog box, makes all other types unavailable, and displays the Ignore Render Setting check box. If you want to override the Render setting, select the Ignore Render Setting check box, and then select one of the four options described in step 7.
9. Complete the effect by doing one of the following:
- Click Create to create the new clip and close the dialog box. Another dialog box asks you to select the target bin for the effect.

*If the effect must be rendered, the Create button is unavailable. Click the Create and Render button to create and render the effect.*

- Click Create and Render to render the clip — creating new media files — and close the dialog box. Another dialog box asks you to select the target bin for the effect.

A new clip appears in the Source monitor and in the current bin. The clip has the original clip name followed by the frame rate in parentheses. You can then edit this clip into your sequence as you would any other clip.

**Using the Fit to Fill Button**

The Fit to Fill button, on the Edit tab of the Command palette, performs an overwrite edit and uses a Variable Speed motion effect to fill the marked duration. When you click the Fit to Fill button, the application automatically selects variable speed parameters so that the duration of the motion effect matches the IN to OUT duration marked in the Record monitor. The application then overwrites the motion effect into the sequence.
Chapter 5  Creating and Customizing Motion Effects

The motion effect you create with the Fit to Fill button uses the parameters you set in the Render Settings and Media Creation dialog boxes. If the Render preference is set to Original Preference, the new motion effect is rendered with duplicated fields.

To create an unrendered motion effect, press the Alt key (Windows) or the Option key (Macintosh) when you click the Fit to Fill button.

For more information, see the following topics in the Help:
• Command palette: “Using the Command Palette”
• Overwrite edit: “Performing an Overwrite Edit”
• Media Creation dialog box: “Media Creation Settings”

For information about Render settings, see “Creating and Using Render Settings” on page 178.

Creating a Traditional Strobe Motion Effect

Strobe motion results in a stuttering effect during playback of a clip. You determine the degree of the “stutter” or strobe when you create the effect.

You can also combine the Strobe Motion effect with the Variable Speed effect. For more information on the Variable Speed effect, see “Creating a Traditional Variable Speed Effect” on page 222.

The procedure in this section uses a traditional motion effect. For a procedure using the Timewarp effect, see “Strobe Motion Using the Timewarp Effect” on page 261.

To create a Strobe Motion effect:

1. (Option) If you want to use only part of the source clip for the effect, mark IN and OUT points in the Source monitor.
2. Do the following:
   a. Select Tools > Command Palette.
   b. Click the FX tab.
   c. Select Active Palette.
   d. On the Command palette, click the Motion Effect button.

   The Motion Effect button on the Tool palette and in the Timeline top toolbar opens the Motion Effect Editor for Timewarp effects. If you map the Motion Effect button from the Command palette to another button, it opens the Motion Effect Editor. You must use the Motion Effect button on the Command palette to create traditional Variable Speed or Strobe Motion effects.

   The Motion Effect dialog box opens.

   The selections for Render 2-Field Motion Effect Using are available for two-field media in interlaced projects only. See step 5 and step 6.

3. Select the Strobe Motion option.

4. Specify the update rate in frames for the Strobe Motion effect. For example, a rate of 5 causes every fifth frame to be held for five frames before updating in the Strobe Motion effect.

5. (Option) If you are using two-field or uncompressed interlaced media, select one of the Render 2-Field Motion Effect options:
   - Duplicated Field — A single field is displayed in the effect.
   - Both Fields — Both fields are displayed in the effect.
   - Interpolated Field — A second field is created for the effect by combining scan line pairs from the first field in the original media. The interpolation causes a slight softening of the final image.
   - VTR-Style — The Avid application creates a second field for the effect by shifting selected video fields of the original media by a full scan line. This technique is similar to that used by high-quality professional video decks when playing footage at less than normal speed.
Chapter 5  Creating and Customizing Motion Effects

For more information on these options, see “Motion Effect Parameters” in the Help.

6. (Option) If you are using two-field media, and a specific motion effect type is set as the Motion Effects Render Using option in the active Render setting, the application automatically selects that type in the Motion Effect dialog box, makes all other types unavailable, and displays the Ignore Render Setting check box. If you want to override the Render setting, select the Ignore Render Setting check box, and then select one of the four options described in step 5.

7. Click Create and Render to render the clip and close the dialog box.

You must render a Strobe Motion effect in order to play it back in real time.

A new clip appears in the Source monitor and in the current bin preceded by a Motion Effect icon. The new clip has the original clip name followed by the word Strobe and the number of update frames in parentheses.

Working with the Timewarp Effect

This section introduces the Timewarp effect and the rendering option FluidMotion™. The Timewarp effect not only gives you the ability to create traditional Variable Speed and Freeze Frame effects but also delivers unprecedented control over these and other motion effects.

FluidMotion is a method of interpolating motion in a Timewarp effect. It results in extremely smooth motion. The tools available in FluidMotion Edit allow you to refine the results of rendering effects with FluidMotion.
The Timewarp effect is a powerful tool for creating and customizing motion effects. When you use keyframes with the Timewarp effect, you can control the speed and the position of any image in the effect. For example, you can create a sequence that begins and ends with specific images, and in which the speed of motion changes an arbitrary number of times between the first image and the last.

A significant difference between the Timewarp effect and traditional Avid motion effects is that you apply a Timewarp effect to a sequence in the Record monitor, not to a clip in the Source monitor. With traditional effects, you load a source clip, create a motion effect on that source clip, and then edit the motion effect into the sequence. If you want to change the speed, you must go back to the original clip, make a new motion effect, and then cut the new effect into the sequence.

With traditional motion effects, if you create an effect at 50-percent speed, the clip becomes twice as long. With the Timewarp effect, the duration of the clip in the sequence does not change. You enter Trim mode directly from the Motion Effect Editor to make the clip longer or shorter.

Traditional motion effects display the effect speed in parentheses beside the effect icon in the Timeline. Because the speed in a Timewarp effect is not fixed, a clip with a Timewarp effect does not display the speed.

You create a Timewarp effect by clicking the Timewarp Effect icon in the Effect Palette and dragging it to a sequence. You modify a Timewarp effect from the Motion Effect Editor. To open the Motion Effect Editor, click the Motion Effect button.

The Motion Effect button appears on the Tool palette and in the Timeline top toolbar. You can also map the Motion Effect button from the Command palette to another button or to the keyboard. For more information, see the following topics in the Help: “Using the Tool Palette,” “Displaying the Timeline Top Toolbar,” and “Using the Command Palette.”

You do not have to be in Effect mode to open or use the Motion Effect Editor.
The Timewarp effect, like many other Avid effects, gives you the ability to modify your results in the sequence. You use the Motion Effect Editor instead of the Effect Editor. This allows you to adjust the speed or position of a Timewarp effect without changing the length of the clip in the Timeline. Trim the length of the clip after you modify the effect so the clip ends in the correct place in the resulting sequence.

**Speed and Position**

The Timewarp effect provides two ways to control motion: speed and position. You display the Speed graph and the Position graph in the Motion Effect Editor.

Of the two effect controls, Speed more closely resembles traditional motion effects. You determine how fast you want the clip to play and change the speed accordingly. The Motion Effect Editor displays the speed of the source (input speed) at output time in the Speed graph. You customize the effect by using the Speed graph to add keyframes at specific times and then setting the speed of the effect at that time. For more information, see “Using the Timewarp Speed Graph” on page 249.

Position maps input (source) time to output (effect) time. The Motion Effect Editor displays input time (vertical axis) over output time (horizontal axis) in the Position graph. You use the Position graph if you need a specific frame in the source to be at a specific frame in the effect. For example, in a sports clip, you might want the clip to begin with the striker kicking the ball and end with the goalie catching the ball. You can position everything in between for effect, but you keep these two keyframes fixed. For more information, see “Using the Timewarp Position Graph” on page 252.

The Motion Effect Editor works with one control graph at a time. You can work with either the Speed graph or the Position graph but not both at once. Further, the adjustments you make with one control graph do not alter adjustments made on the other control graph. Activate the graph with which you want to work by selecting it from the Edit Graph pop-up menu. See “Speed Graph Display and Position Graph Display” on page 244.
When you render a Timewarp effect, the Avid application applies only the information from the active graph.

The Avid application stores the keyframe information for both control graphs and maintains the two sets of keyframe information separately. For example, suppose you make adjustments using the Speed graph, switch to working with the Position graph, and then change back to the Speed graph. The application displays and applies all the keyframe information you initially created using the Speed graph. It does not show what you have done with the Position graph but does save the Position graph information so you can return to it if you choose.

While you adjust the active graph, the Motion Effect Editor represents changes in the inactive graph as well. This gives you a visual check in the inactive graph of your modifications to the active graph. You might find this useful, especially when working with the Position graph, to give you an idea of how your position alterations affect the speed of the effect.

**Interpolation Options**

The way the Timewarp effect changes speed or position in a clip is governed by which keyframe interpolation option you select. Keyframe interpolation refers to the method by which the application determines the rate of change and the relative smoothness of change at keyframes. For example, you can create an effect in which all changes occur abruptly, or you can choose to smooth out all changes. For a full explanation of interpolation options, see “Parameter Changes at Keyframes” on page 138.

You select an interpolation option from the Motion Effect Editor Fast menu.

**Rendering Timewarp Effects**

The rendering options for Timewarp effects display different playback characteristics. Duplicated Field, Both Fields, Interpolated Field, and VTR-Style are familiar from other Avid effects. Blended Interpolated,
Blended VTR, and FluidMotion are rendering options for the Timewarp effect. For more information, see “Selecting a Rendering Option” on page 241.

The Blended Interpolated rendering option takes the quality of the Interpolated Field option and combines it with frame blending. In the same way, the Blended VTR rendering option first applies the VTR-Style rendering option and then applies frame blending.

The FluidMotion option uses an interpolation algorithm that creates intermediate images by morphing the motion across the bracketing images. This results in extremely smooth motion. However, it can also cause artifacts (distorted areas) to appear when objects move in front of or behind other objects, move significantly from one frame to the next, or move into the image from outside the frame. FluidMotion Edit provides tools for correcting artifacts. See “Working with FluidMotion Timewarp Effects” on page 266.

Rendering time for a Timewarp effect varies considerably, depending on which rendering option you select. The rendering options are ranked in the following list by length of rendering time, from shortest to longest:

- Duplicated Field
- Both Fields
- Interpolated Field and VTR-Style (approximately the same)
- Blended Interpolated and Blended VTR (approximately the same)
- FluidMotion

To save time while rendering the Timewarp effect, select one of the other rendering options to rough out your sequence and use FluidMotion only when you are satisfied with the overall sequence.
Creating a Timewarp Effect

You create a Timewarp effect by using the Effect Palette or by using the Motion Effect Editor to promote a traditional motion effect. For more information, see “Promoting a Traditional Motion Effect to a Timewarp Effect” on page 233.

Creating a Timewarp Effect from the Effect Palette

To apply a Timewarp effect from the Effect Palette:

1. Create a sequence in the Record monitor by using the standard Avid editing procedures. For information about editing a sequence, see “Editing in Source/Record Mode” in the Help.

2. Enter Effect mode by selecting Toolset > Effects Editing.

3. In the Effect Palette, click the Motion Effect category.

4. Click the Timewarp Effect icon, and drag it to the clip in the Timeline. The Timewarp Effect icon appears in the Timeline.

If you apply the Timewarp effect as part of a nested effect, it must be the outermost effect.

Promoting a Traditional Motion Effect to a Timewarp Effect

If you load a sequence with a traditional motion effect, you can promote the effect to a Timewarp effect by using the Promote button in the Motion Effect Editor. The Promote button appears in the Motion Effect Editor only when you have the position indicator on a traditional motion effect in the Timeline.
Chapter 5  Creating and Customizing Motion Effects

To promote a traditional motion effect to a Timewarp effect:

1. Click the Motion Effect button. For more information, see “Opening the Motion Effect Editor” on page 235.
   The Motion Effect Editor opens.
2. Click the motion effect in the Timeline.
   The Promote button appears in the Motion Effect Editor. The Duration, Speed, and Strobe text boxes for the motion effect appear above the Motion Effect Editor toolbar.
3. In the Motion Effect Editor, click the Promote button.
   The Timewarp icon appears in the Timeline. The Motion Effect Editor uses the duration and speed information from the traditional motion effect to create a Timewarp effect.

Strobe motion information does not carry over to the Timewarp effect.
The name of the clip in the Timeline does not change. The Avid application creates traditional motion effect clips with speed and strobe information in parentheses following the name. For example, a traditional motion effect clip named Turbocharge (15FPS) (Strobe: 5) is a half-speed effect with a strobe every five frames. After you promote the effect to a Timewarp effect, the name remains the same. This can be confusing if you rely on the information in parentheses to accurately reflect the effect’s parameters.

Once you promote the effect, you might not be able to load or use the sequence on an older system. Before promoting any effect, create a copy of the original sequence.

Opening the Motion Effect Editor

You customize a Timewarp effect by using the Motion Effect Editor.

To open the Motion Effect Editor:

- Click the Motion Effect button.

The Motion Effect button appears on the Tool palette and in the Timeline top toolbar. You can also map the Motion Effect button from the Command palette to another button or to the keyboard. For more information, see the following topics in the Help: “Using the Tool Palette,” “Displaying the Timeline Top Toolbar,” and “Using the Command Palette.”

The Motion Effect Editor opens.

The Motion Effect Editor layout and use are described in the following sections.

You do not have to be in Effect mode to use the Motion Effect Editor, and you do not have to close the Motion Effect Editor to use other modes. You can, for example, use the Motion Effect Editor while in Trim mode.

You cannot create a traditional motion effect with the Motion Effect Editor open. To create a traditional motion effect, close the Motion Effect Editor and follow the procedure in “Creating Traditional Motion Effects” on page 213.
Understanding the Motion Effect Editor Display

When you first open the Motion Effect Editor, its appearance depends on whether or not there is no motion effect, a Timewarp effect, or a traditional motion effect in the segment at the position indicator. The following illustration shows three possibilities.
Table 10 describes the components of the Motion Effect Editor display.

### Table 10  Motion Effect Editor Components

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timewarp Effect icon</td>
<td>Click the icon, and drag it to a bin to create a Timewarp Effect template from the current settings in the Speed graph and Position graph.</td>
</tr>
<tr>
<td>Speed Graph display button</td>
<td>Click to open the Speed graph. Click again to close the Speed graph. See “Speed Graph Display and Position Graph Display” on page 244.</td>
</tr>
<tr>
<td>Position Graph display button</td>
<td>Click to open the Position graph. Click again to close the Position graph. See “Speed Graph Display and Position Graph Display” on page 244.</td>
</tr>
<tr>
<td>Promote to Timewarp button</td>
<td>Click to promote a traditional motion effect to a Timewarp effect. See “Promoting a Traditional Motion Effect to a Timewarp Effect” on page 233.</td>
</tr>
<tr>
<td>Formats button</td>
<td>Click to open the Formats dialog box. Select the input format that matches your source format. Select an output format based on the result you want to obtain. For more information, see “Setting Input Format and Output Format Options” on page 240.</td>
</tr>
</tbody>
</table>
### Table 10  Motion Effect Editor Components (Continued)

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit Graph pop-up menu</td>
<td>Click to select a control graph with which to customize the Timewarp effect. You can work with either the Speed graph or the Position graph but not both at once.</td>
</tr>
<tr>
<td>• Speed</td>
<td><strong>The Motion Effect Editor applies information only from the active control graph.</strong></td>
</tr>
<tr>
<td>• Position</td>
<td></td>
</tr>
<tr>
<td>Render Using pop-up menu</td>
<td>Click to select a rendering option. For more information, see “Selecting a Rendering Option” on page 241 and “Rendering Timewarp Effects” on page 231.</td>
</tr>
<tr>
<td>Source Anchor Frame button</td>
<td>Click to set the Source Anchor Frame at the active keyframe. The default Source Anchor Frame is the first frame of the source clip. For more information, see “Using the Source Anchor Frame” on page 251.</td>
</tr>
<tr>
<td>Anchor text box</td>
<td>Displays the source timecode of the Source Anchor Frame. Use the Anchor text box to set the timecode of the Source Anchor Frame for the Timewarp effect. For more information, see “Using the Source Anchor Frame” on page 251.</td>
</tr>
<tr>
<td>Duration display</td>
<td>Displays the duration of the effect. If you change the output duration by manipulating the Speed graph or Position graph, or by trimming the clip in the Timeline, the application reflects the new duration in this display.</td>
</tr>
<tr>
<td>Speed display</td>
<td>Displays the percent speed of the traditional motion effect.</td>
</tr>
<tr>
<td>Strobe n frames text box</td>
<td>Displays the number of frames the Strobe Motion effect holds the image before updating.</td>
</tr>
</tbody>
</table>

**To change the strobe rate of the effect:**

- Type a new strobe rate in the text box and press Enter (Windows) or Return (Macintosh).
Table 11 describes the buttons in the Motion Effect Editor toolbar.

### Table 11  Motion Effect Editor Toolbar Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Render Effect</td>
<td>Renders the Timewarp effect with the selected rendering option.</td>
</tr>
<tr>
<td>Remove Effect</td>
<td>Removes the Timewarp effect.</td>
</tr>
<tr>
<td>Match Frame</td>
<td>Finds and displays the frame in the source material that matches the frame in the Timewarp effect. In the case of an intermediate (interpolated) frame, the application displays the frame closest to the intermediate frame.</td>
</tr>
<tr>
<td>Play Loop</td>
<td>Plays the Timewarp effect in a loop.</td>
</tr>
<tr>
<td>Play</td>
<td>Plays the Timewarp effect from the current position in the effect’s position bar.</td>
</tr>
<tr>
<td>Trim Mode</td>
<td>You can trim out or trim in material while the Motion Effect Editor is active. For more information, see “Working in Trim Mode” in the Help.</td>
</tr>
</tbody>
</table>

**Selecting the Active Control Graph**

You can work with either the Speed graph or the Position graph but not both at once. The Motion Effect Editor applies information only from the active control graph. For more information, see “Speed and Position” on page 230.

**To select the active control graph:**

- Click the Edit Graph pop-up menu, and select Speed or Position.
Setting Input Format and Output Format Options

You can select the format of the rendered Timewarp effect. Your possible output formats depend on your input format. Table 12 describes the output format options for all input formats.

<table>
<thead>
<tr>
<th>Project Type</th>
<th>Input Format</th>
<th>Output Format Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>NTSC</td>
<td>Interlaced</td>
<td>Interlaced</td>
</tr>
<tr>
<td></td>
<td>Progressive</td>
<td>Progressive</td>
</tr>
<tr>
<td></td>
<td>Film With 2:3 Pulldown(^a)</td>
<td>Film With 2:3 Pulldown(^a)</td>
</tr>
<tr>
<td></td>
<td>Film With 2:3 Pulldown(^b)</td>
<td>Progressive</td>
</tr>
<tr>
<td>PAL</td>
<td>Interlaced</td>
<td>Interlaced</td>
</tr>
<tr>
<td></td>
<td>Progressive</td>
<td>Progressive</td>
</tr>
</tbody>
</table>

\( ^a\) The application adds 2:3 pulldown when creating the output.
\( ^b\) The application removes 2:3 pulldown before processing the effect.

To set input format and output format options:

1. In the Motion Effect Editor, click the Formats button. The Formats dialog box opens.
2. Click the Input pop-up menu, and select your input format. See Table 12 for the available options.
3. Click the Output pop-up menu, and select an output format. See Table 12 for the available options.
4. Click OK.
Selecting a Rendering Option

For information on the rendering of Timewarp effects, see “Rendering Timewarp Effects” on page 231.

To select a rendering option:

- Click the Render Using pop-up menu in the Motion Effect Editor, and select an option. See Table 13 for the available options.

If the Render Using pop-up menu is dimmed and the Ignore Render Setting button appears in the Motion Effect Editor, you have made a rendering selection in the Render Setting dialog box. To change the rendering option, click the Ignore Render Setting button, and then select an option from the Render Using pop-up menu. For information about the Render Setting dialog box, see “Creating and Using Render Settings” on page 178.

Table 13 Timewarp Effect Rendering Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicated Field</td>
<td>Displays a single field in the effect. For two-field media, this reduces the information stored by half because it drops one field of the image, resulting in a lower quality image. For single-field media, this is usually the best choice because of its speed. (The other options do not improve effect quality for single-field media.) Timewarp effects created using Duplicated Field render in the shortest amount of time.</td>
</tr>
<tr>
<td>Both Fields</td>
<td>Displays both fields in the effect. For example, the first two frames of a half-speed (50%) slow-motion effect repeat the original Frame 1 (both fields) twice. This option is good for clips without inter-field motion, for NTSC or PAL film-to-tape transfers, and for stills. With footage that includes inter-field motion, this method might result in minor shifting or bumping of the image because it disturbs the original order of fields: a Field 1 appears both before and after the corresponding Field 2. Timewarp effects created using Both Fields render relatively quickly. For best results, use evenly divisible frame rates with this option.</td>
</tr>
</tbody>
</table>
### Table 13  
**Timewarp Effect Rendering Options (Continued)**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interpolated Field</td>
<td>Creates a second field for the effect by combining scan line pairs from the first field in the original media. This option calculates the motion effect at the field level rather than the frame level. Because the application considers all fields and does not disturb the original order of fields, the smoothness of the rendered effect is second only to FluidMotion. This method is best for video-originated material or film-originated material transferred at 24 fps. Timewarp effects created using Interpolated Field or VTR-Style render less quickly than Both Fields but more quickly than Blended Interpolated, Blended VTR, or FluidMotion.</td>
</tr>
<tr>
<td>VTR-Style</td>
<td>Creates a second field for the effect by shifting selected video fields of the original media by a full scan line. This option also creates the motion effect at the field level rather than the frame level, but because pixels are not filtered, the final image is sharper than that created by the Interpolated Field option. The image might display some slight jitter at certain speeds. This technique is similar to that used by high-quality professional video decks when playing footage at less than normal speed. Timewarp effects created using Interpolated Field or VTR-Style render less quickly than Both Fields but more quickly than Blended Interpolated, Blended VTR, or FluidMotion.</td>
</tr>
<tr>
<td>Blended Interpolated</td>
<td>Blends, or averages, pixels from the original frames or fields to create intermediate frames or fields. For example, at 25% speed, the application creates three blended images between outgoing Image A and incoming Image B. The first blended image weights the pixels from Image A at 75% and Image B at 25%. The second blended image weights the pixels from Image A at 50% and Image B at 50%. The third blended image weights the pixels from Image A at 25% and Image B at 75%. Objects in motion from Image A to Image B appear to fade out of Image A and fade in to Image B. Timewarp effects created using Blended Interpolated or Blended VTR render less quickly than Interpolated Field or VTR-Style but more quickly than FluidMotion.</td>
</tr>
</tbody>
</table>
Blended VTR First creates a second field for the effect by shifting selected video fields of the original media by a full scan line. Then blends, or averages, pixels from the original frames or fields to create intermediate frames or fields. For example, at 25% speed, the application creates three blended images between outgoing Image A and incoming Image B. The first blended image weights the pixels from Image A at 75% and Image B at 25%. The second blended image weights the pixels from Image A at 50% and Image B at 50%. The third blended image weights the pixels from Image A at 25% and Image B at 75%. Objects in motion from Image A to Image B appear to fade out of Image A and fade in to Image B.

Timewarp effects created using Blended Interpolated or Blended VTR render less quickly than Interpolated Field or VTR-Style but more quickly than FluidMotion.

FluidMotion Analyzes the motion between outgoing Image A and incoming Image B, and interpolates intermediate frames pixel-by-pixel. The motion generated by FluidMotion is the smoothest of all the rendering options.

Timewarp effects created using FluidMotion are the slowest to render.

---

**When you step through a sequence with a Timewarp effect, the editing application can take a noticeable amount of time to update the Effect Preview monitor. In addition, on a Macintosh system FluidMotion requires significant system resources and rendering times can be very long. For better performance, use Draft Quality while you work on your sequence. For more information see “Controlling Video Quality for Playback” on page 175.**

To save time while rendering the Timewarp effect, select one of the other rendering options to rough out your sequence and use FluidMotion only when you are satisfied with the overall sequence.
Creating and Customizing Motion Effects

Chapter 5

Speed Graph Display and Position Graph Display

When you click the Speed Graph Display button or the Position Graph Display button, the Motion Effect Editor expands and opens the graph you selected. The following illustration shows the fully expanded Motion Effect Editor.

The Motion Effect Editor works with one control graph at a time. You can work with either the Speed graph or the Position graph but not both at once. Select the graph with which you want to work from the Edit Graph pop-up menu.

Displaying a graph does not activate the graph. Use the Edit Graph pop-up menu to select the active graph.

To activate a graph for customizing a Timewarp effect:

- Select one of the following from the Edit Graph pop-up menu:
  - Speed to activate the Speed graph
  - Position to activate the Position graph

The Edit Graph pop-up menu changes to show the active graph. The Fast Menu, Rewind, Fast Forward, and Add Keyframe buttons appear under the active graph. The graph you selected becomes the active graph.
Changing a Graph Display with the Scale Sliders

Directly below each graph are two scale sliders. The left slider of each graph is the Value scale slider. The right slider of each graph is the Position scale slider. Use the sliders to scale the graph view up or down to see more or less detail.

For the Speed graph, the Value scale slider controls the Percent Speed axis. The Position scale slider controls the Output Position axis.

For the Position graph, the Value scale slider controls the Input Position axis. The Position scale slider controls the Output Position axis.

To show more detail in the Percent Speed axis (Speed graph) or the Input Position axis (Position graph):

- Click the Value scale slider for either the Speed graph or the Position graph, and drag it to the right.
  The graph’s vertical view expands to show more detail.
To show less detail in the Percent Speed axis (Speed graph) or the Input Position axis (Position graph):

- Click the Value scale slider for either the Speed graph or the Position graph, and drag it to the left.
  
The graph’s vertical view contracts to show less detail.

To show more detail in the Output Position axis for either graph:

- Click the Position scale slider for either the Speed graph or the Position graph, and drag it to the right.
  
The graph’s horizontal view expands to show more detail.

To show less detail in the Output Position axis for either graph:

- Click the Position scale slider for either the Speed graph or the Position graph, and drag it to the left.
  
The graph’s horizontal view contracts to show less detail.

The darker gray area of a graph represents the valid working area; that is, it depicts the amount of source material you have available. The lighter gray area represents handles before and after the source material.

You can also move the view in the display without scaling.

To move the view in the graph display:

1. Click within the boundaries of the graph display you want to move.
2. Press and hold Ctrl+Alt (Windows) or ⌘+Option (Macintosh).
   
The pointer changes to a hand.
3. Drag the hand in any direction to reposition the view within the graph display.
Motion Effect Editor Fast Menu Commands

The Motion Effect Editor Fast Menu button appears in the toolbar of the active graph and provides keyframe commands and operations.

The same menu appears as the shortcut menu when you right-click (Windows) or Ctrl+Shift+click (Macintosh) the active control graph.

Because the Motion Effect Editor uses advanced keyframes, its Fast menu is similar to the Effect Editor shortcut menu for keyframe graphs. The components of these menus are described in “Shortcut Menus for the Motion Effect Editor and Keyframe Graphs” on page 120.

- Add Keyframe
- Delete Keyframe
- Select All Keyframes
- Align Keyframe
- Slip Keyframes
- Shelf
- Linear
- Spine
- Bezier
- Fixed Keyframes
- Elastic Keyframes
- Reset Graph View

- Commands for adding, moving, and selecting keyframes
- Commands for moving keyframes
- Keyframe interpolation options
- Keyframe trim options
- Resize the graph view after scaling
Chapter 5  Creating and Customizing Motion Effects

Toolbar Buttons for the Active Control Graph

Table 14 describes the buttons that appear in the toolbar below the active control graph.

Table 14   Active Control Graph Toolbar Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fast Menu</td>
<td>Displays the Fast menu. See “Motion Effect Editor Fast Menu Commands” on page 247.</td>
</tr>
<tr>
<td>Rewind</td>
<td>Moves the position indicator one keyframe to the left and activates the keyframe. If there is no keyframe to the left, nothing happens. That is, the position indicator does not move to the beginning of the effect unless you have a keyframe there.</td>
</tr>
<tr>
<td>Fast Forward</td>
<td>Moves the position indicator one keyframe to the right and activates the keyframe. If there is no keyframe to the right, nothing happens. That is, the position indicator does not move to the end of the effect unless you have a keyframe there.</td>
</tr>
<tr>
<td>Add Keyframe</td>
<td>Creates a keyframe at the current position. Alt+click (Windows) or Option+click (Macintosh) this button to delete a keyframe.</td>
</tr>
</tbody>
</table>
Using the Timewarp Speed Graph

The following illustration shows the activated Speed graph.

Table 15 describes the components of the Speed graph.

The Fast menu that appears when you click the Fast Menu button in the Speed graph toolbar is the same as the shortcut menu that appears when you right-click (Windows) or Ctrl+Shift+click (Macintosh) the Speed graph. The menu is described in “Shortcut Menus for the Motion Effect Editor and Keyframe Graphs” on page 120.
### Table 15  Speed Graph Components

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Percent Speed axis</td>
<td>The Percent Speed axis represents the speed of the resulting effect as a percentage of the speed of the source material. The Output Position axis represents the timecode for the resulting effect. For example, if Percent Speed is 200 at an Output Position of 00:00:02:15, then at 2:15 after the start of the effect, the speed of the effect will be twice the speed (200%) of the source material.</td>
</tr>
<tr>
<td>Output Position axis</td>
<td></td>
</tr>
<tr>
<td>Position indicator (blue)</td>
<td>The image that appears in the monitor is the image at this position in the effect. You move the Speed graph position indicator as you would any other position indicator. When you add a keyframe, it appears at the position indicator.</td>
</tr>
<tr>
<td>Green line</td>
<td>Indicates output speed in the effect as a percentage of input speed. The slope of the line tells you how fast and in which direction the speed changes over the course of the effect. You add keyframes to further refine the effect.</td>
</tr>
<tr>
<td>Percent Speed text box</td>
<td>Displays the percent speed at the active keyframe. You change the percent speed by moving keyframes vertically or more precisely by typing a number in the Percent Speed text box.</td>
</tr>
<tr>
<td>Output Position text box</td>
<td>Displays the timecode for the resulting effect at the active keyframe. You can change the output position by Alt+dragging (Windows) or Option+dragging (Macintosh) keyframes horizontally or more precisely by typing a timecode in the Output Position text box.</td>
</tr>
<tr>
<td>Active keyframes</td>
<td>The keyframes to which the application applies any changes you specify. The active keyframe indicators are pink.</td>
</tr>
<tr>
<td>Active control graph toolbar</td>
<td>Appears under the active control graph. See Table 14 on page 248.</td>
</tr>
<tr>
<td>Source Anchor Frame button</td>
<td>Click to anchor the Source Anchor Frame at the current keyframe. For more information, see “Using the Source Anchor Frame” on page 251.</td>
</tr>
<tr>
<td>Anchor text box</td>
<td>Displays the timecode of the Source Anchor Frame. For more information, see “Using the Source Anchor Frame” on page 251.</td>
</tr>
</tbody>
</table>
### Table 15  Speed Graph Components (Continued)

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Anchor Frame indicator</td>
<td>Indicates the point (timecode) in the effect where you have anchored the source. The default Source Anchor Frame is the first frame or field of the source, and the default point for anchoring the Source Anchor Frame is timecode 0; that is, the first frame or field of the effect. For more information, see “Using the Source Anchor Frame” on page 251.</td>
</tr>
<tr>
<td>Value scale slider</td>
<td>Use the scale sliders to scale the Speed graph view up or down to see more or less detail. The Value scale slider controls the Percent Speed axis. The Position scale slider controls the Output Position axis. For more information, see “Changing a Graph Display with the Scale Sliders” on page 245.</td>
</tr>
</tbody>
</table>

### Using the Source Anchor Frame

The Source Anchor Frame is necessary for the application to completely determine the results of Speed graph settings. One point in the source material — the input material for the effect — must map to one point in the effect — the output material. Then the application uses your Speed graph keyframe information to create the Timewarp effect.

The default Source Anchor Frame is the first frame or field of the source, and the default point for anchoring the Source Anchor Frame is timecode 0 — the first frame or field of the effect’s output.

When you select elastic keyframes, the Source Anchor Frame determines which frame remains anchored (stays the same) while the other keyframes stretch or compress. See “Elastic Keyframes and Fixed Keyframes” on page 135.

**To change the Source Anchor Frame:**

- Enter the source timecode of the frame or field you selected in the Anchor text box.
Chapter 5  Creating and Customizing Motion Effects

To anchor the Source Anchor Frame at the active keyframe:

- Click the Source Anchor Frame button.

  The Source Anchor Frame indicator moves to the active keyframe. The output timecode shows above the Record monitor.

To anchor the Source Anchor Frame manually:

- Click the Source Anchor Frame indicator, and drag it in the Output Position axis of the Speed graph.

  The output timecode shows above the Record monitor.

Using the Timewarp Position Graph

The following illustration shows the activated Position graph.
Table 16 describes the components of the Position graph.

The Fast menu that appears when you click the Fast Menu button in the Position graph toolbar is the same as the shortcut menu that appears when you right-click (Windows) or Ctrl+Shift+click (Macintosh) the Position graph. The menu is described in “Shortcut Menus for the Motion Effect Editor and Keyframe Graphs” on page 120.

### Table 16  Position Graph Components

<table>
<thead>
<tr>
<th>Components</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input Position axis</td>
<td>The Input Position axis represents the timecode for the source clip. The Output Position axis represents the relative timecode for the resulting effect. The exact timecode is shown above the Record monitor.</td>
</tr>
<tr>
<td>Output Position axis</td>
<td></td>
</tr>
<tr>
<td>Position indicator (blue)</td>
<td>The image that appears in the monitor is the image at this position in the effect. You move the Position graph position indicator as you would any other position indicator. When you add a keyframe, it appears at the position indicator.</td>
</tr>
<tr>
<td>Green line</td>
<td>A point on the green line indicates the timecode in the source clip relative to the timecode in the resulting effect. The line shows the mapping of source material to the effect. You add keyframes to further refine the effect.</td>
</tr>
<tr>
<td>Input Position text box</td>
<td>Indicates the input position (timecode in the source clip) at the active keyframe. Change the input position by moving keyframes vertically or more precisely by typing a number in the Input Position text box.</td>
</tr>
<tr>
<td>Output Position text box</td>
<td>Indicates the relative timecode for the resulting effect at the active keyframe. Change the output position by Alt+dragging (Windows) or Option+dragging (Macintosh) keyframes horizontally or more precisely by typing a timecode in the Output Position text box.</td>
</tr>
<tr>
<td>Active keyframes</td>
<td>The keyframes to which the application applies any changes you specify. The active keyframes are pink.</td>
</tr>
</tbody>
</table>
Chapter 5  Creating and Customizing Motion Effects

Table 16  Position Graph Components (Continued)

<table>
<thead>
<tr>
<th>Components</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active control graph</td>
<td>The active control graph toolbar appears under the active control graph. See Table 14 on page 248.</td>
</tr>
<tr>
<td>toolbar</td>
<td></td>
</tr>
<tr>
<td>Value scale slider</td>
<td>Use the scale sliders to scale the Position graph view up or down to see more or less detail. The Value scale slider controls the Input Position axis. The Position scale slider controls the Output Position axis. For more information, see “Changing a Graph Display with the Scale Sliders” on page 245.</td>
</tr>
<tr>
<td>Position scale slider</td>
<td></td>
</tr>
</tbody>
</table>

Setting Up the Motion Effect Editor

The following procedure outlines the process for setting up the Motion Effect Editor to customize a Timewarp effect. After you follow the setup, you customize the effect by using either the Speed graph or the Position graph. You can change from one to the other while working.

To set up the Motion Effect Editor for customizing a Timewarp effect:

1. Do one of the following:
   - Apply a Timewarp effect by clicking the Timewarp Effect icon in the Effect Palette and dragging it to the segment in the Timeline where you want to create a Timewarp effect.
   - Move the position indicator to an existing Timewarp effect in the sequence.

2. If the Motion Effect Editor is not already open, click the Motion Effect button. For more information, see “Opening the Motion Effect Editor” on page 235.

   The Motion Effect Editor opens.

3. Do one or both of the following:
   - Click the Speed Graph Display button to open the Speed graph.
     The Speed graph opens, and the Speed Graph Display button changes.
- Click the Position Graph Display button to open the Position graph.

The Position graph opens, and the Position Graph Display button changes.

4. Click the Edit Graph pop-up menu, and select the active control graph. See “Selecting the Active Control Graph” on page 239.

The Active Control Graph toolbar appears below the active control graph.

5. Make input and output format selections required by your project from the Formats dialog box. See “Setting Input Format and Output Format Options” on page 240.

6. Click the Motion Effect Editor Fast Menu button, and select an interpolation option. See “Parameter Changes at Keyframes” on page 138.

7. (Option) If you are using two-field media, and a specific motion effect type is set as the Timewarp Effects Render Using option in the active Render setting, the application automatically selects that type in the Render Using pop-up menu, makes all other types unavailable, and displays the Ignore Render Setting check box. If you want to override the Render setting, select the Ignore Render Setting check box, and then select a new rendering option. For a complete description of rendering options, see “Selecting a Rendering Option” on page 241 and “Rendering Timewarp Effects” on page 231.

8. At this point, you are ready to begin customizing your effect. See “Using the Timewarp Speed Graph” on page 249 and “Using the Timewarp Position Graph” on page 252.

For examples using the Speed graph and the Position graph to create various effects, see “Timewarp Effect Examples” on page 256.
Chapter 5  Creating and Customizing Motion Effects

Timewarp Effect Examples

The examples in this section demonstrate several basic effects you can achieve with the Timewarp effect. You can also use the Timewarp templates that appear in the Motion Effect category as a starting place for familiarizing yourself with the capabilities of the Timewarp effect. See “Motion Effects” in the Help.

Speed Graph Example: Creating a Rolling Clip That Freezes

When you create a traditional Freeze Frame effect, you create a clip of a single frozen image in the Source monitor and edit it into your sequence at the right place. To change the location of the frozen image, you must create a new Freeze Frame clip.

You create a freeze frame with a Timewarp effect by cueing to the image in your sequence that you want to freeze and adding a keyframe to set the speed of the clip to 0% at that point. When you want motion to resume, add a keyframe at that timecode and set the speed of the clip to 100%.

You can easily add multiple freeze frames to a single clip by creating additional pairs of keyframes: one at the beginning of each freeze frame to set the speed to 0%, and one at the end of each freeze frame to return the speed to 100%.

To create a rolling clip that freezes by using the Timewarp effect Speed graph:

1. Apply a Timewarp effect, and set up the Motion Effect Editor by using the procedure in “Setting Up the Motion Effect Editor” on page 254, with the following specifics:
   - Click the Edit Graph pop-up menu, select Speed, and click the Speed Graph Display button to open the Speed graph.
   - Click the Motion Effect Editor Fast Menu button, and select Shelf as the interpolation option. See “Parameter Changes at Keyframes” on page 138.
2. (Option) Click the Position Graph Display button to open the Position graph.

Changes you make to the Speed graph are reflected in the Position graph. Having the Position graph open lets you see how your changes could have been achieved by using the Position graph.

The Position graph opens, and the Position Graph Display button changes.

3. Cue to the image in your sequence where you want the image to freeze.

4. In the toolbar below the Speed graph, click the Add Keyframe button.

A keyframe indicator appears at the position indicator in the Speed graph.

5. Move the position indicator to the timecode at which you want action to resume.

As you drag the position indicator in the Position graph, the output timecode shows in the upper left corner of the Position graph.
6. In the toolbar below the Speed graph, click the Add Keyframe button. A keyframe indicator appears at the position indicator in the Speed graph.

7. Click the middle keyframe indicator to activate it, and set the speed at 0% for this keyframe by doing one of the following:
   - Type 0 in the Percent Speed text box, and press Enter (Windows) or Return (Macintosh).
   - Click the keyframe indicator, and drag it down until it reaches the zero (0) marking on the Percent Speed axis.
You move Timewarp keyframes directly in the same way you move keyframes in keyframe graphs. See “Moving a Keyframe in a Keyframe Graph” on page 131.

Notice the line in the Position graph. At the beginning of the effect, the line shows that input position (timecode in the source) and output position (timecode in the effect) are changing at the same rate.

The effect plays at 100% speed until the freeze frame, and at that point the line becomes flat. For the length of the freeze frame, the line remains flat, because the timecode in the source does not change.

From the end of the freeze frame to the end of the effect, the line again shows that input position and output position are changing at the same rate.

You can become familiar with using the Position graph by experimenting with duplicating the Speed graph freeze frame results with the Position graph as the active control graph.

8. In the Motion Effect Editor toolbar, click the Render Effect button.

9. (Option) In the Motion Effect Editor toolbar, click the Trim Mode button, and trim the effect to achieve the duration you want. See “Working in Trim Mode” in the Help.

10. (Option) Click the Timewarp Effect icon in the Motion Effect Editor, and drag it to a bin to create an effect template with the current parameters.

Speed Graph Variations: Moving Keyframes

By moving the keyframes controlling the starting and ending times of the freeze frame, you can change the time in the clip at which the freeze frame starts or ends, and you can change the length of the freeze.

You move Timewarp keyframes directly in the same way you move keyframes in keyframe graphs. See “Moving a Keyframe in a Keyframe Graph” on page 131.
To change the time at which the freeze frame starts:

1. Click the keyframe indicator at which the freeze frame ends.

2. Shift+click the keyframe indicator at which the freeze frame starts.

3. Do one of the following:
   - Alt+Shift+click (Windows) or Option+Shift+click (Macintosh) the first keyframe indicator, and drag it to its new position.
   - Type a new start timecode in the Output Position text box.

The keyframes move together to the new position.

The freeze frame will now start and end at the new keyframe positions.
To change the length of the freeze frame, without changing the starting time, do one of the following:

- Alt+Shift+click (Windows) or Option+Shift+click (Macintosh) the second keyframe indicator, and drag it to its new position. Dragging to the left shortens the freeze frame; dragging to the right lengthens it.
- Type a new ending timecode in the Output Position text box.

### Strobe Motion Using the Timewarp Effect

Strobe motion is essentially the same for the Timewarp effect as for a traditional motion effect.

**To create a Strobe Motion effect by using the Timewarp effect:**

1. Apply a Timewarp effect, and set up the Motion Effect Editor by using the procedure in “Setting Up the Motion Effect Editor” on page 254.

2. Click the Motion Effect Editor Fast Menu button, and select Shelf as the interpolation option. See “Parameter Changes at Keyframes” on page 138.

3. Type the strobe motion rate in frames in the Strobe Motion Rate text box. For example, a rate of 5 causes every fifth frame to be held for five frames before updating.

4. In the Motion Effect Editor toolbar, click the Render Effect button.

5. View the result. If you want to change the strobe motion rate, repeat steps 3 and 4.

6. (Option) You can combine strobe motion and variable speed in the same Timewarp effect. Set and customize keyframes in either the Speed graph or the Position graph to achieve the result you want.

7. (Option) In the Motion Effect Editor toolbar, click the Trim Mode button, and then trim the effect to achieve the duration you want. See “Working in Trim Mode” in the Help.

8. (Option) In the Motion Effect Editor, click the Timewarp Effect icon, and drag it to a bin to create an effect template with the current parameters.
Chapter 5  Creating and Customizing Motion Effects

Setting Effect Position with the Position Graph

When you use the Position graph to customize a Timewarp effect, you map source material position to output position. That is, any timecode of the source material is mapped to any timecode of the result, within the constraints of the Position graph. The results of the Position graph are reflected in the Speed graph.

To set effect speed with the Position graph:

1. Apply a Timewarp effect, and set up the Motion Effect Editor by using the procedure in “Setting Up the Motion Effect Editor” on page 254, with the following specifics:

   - Click the Edit Graph pop-up menu, select Position, and then click the Position Graph Display button to open the Position graph.

   - Click the Motion Effect Editor Fast menu, and select an interpolation option. See “Parameter Changes at Keyframes” on page 138.

2. (Option) Click the Speed Graph Display button to open the Speed graph.

   Changes you make to the Position graph are reflected in the Speed graph. Having the Speed graph open gives you a visual check on how your changes affect the speed of the result.

   The Speed graph opens, and the Speed Graph Display button changes.

3. Where you want to have a particular part of the source appear at a fixed time in the effect, move the position indicator to that timecode in the Output Position axis, and add a keyframe. Use the procedure outlined in “Adding and Deleting Keyframes in Keyframe Graphs” on page 122.

   A keyframe indicator appears on the green line at the position indicator.

4. Map the source timecode to the output by doing one of the following:

   ▶ Move the keyframe indicator to the point where the input timecode (shown in the Input Position text box) maps to the output timecode (shown in the Record monitor) to achieve the effect you want.
You move Timewarp keyframes directly in the same way you move keyframes in keyframe graphs. See “Moving a Keyframe in a Keyframe Graph” on page 131.

As you drag the keyframe over major position markings, you will notice a detent — a slight “stickiness.” This helps you place keyframes more accurately.

- Type the input timecode in the Input Position text box.

5. Add and customize more keyframes to achieve the effect you want.
   For more detailed information, see “Position Graph Example: Reverse Motion” on page 263.

6. Render and review the effect.

7. (Option) Click the Timewarp Effect icon in the Motion Effect Editor, and drag it to a bin to create an effect template with the current parameters.

**Position Graph Example: Reverse Motion**

While the Motion Effect category contains a Reverse Motion template for the Timewarp effect, setting up reverse motion directly in a clip demonstrates how the Position graph works in this basic effect. You can use the same technique to create reverse motion in part of a clip instead of across the entire clip.

To create reverse motion, you map the end of the source to the beginning of the effect, and the beginning of the source to the end of the effect. You do this by setting new input positions for the first keyframe and the last keyframe, either by dragging the keyframe indicators to their new locations or by typing the input position timecodes for each keyframe.

You move Timewarp keyframes directly in the same way you move keyframes in keyframe graphs. See “Moving a Keyframe in a Keyframe Graph” on page 131.
To create reverse motion in a clip:

1. Apply a Timewarp effect, and set up the Motion Effect Editor by using the procedure in “Setting Up the Motion Effect Editor” on page 254 with the following specifics:

   - Click the Motion Effect Editor Fast Menu button, and select Linear as the interpolation option. See “Parameter Changes at Keyframes” on page 138.

   - (Option) Click the Motion Effect Editor Fast Menu button, and select Bézier. This interpolation option gives ease-in and ease-out to the parameter change at each keyframe. By manipulating the Bézier direction handles, you control the characteristics of the speed change.

   - Click the Edit Graph pop-up menu, and select Position to make the Position graph the active control graph.

The Motion Effect Editor displays the graphs for the unaltered clip. In the Position graph, a straight diagonal line stretches from the first keyframe to the last keyframe. Each frame of the input is the same as each output frame, with no variations in speed. The Input Position timecode is the same as the Output Position timecode at each keyframe.

In the Speed graph, a straight line crosses the graph at 100% speed.
2. Click the first keyframe indicator, and note the starting timecode displayed in the Input Position text box.

3. Click the last keyframe indicator, and note the ending timecode displayed in the Input Position text box.

4. Do one of the following:
   
   ▶ Reverse the starting and ending timecodes by dragging the keyframe indicators:
     
     a. Click the first keyframe indicator, and drag it up the Input Position axis until it is even with the last keyframe indicator.

       As you drag, the Input Position text box changes until it reaches the timecode for the last frame of the source. In the Speed graph, the Percent Speed at the left changes until it reaches 0% — with starting and ending timecodes the same, if you played the effect it would be a freeze frame of the last frame.

     b. Click the last keyframe indicator, and drag it vertically down the graph. Watch the line in the Speed graph change from 0% to –100%. When the line reaches –100%, release the mouse button.

       As you drag, the value in the Input Position text box changes until it reaches the timecode for the first frame of the source.

   ▶ Reverse the starting timecode and ending timecode by entering new Input Position timecodes:
     
     a. Click the first keyframe indicator, and type the original ending timecode in the Input Position text box.

     b. Click the last keyframe indicator, and type the original starting timecode in the Input Position text box.

     In the Position graph, a straight line descends across the graph, mapping the effect’s starting time to the clip’s ending time, and the effect’s ending time to the clip’s starting time, effectively reversing the clip.
Chapter 5  Creating and Customizing Motion Effects

The effect plays back in reverse motion.

5. (Option) Click the Timewarp Effect icon in the Motion Effect Editor, and drag it to a bin to create an effect template with the current parameters.

Working with FluidMotion Timewarp Effects

When you use FluidMotion to render a Timewarp effect, the rendered effect plays very smoothly. FluidMotion uses an interpolation algorithm that creates intermediate images by morphing the motion across the bracketing images. The application examines each pixel in the outgoing image, finds the corresponding pixel in the incoming image, and creates a motion path between the two that it uses to build the intermediate images necessary to fill out the effect.

On a Macintosh system, FluidMotion requires significant system resources and rendering times can be very long. In addition, when you step through a sequence with a Timewarp effect, the editing application can take a noticeable amount of time to update the Effect Preview monitor.

The algorithm FluidMotion uses can introduce artifacts into the effect, particularly when objects move in front of or behind other objects, move significantly between one frame and the next, or move into the image from outside the frame. FluidMotion Edit provides tools to correct artifacts in a Timewarp effect.
In the following example, a table tennis ball crosses a net. Using FluidMotion to render the effect results in one artifact where the ball crosses the net and a second artifact directly above the first at the edge of the table.

By definition, artifacts appear only in images created by the application when you select FluidMotion to render a Timewarp effect. The bracketing images, whether frames or fields of original material, do not have artifacts. You use FluidMotion Edit to make corrections by either incorporating motion information from other parts of the image or clip or directly manipulating the artifact’s motion vectors.

**Opening FluidMotion Edit**

**To open FluidMotion Edit:**

1. In the Motion Effect Editor, click the Render Using pop-up menu, and then select FluidMotion.

   The Edit FluidMotion Vectors button appears in the Motion Effect Editor next to the Render Using pop-up menu.

2. Click the Edit FluidMotion Vectors button.

   If the application was not in Effect mode, it enters Effect mode and the Effect Editor opens.

   FluidMotion Edit appears in the Effect Editor.
Chapter 5  Creating and Customizing Motion Effects

Using the Effect Editor with FluidMotion Edit

For more information on working with the Effect Editor, see “Using the Effect Editor” on page 97.

The following illustration shows the FluidMotion Edit parameters in the Effect Editor.

Making Corrections with FluidMotion Edit

FluidMotion Edit provides a variety of methods for dealing with artifacts. In general, you define a region around an artifact and then modify the way FluidMotion creates new material from the source material within that region. FluidMotion does not alter the way it creates new material outside defined regions.
Displaying Vectors in FluidMotion Edit

FluidMotion Edit uses motion vectors to represent the relative speed and direction of a pixel from the outgoing Image A to the incoming Image B. FluidMotion Edit represents motion vectors as arrows and as colors.

To view vectors as arrows:

- In the Display parameter category, select Show Vectors.

Notice the motion vectors around the rope and the child’s hand. The length of a vector arrow represents the speed at which a pixel moves between Image A and Image B, and the arrow’s orientation shows the direction of motion.
To view vectors as colors:

1. In the Display parameter category, click the Fast Menu button, and select Color Warp 50%.
2. (Option) Deselect Show Vectors to see the color vectors and the underlying image more clearly.

The saturation of a vector color corresponds to speed, and hue corresponds to direction.

*If you are reading a hardcopy version of this document, you might find it useful to view the color images in the Help or in the online version of this document on the online library CD-ROM.*
Defining a Region Around an Artifact

An artifact occurs when the application makes an incorrect estimation about the motion for a region of pixels. To fix an artifact, first define a region and then apply a new motion value to that region.

To define a region for FluidMotion Edit:

1. In the Display parameter category, click the Fast Menu button, and then select Warp 50% or Color Warp 50%.

   Warp 50% shows the image generated by FluidMotion that is halfway between source material Image A and Image B. Color Warp 50% shows the same image, with an overlay of motion vector colors. See “Displaying Vectors in FluidMotion Edit” on page 269.

2. (Option) Select Show Vectors to display the motion vector arrows.

3. Step through your clip until you reach an image in which you want to make a correction.

4. Select a shape from the drawing tools in the Effect Editor, and draw around the region that has the artifact.

   You use the drawing tools in the same way you would for Intraframe editing. You can copy, move, and modify any shape. See Chapter 11.

Use the Feathering and Brush parameters to help define and modify the selected area. You can make these modifications anytime during the correction process.

Applying Corrections to a Region

Correcting an artifact involves changing the motion vectors calculated by FluidMotion to motion vectors that produce no, or minimal, distortion. You can use the following approaches to make corrections:

- Copy the motion vectors from an area of the image that behaves correctly to the defined region, replacing the original motion vectors with the copied motion vectors.

- Copy a correction from one image, and paste it into another to correct multiple artifacts.
Chapter 5  Creating and Customizing Motion Effects

- Inside a defined region, clear the motion vectors that FluidMotion created. You can do this by drawing a region and setting the vectors within the region to zero with the Vector X and Vector Y sliders.
- Use the Mask parameter to prevent black borders around the image from affecting the result. Mask defines a border around the edge of the image, shown by a blue wire frame on the Effect Preview monitor.

FluidMotion Example

This example discusses the typical workflow for working with FluidMotion effects and shows an example of how to correct artifacts in a rendered effect.

FluidMotion Workflow

The typical workflow for using FluidMotion effects is as follows:

1. Use Blended Interpolated to set up the initial motion effect. This allows you to quickly set up the ramp rates and time curves you want. Blended Interpolated is the closest in quality to FluidMotion but takes less time to render. For more information, see “Interpolation Options” on page 231.

2. Render and play the effect. For more information, see Chapter 4.

3. If you want smoother motion, use the Motion Effect Editor to change the effect to FluidMotion.

4. Render the effect, and look for artifacts in the rendered media.

5. Use the Effect Editor and the Effect Preview monitor to step through the effect to the first frame that contains artifacts.

6. Fix the artifacts on that frame, and render the effect again. The application will render just the portion that has changed.

7. Make a determination of whether you need to continue to work on the current frame or move on to the next frame.
Working with FluidMotion Timewarp Effects

8. Each time you fix an artifact, render the effect again. This is often the fastest way to remove all the artifacts.

*By fixing the intermediate frame represented by Warp 50% or Color Warp 50%, you will be fixing all the intermediate frames in the final result between Image A and Image B.*

**FluidMotion Effect and the Timeline**

The application performs motion estimation based on the original source frames. When you use the Effect Editor to edit the motion vectors in a FluidMotion effect, the Timeline changes to a source-frame Timeline. The position indicator under the Record monitor appears green when you are working in a source-frame Timeline.

**Fixing Artifacts**

This example fixes three artifacts in footage that shows a table tennis ball moving across a net from upper right to lower left. The following illustrations show the two images from the source file and the intermediate image created by the FluidMotion effect.

![First source image (Image A) Image created with FluidMotion Second source image (Image B)](image)

Areas with artifacts

The artifacts identified in the illustrations are caused by the ball moving across the net. The following illustrations show the vector information in the image as vector arrows and vector colors. You can see from the vector displays that there is motion across a large portion of the image.
In this example, we will use vector colors to fix the artifacts.

*If you are reading a hardcopy version of this document, you might find it useful to view the color images in the Help or in the online version of this document on the online library CD-ROM.*

You can view artifacts by stepping through the effect while keeping the Display Fast menu in the Effect editor set to Warp 50% or Color Warp 50%. This shows the images created at the halfway point between the source images. To view the corresponding source images, change the Display Fast menu to Image A or Image B.

**Fixing the Artifacts**

In this example, we will fix the artifacts by reducing the amount of motion within the areas where the artifacts occur.

**To fix the artifacts:**

1. In the Effect Editor, click the Fast Menu button in the Mode parameter category, and select Set Vector.
2. Select the Oval tool, and draw ovals around the areas containing the artifacts.
The application automatically sets the Vector X and Vector Y values to 0 within the new objects. This removes all motion information from within the regions. You can see that the artifacts are removed but the image of the ball now appears extended and dimmer than before. This occurs because the application displays a blend of the two original images in the oval region as shown in the following illustrations.

If you played the effect now, the image of the ball over the net would fade out as the image of the ball under the net faded in. The Warp 50% image shows the two images faded at 50%. We need to add motion information back into the image so we can view the moving ball.
3. Turn on the color vector information in the image by doing the following:
   - Click the Fast Menu button in the Display parameter category, and select Color Warp 50%.

The Color Warp 50% display mode shows movement as chroma (color) and direction and hue (color intensity). You can see from the image that there is no motion information within the oval.

If you are reading a hardcopy version of this document, you might find it useful to view the color images in the Help or in the online version of this document on the online library CD-ROM.

You can see that there is some motion along the top of the net, shown as yellow in the image. We will use the eyedropper in the Mode parameter category to copy motion information into the oval.

a. Select the oval shape that you created to make it active.

b. Press and hold the cursor over the Color Preview window of the Effect Editor.

   The cursor changes to an eyedropper.
c. Drag the eyedropper over the top of the net, and view the changes in the Vector X and Vector Y parameter values. You will see that the values change as they move over an area containing motion information.

<table>
<thead>
<tr>
<th>Mode</th>
<th>Set Vector</th>
<th>Object Visible</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vector X</td>
<td>-2.7</td>
<td></td>
</tr>
<tr>
<td>Vector Y</td>
<td>0.0</td>
<td></td>
</tr>
</tbody>
</table>

Vector X and Vector Y sliders

Color Preview window

After releasing the mouse button over the yellow portion of the net (the top of the net to the left of the oval), the application applies the yellow color (and the corresponding motion information) to the oval.

![Before and After Images](image-url)

Now we know that the portion within the oval is no longer completely without motion.

You can use the eyedropper to view Vector X and Vector Y information in the image even if Color Warp 50% is not enabled.
4. Render the effect, and click the Play Loop button to review the rendered effect. For more information, see Chapter 4.

In this example, we would like to put some of the motion information back into the image of the ball. One way to do this is to draw an object around the ball and use the object to cut a hole through the oval that we just created. This hole will reveal the original motion of the ball.

5. Select the Polygon tool, and draw an object around the blurred image of the ball. The following illustrations show the result displayed with Color Warp 50% and Warp 50%.

6. In the Mode parameter category, click the Fast Menu button, and select Erase.

7. Add some feathering to create a smooth transition between the motion within the polygon and the motion in the oval. We used the following feathering values:
   - Bias 92
   - Feathering X 5
   - Feathering Y 5

For more information on feathering and bias, see Chapter 11.
8. Render the effect, and play the resulting media.

The following illustrations show the images before and after removing the artifact.

After you remove the artifact at the Warp 50% position, all intermediate frames between Image A and Image B will reflect the change.
Chapter 6

Creating Layered and Nested Effects

This chapter describes how to apply multilayer effects to your sequence. Layered effects consist of two or more layers of video built up vertically in the Timeline that play back simultaneously with effects such as Picture-in-Picture, Superimpose, or Submaster applied to the tracks. Nested effects consist of one or more effect layers that are contained within another effect on the same video layer. This chapter also explains the Reformat effects, including Pan and Scan, which are applied to a separate layer in the Timeline and which allow you to reformat media to different aspect ratios.

The methods and concepts for creating multilayer effects described in the following sections build on the procedures for creating single-layer effects described in Chapter 2.

- Creating Key Effects
- Working with Imported Graphics and Animation
- Nesting Effects
- Submaster Editing
- Performing a Video Mixdown
Creating Key Effects

Your Avid application supports the following key effects:

- **Chroma Key** — Replaces one part of the video image with another video image based on color.
- **Luma Key** — Replaces one part of the video image with another video image based on luminance (brightness).
- **Matte Key** — Replaces one part of the video image with another video image or graphic based on the location of a high-contrast image known as a matte.

Using the Chroma Key Effect and the RGB Keyer Effect

The Chroma Key effect and the RGB Keyer effect are used most frequently with a foreground image shot in front of a highly saturated color screen that is keyed against a background image. The following sections describe the process of creating these effects.

**Chroma Key Effect**

The Chroma Key effect includes several standard digital video effect (DVE) parameters such as scaling, position, and crop in addition to key control parameters. You can also promote the Chroma Key effect to 3D for additional adjustments to various 3D DVE parameters such as skew, perspective, and spline-based motion.

Use the Chroma Key effect when you want to work in real time, or when you need to adjust various DVE parameters of the foreground chroma key footage.
Creating Key Effects

RGB Keyer Effect

The RGB Keyer effect is a non-real-time plug-in effect that includes additional parameters for fine-tuning the edges of the key and for applying post-key color correction (correction applied to the foreground image without affecting the key itself) to the foreground elements. You cannot promote the RGB Keyer effect to 3D.

Use the RGB Keyer when working with full-screen chroma key footage that does not require DVE parameter adjustments such as repositioning or scaling, or when you need the RGB Keyer’s post-key color correction capabilities to better match the foreground to the background.

Chroma Key effect example

This example shows a Chroma Key effect that has been promoted to 3D and then repositioned with defocus applied to enhance the effect of perspective between foreground and background.

Before

After
Creating a Chroma Key Effect

To create a Chroma Key effect:

1. Create a sequence with two video layers.
2. Edit the background image onto track V1.
3. Edit the foreground image onto track V2.
4. Enter Effect mode by selecting Toolset > Effects Editing.
5. In the Effect Palette, click the Key category.
6. Drag either the RGB Keyer icon or the Chroma Key Effect icon from the Effect Palette to the clip on track V2.

The following example shows the Chroma Key effect applied to V2.

The Avid application adds the Chroma Key effect. Ultimatte® blue is the default key color.
7. Move the position indicator to the segment containing the effect in the Timeline.

The Effect Editor displays parameters for adjusting the effect you applied.

8. Open the Key Color parameter category (RGB Keyer) or the Key parameter category (Chroma Key effect).

For the Chroma Key effect and the RGB Keyer, Ultimatte blue is selected by default. To match the key color more closely to the color of the background screen used in the footage, proceed with step 9.

9. Click the Color Preview window in the Key parameter category to display the Eyedropper icon, and then drag the eyedropper to a representative region of the blue or green background screen in the Record monitor.

The application selects the primary key color, and the key takes effect.
Chapter 6  Creating Layered and Nested Effects

10. Fine-tune the key by enabling additional parameter categories and then adjusting parameters as necessary:
   - For more information on specific parameters, see “Key Control Parameters” in the Help.
   - For more information on using post-key color correction with the RGB Keyer, see “Using Post-Key Color Correction” on page 286.

Using Post-Key Color Correction

You can use the Color Correction parameters in the RGB Keyer effect for post-key color correction of the foreground elements in the key.

Because the foreground and background elements of a chroma key are often shot at different times and locations, post-key color correction is especially useful for maintaining the key while matching the visual characteristics of the foreground elements to the background footage.

To perform post-key color correction:
1. Apply and adjust the RGB Keyer effect as described in “Creating a Chroma Key Effect” on page 284.
2. While in Effect mode, adjust the hue, saturation, and value of the foreground elements by using the Color Correction parameters in the Effect Editor. For more information on the specific parameters, see “Color Correction” in the Help.

Creating a Luma Key Effect

Use a Luma Key effect to replace portions of the foreground video with the background video based on brightness or luminance.

To create a Luma Key effect:
1. Create a sequence with two video layers. For information about creating and editing a sequence, see “Editing in Source/Record Mode” in the Help.
2. Edit the background image onto track V1.
3. Edit the foreground image onto track V2.
Creating Key Effects

For more information, see “Entering Effect Mode” on page 82.

4. Enter Effect mode by selecting Toolset > Effects Editing.

5. In the Effect Palette, click the Key category.

6. Drag the Luma Key Effect icon from the Effect Palette to the segment on track V2.

7. In the Timeline, move the position indicator to the segment with the Luma Key effect.

   The Luma Key parameters appear in the Effect Editor.

8. Use the eyedropper or the Luma Key sliders to select a brightness value in the foreground video.

   The application replaces the corresponding portions of the foreground video with background video. For an example, see “Key: Luma Key” in the Help.

Creating a Matte Key Effect

The Matte Key effect uses three layers of video to create the effect. The bottom layer is the background image, the middle layer is the foreground image, and the top layer contains the matte or alpha channel.

To create a Matte Key effect:

1. Create a sequence with three video layers. For information about editing a sequence, see “Editing in Source/Record Mode” in the Help.

2. Edit the background image onto track V1.

3. Edit the foreground image onto track V2.

4. Load a high-contrast image into the Source monitor, and edit it onto track V3. For more information, see “Editing in Source/Record Mode” in the Help.

   The high-contrast image can be an imported graphic or a clip that you adjust within the application.

   If the image is not high enough in contrast, you can adjust the contrast by applying the Color Effect, and then adjusting its parameters in Effect mode. For more information, see “Using the Color Effect to Prepare a High-Contrast Image” on page 290.
5. Enter Effect mode by selecting Toolset > Effects Editing.
6. In the Effect Palette, click the Key category.
7. Apply the Matte Key effect as follows:
   - If your high-contrast image was created with the Color Effect, press and hold the Alt key (Windows) or Option key (Macintosh) and drag the Matte Key Effect icon from the Effect Palette onto the segment on track V3 to nest the Color Effect within the Matte Key effect.
   - If your high-contrast image on track V3 does not include a Color Effect, drag the Matte Key Effect icon from the Effect Palette onto the segment on track V3.
8. Click the Record Track Monitor button for track V3 in the Track Selector panel. You should see tracks V2 and V1 through the high-contrast image on track V3.
9. Move the position indicator to the Matte Key effect, and render the effect. For more information, see “Rendering Effects” on page 176.

For an example of a Matte Key effect, see “Using Matte Keys with 3D Effects” on page 351 and “Key: Matte Key” in the Help.

**Real-Time Moving Mattes**

If you import a moving matte as a 32-bit QuickTime® file or a graphic sequence, the application handles the effect in real time. The basic procedure for importing a moving matte is described in “Importing Files” in the Help.

The application treats a QuickTime file with embedded alpha as a moving matte if it has more than one frame.

**To import a QuickTime file as a moving matte:**
1. Click the Image tab of the Import Settings dialog box.
2. In the Alpha parameter category, select either Use Existing or Invert Existing.
To import a graphics sequence as a moving matte:

1. Select the first file in the sequence as the file to import.
2. In the Image tab of the Import Settings dialog box, select Autodetect Sequential Files.

   The application uses all the files in the sequence to make the moving matte. If you import only one graphic file with alpha, it becomes a static matte.

The application creates a real-time Matte Key effect with nested alpha and video fill. To preserve real-time performance, the application locks the alpha track so that you cannot replace it.

These guidelines apply to editing with real-time moving mattes:

- You can promote a real-time Matte Key effect to a 3D Warp effect, and use the 3D manipulation parameters.
- If the Matte Key effect is not on the top video track of a multilayered composite, it must be rendered before it will play in real time.
- If you add a motion effect to the matte and foreground, the effect will not play in real time until you render the motion effect.
- Real-time moving mattes cannot be combined with real-time titles without rendering the effect.
- Moving mattes in a 24p or 25p project play in real-time in their native format only. You must render moving mattes in order to output the sequence in alternate formats when using the Digital Cut tool. For example, a moving matte imported into a 24p NTSC project will not play back to the PAL format on output unless you render it first.
Chapter 6  Creating Layered and Nested Effects

Using the Color Effect to Prepare a High-Contrast Image

This section describes how to enhance high-contrast images for use in creating Matte Key effects.

To create a high-contrast image from available footage:

1. Apply the Color Effect to the clip. For more information, see “Applying Effects to a Sequence” on page 56.
2. Enter Effect mode by selecting Toolset > Effects Editing.
3. Change the Luma Range to 0 to 255.
4. Drag the Sat (saturation) slider under Chroma Adjust all the way down to remove all color saturation from the image.
5. Adjust the Gamma to change the color of the midtones; this is the only nonlinear function in the Color Effect.

The high-contrast image can now be used as a matte for the key effect, as described in “Creating a Matte Key Effect” on page 287.

Black portions of the high-contrast image will be transparent and white portions will be opaque. To switch the order, use the Reverse option in the Foreground parameter category of the Matte Key effect.

You can also import a graphic image with an alpha channel and use it as a Matte Key effect. See “Editing with Imported Matte Key Clips” on page 291.

Working with Imported Graphics and Animation

This section describes two different approaches to editing with imported graphic images, depending upon whether:

- The image was imported as a master clip with no alpha channel (an opaque graphic element).
- The image was imported as a Matte Key clip with an alpha channel (a keyable graphic element for video overlay).
Working with Imported Graphics and Animation

These alternatives apply to both single-frame graphic images and animation. In addition, you can edit imported images into sequences by using standard Avid application effects. These topics are described in this section.

*(Windows only)* AVI files cannot be imported with an alpha channel. To import animation with an alpha channel, you must use another supported format. For more information on importing graphic and animation clips, see “Importing Files” in the Help.

Editing with Imported Matte Key Clips

When an imported clip includes an alpha channel for keying the graphic over video, it appears in the bin with a Key Effect icon.

Both single-frame graphic images (such as a single JPEG file) and multiple-frame animation sequences (such as a JPEG file sequence) appear in the bin in the same form after import, and you use the same editing techniques for both. You can edit this type of clip into a sequence as a standard matte key overlay.

*Only single-frame files can be used as real-time keyed graphics. PICT sequences, QuickTime files, PICS animation files, and ERIMovie files cannot be used as real-time keyed graphics.*

To edit a Matte Key clip into the sequence:

1. Edit the main video sequence.
2. Add a new track above the tracks in the sequence by selecting Clip > New Video Track.
You must edit Matte Key clips onto an upper track to achieve the keying effect. If you edit a Matte Key clip onto track V1, for example, the image is keyed over black unless track V1 contains nested tracks.

3. Play the sequence, and mark an IN point and an OUT point where you want to overlay the graphic.

4. Load a Matte Key clip into the Source monitor. Mark an IN point toward the center of the clip if it is a still. For more information, see “Editing in Source/Record Mode” in the Help.

5. In the Track Selector panel, click the V1 Source Track button and drag it to the Record Track button for the new track to patch the video from track V1 of the Source monitor to the track in the sequence that will receive the Matte Key clip.

6. Click the Lift/Overwrite button to edit the matte key into the sequence. The application keys the graphic over the video on the lower tracks.

In the following example, the graphic appears on track V3 above the main video sequence edited onto tracks V1 and V2.
7. Adjust effect parameters in the Effect Editor, if necessary, using procedures described in “Using the Effect Editor” on page 97.

If the keyed portions of the images are the reverse of the intended effect, open the Foreground parameter category and click the Invert button. For more information, see “Foreground” in the Help.

8. Use standard effect editing procedures to preview, render, or play the Matte Key clip.

To see the complete effect, make sure the Record Track Monitor button for the topmost track is selected in the Track Selector panel.

Editing with Imported Master Clips

When an imported clip does not include an alpha channel for keying the graphic over video, its icon is the standard Master Clip icon. This is true for both single-image graphics and animation sequences. You can edit this type of clip into a sequence as an opaque image or animation (in other words, as a single layer) using basic editing techniques described in this section.

To edit an imported master clip into the sequence:

1. Load a graphic clip into the Source monitor, and load a sequence into the Record monitor.

2. In the Source monitor, mark an IN point at the start of the clip and mark an OUT point to specify the duration of the graphic.

3. In the Record monitor, mark an IN point where you want to edit the graphic clip into the sequence.

4. Click the Source Track and Record Track buttons.

5. Click the Extract/Splice-in button or the Lift/Overwrite button to add the opaque graphic to the sequence.

The opaque image appears in the sequence. In the Timeline, the graphic looks like a standard video clip edited into the sequence.

6. Play the clip by using the standard playback procedures. For more information, see Chapter 4.
Nesting Effects

You can place effect tracks inside one another to better combine multiple images and digital video effects (DVEs). This involves a process known as nesting, which allows you to use the Timeline to step into a track, to perform a series of editing operations, and then to step out to view and render the effect as one segment on the track.

You can edit up to 24 video track layers. Into each layer of video, you can additionally nest (stack inside) up to 24 more video tracks. You can step into each video track indefinitely, constrained only by your Avid system’s memory.

Nested effects must be rendered to play back correctly.

You can use nesting when you want to create layered effects. In this case, the nested layers are treated as one element during the transition. Since transition effects, such as dissolves, fades, and wipes, are not multilayered, nesting is not applicable to these types of effects; nor are nesting effects applicable to audio tracks.

Some effects do not work well with each other when nested. For example, the Box Wipe effect and Edge Wipe effect cannot be used together in a nested segment because the two effects are competing to establish the shape of the wipe.
Another use of nesting is to constrain one effect using another effect. For example, you can use the Circle Shape Wipe effect to constrain an image posterization inside a region.

Using advanced keyframes, you can change the order of nested effects by manipulating the Nesting Priority icons that appear in the Effect Editor. See “Changing the Order of Nested Effects” on page 298.

Nested effects do not appear in edit decision lists (EDLs) because they are not supported by linear tape-based edit controllers.

Stepping Into and Out of Nested Effects

You can step into an existing nested effect for editing. When you step into the effect, the full sequence in the Timeline is replaced with just the tracks that make up the nested effect. You can then add new tracks, monitor individual tracks, edit source material into the tracks, apply effects, and adjust effects on the nested tracks. You can step into any segment effect in this way.

You can also expand nested effects while leaving the rest of the sequence visible in the Timeline. See “Expanding Nested Effects in the Timeline” on page 295.

To step into a nested effect:

- In the Timeline toolbar, click the Step In button.

To step out of a nested effect, do one of the following:

- In the Timeline toolbar, click the Step Out button.
- Double-click the effect’s icon in the Timeline.

Expanding Nested Effects in the Timeline

You can expand an existing nested effect for editing within the Timeline. You can then add new tracks, edit source material into the tracks, apply effects, and adjust effects on the nested tracks. Any segment with a segment effect applied can be expanded in this way.
You cannot monitor individual tracks when you expand nested tracks in the Timeline. To monitor individual tracks within a nested effect, see “Stepping Into and Out of Nested Effects” on page 295.

To expand a nested effect, do one of the following:

- In Effect mode, double-click a nested effect to expand the effect within the Timeline.
- In Source/Record mode, click either the Extract/Splice-in button or the Lift/Overwrite button, and then double-click the nested effect.

The nested tracks appear in the Timeline above the track you double-clicked. Editing and patching features are available for changing the content of the track’s effect.

When you expand a nested effect, a number appears with the letter N in the Timecode button. This number represents the level of nesting that you are currently in. For example, N2 indicates that you are two levels in from the outermost track level.

Creating a Simple Nested Effect

This example involves nesting a sequence of clips with dissolves inside another segment effect.

To create the nest:

1. Create a sequence, and add a segment effect. For information about editing a sequence, see “Editing in Source/Record Mode” in the Help.

2. Click either the Extract/Splice-in button or the Lift/Overwrite button, and then double-click the segment.
The segment opens to reveal the nested tracks.

3. Edit new footage into the nested tracks, and apply additional effects as necessary.

In this example, a series of clips is edited onto nested track 1.2, with dissolves applied between the shots. The 3D Picture-in-Picture effect applies to the entire nested dissolve sequence.

4. Double-click the main track for the nested effect (V2 in this example) to close the nested tracks again.
Chapter 6  Creating Layered and Nested Effects

Changing the Order of Nested Effects

When you use advanced keyframes with nested effects, you can change the order of nested effects by manipulating the Nesting Priority icons that appear in the Effect Editor.

If the effect you are editing has nested tracks, the effect icon and the name of nested effects appear at the bottom of the Effect Editor. A Nesting Priority icon appears in line with each effect name. Click this icon, and drag it to a new position to reorder the effects.

To change the order of nested effects:

1. Click the Nesting Priority icon of the effect you want to move, and hold down the mouse button.
   
   The pointer changes to a hand and a white outline appears around the selected effect.

2. Drag the outline above the effect you want to have nested inside the selected effect or below the effect inside which you want the selected effect to nest.
3. Release the mouse button.

The effects move to their new locations, and the Effect Editor display changes to reflect the new nesting.

Note the following considerations about the display and manipulation of nested effects:

- You can change the nesting order only when the nested effects have the same number of internal tracks.
- The Effect Editor does not display layered components of a nested effect.
- If there is no effect on the foreground track (for example, V1.2), then the Effect Editor looks for a nested effect on the next track stepping in (V1.3, V1.4, and so forth). The Effect Editor identifies the first track with an effect as the foreground track. Effects on subsequent tracks are identified as part of the nested effect.
- The Effect Editor does not display nested effects when the foreground track has an add edit.

**Nesting a Matte Key Effect**

A Matte Key effect uses three layers of video to create the effect.

**To nest a Matte Key effect:**

1. Create a sequence with the background video on track V1. For more information about editing a sequence, see “Editing in Source/Record Mode” in the Help.

2. Load a high-contrast image into the Source monitor, and edit it onto track V2.

   For an example of a high-contrast image, see “Key: Matte Key” in the Help.
3. Enter Effect mode by selecting Toolset > Effects Editing.

4. In the Effect Palette, click the Key category.

5. Drag the Matte Key Effect icon from the Effect Palette to the segment on track V2.

6. Click one of the Segment Mode buttons (the Extract/Splice-in button or the Lift/Overwrite button) below the Timeline.

7. Double-click the Matte Key Effect icon in the segment. The Timeline expands to display three nested tracks (1.1, 1.2, and 1.3).

By default, nested track 1.3 contains the same image segment as track V2. Nested track 1.2 is empty (foreground filler track). Nested track 1.1 (background video) is also empty.

8. Deselect the Segment Mode button so you can edit the tracks.

9. Edit the foreground image onto nested track 1.1.
10. Click one of the Segment Mode buttons, and double-click track V2 to collapse the nested tracks.

11. Click the Record Track Monitor button for track V2 in the Track Selector panel. You should see tracks V1 and nested track 1.1 through the high-contrast image on track 1.3.

For an example of a Matte Key effect, see “Key: Matte Key” in the Help.

**Submaster Editing**

The Submaster effect is in the Image category of the Effect Palette. It is a single-track segment effect. When you render the Submaster effect, the application creates a single media file from several clips or effects in a sequence.

When you render, the application saves the new Submaster clip to the drive as a single media file. However, each element that makes up the composite is left untouched so you can still manipulate any element.

The Submaster effect is useful when you want to play back bandwidth-limited sequences, such as sequences composed of several seconds of single-frame clips. It is much faster to use the Submaster effect than to use methods such as applying a graphic, or using a Picture-in-Picture, Mask, or Resize effect. Normally, Submaster effects render at about the same rate as motion effects.
You can nest up to 24 tracks inside a Submaster effect depending on your Avid application.

An EDL for a sequence that contains a Submaster effect represents the contents of the Submaster effect as a single cut. To work around this, you can create a new sequence with the contents of the Submaster effect and generate a separate EDL for that sequence.

**Applying the Submaster Effect to a Multilayered Sequence**

You can use the Submaster effect to speed the rendering process by applying it to a track above layered or nested effects and then rendering only the Submaster. The application renders the composite result of all tracks into the top track.

The Submaster effect maintains links to the original media files, so you should not delete the original media files. If you want to combine tracks to create a sequence that is independent from the original media files, perform a video mixdown. See “Performing a Video Mixdown” on page 306.

The Submaster effect does not render each track separately, so you cannot play each track individually, and the blue dot remains in the effect icon. In addition, if you delete or modify a track below a Submaster effect, the Submaster effect becomes unrendered.

**To apply the Submaster effect to a multilayered sequence:**

1. Select Clip > New Video Track.

2. On the new video track (V5 in this example), create one add edit before and another after the group of clips to be submastered.
3. Enter Effect mode by selecting Toolset > Effects Editing.
4. In the Effect Palette, click the Image category.
5. Drag the Submaster Effect icon to the space between the add edits you added on the new track (V5 in this example).

The application applies the effect above the layers.

6. Render the Submaster effect, as described in “Rendering Effects” on page 176.
Using the Submaster Effect with a Series of Short Clips

The Submaster effect is useful when you want to play back bandwidth-limited sequences, such as a sequence composed of a series of short clips (a few frames each). You can apply and render the Submaster effect above the clips to improve playback.

**To apply the Submaster effect to multiple clips:**

1. Select Clip > New Video Track.
2. On the new video track, create one add edit before and another after the group of clips.
3. Enter Effect mode by selecting Toolset > Effects Editing.
4. In the Effect Palette, click the Image category.
5. Drag the Submaster Effect icon to the space between the add edits you added on the new track.

6. Render the Submaster effect.

*If you alter or move either the Submaster segment or the clips below it, the effect becomes unrendered. You must render it again.*

Collapsing Layers into One Submaster Effect

You can use the Collapse feature to build a multilayer effect and then nest the effect within a single Submaster effect in one step. To use this feature, map the Collapse button from the Command palette to your keyboard or a user-selectable palette. For more information, see “Using the Command Palette” in the Help.
The Collapse feature allows you to build your effect at the topmost level and when you are finished, collapse the layers automatically into one Submaster effect. This feature is useful for simplifying a sequence with complex compositing. Once you have collapsed a complex composite, you can easily add transition effects to the start and end of the newly created Submaster composite effect.

You can also use the Collapse feature to simplify the deletion of multilayer segment effects. After collapsing the effects, you can select the resulting segment and press the Delete key twice to delete the effect and all the layers.

After the application collapses the tracks into a Submaster effect, it recognizes a Submaster effect as a multilayer effect instead of a single-layer effect. This allows you to add chroma keys and other multilayer effects to the nested tracks within a Submaster effect.

You can drag “two-channel” effects (such as chroma key) onto Submaster effects if the Submaster segment contains two or more nested tracks. This is useful after performing a Collapse operation to composite the newly created Submaster effect over another background.

To collapse layers into a submaster effect:
1. Select all the tracks you want to collapse. The tracks must be adjacent.
2. Mark an IN point and an OUT point around the area to be collapsed.
3. In the Timeline toolbar, click the Collapse button. For more information, see “Displaying the Timeline Top Toolbar” in the Help.

The application collapses the tracks into a Submaster effect on a single track.

To open the nested tracks again:
1. Click either the Extract/Splice-in button or the Lift/Overwrite button below the Timeline.
2. Double-click the Submaster effect.
The following procedure explains an alternative way to use the Collapse feature:

1. Click either the Extract/Splice-in button or the Lift/Overwrite button below the Timeline.
2. Select the segments you want to collapse.
3. Click the Collapse button.

Performing a Video Mixdown

Video mixdown allows you to combine several tracks into a new master clip. You can use video mixdown after you have finished building your sequence and want to make it into one piece (for example, a standard opening to a program). It can be useful for a complex sequence you need to use repeatedly or if you want to add a motion effect to an entire sequence.

Video mixdown is similar to the Collapse feature; the difference is the end result.

- With the Collapse feature, you collapse the tracks into a Submaster effect. After you collapse the tracks, you are still able to step in to the Submaster effect and work on the individual elements.
- With video mixdown, your end result is a new master clip made up of all the tracks you built on different layers. Those tracks become one clip; you cannot separate the tracks to work on them or step in to the sequence.

You cannot generate an EDL for a sequence that contains a video mixdown. To work around this, you can either remove the video mixdown or maintain a version of the sequence that does not contain a video mixdown.
To perform a video mixdown:

1. Select the Record Track Monitor button in the Track Selector panel for the highest track you want to include in the video mixdown.

   *Video Mixdown collapses the selected track and all tracks under it. If you want to perform a video mixdown of only one track, select the track for solo monitoring: Ctrl+click (Windows) or Shift+click (Macintosh) the Record Track Monitor button. See “Monitoring a Solo Track” in the Help.*

2. Mark an IN point and an OUT point around the area to mix down.

3. Select Special > Video Mixdown.

   The Video Mixdown dialog box opens.

4. Select a target bin and target drive for storing the new master clip, and then click OK.

   A progress indicator appears. When the video mixdown finishes, a new clip appears in the bin along with the sequence, and the application creates a new media file on the target drive.
This chapter describes effects that control aspect ratio, format, or apparent camera motion in a clip.

The Region Stabilize effect allows you to stabilize a clip that exhibits unwanted motion such as motion caused by an unstable camera.

The Reformat effects, including Pan and Scan, allow you to reformat media to different aspect ratios.

The Pan and Zoom effect allows you to import a high-resolution still image and then pan and zoom around that image with extensive keyframe control over the apparent camera motion.

The following topics are covered in this chapter:

- Using the Region Stabilize Effect
- Using the Reformat Effects
- Working with the Pan and Scan Effect
- Using Avid Pan & Zoom
Using the Region Stabilize Effect

The Region Stabilize plug-in effect, in the Image category of the Effect Palette, defines and tracks an area of an image to eliminate unwanted motion in a clip, such as motion from an unstable camera.

Stabilizing an Image

Region Stabilize allows you to select an area of the image that you want to remain stationary and then uses the information to reposition each frame in the clip to keep the region steady.

Stabilization exposes black around the edges of the repositioned frames. You can resize (and, if necessary, reposition) the rendered clip to remove the exposed edges. Auto Zoom, in the Options parameter category, does this automatically.

The following illustration shows the Region Stabilize parameters.

To stabilize a clip:

1. Enter Effect mode by selecting Toolset > Effects Editing. The Effects Editing toolset appears.
2. In the Effect Palette, click the Image category.
3. Drag the Region Stabilize Effect icon to the segment you want to stabilize. Move the effect position bar to the segment with the Region Stabilize effect.
A wire frame appears in the Effect Preview monitor to indicate the region of interest. This is the area you want to use in stabilizing the image.

4. Reposition and resize the wire frame by doing one of the following:
   - Use the sliders in the Region of Interest parameter category.
   - Click the wire frame, and drag it in the Effect Preview monitor.

   Select a region that contains one or more features that do not change much from frame to frame, for example, objects such as buildings or rocks. Another approach is to shoot the scene with stabilization in mind: include an object, such as a reflective sticker, that you intend to use as your region of interest.

5. Click the Model Fast Menu button, and select the type of stabilization:
   - **Translational** keeps the region of interest steady along both the horizontal and the vertical axes.
   - **Horizontal** constrains horizontal motion in the region of interest. Features in the region of interest can move vertically but not horizontally.
   - **Vertical** constrains vertical motion in the region of interest. Features in the region of interest can move horizontally but not vertically.
6. (Option) Turn on Auto Zoom:
   a. Click the triangular opener for the Options parameter category.
   b. Select Auto Zoom.

   Stabilization exposes black around the edges of the repositioned frames. Auto Zoom compensates by resizing and, if necessary, repositioning the clip to remove the exposed edges.

7. (Option) Select Progressive Source:
   a. Click the triangular opener for the Options parameter category.
   b. Select Progressive Source.

   Select Progressive Source if your footage was captured or converted to progressive footage (not interlaced). If your sources are progressive, selecting Progressive Source produces smoother results.

   \[\text{Progressive Source has no effect in 24p projects because the application assumes that you are using progressive footage.}\]

8. Render and review the effect.
   If the rendered clip does not perform as expected, see “Making Adjustments to the Region of Interest” on page 313.

9. (Option) Add keyframes to further refine the motion of the stabilized clip.

10. Continue to review and refine the effect until you achieve the results you want.

11. (Option) Resize and, if necessary, reposition the clip to eliminate black edges.
Making Adjustments to the Region of Interest

If the Region Stabilize effect does not perform as expected, it might be due to one of the following:

- **Large motion.** If an object in your region of interest moves too far away from the region from one frame to the next, the rendered clip might display unexpected results.

- **Extraneous motion.** An object in your region of interest might move over the course of the clip in a way that unpredictably affects the stabilization.

- **Insufficient texture.** The region of interest might not have enough features to allow Region Stabilize to track it effectively.

If the Region Stabilize effect does not perform as expected, experiment with the following adjustments:

- Increase the size of the region of interest, or reposition it, to encompass large motion.

- Decrease the size of the region of interest to eliminate extraneous motion that is affecting the stabilization.

- Select a new region of interest.

- Add keyframes to reestablish or refine the region of interest over the course of the clip.
Chapter 7  Working with Camera Effects

Using the Reformat Effects

The Reformat category contains effects for conforming media of different aspect ratios. One of these effects, Pan and Scan, usually works as a vertical effect that you apply to a layer above the rest of your video material and that affects all the video material beneath it. For more information, see “Understanding the Pan and Scan Effect” on page 316.

Reformat effects allow you to reformat media to different aspect ratios, for example, when you need to reformat a film aspect ratio for television programming.

Reformat works on all tracks below the track to which you apply it. For example, if you apply Reformat above a title track, the titles become reformatted as well. If you don’t want to reformat the titles, apply Reformat below the title track.

The Reformat category contains three effects, other than Pan and Scan, that reformat media to new aspect ratios:

• 16:9 Letterbox — Scales the image vertically to the 16:9 aspect ratio within a 4:3 frame; works on 16:9 Anamorphic media.
Working with the Pan and Scan Effect

- **14:9 Letterbox** — Reformats media to the 14:9 Letterbox aspect ratio with a black band at the top and bottom. First the application expands the media horizontally by a fixed amount before scaling it down vertically, resulting in a slight horizontal cropping of the image. You control what part of the image is cropped with the Position slider.

- **4:3 Sidebar** — Reformats 4:3 source media to the 16:9 Anamorphic aspect ratio by scaling down the media horizontally and applying a black band to the left and right sides of the image.

Use one of these effects when you need to reformat a film aspect ratio for television programming. These effects also make it easier to combine 4:3 legacy media into a 16:9 master.

For more information, see “Reformat Effects” in the Help.

**Working with the Pan and Scan Effect**

Pan and Scan allows you to select a portion of the media to reformat and provides other parameters. See “Understanding the Pan and Scan Effect” on page 316.

Pan and Scan also supports conversion of 15:9 Anamorphic source media to 16:9 Anamorphic. See “Selecting the Source and Target Aspect Ratios” on page 319.

*If you use the Pan and Scan effect and another Reformat effect on the same sequence, you must render one of the effects before the sequence will play in real time.*

The following sections describe the Pan and Scan effect and explain how to use it to change the aspect ratio of your media.
Understanding the Pan and Scan Effect

Pan and Scan is a technique for reformatting media to different aspect ratios. The most widespread use of this technique is for reformatting television programming, for example, when 16:9 Anamorphic material needs to be converted to the 4:3 aspect ratio.

Merely stretching or shrinking the media to fit a new aspect ratio would distort the media. If you do not want to distort the original media, select a portion of each frame in your media for output. Traditionally, this selection process, known as Pan and Scan, is done during the transfer from film to tape in a telecine room.

The Pan and Scan effect lets you pan across your media and select what portion of the media you want to retain for output. If necessary, you can insert keyframes into the Pan and Scan effect and adjust the effect for each keyframe.

You can use Pan and Scan on any type of project (24p or 25p NTSC, 30i NTSC, 24p or 25p PAL, or 25i PAL).
Outputting the Media with the Pan and Scan Effect

Media with the Pan and Scan effect can be output in two video formats: 4:3 or 16:9 Anamorphic. Currently, the Pan and Scan effect does not generate data for inclusion in cut lists created with Avid FilmScribe. Consequently, if your target is not video, or if your source requires excessive scaling, you can preview the reformatting operation but the Pan and Scan effect will not automate a film-to-film or a film-to-tape transfer.

Positioning the Pan and Scan Track

When your sequence does not contain titles, the Pan and Scan track should typically be the top track. If you use titles, the most effective way to work with Pan and Scan and titles is to work with multiformat titles, available in any project on a system that includes support for 24p or 25p projects. For more information on multiformat titles, see “Working with Titles on Systems with 24p or 25p Support” on page 443.

If you work with multiformat titles, you can place the Pan and Scan track below the titles. This placement ensures that both titles and the Pan and Scan effect play correctly in real time.

When you place the Pan and Scan effect below multiformat titles, you might not see the titles with the correct Target aspect ratio as you work. For example, if you are reformatting from 4:3 to 16:9, titles will appear distorted in the Client monitor. When you output the sequence at 16:9 by using the Digital Cut tool, select the 16:9 aspect ratio and the titles will be sized correctly during the digital cut. For more information, see “Generating Output” in the Help.

When not using multiformat titles, you can place the Pan and Scan track above a title track to properly scale the title along with the video tracks beneath it. If you need to pan, however, the pan will apply to the title as well as the other video tracks. Since this technique results in the title being panned, the results might not be what you want.

If you need to pan your footage and the title aspect ratio is not critical, you can move the titles above the Pan and Scan track. If the title aspect ratio is important, you might need to create a new title in your target aspect ratio.
Applying the Pan and Scan Effect

Because the Pan and Scan effect controls the aspect ratio of your final output, the effect must be applied to your entire sequence. You should apply Pan and Scan to its own video track after you finish editing the sequence.

There might be some situations in which you will want to place a Pan and Scan effect directly on a video segment. For more information, see “Combining the Pan and Scan Effect with Transition Effects” on page 330.

To apply the Pan and Scan effect:

1. After you finish editing your sequence, press Ctrl+Y (Windows) or ⌘+Y (Macintosh) to create a new video track on the topmost track.

2. Enter Effect mode by selecting Toolset > Effects Editing.

3. In the Effect Palette, click the Reformat category.

4. Drag the Pan and Scan Effect icon from the Effect Palette to the new track.

If you apply the Pan and Scan effect and then add a segment to or remove a segment from your sequence, the Pan and Scan effect does not automatically adjust to cover the entire segment. Either trim the Pan and Scan effect manually, or remove the Pan and Scan effect and insert a fresh effect.
Selecting the Source and Target Aspect Ratios

If you enter Effect mode and select the Pan and Scan effect, you see a white wire frame in the Effect Preview monitor. This wire frame lets you select the portion of the media that appears in your output. The Pan and Scan aspect ratios determine the size and shape of the wire frame.

Correctly setting the Pan and Scan aspect ratios is the most important part of using Pan and Scan. Whenever you change aspect ratios, you must decide which part of an image you will retain for the final output and which part you will discard. The Pan and Scan aspect ratios specify the size of the incoming image and determine how much of that image you can retain for your final output.

You must set two ratios:

- **Source ratio** specifies the aspect ratio of your incoming media.
- **Target ratio** specifies the aspect ratio of the final output.
To set the Source and Target aspect ratios for a Pan and Scan effect:

1. Apply the Pan and Scan effect to the new video track, following the procedure described in “Applying the Pan and Scan Effect” on page 318.

2. Enter Effect mode by selecting Toolset > Effects Editing.
   The Effect Editor opens.

3. Move the position indicator to the Pan and Scan effect.

4. Click the triangular opener for the Aspect Ratios parameter category.
5. Set the Source aspect ratio to the ratio of your source material.

<table>
<thead>
<tr>
<th>Aspect Ratios</th>
<th>1.33 (4:3)</th>
<th>1.66</th>
<th>1.78 (16:9)</th>
<th>1.85</th>
<th>2.35</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>✔</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Target</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15:9 Anamorphic</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16:9 Anamorphic</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

6. Set the Target aspect ratio to the ratio of the final output.

<table>
<thead>
<tr>
<th>Aspect Ratios</th>
<th>1.33 (4:3)</th>
<th>16:9 Anamorphic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>✔</td>
<td></td>
</tr>
<tr>
<td>Target</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Setting Up Your Monitors for the Pan and Scan Effect**

To accurately view the effects of Pan and Scan while you edit, you need to set your monitors to display the correct aspect ratios. Your Record or Effect Preview monitors can display in 4:3 aspect ratio (the default) or 16:9 aspect ratio. Your Client monitor should also be able to display these two aspect ratios.

Generally, your monitors should all be set to 4:3. However, if your source aspect ratio is 16:9 Anamorphic, you should set the Record or the Effect Preview monitor to 16:9. If your target aspect ratio is 16:9 Anamorphic, the Client monitor should be set to 16:9. Use 4:3 aspect ratio for all other aspect ratios.

*If you are working with 16:9 Anamorphic and do not have the monitors set up correctly, the media and the wire frame will appear distorted. They will appear either elongated or squeezed.*
Chapter 7  Working with Camera Effects

To set the Record or the Effect Preview monitor aspect ratio:
- Right-click (Windows) or Ctrl+Shift+click (Macintosh) in the monitor, and select 16:9 Video to select or deselect 16:9 display.

Viewing Pan and Scan Media

In Effect mode, the Effect Preview monitor displays your original media and the Pan and Scan wire frame. The Client monitor displays the original media.

In Source/Record mode, the Client monitor displays the media inside the Pan and Scan wire frame. The portion of the image inside the wire frame expands to fill the entire monitor. The Record monitor also shows the media inside the wire frame; however, the media will be distorted if either the Source or Target aspect ratio is 16:9 Anamorphic.

Other effects let you view results on a frame-by-frame basis while in Effect mode. The Pan and Scan effect does not. You see the entire source image so that you can select a portion of it. To see the results of the Pan and Scan effect while in Effect mode, click the Play button. In Source/Record mode, you can see the results of the Pan and Scan effect on a frame-by-frame basis or by playing the media.
Using the Effect Grid with the Pan and Scan Effect

The Effect Grid displays a variety of positioning guides to help you move and position the Pan and Scan wire frame. Displaying the Safe Action grid and Thirds grid can be particularly useful when adjusting Pan and Scan compositions.

The following illustration shows the Effect Grid with Show Safe Action, Show Thirds, and Show Axes selected.

Safe Title/Safe Action and Thirds grid marks are based on the Target aspect ratio and are displayed inside the wire frame. Other grid markings are displayed as normal across the entire monitor.

You can open the Grid Settings dialog box by clicking the Other Options button in the Grid parameter category of the Effect Editor. The Grid Settings dialog box controls the size, position, and display of a variety of grids. For more information on Grid settings, see “Working with the Effect Grid” on page 88.
The following illustration shows the Grid parameter category in the Effect Editor.

In addition to using the options in the Grid Settings dialog box, you can use the controls in the Grid parameter category of the Effect Editor to change some Grid settings. For more information on these parameters, see “Grid” in the Help.

**Setting an Origin in the Pan and Scan Effect**

Each Target aspect ratio has default position and scaling settings. You can return to these default settings at any time by selecting the aspect ratio again.
In addition to using the effect’s default values, you can create customized default values for each instance of the Pan and Scan effect by using Establish Origin.

Establish an origin before subdividing or adjusting individual keyframes in your Pan and Scan effect.

After inserting the Pan and Scan effect, you might want to adjust the size and position of the wire frame and save the wire frame’s new settings as base settings for the Pan and Scan effect.

To save wire-frame settings for the Pan and Scan effect:

- In the Effect Editor, open the Actions parameter category and click Establish Origin.

Now, whenever you adjust Pan and Scan, you can return to these settings by clicking Reset to Origin. Reset to Origin is useful for quickly centering the wire frame after you move it.

To reset the wire frame for the Pan and Scan effect:

- In the Effect Editor, open the Actions parameter category and click Reset to Origin.

If you do not set an origin, clicking Reset to Origin returns to the default values for the Target aspect ratio.
Chapter 7  Working with Camera Effects

Subdividing the Pan and Scan Effect

Because your sequence probably contains a variety of segments with different panning requirements, you might need to adjust the position of the Pan and Scan effect on a segment-by-segment basis. To make it easier to adjust Pan and Scan for individual segments, Pan and Scan includes the Subdivide Effect command. Subdivide Effect splits the Pan and Scan effect based on the segment boundaries of the selected video tracks underneath the Pan and Scan track.

You can also use add edits to subdivide a Pan and Scan effect manually.

The following illustrations show the Timeline before and after using the Subdivide Effect command.

Subdividing the effect minimizes the number of keyframes you need to add and manipulate because, by default, each effect has a keyframe at the start and end of the effect. If you want to reposition Pan and Scan for an entire segment, you can select the segment and drag the Pan and Scan wire frame to a new position. If you need to adjust Pan and Scan within the segment, add keyframes to the effect.

You should subdivide the Pan and Scan effect only after you have finished editing your sequence and have selected your Pan and Scan aspect ratios and origin.
To subdivide a Pan and Scan effect:

1. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.
2. Move the position indicator to the Pan and Scan effect.
3. Click the Record Track buttons in the Track Selector panel for the video tracks to use as the subdivision guide.
   - Subdivide Effect divides Pan and Scan based on the segment boundaries of the selected tracks underneath the Pan and Scan track.
4. In the Actions parameter category, click Subdivide Effect.
   - The application divides the Pan and Scan effect into multiple effects.

   - **Subdivide Effect works on the selected Pan and Scan effect, not on the entire track.**
   - **Subdivide Effect does not subdivide segments connected by transition effects.** For information on using Pan and Scan with transition effects, see “Combining the Pan and Scan Effect with Transition Effects” on page 330.

### Using the Wire Frame in the Pan and Scan Effect

The wire frame displayed in the Record monitor outlines the section of media selected for output. The Pan and Scan wire frame functions similarly to the Picture-in-Picture wire frame.

### Scaling the Wire Frame

You can resize the wire frame by dragging its handles or by using the Scaling sliders; however, you cannot change the wire frame’s shape. The wire frame’s initial shape is determined by the Target aspect ratio. The application maintains the wire frame’s shape during scaling.
To scale the wire frame, do one of the following:

- Click one of the wire frame’s handles, and drag it to the position you want.
- Click the triangular opener for the Scaling parameter category in the Effect Editor, and use the slider controls to adjust the wire frame’s height and width.

Scaling lets you zoom in on your media. When you make the wire frame smaller, the image inside the wire frame is enlarged to fit the output monitor. Because making the wire frame very small results in a pixilated (grainy) image, it might not be appropriate to zoom in closely on an image when you plan to output directly to video.

Positioning the Wire Frame

Moving the wire frame and defining a motion path works similarly to other multilayer effects; however, there are minor differences.

Dragging restricts the motion to the most important axis. For example, if you go from a wide aspect ratio (16:9) to a narrow aspect ratio (4:3), you can drag the wire frame from side to side. If you go from 4:3 to 16:9, you can drag the wire frame up and down.

To position the wire frame by dragging:

- Click inside the wire frame, and drag it to a new position.
Pressing and holding the Shift key while dragging the wire frame lets you move in all directions.

You cannot drag the wire frame off the screen because in most circumstances you will not need to select empty space outside the boundaries of the source image. If you do need to position the edges of the wire frame beyond the screen’s limits, use the Position sliders in the Effect Editor.

To position the wire frame by using the Position sliders:

- In the Position parameter category, adjust the wire frame’s horizontal and vertical Position sliders.

The Position sliders let you override some limits imposed by dragging.

Adjusting the Pan and Scan Effect

You might need to adjust Pan and Scan at different points throughout your sequence. The following are some suggestions for adjusting Pan and Scan.

If your sequence needs few adjustments:

1. Click the Play button or the Play Loop button.
2. If you see a problem with the panning, stop playback:
   - Click the Play button or the Play Loop button.
   - Press the space bar.
3. Enter Effect mode by selecting Toolset > Effects Editing.
4. Adjust the Pan and Scan effect.

If your sequence needs many adjustments:

1. Enter Effect mode by selecting Toolset > Effects Editing.
   You will do all your adjustments in Effect mode.
2. Use the Go To Next Edit and Go To Previous Edit buttons to step from one Pan and Scan effect to the next.
The Go To Next Edit and Go To Previous Edit buttons appear on the Command palette. You can map the buttons from the Command palette to the keyboard or to another button. For more information, see “Using the Command Palette” in the Help.

3. Adjust the Pan and Scan effect.

**Combining the Pan and Scan Effect with Transition Effects**

When you subdivide the Pan and Scan effect, the subdivisions are based on the segment boundaries of the selected track. However, if two segments are connected by a transition effect, Pan and Scan does not place a subdivision between those segments. If one or more segments are connected by transition effects, Subdivide Effect treats this string of segments as one continuous segment.

The following illustration shows this behavior for a typical sequence with transition effects.

The Pan and Scan effect above segments with transition effects is not subdivided.

You can set Pan and Scan parameters for the starting and ending keyframes of the entire segment string and insert additional keyframes wherever you need to fine-tune the panning. However, this approach works only if the panning does not vary among the segments in the string.
If panning needs to vary greatly from segment to segment, you might need to handle Pan and Scan on a segment-by-segment basis. To work on a segment-by-segment basis, you need to combine the Pan and Scan effect with the transition effects by placing the Pan and Scan effect on your video track.

**Placing Pan and Scan Effects on the Video Track**

To combine Pan and Scan effects with transition effects, you need to place the Pan and Scan effects in the segments of the segment string.

**To place Pan and Scan effects in the segments:**

1. After subdividing the Pan and Scan effect, select the Pan and Scan effect above the segment string. For more information, see “Subdividing the Pan and Scan Effect” on page 326.
2. Press the Delete key to remove the Pan and Scan effect.
3. Enter Effect mode by selecting Toolset > Effects Editing.
4. In the Effect Palette, click the Image category.
5. Drag the Pan and Scan Effect icon from the Effect Palette to the first segment in the segment string in the Timeline.
6. Repeat step 5 for each segment in the segment string.
7. Adjust each Pan and Scan effect as needed.
Using Avid Pan & Zoom

The Avid Pan & Zoom plug-in effect provides capabilities similar to a motion control camera using high-quality digital processing. You import a high-resolution still image, and then move around the image with extensive keyframe control over the location (pan) and magnification (zoom) of the field of view. You can preview the movement in real time with no filtering and render the effect with a wide range of filtering options that provide exceptional image quality.

Importing the image file is an important step in using the Pan & Zoom effect. To import the image file, you create a segment as a placeholder for your image, apply the effect to the placeholder segment, and then from within the Effect Editor you import the image into the segment.

You import the image for the Avid Pan & Zoom effect after you apply the effect to a placeholder segment in your sequence.

The following sections describe how to apply the Avid Pan & Zoom effect and how to customize the effect using the Avid Pan & Zoom parameters.

Working with Image Files

The Avid Pan & Zoom effect supports any image file format for which your system has the appropriate QuickTime codec. You can download the latest version of QuickTime from the Apple Web site. For more information, see www.apple.com.

Most images you use with Avid Pan & Zoom come from digital cameras, scanners, or third-party graphics applications such as Adobe Photoshop. In the rare case where an image comes from a video source, you can set parameters in the Advanced parameter category to enable the effect to compensate appropriately. For more information, see “Advanced Parameter Category” on page 344.
If you move an image file after you import it into the effect, the image is no longer accessible to the effect. The next time you open the effect a dialog box opens asking you to locate the file.

**Applying the Avid Pan & Zoom Effect**

**To apply the Avid Pan & Zoom effect:**

1. Using standard editing techniques, load a sequence and create a placeholder segment of the duration you want for your image.
   
   The footage you use in the placeholder segment is the footage the effect uses if you set the Background parameter to Video. For more information, see “Selecting the Background” on page 343.

   You cannot use filler in the placeholder segment.

2. Enter Effect mode by selecting Toolset > Effects Editing.
   
   The Effects Editing toolset appears.

3. In the Effect Palette, click the Image category.

4. Click the Avid Pan & Zoom icon, and drag it to the placeholder segment you created in step 1.
Chapter 7  Working with Camera Effects

The Avid Pan & Zoom parameters appear in the Effect Editor.

5. Click the Other Options button.
   A file selection dialog box opens.

6. Navigate to the file containing your image, and click OK.
   The Avid editing application superimposes the image on the placeholder segment. The image appears in the Effect Preview monitor.

   ![Effect Editor pane](image)

   If you select a file that your application does not recognize as an image file, the application takes no action and no error message appears. For more information, see “Working with Image Files” on page 332.
The placeholder segment name does not change. That is, the name of the image file does not appear in the segment.

7. Customize the Avid Pan & Zoom effect using the procedures described in the following sections.

**Viewing the Image While You Work**

The Display Fast menu lets you select how you view the image as you work on it.

**To set the Display parameter:**

- Click the Display Fast Menu button, and select Source or Target.
  - **Source** shows you the entire image scaled to fit inside the Effect Preview monitor. Use Source as you draft the effect.
    
    The pan and zoom settings appear as a rectangle (4:3 aspect ratio) superimposed over the image. The closer in you zoom, the smaller the rectangle appears.

  - **Target** shows you the results of your pan and zoom settings. Use Target for previewing your moves.
    
    A crosshair appears at the center of the image. If you use Target and one of the real-time filtering options, the image appears pixelated in the Effect Preview monitor. This does not affect the quality of the rendered image. For more information, see “Options for Rendering the Avid Pan & Zoom Effect” on page 342.

The Show Action Safe button in the Display Options parameter category controls the display of the Safe Action area. If your material will be viewed on screens with limited viewing areas, such as standard televisions, you can use the Show Action Safe option to provide a visual guideline in the Effect Preview monitor that replicates the actual viewable area on a standard television screen.
Adjusting the Field of View

The field of view is that part of the source image that you select to create the final image. It is represented in the Effect Preview monitor by a gray rectangle superimposed on the source image. You control zoom with the Zoom Factor slider in the Size parameter category. You control pan by either dragging the crosshair across the image or using the X and Y Position parameters.

For information on the Safe Action area, see “Viewing the Image While You Work” on page 335.

Zooming Into and Out of the Source Image

The Size parameter category contains the Zoom Factor slider. This slider controls how far you zoom into or out from the source image. The Zoom Factor ranges from 0.1 to 20. At 0.1, the effect scales down the image to one-tenth the original. At 1, the effect applies no magnification to the source image. At 20, the effect scales up the image 20 times — that is, by 2000 percent. The larger the Zoom Factor, the smaller the field of view rectangle appears when you use Source mode.
Using Avid Pan & Zoom

The Avid Pan & Zoom effect automatically preserves the clip’s aspect ratio. Any aspect ratio you select from the Clip menu is also used by the Avid Pan & Zoom effect.

Panning Over the Source Image

You can use click-and-drag techniques to easily create a rough path, and refine it with the X and Y Position parameters.

To panning over the source image, do one of the following:

- Using either Source Display mode or Target Display mode, click the crosshair and drag it to a new location.
- Use the X and Y Position parameters.
  
  The Position parameters refer to the center of the field of view. A Position of 0, 0 centers the field of view over the center of the image.
Using Velocity In and Velocity Out

You use the Velocity parameter category to control the rate of change for pan and zoom movement at each keyframe.

The Avid Pan & Zoom effect uses Velocity In and Velocity Out at each keyframe to modify apparent camera speed as it pans across the image between keyframes. It modifies changes in the Zoom Factor setting in the same way.

The gradual acceleration at the beginning of movement is *ease in*, and the gradual deceleration at the end of movement is *ease out*. Acceleration, a global parameter found in other effects, adjusts an effect’s speed over time by having the effect ease in and ease out at the first and last keyframes respectively. Velocity is a keyframeable parameter and it gives you more options than does Acceleration. For a description of all the Velocity parameter options, see “Velocity” in the Help.

The Velocity parameters divide the time between keyframes in half. Velocity In controls the rate of movement in the first half; Velocity Out controls the rate of movement in the second half.

Procedures for setting a simple ease in and ease out, and for setting a constant speed for an effect, are described in the following sections. All the Velocity parameter options are described in “Velocity” in the Help.
Using Ease In and Ease Out

With the Avid Pan & Zoom effect, most of the time you probably want to ease in only on the first keyframe and to ease out only on the last keyframe. If you use Ease In and Ease Out for each keyframe, the pan and zoom movements bounce at each keyframe like a car repeatedly speeding up and slowing down.

To set up a simple ease in and ease out for an effect with multiple keyframes:

1. Click the first keyframe indicator to select it.
2. Set Velocity In to Ease In.
3. Set Velocity Out to Linear.
4. Click the next keyframe indicator to select it.
5. Set Velocity In and Velocity Out to Linear.
6. Repeat steps 4 and 5 for all keyframes except the last keyframe.
7. Click the last keyframe indicator to select it.
8. Set Velocity In to Linear.

Creating a Path with Constant Velocity

When you change the time at which a keyframe occurs, for example by moving the keyframe indicator in the Timeline, the length of time it takes the effect to move from the position set in that keyframe to the position set in the next keyframe also changes. Most of the time this is the result you want.
If you want an effect’s path to have a constant velocity across a number of key frames, you can make the calculations manually and place the keyframes accordingly, or you can use the Constant option for the Velocity parameters.

When you use the Constant option, your Path parameter selection can affect the result of changes you might make to the effect.

- If you select Linear for the Path parameter, moving keyframes or changing the Position parameters does not affect the velocity of the effect’s path.
- If you select Spline for the Path parameter, moving keyframes or changing the Position parameters might affect the velocity of the effect’s path.

For more information, see “Setting the Path Parameter” on page 341.

To create a path with constant velocity:

2. Add keyframes to define the path you want the effect to take.
3. At each keyframe, set the Velocity In and Velocity Out parameters to Constant.

When you use Constant for Velocity In and Velocity Out, the position at which you placed a keyframe in the Timeline is not necessarily the time at which the Avid Pan & Zoom effect applies the keyframe’s parameters. The effect applies the parameters at the time calculated by the effect to achieve a constant velocity for the path you created.

4. Press the Play button or the Play Loop button to preview the effect.

The velocity of the path is constant.
Setting the Path Parameter

The Path parameter controls how the Avid Pan & Zoom effect interpolates Position parameter changes at keyframes.

- **Linear** interpolation creates straight-line changes from one keyframe to the next.

- **Spline** interpolation smooths out changes at keyframes to create a more natural movement.
The Avid Pan & Zoom effect calculates a Spline path so that it is smooth through all points. If you move a point, the effect recalculates the entire path.

If you combine a Spline path with Constant velocity, when you move a keyframe, the path recalculation might result in a change to the velocity of the effect.

Options for Rendering the Avid Pan & Zoom Effect

The rendering option you choose for the Avid Pan & Zoom effect determines the quality of the rendered result.

The image quality of the effect in the final output is dependent in part on the resolution at which you output the sequence. Some sharpness might be lost due to compression during the final output.

Use the Filtering parameter category to select the rendering method. The various filtering options allow you to trade off the clarity or sharpness of the resized image and the speed at which the effect renders.

You might not always want the sharpest possible result. Images with many sharp edges might look better with a softer rendering. Many users find that B-Spline Catmull is the best compromise between image quality and rendering time. Experiment with Filtering options to decide which one produces the effect you want.

The following list ranks the Filtering options from fastest render and lowest quality image to slowest render and highest quality image:

- **Real Time** renders most quickly but results in a draft-quality image.
- **Triangle** results in fairly soft images.
- **Quadratic** has slightly sharper images than Triangle filtering.
- **Cubic** results in sharper images than Quadratic filtering although they are still fairly soft.
Using Avid Pan & Zoom

- **B-Spline Catmull.** When you use this option and shrink an image (zoom out) by a large amount, the result is similar to that produced by Cubic filtering. B-Spline Catmull produces a sharper image than Cubic filtering when you:
  - Stay close to the original size of the image (very little zooming in or zooming out).
  - Enlarge the image (zoom in) past the source image resolution.
- **Gaussian** results in an image that is relatively soft but sharper than B-Spline Catmull.
- **Avid Hi Qual** creates sharp images when you shrink the original (zoom out).
- **Avid Ultra Qual** creates extremely sharp images when you shrink the original (zoom out).

**Selecting the Background**

With the Avid Pan & Zoom effect, you can select a field of view from the original image that does not fill the entire screen. The Background parameter determines what appears outside the field of view.

> The Background parameter is not keyframeable.

**To set the background:**

1. Click the Background Fast Menu button, and select Color or Video.
   - **Color** lets you select a background color.
   - **Video** uses the video from the segment upon which you placed the Avid Pan & Zoom effect.
2. (Option) If you selected Color, use one of the following methods to set the background color:
   - Manipulate the RGB sliders directly, or use the numeric keypad to enter values.
   - Click the Other Options button to use the Windows Color dialog box or the Macintosh Color Picker.
   - Click the Color Preview window, and use the eyedropper.

For more information, see “Adjusting a Color Parameter” on page 106.

Advanced Parameter Category

The Advanced parameter category provides controls to compensate for differences in pixel shape between source and output, and to select input color levels.

Pixel Types in the Source and Output

Digital cameras and scanners, common sources for the Avid Pan & Zoom effect, use square pixels. Computer monitors also use square pixels but television monitor pixels are rectangular.

Source Has Square Pixels is enabled by default. The Avid Pan & Zoom effect makes the calculations necessary to produce results compatible with rectangular pixels.

When you deselect Source Has Square Pixels, the Avid Pan & Zoom effect makes no changes to the pixel shape but does apply the aspect ratio in effect for the project.
Using Avid Pan & Zoom

Color Levels for Avid Pan & Zoom

The Level setting tells the effect how to treat the color levels in the image.

- **RGB** is for images with a black level of 0 and a white level of 255. Most images you import into the Avid Pan & Zoom effect (except those from a video source) use RGB values. The effect maps colors to video black and white levels, which are 16 and 235 respectively. RGB is the default Level setting.

- **601** refers to the ITU-R-601 standard for video black and white levels. Select 601 in the rare case when you use images from a video source. When you select 601 for the Level setting, the effect makes no adjustment to color levels.

Memory Management with the Avid Pan & Zoom Effect

The images you import into Avid Pan & Zoom can be extremely large. The amount of memory used to store a large image can impact the performance of the Avid editing application. The Cache parameter gives you control over the amount of memory used to store your images for playback. A full resolution image is always used for rendering.

- **Video Resolution** — The effect stores the resized source image at 720 x 480 pixels, using about 1 MB per image. Use Video Resolution if you have many images in your sequence and you need to limit how much memory they occupy.

- **Image Resolution** — The effect stores a source image at its original resolution. The amount of memory used varies with the size of the image.

- **Multi-Resolution** — The effect stores several versions of the image: original image resolution, half resolution, quarter resolution, and so on, for eight versions of the image. The result is higher quality real-time preview and faster rendering. Multi-Resolution uses about twice the memory of Image Resolution.
Chapter 7  Working with Camera Effects

- **Free Current Cache** — The effect frees all memory used for image storage and then reverts to Image Resolution. Use this setting to free up memory after you have rendered the clip.

- **Cache All** — The application sets the same Cache parameter for all instances of the effect in a sequence.
Chapter 8

Working with 3D Effects

This chapter describes procedures for creating and manipulating 3D effects. For reference information on the parameters that apply to 3D effects and all the available 3D shapes, see “3D Effects Reference” in the Help.

• Understanding 3D Effects
• Accessing 3D Effects
• Understanding the 3D Effects Interface
• Creating Custom 3D Effects
• Using Xpress 3D Effects
Understanding 3D Effects

Avid 3D effects feature a wide range of digital video effects, including the following:

- Image effects such as blur (defocus), corner pin, and resize with rotation and perspective
- Two-channel segment effects including smooth-motion picture-in-picture
- Shapes, including 3D spheres and four-way page curls
- Positioning, scaling, skewing, and rotation, with perspective
- Source cropping
- Internal borders including beveled and rounded edges
- Soft borders
- Trails and drop shadows with varying opacity
- Highlights and wipe generator
- Luma key and chroma key effects

This documentation describes all Avid 3D effects. Not all Avid editing applications support all 3D effects.

Accessing 3D Effects

To access 3D effect parameters, do one of the following:

- Apply the 3D Warp effect to a transition or segment. See “Applying the 3D Warp Effect” on page 349.
- Promote an existing 2D effect to 3D. See “Promoting 2D Effects to 3D Effects” on page 350.
Applying the 3D Warp Effect

All the 3D effects features are accessible through the 3D Warp effect in the Blend category.

Before you use the following procedure, you need to be familiar with adding effects to a sequence. For more information, see “Applying Effects to a Sequence” on page 56.

To apply the 3D Warp effect:

1. Create a sequence by using standard Avid application editing procedures.
2. Enter Effect mode by selecting Toolset > Effects Editing. For more information, see “Entering Effect Mode” on page 82.
3. Click the Blend category.
4. Drag the 3D Warp Effect icon to a transition or a segment in the Timeline, and release the mouse button.

The 3D Warp Effect icon appears in the Timeline as shown in the following illustration.
5. In the Timeline, move the position indicator to the 3D Warp effect. The two default keyframe indicators appear under the Effect Preview monitor.

6. (Option) In the Effect Editor toolbar, click the Promote to Advanced Keyframes button. For more information, see “Working with Advanced Keyframes” on page 115.

Now you can begin adjusting the 3D Warp parameters to customize your effects.

**Promoting 2D Effects to 3D Effects**

You can use 2D effects as building blocks for 3D effects. For example, if you have a 2D Picture-in-Picture effect, you can add 3D features like 3D borders, drop shadow, page curls, smooth curve movement, and rotation. You can also promote a Title effect created with the Title tool to a 3D effect.

The following rules and restrictions apply to promoting effects to 3D:

- Some software-based effects cannot be promoted to 3D.
- You cannot demote a 3D effect to a 2D effect. If you play an unrendered 3D effect on a system that does not have 3D hardware, the effect plays as a cut. However, you can reapply the 2D effect.
- All effects that were real-time in 2D are still real-time when you upgrade to 3D.

**To promote a 2D effect or title to a 3D effect:**

1. Enter Effect mode by selecting Toolset > Effects Editing.
2. Click the effect icon in the sequence to select it.
3. In the Effect Editor, click the 3D Promote button.

*For information on creating a 2D Title effect, see Chapter 9.*
Using Matte Keys with 3D Effects

A matte key is an effect made up of three components:

- High-contrast image or matte, also called the key
- Background image (the image that shows through the lightest part of the matte)
- Foreground image (the image that shows through the darkest part of the matte)

For more information on Matte Key clips, see “Creating a Matte Key Effect” on page 287.

You can promote real-time 2D Matte Key effects (graphics imported with alpha channel) to 3D effects, called 3D Warp, and apply additional parameters, such as Shape Wipe effects, or X, Y, and Z positioning.

You cannot promote matte keys created using the Matte Key effect from the 2D Effect Palette to a 3D matte key.

To create a matte key for use with 3D effects:

1. Import a graphic file containing an alpha channel.

   The application creates a Matte Key clip when you import the file. In this example, the imported graphic is a title created in Adobe Photoshop.
2. Edit the Matte Key clip into your sequence as an overlay.

Make sure Render On-the-Fly is enabled (displays a check mark in the Special menu) so you can see the matte key as you are working with it.

3. Promote the Matte Key clip to a 3D Warp effect as explained in “Promoting 2D Effects to 3D Effects” on page 350.

4. Enter Effect mode by selecting Toolset > Effects Editing.

5. Apply changes to additional parameters to achieve the effect you want.
Understanding the 3D Effects Interface

This section provides basic information for using the 3D effects parameters and the Effect Preview monitor and controls.

Moving in 3D Space

You do not need to use a lot of math to create most 3D effects, but you do need some basic understanding of degrees of motion and geometry, as described in this section.

Moving objects in 3D space requires an understanding of each of the 3D effects parameters and their correct order in the effects parameters hierarchy. For more information, see “3D Effects Reference” and “The Hierarchy of Parameters” in the Help.

The 3D Coordinate System

Throughout this chapter, the terms X, Y, and Z refer to the three axes or dimensions of the image that can be manipulated in the 3D effect’s coordinate space.

- X refers to the image’s left/right direction.
- Y refers to the image’s up/down direction.
- Z refers to the image’s front/back dimension.

X Axis — values increase from left to right
Y Axis — values increase from bottom to top
Z Axis — values increase from back to front
Rotation Axes

The Shape and Rotation parameters allow you to rotate the image around the X, Y, and Z axes. Note that you can rotate more than 360 degrees (from –720 to 720 degrees) between keyframes.

The following illustration shows how angles of rotation are distributed around a circle.

The following illustration shows several rotation examples.
3D Effects Parameters

The following sections provide a basic introduction to 3D effects parameters. For specific information on each of the parameters available in the Effect Editor, as well as important information on the hierarchy of 3D effects parameters, see “3D Effects Reference” and “The Hierarchy of Parameters” in the Help.

Manipulating 3D effects parameters requires a basic understanding of degrees of motion and the system of geometry used in the 3D effects interface. For more information, see “Moving in 3D Space” on page 353.

Accessing 3D Effects Parameters

To access the 3D effects parameters:

1. Move the position indicator to the icon for the 3D Warp effect in the Timeline.

   For more information, see “Entering Effect Mode” on page 82.

2. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.

   The Effect Editor opens and displays the parameters for the 3D Warp effect.

   If the Effect Editor is already open and active, select the segment or transition effect to display the effect’s parameters in the Effect Editor.

Manipulating 3D Effects Parameters

As in 2D effects, the 3D Warp parameters are grouped in collapsible panes. Each parameter pane represents a specific type of manipulation, called a category or group, that you can apply to an image. You can apply category adjustments either individually or in combination.
The following illustration shows the 3D Warp parameters in the Effect Editor.

Basic manipulation of the parameter categories, sliders, and buttons is identical to that of 2D effects parameters. For more information, see “Using the Effect Editor” on page 97.
Resetting Default Values

To reset the parameters for a category to their default values:

- Alt+click (Windows) or Option+click (Macintosh) the parameter category’s Enable button.

This operation affects only selected keyframes.

*This method works only for 3D effects and AVX plug-in effects.*

Using Effect Templates

Once you create a 3D effect and adjust parameters, you can save the adjustments as a template for later use. This allows you to use the same effect parameters in multiple places in a sequence or in different sequences.

- You can drag an effect template and drop it into the Effect Preview monitor or onto the effect segment in the Timeline to apply all the values from the template.
- You can drag an effect template and drop it onto an open parameter category to reset the parameters of the category to those of the first keyframe of the effect template. This allows you to use selected portions of effect templates.

For more information, see “Applying an Effect Template” on page 166.
Zooming In or Out on the Effect Preview Monitor

Because you can move the edges of a 3D effect outside the enclosing frame, the application lets you view an outline of the image area at a reduced scale. Use the Enlarge and Reduce buttons in the Effect Editor.

Manipulating 3D Effects Directly

You can perform a number of operations on an image by clicking buttons in the Effect Editor and dragging handles attached to the image in the Effect Preview monitor. This is similar to the procedures you use to directly manipulate 2D effects; some additional manipulations are possible, however, when working with 3D effects.

For more information on direct manipulation of 2D effects, see “Moving the Image Directly to Add a Motion Path” on page 161.

Manipulating 3D Effect Handles

Various 3D effect handle buttons appear along the right side of the Effect Editor. You determine the direction and type of manipulation performed in the Effect Preview monitor by selecting one of the image manipulation buttons in the Effect Editor.
To manipulate a 3D effect handle in the Effect Preview monitor:

1. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.
2. In the Effect Editor, click one of the image manipulation buttons to activate the specific handles.
3. Click the handles, and drag them to manipulate the image.
4. Click the image manipulation button a second time to turn off the handles.

The following illustrations show the handles for several image manipulation buttons.

Using the Motion Path Editor

Use the Outline/Path button when you want to see the path an image takes on the screen (for example, moving a Picture-in-Picture effect as described in “Defining a Motion Path” on page 161). The motion path editor displays the path between keyframes as either a straight line or a smooth curve.

Click the Enable button in the Spline category to switch between a straight line and smooth curve. For a description of the Spline parameters, see “Spline” in the Help. For an example, see “Using the Spline Parameters with 3D Effects” on page 373.
Creating Custom 3D Effects

This section provides examples of some basic 3D effects, including the steps and values used to create the effects. You can use them to practice creating 3D effects, or you can use them to get ideas for building your own effects. Examples of both segment effects and transition effects are included.

If you need more information while you are trying to complete the examples shown here, see the following sources:

- For basic information on effects editing, see Chapter 2.
- For information on the 3D interface and moving in 3D space, see “Understanding the 3D Effects Interface” on page 353.
- For reference information on all 3D effects parameters and controls, see “3D Effects Reference” in the Help.
- For basic information on editing, see the Help.

In addition to re-creating the examples in this chapter, you can experiment with the default shape effects. Each shape effect has default values for the first and last keyframes. Examples of the default shapes are provided in “3D Effects Reference” in the Help.

*When you apply a shape effect, what you see in the Effect Preview monitor depends on where in the clip the position indicator is located. If the position indicator is at the start or end of the clip it might look as if the effect is missing.*
Some Tips for Creating 3D Effects

The following tips apply to the examples in this chapter:

- **Creating the sequence**: Transition effects require only a two-clip sequence. Some of the segment effects require at least two tracks.

- **Avoiding Insufficient Source errors**: Several of these examples assume that you are creating a transition effect centered on the cut between the incoming and outgoing video. Leave enough material for the overlapping portions of the transition when you mark the source material. For example, the following illustration shows the Source monitor position bar for the outgoing video clip.

If you receive an Insufficient Source message when you apply an effect to the transition, you did not leave enough source material behind for the application to create the transition.

- **Using the Swap Sources button**: When you use the 3D Warp effect as a transition and click the effect for the first time, the application applies the effect to the incoming video. To apply the effect to the outgoing video, click the Swap Sources button in the Foregnd (foreground) parameter category. Click anywhere in the effect’s Timeline to view the results.
The following illustration shows the display (in Big Effect mode) for “Creating a Page Curl Transition” on page 362 and identifies several areas that are referred to throughout the chapter.

Creating a Page Curl Transition

This example uses the Page Curl effect. This effect treats the foreground video channel as though it were a sheet of paper being rolled up to reveal another page beneath. Page Curl supports two highlights on the curl. The following illustrations show the effect created in this example.
To create the Page Curl effect:

1. Create a sequence, and apply the 3D Warp effect as described in “Applying the 3D Warp Effect” on page 349.

2. In the 3D Warp parameter list, click the triangular opener to open the Shape parameter category.

3. Click the Shape Fast Menu button, and select Page Curl.
The default Page Curl effect appears on the incoming video. To apply the effect to the outgoing video, swap the video sources as follows:

1. Scroll down to display the Foregnd (foreground) parameter category, and click the triangular opener.
2. Click the Swap Sources button.
3. Click anywhere in the Effect Preview monitor’s position bar, and the application displays the effect on the outgoing video.

4. Locate the Highlight parameter category, and click the Enable button.

5. Click the first keyframe indicator.

The 3D Warp parameters for the first keyframe are now active.

6. In the Shape parameter category, set the Curl slider to 0 (no curl).
7. Click the last keyframe indicator.
8. Set the Curl slider to 80. This takes the curl completely off the underlying video.

9. Click the Play button or the Play Loop button to preview the effect.

You might want to use the Transition parameters to lengthen the effect. For more information, see “Using the Transition Parameters” on page 65.

A Simple Variation on the Page Turn Transition

This example describes how to make some simple changes to the Page Turn transition to create a dramatically different effect. To create this variation, use the example you created in “Creating a Page Curl Transition” on page 362.
For the previous example, you used the No Split command in the Split Fast menu. This example uses the Quad Split command.

**To use the Quad Split command:**

1. In the Shape parameter category, click the Split Fast Menu button, and select Quad Split.

2. Set the Angle for the first keyframe to 135 degrees:
   a. Click the first keyframe indicator.
   b. Click the Angle slider.
   c. Type **135** on the numeric keypad, and press Enter (Windows) or Return (Macintosh).

3. Set the Angle for the last keyframe to 135 degrees:
   a. Click the last keyframe indicator.
   b. Click the Angle slider.
   c. Type **135** on the numeric keypad, and press Enter (Windows) or Return (Macintosh).

The following table shows the values for each keyframe.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>First Keyframe</th>
<th>Last Keyframe</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shape</td>
<td>Curl = 0</td>
<td>Curl = 80</td>
</tr>
<tr>
<td>• Page Curl</td>
<td>Radius = 15</td>
<td>Radius = 15</td>
</tr>
<tr>
<td></td>
<td>Angle = 135</td>
<td>Angle = 135</td>
</tr>
<tr>
<td></td>
<td>Quad Split</td>
<td>Quad Split</td>
</tr>
<tr>
<td>Highlight</td>
<td>Enabled</td>
<td>Enabled</td>
</tr>
</tbody>
</table>
Now step through or play the effect. The following illustrations show the effect.

Creating a Splash Dissolve

This example creates a Splash effect and uses it as a dissolve. Use the Opac. (opacity) slider in the Foregnd (foreground) parameter category to create the dissolve. Changing the opacity value from solid to transparent creates the same effect as a dissolve.

The following illustrations show the effect and the outgoing and incoming video.

Here are some tips for creating this effect:

- Use the Multi Wave shape and increase the radius throughout the effect, starting at 0 and ending at 55.
- Add a new keyframe (shown as the second keyframe in the following illustration) to provide a starting point for the dissolve. The complete dissolve occurs between the second and last keyframes.
Creating Custom 3D Effects

For information on working with keyframes, see “Using Standard Keyframes” on page 111.

To create the Splash effect:

1. Create a sequence with two video clips as you did in the Page Curl examples, and drag the 3D Warp effect onto the transition point in the Timeline.

2. Click the effect in the Timeline.

3. Enter Effect mode by selecting Toolset > Effects Editing. For more information, see “Entering Effect Mode” on page 82.

4. Click the Shape Fast Menu button, and select Multi Wave.

   The default Multi Wave Effect icon appears on the incoming video.

5. In the Foregnd (foreground) parameter category, click the Swap Sources button to display the effect on the outgoing video.

   Now click anywhere in the effect’s Timeline, and the effect appears on the outgoing video.

6. Click the first keyframe indicator.

7. In the Shape parameter category, set the Radius value to 0.

8. Click the last keyframe indicator.

9. In the Shape parameter category, set the Radius value to 55.

10. With the last keyframe still selected, set the Opac. (opacity) slider in the Foregnd parameter category to 0.

11. Add a new keyframe approximately three-quarters of the way through the effect.

   This keyframe will have a predetermined radius value (calculated by the application to create a smooth splash between radius values 0 and 55). You do not need to change this value.

12. For the keyframe you just added, set the Opac. slider to 100 in the Foregnd parameter category.
13. Click the Play button or the Play Loop button to preview the effect.

The following table shows the nondefault keyframe values for this example.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>First Keyframe</th>
<th>Second Keyframe</th>
<th>Last Keyframe</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shape</td>
<td>Radius = 0</td>
<td>Let the application set the Radius.</td>
<td>Radius = 55</td>
</tr>
<tr>
<td>• Multi Wave</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Foregnd</td>
<td>Opac = 100</td>
<td>Opac = 100</td>
<td>Opac = 100</td>
</tr>
<tr>
<td>• Full Key</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Experiment with the Highlight parameter category for this effect by adjusting the Inty (intensity) value.

**Turning a Splash into a Flat Image**

The following techniques show two different ways to turn a splash into a flat image.

**To turn a splash into a flat image, do one of the following:**

- Set the Radius value to 0. This setting conceals the ripples entirely. It allows you to create splash sequences simply by increasing the Radius.

- Lower Amplitude and Automatic Highlight intensity to 0. Lowering the amplitude reduces the distortion. Reducing the highlight intensity to 0 eliminates highlights and shading. This allows you to:
  - Bring up a full-sized splash from beneath the center of the picture by keeping the Radius constant and increasing the Amplitude and Highlight intensity settings.
  - Create a splash that starts small, becomes a full-sized splash, and then changes to a flat picture. The following example shows how to do this.
Creating Custom 3D Effects

This example creates a splash that grows from the center of the screen. As the splash begins to cover the screen, the splash slowly fades away so that the final scene is completely flat. Fade the splash by lowering the Amplitude and Highlight intensity values to 0. The following illustrations show several stages of the effect.

To turn a splash into a flat image:

1. Apply the 3D Warp effect as a segment effect as shown in the following illustration. For more information, see “Applying an Effect to a Single Transition or Segment” on page 56.

2. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing. For more information, see “Entering Effect Mode” on page 82.

3. Click the Shape Fast Menu button, and select Multi Wave.
4. Set Highlight parameter values for the first and last keyframes, using values from the following table.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>First Keyframe</th>
<th>Second Keyframe</th>
<th>Last Keyframe</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shape</td>
<td>Radius = 0</td>
<td>Let the application set the Radius.</td>
<td>Radius = 50</td>
</tr>
<tr>
<td></td>
<td>Freq = 70</td>
<td>Freq = 70</td>
<td>Freq = 0</td>
</tr>
<tr>
<td></td>
<td>Ampl = 36</td>
<td>Ampl = 36</td>
<td>Ampl = 0</td>
</tr>
<tr>
<td>Highlight</td>
<td>Inty = 20</td>
<td>Inty = 20</td>
<td>Inty = 0</td>
</tr>
</tbody>
</table>

5. Create a new keyframe in approximately the center of the effect’s position bar. This new keyframe is shown as the second keyframe in the following illustration.

![Keyframe Illustration](image)

The application automatically calculates a radius size for this new keyframe to continue the smooth transition from 0 radius to a radius of 50.

6. Set the Shape and Highlight values for the second keyframe as shown in the previous table.

7. Step through or play the effect.

Experiment with the X Pos and Y Pos Shape parameter values to reposition the splash on the screen. Also experiment with the Aspect and Angle parameters to stretch and rotate the splash.
Creating a Cropped Foreground Effect

This example shows how to adjust 3D Warp parameters and apply them repeatedly as a template to create a consistent band of foreground segments — scaled and cropped with a soft border shadow — across a background.

Settings for the 3D Warp effect are saved as a template and then are applied to all segments on the top video track for consistency throughout the dissolve sequence.
To create a foreground band of footage:

1. Build the sequence with the background footage on the bottom track and the foreground footage on the top track. In this example, dissolves are added between a series of foreground segments.

2. Apply the 3D Warp effect to one segment of the top video track.

3. Enter Effect mode by selecting Toolset > Effects Editing. For more information, see “Entering Effect Mode” on page 82.

4. Click the segment to display the parameters in the Effect Editor.

5. Make sure both the starting and ending keyframes are selected; then adjust the effect parameters as shown in the following table.

<table>
<thead>
<tr>
<th>Parameter Category</th>
<th>Parameter Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crop</td>
<td>T (top): 600</td>
</tr>
<tr>
<td></td>
<td>L (left): –999</td>
</tr>
<tr>
<td></td>
<td>B (bottom): –600</td>
</tr>
<tr>
<td></td>
<td>R (right): 999</td>
</tr>
<tr>
<td>Scaling</td>
<td>Wid: 110</td>
</tr>
<tr>
<td></td>
<td>Hgt: 100</td>
</tr>
<tr>
<td>Position</td>
<td>Enable the category (leave parameter defaults).</td>
</tr>
<tr>
<td>Border</td>
<td>Select a dark color for the border. For more information on color selection, see “Adjusting a Color Parameter” on page 106.</td>
</tr>
<tr>
<td></td>
<td>Width: 40</td>
</tr>
<tr>
<td></td>
<td>Soft: 100</td>
</tr>
<tr>
<td></td>
<td>H (hue): 0</td>
</tr>
<tr>
<td></td>
<td>S (saturation): 0</td>
</tr>
<tr>
<td></td>
<td>L (luminance): 255</td>
</tr>
</tbody>
</table>

Leave all other categories deselected.
6. Save the parameters as a template by dragging the effect icon from the Effect Editor to a bin.

7. Apply the template from the bin to the remaining segments on the top track.

8. Click the Play button or the Play Loop button to preview the effect. The foreground segments play through smoothly with the same scale, border, and cropping effect against the background.

Using the Spline Parameters with 3D Effects

This example shows how to use the Spline parameters to create a smooth path for moving a 3D Warp effect.

The following illustrations show the motion path editor with the Spline parameter turned on and off. (The background image is black to make the motion paths more visible in this illustration.)

To use the Spline parameters:

1. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.
2. Click the first keyframe indicator (on the left end of the effect’s position bar).
3. In the Effect Editor, click the Outline/Path button.
A dot appears in the center of the image, and the arrow indicator appears to show the orientation of the image.
4. Click anywhere in the foreground video, and move the image to the bottom left corner of the Effect Preview monitor.

Click a wire frame and drag it to move it around the monitor. Press the Alt key (Windows) or Option key (Macintosh), and drag to move the actual effect object.

5. Click the last keyframe indicator, and move the image for that keyframe to the top right corner of the monitor. Notice that the two dots are connected by a straight line.

6. Move the position indicator approximately halfway along the effect’s position bar, and click the Add Keyframe button.

7. Move the image for the center keyframe to the top left corner of the monitor.

8. Play the effect. Notice that the image moves along straight lines.

9. In the Spline parameter category, click the Enable button.

Notice that the straight lines connecting the dots turn into a smooth curve.

10. Play the effect again, and notice the smooth movement.

Experiment with the XY Position and XZ Position buttons at any one of the keyframes. Also experiment with the Rotation buttons.
Corner Pinning an Image

Corner pinning is a way of precisely positioning a foreground image over an image in the background video track, with matching perspective.

This example shows the background and foreground videos used to create a segment transition using corner pinning. The segment starts with the foreground image “pinned” onto the video monitor in the scene; the image then moves off the TV and eventually fills the screen.

Basic Procedure for Corner Pinning an Image

**To corner pin an image:**

1. Create a segment with two video tracks, placing the foreground video on the top track. For more information, see “Editing in Source/Record Mode” in the Help.

2. Apply the 3D Warp effect to the top track.
Chapter 8  Working with 3D Effects

3. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing. For more information, see “Entering Effect Mode” on page 82.

4. Position, scale, and rotate your image if necessary.

   For best results, make adjustments to the Position, Scale, and Rotate parameters before you use Corner Pin. The center of the image for Corner Pin scale and rotation adjustments will be closer to the apparent center of the image, and you will find it easier to get the results you want.

5. Position the corners using one of the methods described in the following sections.

6. To review your edit, click the Play button or the Play Loop button.

Using the Corner Pin Button

   To use the Corner Pin button:

1. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.

2. In the Effect Editor, click the Corner Pin button to activate the handles.

3. Click the handles, and drag to manipulate the image.

4. Click the Corner Pin button a second time to turn off the handles.
Creating Custom 3D Effects

Using the Quick Pin Feature

To use the Quick Pin feature:

1. In the Effect Editor, click the Corner Pin button to activate the handles.

2. Press and hold the Ctrl and Alt keys (Windows), or the Ctrl and Option keys (Macintosh). Position the pointer where you want the highlighted corner to be corner pinned, and click.

   The next corner is highlighted.

3. Continue using the Ctrl and Alt keys (Windows), or the Ctrl and Option keys (Macintosh), while clicking until the image is positioned where you want it.

   The next corners continue to be highlighted in a clockwise rotation each time you click.

4. Click the Corner Pin button a second time to turn off the handles.

Using the Corner Pin Parameter Category

To use the Corner Pin parameter category:

1. In the Corner Pin category, click the Enable button.

   ![Enable button]

2. Use the X and Y sliders in the Corner Pin parameter category to position the image.

   The Corner Pin parameter category has a button for each corner, letting you pin one corner at a time.

Returning a Corner to the Default Position

To return a corner to the default position:

1. In the Corner Pin parameter category, click the button for the corner you want to reset.

2. Alt+click (Windows) or Option+click (Macintosh) the Corner Pin Enable button.
Creating a Stamp

The Stamp category of the 3D Warp effect allows you to make certain effects — such as titles and Matte Key effects — remain on screen while other effects come and go, even though the effect segment itself has ended. For example, you can stamp a product or channel logo onto the lower corner to act as a type of watermark effect without adding additional layers onto the sequence.

In the following example, two effects (one Title effect and one imported Matte Key effect) are applied sequentially on the top track. Each one has Stamp enabled on the last keyframe. Enabling Stamp lets each element remain in place as the next element appears on the screen.

Both elements remain in place, and you could add additional stamps until you enable Clear to clear the Stamp buffer.

The first element zooms into position from full screen. The first element is then “stamped” in place on the last keyframe. The second element appears and is also stamped in place.
**Creating Custom 3D Effects**

**To create a stamp:**

1. Create the image you want to use as a stamp.
   - For example, you can use the Title tool to create a title or you could import a PICT image. For more information, see Chapter 10.
2. Create a segment with at least two video tracks. For more information, see “Editing in Source/Record Mode” in the Help.
   - If you want the stamp to be in the foreground, it has to be on the top track.
3. Add the track with your stamp image to the segment.
   - For more information, see “Entering Effect Mode” on page 82.
4. Enter Effect mode by selecting Toolset > Effects Editing.
5. Click the 3D Promote button to turn on the 3D parameters.
6. Select the keyframe indicator where you want the stamp to occur.
   - If you do not want to use the first or last keyframe, add a keyframe where you want the stamp to occur.
7. In the Stamp parameter category, click the Enable button.
   - You can enable Stamp on more than one keyframe by repeating steps 6 and 7.
8. To review your edit, click the Play button or the Play Loop button.

**To clear a stamp:**

1. Select the keyframe where you want the stamp to be cleared.
2. In the Stamp parameter category, click the Clear button.
   - Everything in the Stamp buffer is cleared.
Chapter 8  Working with 3D Effects

Using Axis for a Transition

The effect created in this example uses changes to axis and rotation to create a transition. If you move the axis in Z, the point of rotation moves off the object and creates a “barrel roll” effect as if the object is inside a rolling barrel. By breaking the move into two parts, you can add another shot on the reverse side of the image.

To use axis for a transition:

1. Create a two-track sequence.
2. Apply the 3D Warp effect to the segment on the second track. For more information, see “Applying the 3D Warp Effect” on page 349.
3. Make the effect at least 5 seconds long.
4. With both keyframes selected, set Z to –90 in the Axis parameter category.
5. Select the second keyframe and set Y to –180 in the Rotation parameter category.
6. Play the effect to see the simple YZ barrel roll.
7. Go back 3 seconds from the end of the effect and add a new keyframe.
8. Copy the last keyframe values to the new keyframe.
9. Duplicate this new keyframe 1 second later by copying and pasting so that the last three keyframes are identical.
   The frame stays at the half barrel roll position for 3 seconds.
10. Select the last keyframe and set Z to 180 in the Position parameter category.
    This should bring the frame full screen for the new ending position.
11. Play the effect.
    It should do a half barrel roll back, stay in position, and then move forward.
12. Find the point during the half barrel roll where the image is edge on to the viewer.
    The image should disappear and reappear with the back of the image showing.
Creating Custom 3D Effects

13. Perform an add edit at this point.
   
   This divides the effect in two with the correct keyframes being sent to the correct parts of the clip.

14. Load the incoming video into the Source monitor, and mark it so that you can use it for the back of the image.

15. Step into the second part of the effect until all you see in the Timeline is the original video.

16. Mark the clip and replace it with the new shot.

17. Step out and play the effect.

   Notice that the new incoming shot is reversed.

18. Step back in and apply a Flop effect to the incoming image.

19. Render the Flop effect.

20. Step out again and play the effect.

   The incoming shot correctly transitions to full screen at the end of the effect.

Applying a Chroma Key Effect

Like matte keys, chroma keys are used to replace an area of one shot with another shot. However, unlike matte keys, the area of replacement is determined by a single highly saturated color, usually a distinctive blue or green. The foreground object, such as a person, is shot in a studio in front of a screen of the selected color. Then the background is keyed out with a more desirable background, such as a weather map, an outdoor scene, or computer-generated animation.

Chroma keys work better when you use component sources that have been captured as a component signal. You can achieve this using a component format, such as Betacam SP® or D1. Proper lighting is also crucial to separating the foreground image from the chroma key color background.
Chapter 8  Working with 3D Effects

To apply a Chroma Key effect:

1. Edit the foreground image onto track V2 and the background image onto track V1 in the Timeline.

2. Apply the 3D Warp effect to track V2. For more information, see “Applying the 3D Warp Effect” on page 349.

3. Open the Foregnd (foreground) parameter category, click the Fast Menu button, and select Chroma Key.

4. Click the Color Preview window, and press and hold the mouse.

5. When the eyedropper appears, drag it to the most representative area of color to be keyed and release the mouse.

When selecting a color, stay away from corners of the frame or the area immediately around the foreground because these areas might contain subtle shades of gray.

When you are finished, the application replaces the color with the video on track V1.

6. (Option) If your Avid application includes the 3D Spill Suppression parameter category, use Spill Suppression if necessary to remove spill in the foreground image.

7. (Option) Use the sliders in the Foregnd parameter category to make refining adjustments to improve the look of the key.
Using Xpress 3D Effects

The Effect Palette contains an Xpress 3D Effect category.

The Xpress 3D effects are completely compatible with Avid Xpress® editing applications that are also equipped with the 3D Effects option. As a result, you can move sequences containing Xpress 3D effects between Avid applications.

To maintain compatibility when transferring sequences between Avid applications, use only Xpress 3D effects. Do not use the 3D Warp effect to create 3D effects.

Xpress 3D effects provide a fast way to apply basic 3D effects to your sequence, without using the 3D Warp effect to make custom adjustments. For example, the 3D Page Curl effect automatically creates a page curl effect when you apply it.

You can further adjust Xpress 3D effects in the Effect Editor; use the 3D Warp effect, however, when you need finer control of 3D effects parameters.
Chapter 9
Creating Titles and Graphic Objects

The Title tool enables you to create titles that incorporate text, graphic objects, imported graphics, and video. This chapter explains how to create titles, including graphic objects. Throughout this chapter, the term “title” refers to both text and graphics.

Your Avid editing application also has the Marquee® Title tool. You can promote titles created using the Title tool to Marquee titles. Titles promoted to or created in Marquee cannot be edited with the Title tool. For information on Marquee titles and the Marquee Title tool, see the Avid Marquee Title Tool User’s Guide or the Help.

- Workflow for Creating and Editing Titles
- Opening the Title Tool
- Understanding the Title Tool
- Setting Up the Drawing Environment
- Working with Text
- Working with the Drawing Tools
- Creating Graphic Objects
- Creating Rolling and Crawling Titles
- Selecting Colors and Setting Transparency
- Working with Shadows
- Manipulating Objects
Chapter 9  Creating Titles and Graphic Objects

- Saving Titles and Title Styles
- Creating and Using Title Templates
- Working with Titles on Systems with 24p or 25p Support
- Saving and Recalling Title Styles
- Exporting a Title as a Graphics File

Workflow for Creating and Editing Titles

The following is an overview of the tasks you perform to create a title:

- **Set up the drawing environment.** After you open the Title tool, you can choose whether to display a color background or a frame of video from your sequence. You can also use safe colors or safe title and action guidelines or apply a grid for the placement of objects.

- **Create a new title with the Title tool.** You create the title by working with text and graphic objects and then applying and adjusting borders, colors, transparency, and shadows.

- **Save the title and exit the Title tool.** When you save a new title, you select a resolution that is compatible with your project and a target drive for the title media. You can also save just the styles for the title for future use. When you close the Title tool, the new title appears in the bin and in the Source monitor, ready for editing.

These basic procedures are described throughout this chapter. For information on editing a title into a sequence, see Chapter 10.

*You have some additional options available on 24p or 25p projects when you are working with titles. For more information, see “Working with Titles on Systems with 24p or 25p Support” on page 443.*
Opening the Title Tool

To open the Title tool:

1. In the Record monitor, move the position indicator to the video frame to be used as a reference.

   If you are not using video as the background, you can ignore this step. For more information, see “Selecting a Background” on page 394.

2. Do one of the following:
   - Select Clip > New Title.
   - Select Tools > Title Tool.

   A dialog box opens.

3. Do one of the following:
   - To use the Marquee Title tool, click Marquee.
     The Marquee Title tool opens. For information on Marquee titles and the Marquee Title tool, see the Avid Marquee Title Tool User’s Guide or the Help.
   - To use the Title tool, click Title Tool.

   The Title tool opens. The Text tool is automatically selected, and the pointer becomes an I-beam, ready for entering text.

For the current session, if you know you want to create only Marquee titles or only standard titles, select Persist before you click Marquee or Title Tool. For the rest of your editing session, the application will automatically open the title tool you selected. You turn off automatic selection from the Settings scroll list: open the Marquee Title Setting dialog box and click Ask Me.
Understanding the Title Tool

The following illustration shows a title over a video background.

The Title tool has several major components:

- A video background based on a sequence or a color background that you create.
- The title or graphic in the foreground that you create.
- The safe title and safe action area guidelines. For more information, see “Using Title and Action Guidelines” on page 394.
- The toolbar at the bottom of the screen. For more information, see “Understanding the Toolbar” on page 389.
- In addition, there are title-related menu items in the File, Edit, Object, and Alignment menus. These menu items are described throughout this chapter.
# Understanding the Toolbar

At the bottom of the Title tool are tools and menus you can use for creating and editing text and objects. They work much like similar tools in other draw and paint programs.

Table 17 briefly describes each section of the toolbar.

## Table 17 Title Toolbar Elements

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection tool</td>
<td>Changes the pointer to an arrow and allows you to select text or objects for operations. See “Using the Selection Tool” on page 391.</td>
</tr>
<tr>
<td>Text tool</td>
<td>Changes the pointer to an I-beam and allows you to enter text. See “Working with Text” on page 398.</td>
</tr>
<tr>
<td>Video Placement tool</td>
<td>Changes the pointer to a hand and allows you to pan around the entire video clip within the Title tool.</td>
</tr>
<tr>
<td>Drawing tools</td>
<td>Allow you to draw boxes, circles, ovals, and lines. See “Creating Graphic Objects” on page 408.</td>
</tr>
<tr>
<td>Styles button</td>
<td>Displays (as a tear-off menu) examples of the styles you defined and allows you to select one. See “Recalling a Title Style” on page 449.</td>
</tr>
</tbody>
</table>

![Diagram of Title Toolbar Elements](image)
### Table 17  Title Toolbar Elements (Continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save Style Parameter button</td>
<td>Displays the Title Style sheet and allows you to modify it and save the changes. See “Saving a Title Style” on page 446.</td>
</tr>
<tr>
<td>Templates button</td>
<td>Allows you to create a standard format for text and graphics that you use regularly. The template prevents you from changing the position, colors, shadows, or graphics, which ensures consistency. See “Creating and Using Title Templates” on page 441.</td>
</tr>
<tr>
<td>Line attribute tools</td>
<td>Allow you to change the corners of boxes, line and border thickness, and arrowhead styles. See “Selecting Line Attributes” on page 410.</td>
</tr>
<tr>
<td>Background Selection tools</td>
<td>Allow you to switch between a video and an opaque background and change the color of opaque backgrounds. See “Selecting a Background” on page 394.</td>
</tr>
<tr>
<td>Text formatting tools</td>
<td>Allow you to set various text attributes such as font, font size, kerning, and leading. See “Formatting the Text” on page 401.</td>
</tr>
<tr>
<td>Color Selection boxes</td>
<td>Allow you to change the color of text and objects. See “Selecting Colors and Setting Transparency” on page 421.</td>
</tr>
<tr>
<td>Transparency Level boxes</td>
<td>Allow you to change the transparency levels of text and objects. See “Adjusting the Transparency” on page 424.</td>
</tr>
<tr>
<td>Color and Transparency Blend tools</td>
<td>Allow you to create a blend between two colors or two transparency values. See “Blending Two Colors in an Object” on page 423.</td>
</tr>
<tr>
<td>Shadow tools</td>
<td>Allow you to create drop shadows and depth shadows for text and objects and to preview the degree of softness set for shadows. See “Working with Shadows” on page 425.</td>
</tr>
</tbody>
</table>
Table 17  Title Toolbar Elements (Continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crawling Title</td>
<td>Allows you to create crawling titles. See “Creating Rolling and Crawling Titles” on page 413.</td>
</tr>
<tr>
<td>button</td>
<td></td>
</tr>
<tr>
<td>Rolling Title</td>
<td>Allows you to create rolling titles. See “Creating Rolling and Crawling Titles” on page 413.</td>
</tr>
<tr>
<td>button</td>
<td></td>
</tr>
</tbody>
</table>

Using the Selection Tool

The Selection tool is one of the most frequently used tools. You use the Selection tool when performing certain operations on objects you create, such as moving, formatting, resizing, or applying color.

To select an object:

- Click the Selection tool, and then click an object.
  
  Selection handles appear around the object.

You can press the Alt key (Windows) or Option key (Macintosh), and click anywhere in the Title tool to switch between the Selection tool and the Text tool. You can also press and hold the Ctrl and Alt keys (Windows), or the Ctrl and Option keys (Macintosh), to display the Selection tool temporarily at any time.
To select multiple objects, do one of the following:

- Shift+click with the Selection tool.
- Click outside the objects, and drag to surround the objects with a lasso.

After you use a tool in the toolbar, the Title tool reverts to the Selection tool, and the pointer becomes an arrow. To prevent a tool from automatically reverting to the Selection tool, double-click the tool’s icon.

Setting Up the Drawing Environment

This section describes some aspects of the Title tool that you can use to set up your titling or drawing session.

You can set or change these features at any time during your work on a title. These settings are stored with User settings and will appear each time a particular user opens the Title tool.

Installing Fonts

You can apply any font that is installed on your system when creating titles in the Title tool. When installing and using fonts, consider the following:

- If you want to apply a special font that is not currently on the system, you must install the font first before creating titles.
- If you are bringing a project from another system, check to make sure you have installed any fonts used in titles contained in the project. These fonts must match exactly (you cannot use variations of the font in the same font family). If the Title tool does not recognize a font contained in a title, the Font Replacement dialog box opens to enable you to substitute an alternative font.
- If you are bringing a project from one platform to another (Macintosh platform to Windows platform, or Windows platform to Macintosh platform), you might need to substitute a font from the new platform for an existing font in the project. Windows and Macintosh fonts
sometimes differ even when they have the same name. If the Title tool does not recognize a font contained in a title, the Font Replacement dialog box opens to enable you to substitute an alternative font.

- If you intend to create titles with font sizes of 128 points or larger, use TrueType® fonts. Some fonts cannot display consistently at sizes of 128 points or higher, but TrueType fonts can accommodate larger font sizes.

For more information on installing fonts, see your Windows system documentation or your Macintosh system documentation.

Previewing Titles

Text and objects in titles are created anti-aliased with an 8-bit alpha channel. Anti-aliasing ensures that text, lines, and object edges appear smooth, regardless of size. You can preview a title to see the title drawn with anti-aliasing, just as it will be saved.

To switch the display of anti-aliased titles on or off:

- Select Object > Preview.
  
  A check mark indicates that Preview mode is enabled.

Titles are always saved in anti-aliased format.

The display behavior for title objects in Preview mode is as follows:

- You can alter the graphics characteristics of title objects (including colors, shadows, borders, and transparency) without losing the anti-aliased preview.

- You can select text objects and apply text styles from the Styles pop-up menu without losing the anti-aliased preview.

- When you click a text object for editing, the Title tool displays the text without anti-aliasing. When you finish editing the text and click outside the object to deselect it, the Title tool restores the anti-aliased preview.
Chapter 9  Creating Titles and Graphic Objects

Using Title and Action Guidelines

By default, the Title tool displays two outlined boxes to use as guidelines (see the illustration at the beginning of the section “Understanding the Title Tool” on page 388). The inner box is the safe title area. All text for television broadcast should remain within this inner box. The outer box is the safe action area for video display. These guidelines are self-adjusting for PAL and NTSC projects.

You can customize the Effect Grid display. For more information, see “Working with the Effect Grid” on page 88.

To display the safe title area or safe action area guidelines:
- Select Object > Safe Title Area/Global Grid.

Using Safe Colors

If you plan to use your title for television broadcast, you can select the Safe Colors command from the Object menu. This command displays only low saturation colors for use in text, objects, and background. Colors with low saturation look best when combined with video. By default, Safe Colors is turned on.

To display only safe colors:
- Select Object > Safe Colors.

Selecting a Background

Use the Video Background button to switch between a video background and an opaque color background.
Using a Video Background

If there is a sequence in the Record monitor, the Title tool opens with a video background. The location of the position indicator in the Timeline at the time you open the Title tool determines the initial video frame that displays. If there is no sequence in the Record monitor, the Title tool opens with no video showing (the background appears black).

The Video Background button is green when you are creating a title for display over a video background.

Use the background video frame as a reference. It does not become part of the title you create. You can edit the title anywhere else in the current sequence or in another sequence.

Updating the Video Background

You can update the video background at any time while creating titles within the Title tool.

To update the video background:

1. Click the Video Background button in the toolbar to activate video background if you have not already done so.
2. Load the sequence into the Record monitor.
3. Move the position bar in the Timeline or in the monitor to display the new frame.
4. Click again in the Title tool to activate its window.
   The background is updated to reflect the current contents of the Record monitor.
Creating a Color Background

To create a title that appears over an opaque color background:

1. Click the Video Background button to switch off the video background if it was previously turned on.
2. Click and hold on the Background Color window.
   The Title Tool Color Picker dialog box opens.
3. Use the Title Tool Color Picker dialog box, eyedropper, Windows Color dialog box, or Macintosh Color Picker to select a color. For a description of how to use these tools, see “Selecting Colors and Setting Transparency” on page 421.
   The default background color is black.

- When you create a title with a color background, it is opaque and it cannot be used to key over video.
- You cannot create rolling or crawling titles with a color background. You can create a separate color background as a title and then edit the rolling or crawling title over it in the sequence.

Displaying a Grid

You can display a grid to help you position text and objects. The visible grid does not appear when you save the title.

To display a grid:

- Select Alignment > Show Alignment Grid.

Snapping to a Grid

The snap grid is an invisible grid that helps position and connect objects. The snap grid has four lines for each line in the visible grid. Each square in the grid is subdivided by four invisible vertical and horizontal grid lines. Text and objects can snap to these lines.
To snap to a grid:

- Select Alignment > Align to Grid.

When you create or drag an object in the Title tool, the object snaps to the nearest grid line.

**Bringing the Title Tool to the Foreground**

If the Title tool becomes obscured by another window, you can instruct the application to redisplay the tool.

To bring the Title tool to the foreground, do one of the following:

- Select Windows > Title Tool.
- Select Tools > Title Tool.

**Using the 16:9 Display Format for Titles**

The Title tool supports the 16:9 aspect ratio for display of NTSC and PAL footage. The 16:9 option allows you to display the full-aspect ratio of wide-screen video used in the high-definition television (HDTV) format.

When you select the 16:9 option in the Composer settings, the Title tool increases its maximum horizontal size, and saved titles appear correctly in the Source and Record monitors set to 16:9.

*Because the 16:9 aspect ratio extends the horizontal dimensions of the footage, when you first open the Title tool in 16:9 mode, you must use the Video Placement tool (the hand icon) to pan back and forth to view footage on the sides. To automatically resize the tool to fit the monitor, click the Maximize button in the upper right corner of the Title tool.*

For more information on HDTV and the 16:9 option, see “Using the 16:9 Display Format” in the Help.
Chapter 9  Creating Titles and Graphic Objects

Working with Text

By default, the Text tool is active when you open the Title tool, and you can begin entering text as soon as you click in the Title tool.

**To use the Text tool at any other time:**

- Click the Text tool, click anywhere within the text object, and begin typing.

  An I-beam pointer indicates your position within the text. The Text tool remains selected until you select another tool.

**To switch between the Selection tool and the Text tool:**

- Press the Alt key (Windows) or Option key (Macintosh), and click anywhere in the Title tool.

*For information on previewing smooth text, see “Previewing Titles” on page 393.*

Creating Text

**To create text:**

1. Click the Text tool in the toolbar.
   
   The pointer becomes an I-beam.

2. Click the position in the frame where you want to add text.

   An insertion point appears.

3. Type the text.

   To insert a line return, press Enter (Windows) or Return (Macintosh).

*Text is word-wrapped automatically as you type. You can adjust the wrapping by changing the width of the text object. For more information, see “Resizing Text Objects” on page 400.*

4. When you have finished typing, click the Selection tool in the toolbar to deselect the text object.
When you create text that is aligned on the left side using left justification (the default), you can eliminate the unused space on the right side of the newly created text object, especially if you want to use the Alignment menu commands.

To eliminate unused space:
- Click the middle selection handle on the right side of the text box, and drag it to the left until it is closer to the text.

Copying and Pasting Text

You can copy and paste text into the Title tool directly from a word processing or text editing application.

There is a limit to the size of text objects you can create in the Title tool. Avoid pasting large blocks of text (numerous pages in a word processor) into the Title tool. Instead, consider pasting smaller blocks of text into separate text objects.

Also see “Page Count Limits for Rolling and Crawling Titles” on page 414.

To copy and paste text into the Title tool:

1. Click the Text tool in the toolbar.
   The pointer becomes an I-beam.
2. Click the position in the frame where you want to add text.
   An insertion point appears.
3. Open the text file in a word processor or text editor.
4. Select the text in the word processor or text editor.
5. Do one of the following:
   - Select Edit > Copy.
   - Press Ctrl+C (Windows) or ⌘+C (Macintosh).
6. Click the Title tool again to activate it.
7. Paste the text into place at the insertion point by doing one of the following:
   - Select Edit > Paste.
   - Press Ctrl+V (Windows) or ⌘+V (Macintosh).

The pasted text takes on the attributes currently set in the Title Tool toolbar.

**Resizing Text Objects**

When you resize a text object, the text remains the same size but rewraps to fill the reshaped area.

**To resize a text object:**

1. Click the Selection tool, and click the text object.
2. Click one of the object selection handles for width, and drag to resize.

*You can resize only the width of a text object. The height of a text object is automatically determined by the number of words and the size of text.*

**Repositioning Text Objects**

**To reposition a text object:**

1. Click the Selection tool, and click the text object.
2. Move the text by doing one of the following:
   - Click in the middle of the object, and drag it to a new position.
   - Use the arrow keys to move the object one pixel at a time.
   - Use commands in the Alignment menu to position the text. For more information, see “Aligning Objects” on page 433.
Editing a Text String

To edit an existing text string:

1. Click the Text tool, and click anywhere in the text.
2. You can perform the following tasks:
   - Use the arrow keys to move around within the text string.
   - Type additional characters.
   - Press Enter (Windows) or Return (Macintosh) to insert a line return.
   - Drag to select characters.
   - Use the Cut, Copy, and Paste commands from the Edit menu.
   - Use the Delete key.
   - Change the formatting of the selected text, as described in “Formatting the Text” on page 401.

Formatting the Text

The text formatting tools control the appearance of text. You can click a text object with the Selection tool to format all the text within it, or you can use the Text tool to select a string of text within a text object to format individual characters or words.

You can modify the following text attributes for either a text object or a selected text string:

- Current font
- Bold and italic
Creating Titles and Graphic Objects

- Point size
- Kerning
- Leading

You can modify the following attributes for an entire text object only:
- Color (see “Adjusting the Color” on page 421)
- Transparency (see “Adjusting the Transparency” on page 424)
- Drop and depth shadows (see “Working with Shadows” on page 425)
- Outlined text (see “Selecting a Line or Border Width” on page 410)
- Justification (see “Justifying the Text” on page 404)

While you type text, only the text color is apparent. Shadows, outlines, and other color attributes appear when you finish typing the text and click the Selection tool.

If you want to create text elements in the title with different appearances, create a separate text object for each set of attributes.

Setting the Default Text Attributes

When you start the application and open the Title tool, it uses default text attributes. You can change the defaults at any time. Changes you make to the default text attributes apply until you quit the application.

To change the default text attributes:

1. Click the Selection tool.
2. Click in the Title tool but do not select any text.
3. Change any of the text attributes.

Now whenever you start typing a new text string, the Title tool uses your new defaults.
Selecting a Font

The Font Selection button displays the name of the current font for a text selection and allows you to change the font. When you first open the Title tool, the font listed is the preferred system font.

To display all the fonts currently installed on the system:
- Click the Font Selection button.

To change the font:
- Click the Font Selection button, and select a font.

The Title tool displays the name in the Font Selection button and uses this font for text until you change it during the editing session.

When you select a text object, the Font Selection button displays the name of the font in the text object.

Changing the Point Size

The point size controls the size of the selected text. A point is a typographical unit of measure. There are 12 points to the pica and 72 points to the inch.

You can enter a point size either before or after you type text.

To change the point size, do one of the following:
- Click the Point Size button, and select a standard point size.
- Double-click in the text box, type a point size between 5 and 999, and then press Enter (Windows) or Return (Macintosh).
- Click in the text box, and use the Up Arrow and Down Arrow keys to change the value incrementally.
Chapter 9  Creating Titles and Graphic Objects

Making Text Bold or Italic

The Bold button and the Italic button are located under the Point Size text box.

The Object menu also contains commands for bold and italic.

To make text bold or italic:
1. Select the text you want to change.
2. Do one of the following:
   ▶ Click the Bold button or the Italic button.
   ▶ Select Object > Bold or select Object > Italic.

To remove bold or italic formatting:
▶ Repeat the procedure.

Justifying the Text

Below the Font Selection button are the buttons for text justification. Text justification controls the alignment of text in an existing text object and also when you type text in a new text object.
To justify the text, do one of the following:

- Click the left text justification button to align text with the left side of the text object.
- Click the center button to center the text.
- Click the right button to align text with the right side of the text object.

Kerning the Text

Kerning improves the appearance of titles by controlling the amount of space between characters. You can expand or condense the character spacing to make text more readable or to create special effects, such as dramatically expanded spacing in a title.

The text kerning controls are located beneath the text justification buttons.

You can kern the text for an entire text object, or you can manually kern individual character pairs or character strings. For example, if you mix italic and plain versions of a font in a title, you might want to adjust the spacing between characters.
You use the Kerning button to select predefined kerning options or the Kerning text box to specify your own custom kerning value. Positive numbers increase the spacing; negative numbers decrease the spacing. You can also use the arrow keys to make incremental adjustments.

For individual characters or selected groups of characters, you can use only the arrow keys to adjust kerning.

You can select the kerning value before you type text.

### Adjusting Kerning Manually

**To adjust kerning manually with the arrow keys:**

1. Click the Text tool in the toolbar.
2. Click between a character pair, or select a group of characters to be kerned.
3. Press the Alt key (Windows) or Option key (Macintosh), and use the Left Arrow key or the Right Arrow key to increase or decrease the kerning.

### Using the Predefined Kerning Sizes

**To adjust kerning with predefined sizes:**

1. Select the text.
2. (Option) Click the Kerning button, and select Pair Kerning to eliminate excessive space between some character pairs.
3. Click the Kerning button, and select a kerning option:
   - *Loose* adds space between letters.
   - *Normal* leaves spacing unchanged.
   - *Tight* closes up the spacing between letters.

Pair kerning works only on fonts that support kerning tables (for example, Palatino).
Using the Kerning Text Box

To adjust kerning with the text box:
- Click in the Kerning text box, and type a positive or negative numerical value. Values are a percentage of the point size.
- Click in the Kerning text box, and use the Up Arrow and Down Arrow keys to change the value incrementally.

The Title tool applies the kerning to the entire text object.

Adjusting Leading

Use **leading** to adjust the line spacing between lines in a title. Leading is measured in points, from baseline to baseline of the lines of text. The Title tool uses the leading that is built into the font as the default. Positive leading values add space; negative values decrease space. You might want to add leading for sans serif, tall, or boldface fonts, and for fonts with a strong vertical emphasis.

To set leading:
- Click in the Leading text box, and type a number to indicate the leading value you want.

The Title tool adjusts leading immediately.
Chapter 9  Creating Titles and Graphic Objects

Working with the Drawing Tools

The drawing tools enable you to draw graphic objects such as squares, rectangles, circles, ovals, and lines. To use the drawing tools, select one of these shapes.

After creating graphic objects, you can change the following attributes:

- To round the corners of a box, adjust the width of lines and text borders, or add arrowheads to lines, see “Selecting Line Attributes” on page 410.
- To change or blend colors in a graphic object, see “Adjusting the Color” on page 421.
- To apply a drop or depth shadow, see “Working with Shadows” on page 425.
- To add transparency to an object or an object’s shadow, see “Adjusting the Transparency” on page 424.

By default, when you use a drawing tool and deselect the created object, the pointer reverts to the Selection tool. To avoid this, double-click the drawing tool when you select it in the Title tool toolbar.

Creating Graphic Objects

This section provides procedures for using the Title tool to create graphic objects.
Drawing a Square or Rectangle

To draw a square or a rectangle:
1. Click the Square and Rectangle tool in the toolbar.
   The pointer becomes a crosshair pointer.
2. Click in the Title tool, and drag to create an object.

Pressing the Shift key while you drag constrains the Square or Rectangle tool to create a square.

Drawing a Circle or Oval

To draw a circle or an oval:
1. Click the Oval tool in the toolbar.
   The pointer becomes a crosshair pointer.
2. Click in the Title tool, and drag to create an object.

Pressing the Shift key while you drag constrains the Oval tool to create a circle.

Drawing a Line

To draw a line:
1. Click the Line tool (slanted line) in the toolbar.
   The pointer becomes a crosshair pointer.
2. Click in the Title tool, and drag to create a line.

Pressing the Shift key while you drag constrains the Line tool to create a horizontal or vertical line.
Selecting Line Attributes

Use the line attribute tools to round the corners of a box, to select the width of lines and borders, and to add arrowheads to line endpoints.

You can also change the following drawing attributes:

- Color (see “Adjusting the Color” on page 421)
- Transparency (see “Adjusting the Transparency” on page 424)
- Drop and depth shadows (see “Working with Shadows” on page 425)

If you do not select an object and you select a line attribute, the Title tool makes that the default for any new objects that you create.

Rounding Corners

To round box corners:

1. Select a box.
2. Click the Box Corner button, and do one of the following:
   - Select a standard rounding option.
   - Specify a custom corner radius by doing the following:
     a. Select the Custom Radius option.
     b. Type a whole number (in pixels) into the dialog box.
     c. Click OK.
     The maximum custom radius is 200.

Selecting a Line or Border Width

You can use the Border Width button to change the width of lines created with the drawing tools or to apply a border outline to text or graphic objects.
Creating Graphic Objects

To select a line or border width:

1. Select an object (such as a line, shape, or text object).
2. Click the Border Width button, and do one of the following:
   - Select from the standard widths.
   - Specify a custom width by doing the following:
     a. Select the Custom Width option.
     b. Type a whole number (in pixels) into the dialog box.
     c. Click OK.

   If you selected a line for modification, the width of the line changes. If you selected an object for modification, the width of the border changes.

To remove a border:

- Click the Border Width button, and select the Remove Border option.

Adding Arrowheads

To add arrowheads to a line:

1. Select a line.
2. Click the Arrowhead button, and do one of the following:
   - Select a standard arrowhead style.
   - Select the Edit Arrowhead option and specify a custom arrowhead as described in “Changing Arrowhead Size” on page 412.

To remove an arrowhead:

- Click the Arrowhead button, and select the Remove Arrowhead option.
Changing Arrowhead Size

To change the arrowhead size:

1. Select a line.
2. Click the Arrowhead button, and select the Edit Arrowhead option.

   The Arrowhead Size dialog box opens.

3. Click the handle on the arrowhead, and drag it vertically or horizontally to resize and reshape it.

   The shape of the arrowhead is in proportion to the line width.

4. Click OK.

   The line changes to show the new arrowhead shape.

To remove an arrowhead:

1. Select a line.
2. Click the Arrowhead button, and select the Remove Arrowhead option.
Creating Rolling and Crawling Titles

You can create title text and graphics that roll up the screen or crawl across the screen. You create the title in the Title tool and refine the motion during editing.

Crawling titles are non-real-time effects. You can step through the effect in a Source monitor, the Composer monitor, or the Effect Preview monitor, but you must render the effect to play it.

Rolling titles scroll vertically, moving from top to bottom or from bottom to top, as shown in the following example.

Crawling titles scroll horizontally, moving from right to left or from left to right, as shown in the following example.

You cannot save a rolling title or a crawling title with a color background even though you can set the Title tool to display a color background while you create a rolling title or a crawling title. To place your rolling title or crawling title over a color background, you must export the background as a PICT file, reimport it (with Ignore Existing Alpha selected in the Import dialog box), edit it into your sequence, and then edit your title onto a new layer above the background graphic.
Page Count Limits for Rolling and Crawling Titles

Rolling and crawling titles form pages in the Title tool that are similar to the pages you create with a word processor. A page in a rolling or crawling title is a unit the size of a PAL or NTSC frame.

The Avid application limits rolling and crawling titles to a maximum of 66 pages for NTSC projects and 56 pages for PAL projects. Typing more text, increasing the size of the font, or adjusting kerning and leading all affect the number of pages in the title.

- If you reach the page count limit while you are typing text, the title stops getting bigger and text entry stops.
- If you attempt to change the text formatting in a way that would make the title exceed the page count limit, a message box opens. To cancel the operation and keep the title within the page count limit, click OK.

Using Auto Size Mode for Rolling and Crawling Titles

Auto Size mode causes the Title tool to add or remove pages automatically as you add, delete, or reformat the text. Auto Size mode is active by default when you click the Rolling Title button or the Crawling Title button.

You can turn off Auto Size mode if you want to add extra pages before or after the text (for example, to make room for additional title elements). For more information on adding extra pages with Auto Size mode turned off, see “Adding Pages to a Rolling Title or a Crawling Title” on page 418.

To switch Auto Size mode off or on:

- Select Object > Auto Size Mode.

  A check mark indicates that Auto Size mode is on. Deselect Auto Size Mode to turn it off.
Setting Up Text Formatting for Rolling and Crawling Titles

Before creating a rolling or crawling title, set the text formatting defaults for attributes such as font, point size, leading, and kerning.

To set the defaults, see “Setting the Default Text Attributes” on page 402.

When you type the text for a rolling or crawling title, lines of text wrap within the safe title area, and the title scrolls down as you type. For rolling titles, this provides you with a sense of positioning, word wrap, and page count limitations.

Workflow Options for Creating Crawling Titles

Unlike rolling titles, which scroll in the direction of the roll as you type the text, crawling titles do not scroll horizontally in the direction of the crawl during typing. When you create crawling text, consider the following workflow options:

- Type the text first as a rolling title. This allows you to view the text as it scrolls down during typing, and also provides you with a scroll bar on the right side of the screen for moving quickly through the text. You can then click the Crawl button in the toolbar to convert the text to a crawling title before resizing, reformatting, and saving the title.

- Begin typing with a small font size, such as 12 point, to view as much of the text in the window as possible before changing the font size and resizing the text box in a horizontal direction.

To set the defaults, see “Setting the Default Text Attributes” on page 402.

- Several options give you control over text and other objects in the Title tool. You can create objects and move or copy them to specific pages, insert pages, and delete pages. For more information, see:
  - “Copying or Moving Objects to Pages in a Rolling Title or a Crawling Title” on page 419
  - “Inserting Blank Pages in a Rolling Title or a Crawling Title” on page 419
  - “Deleting Pages in a Rolling Title or a Crawling Title” on page 420
Chapter 9  Creating Titles and Graphic Objects

Typing the Text in a Rolling Title or a Crawling Title

To type rolling or crawling title text:

1. Do one of the following:
   - Select Clip > New Title.
   - Select Tools > Title Tool.
   The Title tool opens.
2. Click the Text tool in the toolbar.
3. Do one of the following:
   - Click the Rolling Title button to enter Rolling Title mode.
   - Click the Crawling Title button to enter Crawling Title mode.
   The button changes to green, and a Page Number text box appears in the lower right corner of the Title tool.
4. Type the title text.
   The text wraps automatically as you type.
5. When you are finished, click the Selection tool in the toolbar to select the new text object.

You cannot create rolling and crawling titles over a color background, although you can preview them with a color background. For rolling and crawling titles, the Background Selection tools are set to Video Background and the Video Background button changes to green.
Resizing the Width of a Rolling Title or a Crawling Title

You resize titles by manipulating their object selection handles.

To resize a rolling title or a crawling title:

1. Click the Selection tool, and click the title object.
2. Click the object selection handle, and drag to resize the title until it appears as you want.

You can resize only the width of a rolling title or crawling title. The Title tool automatically determines the height of your title by the amount of text it contains.

If you resize a crawling title, save it before rendering to ensure the correct rendering result.

Use the Make Crawl command after you enter and edit your crawling title text. Make Crawl transforms the title into a single-line text object and positions it on the lower third of the screen.

To position a crawling title:

- Select Object > Make Crawl.

Scrolling Through a Rolling Title or a Crawling Title

When you create a rolling title or a crawling title, a scroll bar appears along the right side of the Title tool video background for moving vertically through the rolling title, and at the bottom for moving horizontally through a crawling title.

To scroll through a rolling title or a crawling title, do one of the following:

- Use standard techniques for scrolling, such as clicking the arrow icons, dragging the scroll box, or clicking in the scroll bar.
- Press the Home or the End key to go to the beginning or end of the title.
Creating Titles and Graphic Objects

- (Rolling titles only) Press the Page Up or the Page Down key on the keyboard to move through a rolling title one page at a time.
- (Rolling titles only) Press the Up Arrow or the Down Arrow key to move the pointer through a rolling title one line at a time.

Going to a Page in a Rolling Title or a Crawling Title

When you first create a rolling title or a crawling title, a Page Number text box appears in the lower right corner of the Title tool. The Page Number text box reflects your current position in the title.

To go to a different page:
1. Click the Page Number text box.
2. Do one of the following:
   - Type a page number for a specific page.
   - Use the Up Arrow and Down Arrow keys to cycle through the page numbers.
3. Press Enter (Windows) or Return (Macintosh).
   The selected page appears.

Adding Pages to a Rolling Title or a Crawling Title

You can add pages to a rolling title or a crawling title to create space for new elements.

To add pages:
1. If Auto Size mode is on (a check mark appears next to Auto Size Mode in the Object menu), turn it off by selecting Object > Auto Size Mode.

   The Add Page command is not available when Auto Size mode is on.

2. Select Object > Add Page.

   The Title tool adds a page to the end of the title. You can select Add Page repeatedly to continue adding pages up to the maximum page count.
3. Select text or graphic objects in the title and position them within the range of available pages, or create new elements.

## Copying or Moving Objects to Pages in a Rolling Title or a Crawling Title

**To copy or move an object to a title page:**

1. Create a text block or any other title object.
2. Select the object.
3. Do one of the following:
   - Select Object > Copy to Page.
     The Copy to Page dialog box opens.
   - Select Object > Move to Page.
     The Move to Page dialog box opens.
4. Type a page number, and then click OK.
   The object is copied or moved, and the Title tool automatically adds pages if necessary.

## Inserting Blank Pages in a Rolling Title or a Crawling Title

**To insert a blank page into a rolling title or a crawling title:**

1. Select Object > Insert Page.
   The Insert Page dialog box opens.
2. Type a page number, and then click OK.
   The Title tool inserts a blank page at that page number, and moves all objects after it by one page.
Chapter 9  Creating Titles and Graphic Objects

The Title tool inserts a page only if the left boundary of an object appears on the page whose number you typed. For example, you cannot insert a page in the middle of a long crawling title.

You cannot use the Insert Page command to add a blank page to the end of a roll or crawl.

Deleting Pages in a Rolling Title or a Crawling Title

To delete empty pages from a rolling title or a crawling title:

1. Select Object > Remove Page.

   The Remove Page dialog box opens.

2. Type the page number of the page you want to remove, and then click OK.

   If the page is empty, the page is removed and all pages after the removed page are moved by one page.

   If you select Object > Auto Size Mode, the Title tool removes excess pages at the end of the title.

Formatting Rolling and Crawling Titles

You can modify the text attributes of a rolling or crawling title with the same methods used to format still text elements:

- To adjust font, point size, style, justification, kerning, and leading, see “Formatting the Text” on page 401.
- To create outlines surrounding the text, see “Selecting a Line or Border Width” on page 410.
- To adjust color and transparency, see “Selecting Colors and Setting Transparency” on page 421.
- To add a drop or depth shadow, see “Working with Shadows” on page 425.
Selecting Colors and Setting Transparency

You can select the color and transparency for text and graphic objects, for their shadows, and for their borders. The following illustration shows the boxes associated with color and transparency.

- The Color Selection boxes control fill (Fill), shadow (Shad), and border (Bord) color, respectively.
- The Transparency Level boxes control fill, shadow, and border transparency, respectively.
- The Color and Transparency Blend tools appear when you select a Fill or Border Color Selection box or Transparency Level box.
  - If you select a Color Selection box, the top boxes show the two colors that are used to create the blend. The bottom box shows the blended color and allows you to control the direction of the blend or transparency.
  - If you select a Transparency Level box, the top boxes show the two transparency values that are used to create the blend. The bottom box allows you to control the direction of the transparency blend.

Adjusting the Color

The Title Tool Color Picker dialog box enables you to do the following:

- Select a color from the Title Tool Color Picker.
- Use an eyedropper to select a color from any open application on your computer.
- Use the Windows Color dialog box or the Macintosh Color Picker to select a color.
Chapter 9  Creating Titles and Graphic Objects

To select a color:

1. Select a text or graphic object. If you do not select an object, the color will be applied to the next object you create.

2. Click one of the Color Selection boxes in the toolbar:
   - **Fill** (Fill) applies the color to the selected object.
   - **Shadow** (Shad) applies the color to the selected object’s shadow.
   - **Border** (Bord) applies the color to the selected object’s outline or border.

   The Title Tool Color Picker opens.

   ![Diagram of the Title Tool Color Picker]

   You can drag the Color Picker from the toolbar to create a floating palette.

3. Select a color:
   - To select from the Title Tool Color Picker, drag the pointer along the color selection bar to the color you want, and then move the pointer down into the shade selection palette to select a shade. The color is applied when you release the mouse button.
   - To use the eyedropper, drag the pointer to the Eyedropper icon and release the mouse button. The pointer changes to the eyedropper. Click the color you want from anywhere in the window to apply the color to the selected object.
   - To use the Windows Color dialog box or the Macintosh Color Picker, drag the pointer to the Round Button icon under the eyedropper, and release the mouse button. The Windows Color dialog box or the Macintosh Color Picker opens. For more information, see “Using the Windows Color Dialog Box” on page 107 or “Using the Macintosh Color Picker” on page 108.
   - To select a grayscale value, click in the grayscale selection bar.
Blending Two Colors in an Object

The Title tool lets you blend two colors in a text or graphic object or in a border. You can also specify the direction of the blend.

\textit{You can blend the fill and border, but you cannot blend a shadow.}

To blend two colors:

1. Select text or another object.
2. Click the Color Selection box for either fill or border.
   The Color Blend tools appear.

3. Click one of the Color Blend Selection boxes, and select a color by using either the Title Tool Color Picker, the eyedropper, the Windows Color dialog box, or the Macintosh Color Picker.

4. Click the other Color Blend Selection box, and select the second color for your blend.
   The Blend Direction box appears below the two Color Blend Selection boxes. This box displays the blend and allows you to specify the direction of the blend (for example, left to right).
5. Click the Blend Direction box, and drag clockwise or counterclockwise to achieve the effect you want.

As you rotate the pointer, the position of the two colors rotates. The change takes effect as soon as you release the mouse button.

**Adjusting the Transparency**

After you select a color, you can select the color transparency. To do so, click the appropriate Transparency Level box, depending on whether the transparency will apply to an object or will adjust a shadow or outline around the selected object.

The Transparency Level box displays the text “Hi” with a background that changes from black to white. A completely white background represents a fully transparent object or portion of an object. The following illustration shows an example.

In the pop-up control that appears, drag the slider until you attain the transparency you want, and then release the mouse button. The Title tool immediately applies the transparency to your selection.

You might find it useful to turn off the shadow and shadow softness for an object while experimenting with transparency. Set the shadow value to zero in the Shadow Depth text box and the softness value to zero in the Soft Shadow dialog box, as described in “Working with Shadows” on page 425.
Blending Transparency of Fills and Borders

You can blend the transparency of fills and borders using a technique similar to blending colors. Use the Transparency Blend Selection boxes to set the blend values. Use the Blend Direction box to set the direction of the blend.

For more information on creating a blend, see “Blending Two Colors in an Object” on page 423.

Working with Shadows

You can add a drop shadow or depth shadow to text and objects. A drop shadow is offset from the title itself, as though cast by a light source. A depth shadow extends from the edges of the title, as though the title were three-dimensional. The following illustration shows an example of drop and depth shadows.
You can select the color, width, direction, and transparency for the shadow. You can also soften (blur) shadows or create a glow effect behind title text. You can place the shadow anywhere within the title without restriction. The following illustration shows the tools used to create and modify shadows.

### Applying Shadows

**To apply shadows to text or objects:**

1. Select text or an object.
2. Click the Drop and Depth Shadow button to switch between a drop or depth shadow.
3. Adjust the depth or direction of the shadow as follows:
   - Click the Shadow Depth and Direction button, and drag the shadow displayed to any position.
   - Press the Shift key; then click the shadow in the Shadow Depth and Direction button, and drag to restrict shadow placement to 45-degree angles around the title.
   - Press the Shift key, and use the arrow keys to move the shadow to any position around the title.
   - Type a value in the Shadow Depth text box to change the shadow depth by increments.

The Title tool automatically orients the shadow to the selected object. You can continue to follow these procedures to adjust the shadow until you achieve the effect you want.
Adjusting Shadow Color and Transparency

To apply color and transparency to shadows, use the procedures in “Selecting Colors and Setting Transparency” on page 421.

Adjusting Shadow Softness

You can set a value for the degree of softening or blurring that applies to the shadows you create in the Title tool. The value that you set applies immediately to any selected title. The value is also saved as the new default setting and applies to any new title objects you create in current and future Title tool sessions. To change the degree of softening that applies to objects in the Title tool, you must set a new value.

The following illustration shows a title shadow with a Shadow Softness setting of 15.

Setting Shadow Softness

To set a degree of softening or blurring for shadows:

1. Select Object > Soften Shadow.
   
   The Soft Shadow dialog box opens.

2. Type a number in the Shadow Softness text box to represent the degree of softening you want.
   
   Shadow softness values must fall between 4 and 40. The higher the value, the more blurred the shadows will be. If you set the value to zero, shadows on title objects will have no softening (hard edges).

3. Click OK to close the Soft Shadow dialog box.
Adjusting Shadow Softness On-the-Fly

You can adjust the shadow softness value of a title object on-the-fly either by entering different values in the Shadow Softness text box or by using the Up Arrow and Down Arrow keys.

To adjust shadow softness on-the-fly, using the Soft Shadow text box:

1. Select one or more objects in the Title tool.
2. Select Object > Soften Shadow.
3. Type a number in the Shadow Softness text box to represent a degree of softening.
4. Click Apply.
   The Title tool applies the softness value to the selected title objects.
5. Repeat steps 3 and 4 until you are satisfied with the effect.
6. Click OK.

To adjust shadow softness on-the-fly, using the Up Arrow and Down Arrow keys:

1. Select one or more objects in the Title tool.
2. While pressing and holding the Shift and Alt keys (Windows) or the Shift and Option keys (Macintosh), press the Up Arrow and Down Arrow keys to adjust the softness value incrementally until you are satisfied with the effect.
   Each press of the Up Arrow key adds 1 to the shadow softness value.
   Each press of the Down Arrow key subtracts 1 from the shadow softness value.
Viewing Shadow Softness

The current degree of softness is always represented visually on the shadow display of the Shadow Depth and Direction button. The following illustration shows this representation for a Shadow Softness setting of 10.

To confirm the current numerical value for shadow softness:

- Select Object > Soften Shadow, and check the number in the Shadow Softness text box.

Creating a Glow Effect

If you create a title object with Shadow Softness set to a nonzero value and Shadow Depth set to zero in the Title tool, the object will appear to have a glow or halo around it. In the following illustration, Shadow Softness is set to 10.

To create titles that do not have either softened shadows or glows, you must set the Shadow Softness to zero.

Manipulating Objects

This section describes how to manipulate objects after you have created them. For a description of how to select objects, see “Using the Selection Tool” on page 391.
Basic Object Manipulation

You can use commands from the Edit menu to manipulate objects.

To manipulate objects:

1. Click the Selection tool, and click an object — such as text, a square, a rectangle, a circle, or an oval.
2. Do one of the following:
   - To cut an object and move it to the Clipboard, select Edit > Cut.
   - To copy an object to the Clipboard, select Edit > Copy.
   - To paste an object from the Clipboard, select Edit > Paste.
   - To select all objects, select Edit > Select All.
   - To delete selected objects, select Edit > Delete.

You cannot delete locked objects. Unlock objects you want to delete.
   - To duplicate an object, select Edit > Duplicate.

Layering Text and Objects

You can use commands on the upper portion of the Object menu to layer text and objects to create complex graphics.

<table>
<thead>
<tr>
<th>Object</th>
<th>Key Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bring To Front</td>
<td>Shift+Ctrl+L</td>
</tr>
<tr>
<td>Send To Back</td>
<td>Shift+Ctrl+B</td>
</tr>
<tr>
<td>Bring Forward</td>
<td>Shift+Ctrl+F</td>
</tr>
<tr>
<td>Send Backward</td>
<td>Shift+Ctrl+K</td>
</tr>
</tbody>
</table>

The last object created occupies the top layer, but you can move objects forward or backward within the screen area.
To adjust the layering of objects in a title:

1. Click the Selection tool, and click an object.
2. Do one of the following:
   - To bring an object to the top layer, select Object > Bring To Front.
   - To send an object to the bottom layer, select Object > Send To Back.
   - To move an object forward one layer, select Object > Bring Forward.
   - To move an object back one layer, select Object > Send Backward.

Grouping and Ungrouping Objects

After creating a number of text and graphic objects, you can use commands in the Object menu to group the objects and treat them as a single object.

<table>
<thead>
<tr>
<th>Object</th>
<th>Shift+Ctrl+L</th>
<th>Shift+Ctrl+K</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bring To Front</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Send To Back</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bring Forward</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Send Backward</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Group</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ungroup</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Combining the objects into a group means that actions, such as moving or applying color, affect all objects in the group.

To group objects:

1. Click the Selection tool, and Shift+click multiple objects.
2. Select Object > Group.
   - The Title tool creates a grouped object from the individual objects. Changes to any individual object in the group affect all objects in the group.
To ungroup objects:

1. Click the Selection tool, and click a grouped object.
2. Select Object > UnGroup.

Everything in the group becomes an individual object that you can move or change independently.

Locking and Unlocking Objects

You can use commands in the Object menu to lock objects so that changes to default settings, such as the font setting or object position, do not affect the locked objects.

<table>
<thead>
<tr>
<th>Object</th>
<th>Locking commands</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bring To Front</td>
<td></td>
</tr>
<tr>
<td>Send To Back</td>
<td></td>
</tr>
<tr>
<td>Bring Forward</td>
<td></td>
</tr>
<tr>
<td>Send Backward</td>
<td></td>
</tr>
<tr>
<td>Group</td>
<td></td>
</tr>
<tr>
<td>Ungroup</td>
<td></td>
</tr>
<tr>
<td>Lock</td>
<td></td>
</tr>
<tr>
<td>Unlock</td>
<td></td>
</tr>
</tbody>
</table>

You might also want to lock objects so that you do not inadvertently change them while working on other objects. You can lock an individual object or multiple objects.

To lock objects:

1. Click the Selection tool, and click an object.
2. Select Object > Lock.

The Title tool locks the object. It cannot be changed until you unlock it.
Manipulating Objects

When selected, the object displays hollow selection handles to indicate that it is locked.

To unlock objects:
1. Click the Selection tool, and click a locked object.
2. Select Object > Unlock.
   The Title tool unlocks the object. You can now change it.

Aligning Objects

You can use the Alignment menu commands to align text and objects to each other and to the frame. Aligning to the frame refers to the safe title area. For information about the safe title area, see “Saving Titles and Title Styles” on page 435.

To align objects to the frame:
1. Click the Selection tool, and click an object or Shift+click multiple objects.
2. Do one of the following:
   - Select Alignment > Align To Frame Left.
   - Select Alignment > Align To Frame Right.
   - Select Alignment > Align To Frame Top.
   - Select Alignment > Align To Frame Bottom (Shift+Ctrl+Z).
   The objects are aligned within the safe title area.
Creating Titles and Graphic Objects

To align objects to each other:

1. Click the Selection tool, and Shift+click or lasso multiple objects.
2. Do one of the following:
   - Select Alignment > Align Objects Left.
   - Select Alignment > Align Objects Right.
   - Select Alignment > Align Objects Top.
   - Select Alignment > Align Objects Bottom.
   The last object you selected is used as the reference object to which the others are aligned.

For information on aligning objects to a grid, see “Displaying a Grid” on page 396.

Distributing Objects

You can use Alignment menu commands to distribute text and graphic objects evenly across the safe title area. For information about the safe title area, see “Saving Titles and Title Styles” on page 435.

To distribute objects:

1. Click the Selection tool, and Shift+click at least three objects.
2. Do one of the following:
   - Select Alignment > Distribute Left to Right.
     The Title tool distributes the objects evenly from left to right across the safe title area.
   - Select Alignment > Distribute Top to Bottom.
     The Title tool distributes the objects evenly from top to bottom across the safe title area.
Saving Titles and Title Styles

- Select Alignment > Distribute First to Last.

The Title tool distributes the objects evenly between the position of the first object selected and the position of the last object selected. This command is especially useful for aligning objects diagonally or for roughly positioning a group of objects and then lining them up without spreading them out to the edges of the safe title area.

Saving Titles and Title Styles

After creating a new title, there are three basic ways to save your work:

- Save the title and exit the Title tool.
- Save the title and continue creating additional titles.
- Save a title style that you can apply to additional titles you create.

You can also reopen in the Title tool a previously saved title and make further changes, as described in this section.

FTER editing a title into a sequence and adjusting effect parameters, you can also save a Title Effect template that contains only the effect information (without title media) for applying to other previously created titles. For more information, see “Saving an Effect Template” on page 164.

Before exporting the sequence using OMF®, render all fast-saved titles and any unrendered rolling or crawling titles.
Matching Resolutions

When you save a new title, you must select a resolution for the title that is compatible with the project, based on the following:

- The rules regarding different media resolution groups apply to titles. You cannot mix titles from one resolution group with media from another. For example, you cannot mix single-field titles with two-field media in a sequence.

For detailed information on mixing media resolutions in a project, see “Resolutions and Storage Requirements” in the Help.

- The Avid application uses the resolution information to compute the dimensions of the title.

- Even though titles are uncompressed, if you decide during editing that you need to render the title or create a layered effect, the title renders with the resolution you select when you first save the title.

Saving a Title and Exiting the Title Tool

To save the title and exit the Title tool:

1. Select File > Close.

   If the contents of the title have changed since the last time it was saved, a dialog box opens, asking if you want to save the existing title.

2. Click Save.

   The Save Title dialog box opens.

   Multiformat check boxes appear in the Title Formats area only on systems that support 24p or 25p projects. See step 5.

3. Type a name to identify the title in the bin; then select a bin, drive, and resolution from the pop-up menus.
If you are saving a new title, the resolution you select becomes the default for future new title saves.

You must select a resolution that is compatible with the sequence. Titles will not play with incompatible media. For more information on resolution groups and compatibility, see “Resolutions and Storage Requirements” in the Help.

You can also use the Media Creation dialog box to set the resolution and drives for titles. See “Media Creation Settings” in the Help.

4. Select or deselect Fast Save, depending on your needs. For more information, see “Using the Fast Save Option” on page 439.

5. (Option) If you are working on a system that supports 24p or 25p projects, select the title formats you want to save.
   For more information, see “Working with Titles on Systems with 24p or 25p Support” on page 443.

6. Click Save.
   The Title tool closes, and the application loads the new title into the Source monitor. A 2-minute Title Effect clip that corresponds to the new title appears in the bin.

## Saving Multiple Titles in a Session

To save multiple titles:

1. Select File > Save Title.
   The Save Title dialog box opens.

Multiformat check boxes appear in the Title Formats area only on systems that support 24p or 25p projects. See step 4.

2. Type a name to identify the title in the bin; then select a bin, drive, and resolution from the pop-up menus.
You must select a resolution that is compatible with the sequence. Titles will not play with incompatible media. For more information on resolution groups and compatibility, see “Resolutions and Storage Requirements” in the Help.

You can also use the Media Creation dialog box to set the resolution and drives for titles. See “Media Creation Settings” in the Help.

3. Select or deselect Fast Save, depending on your needs. For more information, see “Using the Fast Save Option” on page 439.

4. (Option) If you are working on a system that supports 24p or 25p projects, select the title formats you want to save.
   For more information, see “Working with Titles on Systems with 24p or 25p Support” on page 443.

5. Click Save.
   The new Title Effect clip appears in the bin.

6. Create another title.

7. Select File > Save Title as, and repeat steps 2 to 5 for each subsequent title that you create.
   The application loads titles into the Source monitor as they are saved, so the most recently saved title always appears in the Source monitor.

Using a Keyboard Shortcut to Save a Title

You can use a keyboard shortcut that is equivalent to selecting “Save Title as” from the File menu of the Title tool. You can quickly save the latest version of your title without replacing the original.

To save a title, using a keyboard shortcut:

1. Press Shift+Ctrl+S (Windows) or Shift+⌘+S (Macintosh).
   The Save Title dialog box opens.

2. Type a name for the title.

3. Select a bin, a drive, and a resolution from the pop-up menus.

4. Click Save.
Using the Fast Save Option

You can use the Fast Save option to work more quickly when creating and saving multiple titles in a Title tool session.

Fast Save skips the steps that create anti-aliased images from title objects. Instead, just the raw title objects (text and graphics) are saved in the bin, with the prefix “unrendered.”

You can edit with the titles and then batch render them at a more convenient time. Fast Save is ideal for working with multipage rolling titles with complex styles and shading.

For information on rendering fast-saved titles, see “Creating Media for Unrendered Titles in a Bin” on page 472.

Fast-saved titles appear as black in the monitors and are labeled as “media offline” during editing.

Before exporting a sequence using OMF and before creating an EDL from the sequence, always render fast-saved titles. In addition, before you export a sequence as OMF, render all rolling titles.

Saving a Title with Fast Save

To use the Fast Save option:

- Select Fast Save (Unrendered) in the Save Title dialog box when saving the title.

For complete procedures for saving titles, see “Saving a Title and Exiting the Title Tool” on page 436 or “Saving Multiple Titles in a Session” on page 437.

Fast Save remains in effect until you deselect it, load a title that was saved without Fast Save selected, or exit the Title tool.
Viewing Fast-Saved Titles in a Bin

To quickly locate the unrendered fast-saved titles:

1. Open the bin containing the unrendered fast-saved titles.
2. Select Bin > Select Unrendered Titles.
   The fast-saved titles are highlighted in the bin.

Revising a Title in a Bin

If you want to revise a title that has not been edited into a sequence, you can reopen the title in the Title tool directly from the bin.

For information on revising a title that has been edited into a sequence, see “Revising a Title in a Sequence” on page 467.

To revise a title in a bin:

1. Press the Ctrl key, and double-click the Title Effect icon in the bin.
   The title opens in the Title tool.

   If the Title tool is already open, you can drag a Title Effect clip from the bin directly into the Title tool.

2. Edit the title, using techniques described in Chapter 10.
3. Save the title with the same name and media parameters (bin, drive, and resolution) by selecting File > Save Title.
   The revised Title Effect clip replaces the previous clip in the bin. The clip also appears in the Source monitor.
   The Title tool remains open. You can continue creating additional titles, or select File > Close.
4. Save the title with a new name or change any of the media parameters (bin, drive, and resolution) by doing the following:
   a. Select File > Save Title as.
      The Save Title dialog box opens.
Creating and Using Title Templates

b. Rename the title, or select other options from the Bin, Drive, and Resolution pop-up menus.
   If you keep the same name for the title, the application retains the original Title Effect clip in the bin and creates a new clip with the same name plus a two-digit extension that adds incremental numbering for each revision.

c. Select or deselect Fast Save, depending on your needs. For more information, see “Using the Fast Save Option” on page 439.

d. (Option) If you are working on a system that supports 24p or 25p projects, select the title formats you want to save.
   For more information, see “Working with Titles on Systems with 24p or 25p Support” on page 443.

e. Click Save to save the title and exit the Title tool.

Creating and Using Title Templates

Title templates let you create a standard format for text and graphics that you use regularly. After you’ve set up your template, open the template, edit the text, and save the new title. The template prevents you from changing the position, colors, shadows, or graphics, which ensures consistency.

Creating Title Templates

To create a title template:
1. Open the Title tool by doing one of the following:
   ▶ Select Clip > New Title.
   ▶ Select Tools > Title Tool.
2. In the Title tool, create the text and graphic elements to include in the template.
3. Click the Templates pop-up menu, and select Save Template.
   The Save Template dialog box opens.
4. Type a name for the template.
5. Click Save.
   By default, the Title tool saves the template in the Title_Templates folder, but you can save it elsewhere.
6. Close the Title tool, and click Don’t Save in the dialog box.

Using Title Templates

To use a title template:
1. Open the Title tool by doing one of the following:
   ▶ Select Clip > New Title.
   ▶ Select Tools > Title Tool.
2. Click the Templates pop-up menu, and select Include Template.
   The Open dialog box opens.
3. Select the template you want to use, and click Open.
   The Title template opens.
4. Make any edits you want to the text.
5. Close the Title tool, and click Save in the dialog box.
   The Save Title dialog box opens.
6. Type a name for your title, and click Save.
   The named title appears in the bin you specify. Now you can edit the title into the sequence. See Chapter 10.
Working with Titles on Systems with 24p or 25p Support

When you are working in a 24p project or a 25p project, you create titles in one of four formats:

- NTSC 4:3
- NTSC 16:9
- PAL 4:3
- PAL 16:9

Although you initially create a title in only one format (the native format in which you are editing when you create the title), you can save it in any of the four formats.

In a project other than a 24p project or a 25p project, you can create a title in one format and then save it in multiple aspect ratios. For example, in an NTSC video project, you might create a title at NTSC 4:3 and then save it in both the 4:3 and 16:9 aspect ratios.

The following sections explain how these multiformat options affect the creation and handling of titles.

The Title tool applies the correct title to each output format for your project. Other imported titles and graphics cannot be saved in multiple formats and will be resized along with the video signal when you generate output in a format different from the native project format. This might affect the finished look of the title or graphic.

Multiformat titles must be unrendered. With 24p or 25p projects, you can save titles in multiple formats (NTSC 4:3, PAL 4:3, NTSC 16:9, or PAL 16:9, depending on your source media). When you create a digital cut, you can select the appropriate format. This feature works only for unrendered titles; it does not work for rendered titles. Rendered titles will play in the original rendered format.
Creating Titles and Graphic Objects

If you need to render effects that play at the same time as the title, render all effects except the title. Alternatively, create a video mixdown of all tracks except the title.

Creating Titles on Systems with 24p or 25p Support

When you create a title on a system that includes support for 24p or 25p projects, you need to consider the different video formats and aspect ratios in which your project will be output. In particular, if you create a title in the 16:9 ratio, you need to use the grid to verify that the title will appear safely within the limits of the 4:3 viewing area. For more information on using the grid, see “Working with the Effect Grid” on page 88.

Saving Titles on Systems with 24p or 25p Support

When you save a title in a 24p project or a 25p project, the Save Title dialog box displays a check box for each of the four possible formats.
You can choose to save a title in any combination of the four formats, with the following restrictions:

- The format in which you created the title is selected by default and is always saved (even if you deselect the check box).

- If you choose to save the alternative video format and the alternative aspect ratio from that in which you created the title, the corresponding aspect ratio in the original video format is also saved. For example, if you create a title as NTSC 4:3 and choose to save it as PAL 16:9, the application will save three formats in total: NTSC 4:3, PAL 16:9, and NTSC 16:9.

When you first save a title after starting the application, the application selects only the native format in the Save Title dialog box. Once you select a combination of formats to save a title, that combination becomes the default when you reopen the Save Title dialog box while the application is running.

For more information on 24p or 25p titles, see “Working with Existing Multiformat Titles” on page 469 and “Re-creating Title Media on Systems with 24p or 25p Support” on page 473.

When you save a title in a project other than a 24p project or a 25p project, the Save Title dialog box displays a check box for each aspect ratio (4:3 and 16:9) of the video format you are working in (NTSC or PAL). The check boxes for the other video format are unavailable.

The aspect ratio in which you created the title is selected by default and is always saved. If you need a version of the title in the other aspect ratio, select the appropriate check box.
Saving and Recalling Title Styles

As you begin to work with a title, you might set up some basic title parameters you will use again for other titles. You can save the following style parameters in the form of a title style:

- Font, style, size, justification, kerning, and leading
- Fill color and transparency
- Shadow color, transparency, depth, direction, softness, and type
- Border color, transparency, and width

You can also assign a title style to one of the function keys on your keyboard. You can then recall that style simply by pressing the appropriate function key.

The following illustration shows the location of the two buttons that allow you to select and define title styles.

Table 18 on page 448 shows the Title Style sheet options.

Saving a Title Style

To save title parameters to a Style sheet:

1. Click the Selection tool, and click the object that you want to use as a basis for the title style.
2. Click the Save Style Parameter button.
   A menu appears that allows you to select either an existing title style name or Save As.
3. Select Save As.

The Title Style Sheet dialog box opens. The following illustration shows an example.

![Title Style Sheet dialog box]

4. Select the parameters that you want to include in the style. The Title tool uses the values from the currently selected object or from the current defaults if no object is selected.

5. (Option) Type a function key number in the Function Key text box to assign the style to a function key.

For example, typing 5 assigns the style to the F5 function key.

6. Type a name in the Name text box, and click Done when you are ready to exit the dialog box and save the values.
Chapter 9  Creating Titles and Graphic Objects

Title Style Sheet Options

The Title Style Sheet dialog box allows you to create templates for the Title tool. Style sheets allow you to define and select basic text and drawing parameters that you can use with the Title tool. Table 18 describes the components of the Title Style Sheet dialog box.

Table 18  Title Style Sheet Dialog Box Components

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check boxes</td>
<td>Select the current attributes of the object that you want to include in the style. You can modify the attributes that are associated with a saved title. Use the check boxes to specify the attributes to save.</td>
</tr>
<tr>
<td>Function Key text box</td>
<td>(Option) Allows you to designate a function key that you can use to apply the title style.</td>
</tr>
<tr>
<td>Style Name text box</td>
<td>This name appears in the Style list in the Title tool and in the Settings scroll list.</td>
</tr>
<tr>
<td>Refresh button</td>
<td>Appears after you change an item in the dialog box. Click to display the change in the sample window.</td>
</tr>
<tr>
<td>Select All button</td>
<td>Allow you to select all or none of the check boxes.</td>
</tr>
<tr>
<td>Select None button</td>
<td></td>
</tr>
<tr>
<td>Revert button</td>
<td>Returns the settings to those used when the style was last saved.</td>
</tr>
<tr>
<td>Done button</td>
<td>Closes the dialog box and saves your changes.</td>
</tr>
<tr>
<td>Convert to Marquee button</td>
<td>Converts your title style to Marquee format. See the Avid Marquee Title Tool User’s Guide or the Help.</td>
</tr>
<tr>
<td>Close button</td>
<td>Acts as a Cancel button. A message box opens, asking whether you want to cancel or save your changes. If you created a new style from within the Title tool, clicking Cancel means that the Title tool will not create the new style.</td>
</tr>
</tbody>
</table>
Recalling a Title Style

After you have saved your title style, you can recall the style and use the attributes as the defaults in subsequent Title tool sessions. You can recall a title style by using the Title Styles tear-off menu or, if you have assigned the style to a function key, by pressing the appropriate key.

**To recall title style attributes, using the Title Styles tear-off menu:**

1. In the Title tool, click the Styles button to display the Title Styles tear-off menu.

   The menu contains a scaled visual representation of each style.

2. Drag the pointer to the selected style, and release the mouse button.

3. The style attributes appear in the Title tool toolbar.

**To recall a title style attribute, using a function key:**

- Press the appropriate function key.

   The style attributes appear in the Title Tool toolbar.

Confirming Function Key Mapping of Title Styles

**To verify which function key is assigned to a particular title style, do one of the following:**

- Open the Title Style Sheet dialog box for the style from the Settings scroll list in the Project window, and then check the function key number in the Function Key text box.

- In the Title tool, click the Styles button to display the Title Styles tear-off menu, and then position the mouse pointer over the style.

   The ToolTip that appears indicates the function key assignment along with the name of the style.
Applying Title Styles to Text Objects

To apply a title style directly to text objects:

1. Select one or more text objects.
2. Do one of the following:
   - Click the Styles button to display the Title Styles tear-off menu, and then select a title style.
   - If the style is assigned to a function key, press the appropriate function key.

Managing Title Styles

The Avid application lists the available title styles in the Project window. Click the Settings tab in the Project window as shown in the following illustration.

To delete a style:

1. Select the style in the Project window.
2. Do one of the following:
   - Press the Delete key.
   - Select Edit > Delete.
To copy a style:
- Select the style in the Project window, and select Edit > Duplicate.

To rename a style, do one of the following:
- Change the name in the Project window.
- Perform a Save As operation as described in “Working with Titles on Systems with 24p or 25p Support” on page 443 and change the name in the Style Sheet text box.

Exporting a Title as a Graphics File

To export a title as a PICT graphics file:
1. With the Title tool open, select File > Export Title.
   The Export Pict As dialog box opens.
2. Select the location where you want to export the file, type a file name, and click Save.
   The Title tool saves the title.
Chapter 10
Editing with Titles

Editing with titles involves placing Title Effect clips in a sequence and then adjusting parameters or revising the title in the Title tool. The following sections provide guidelines for editing with title media.

- Workflow for Editing with Titles
- Before You Begin
- Displaying Title Frames in the Bin
- Editing a Title into a Sequence
- Removing a Title
- Replacing a Title
- Fading a Title
- Adjusting Title Effect Parameters
- Revising a Title in a Sequence
- Working with Existing Multiformat Titles
- Replacing Fill Tracks
- Rendering Titles
- Re-creating Title Media
- Promoting a 2D Title to 3D
- Troubleshooting Titles
Workflow for Editing with Titles

The following is an overview of the tasks you perform to edit a title into a sequence:

• **Editing a Title into a Sequence.** You can load a title into the Source monitor or drag the Title Effect Clip icon from the bin to a segment in the Timeline. Title effects play in real time. See “Editing a Title into a Sequence” on page 457.

• **Adjusting Title Effect Parameters.** With a title edited into a sequence, you can use the Effect Editor to alter the appearance or position of the title. You can also open the title again in the Title tool at any time to revise the title elements. See “Adjusting Title Effect Parameters” on page 465.

• **Revising a Title in a Sequence.** After editing the title and adjusting parameters, you can revise elements of the title in the Title tool or replace fill tracks to create various effects. See “Revising a Title in a Sequence” on page 467.

These basic procedures are described throughout this chapter. For information on creating titles, see Chapter 9.

Before You Begin

The following sections provide guidelines for working effectively with titles and Title effect media.

Restrictions on the Complexity of Titles

Depending on the complexity of the title and the video over which it is keyed, not all titles can be played in real time.

When you attempt to play too complex a title, the following conditions might occur:

• Background video might jitter.
• Title might flash.
Before You Begin

• Title might display a gray slide.
• Video might shift left or right.
• Video might display a gray slide.
• Video underrun error might occur.
• Audio underrun error might occur.
• Rolling title underrun error might occur.

If you encounter any of these conditions, try one or more of the following:

▶ Render the title or underlying effects. See “Rendering Effects” on page 176.
▶ Simplify the title by removing text or drop shadows or by selecting different colors.

It is possible that a title with background video might be so complex that you can neither play it in real time nor render it.

Playback Restrictions for Rolling Titles

The following restrictions apply to rolling titles:

• Rolling titles might jitter slightly at certain speeds. You can adjust the duration by a few frames to fix the problem.
• Rolling titles cannot play back at a rate greater than one page per second. This situation occurs when you edit a lengthy title roll into a short segment in the sequence.

If you experience a playback problem with a title, do one or more of the following:

▶ Render the title or underlying effects. See “Rendering Titles” on page 470.
▶ For a rolling title, slow the roll by extending the duration of the clip. See “Trimming the Duration of Rolling and Crawling Titles” on page 463.
▶ Separate title clips in the sequence.
▶ Store title and video media on separate drives, or use faster drives.
Chapter 10   Editing with Titles

Title Effect Clips in the Bin

When the Title tool saves a title, it creates a Title Effect clip and saves it in the selected bin. One media object, referred to as a precompute, has references to the RGB and alpha channel information. Every time you make a change, the Avid application creates two additional media files. The original media files are left unchanged.

By default, the bin display does not show rendered effects. To view rendered effects in the bin, select Bin > Set Bin Display, then select Rendered Effects and “Show reference clips” in the dialog box.

For more information, see “Managing Effect Media Files” on page 205.
Displaying Title Frames in the Bin

With your bin in Frame view, you can display a frame from the title itself rather than display the Title Effect Clip icon for the clip. This is especially useful if you have many titles in the bin and want a quick visual reference.

To display a frame from the title:
1. Select one or more Title Effect clips.
2. Press the Home key on the keyboard.

Editing a Title into a Sequence

After preparing the sequence with a second track for the title, there are three basic methods for editing the title into place:

- **Edit the title into the sequence, using standard editing methods:**
  Mark edit points in the sequence and in the title clip, and then splice or overwrite the title into place. See “Splicing or Overwriting a Title into a Sequence” on page 458.

- **Drag a marked title clip directly into the sequence from a bin:**
  Mark IN and OUT points in the title clip, and then drag the title directly into the sequence. See “Dragging a Marked Title into a Sequence” on page 460.

- **Drag an unmarked title clip directly into the sequence from a bin:**
  Drag the title clip directly from the bin to the location of the position indicator. See “Dragging an Unmarked Title into a Sequence” on page 462.
Chapter 10  Editing with Titles

Setting Marks in a Rolling Title or a Crawling Title

By default, a rolling title clip or a crawling title clip begins with the visible title just off screen. The clip ends after the last element disappears off screen.

You can mark IN and OUT points of rolling titles in the Source monitor to change the start and finish points; for example, you might want the title to start with the screen full of text rather than start off screen.

You can play and mark a rolling title clip in the Source monitor by using standard procedures. For more information, see “Controlling Playback” in the Help.

If you want to use the complete roll in the sequence, do not set marks. For information about adjusting the duration of the roll, see “Trimming the Duration of Rolling and Crawling Titles” on page 463.

"You can view a crawling title frame by frame if you select Special > Render On-the-Fly."

Splicing or Overwriting a Title into a Sequence

To splice or overwrite a title into a sequence:

1. Load the sequence into the Record monitor.

"Titles must be placed on a track above the video that forms the background. If an upper track already exists with an open region for the title, you can go to step 3."

2. (Option) Select Clip > New Video Track.

The application adds the next video track for the sequence to the Timeline. For example, if the sequence includes only V1, the application adds V2.
3. Double-click the Title Effect Clip icon in the bin to load the title in the Source monitor.

4. Patch the title source to the video track in the sequence by clicking the Source Track button for track V1 in the Track Selector panel and dragging it to the Record Track button for track V2.

You can use any three-point editing method to edit a title into a sequence. The following steps are just one editing method. For other methods, see “Editing in Source/Record Mode” in the Help.

5. In the Source monitor, mark an IN point.

You should mark the IN point toward the middle of a still title clip so you can trim the title, if necessary.

For rolling and crawling titles, set no marks and move the position indicator to the beginning of the clip if you want to use the full roll.
6. In the Record monitor, mark IN and OUT points.

7. Make sure all other Record Track buttons are deselected in the Track Selector panel.

8. Click either the Extract/Splice-in button or the Lift/Overwrite button to edit the title into the sequence.

The Title Effect segment appears in the top video track.

Dragging a Marked Title into a Sequence

To mark a portion of a title clip and then drag the marked clip directly into the Timeline:

1. Load the sequence into the Record monitor. For more information, see “Editing in Source/Record Mode” in the Help.

   Titles must be placed on a track above the video that forms the background. If an upper track already exists with an open region for the title, you can go to step 3.

2. (Option) Select Clip > New Video Track.

   The application adds the next video track for the sequence to the Timeline. For example, if the sequence includes only V1, the application adds V2.

3. Double-click the Title Effect Clip icon in the bin to load the title into the Source monitor.
4. In the Source monitor, mark an IN point and an OUT point to establish the duration that you want for the title.

You should mark the IN point toward the middle of a still title clip so you can trim the title, if necessary.

For rolling and crawling titles, set no marks and move the position indicator to the beginning of the clip if you want to use the full roll. The application uses the position indicator to determine the IN point on rolling titles.

5. Clear the Source monitor by selecting Clip Name > Clear Monitor.

6. Click either the Extract/Splice-in button or the Lift/Overwrite button, depending upon how you want to insert the Title effect.

7. Click the Title Effect Clip icon in the bin, and drag it to the Timeline.

As you drag the Title effect in the Timeline, a white outline of the title clip indicates location in the sequence.

8. Release the mouse button when you have the title positioned where you want it.

The Title effect appears in place in the sequence.
Chapter 10  Editing with Titles

Dragging an Unmarked Title into a Sequence

If you are not concerned about the OUT point for your title, or if you plan on trimming the Title effect later, you can quickly drag the unmarked Title effect directly into the Timeline.

**To apply a Title effect to a sequence without adding marks:**

1. Load the sequence into the Record monitor.
   
   For more information, see “Editing in Source/Record Mode” in the Help.

   *Titles must be placed on a track above the video that forms the background. If an upper track already exists with an open region for the title, you can go to step 3.*

2. (Option) Select Clip > New Video Track.
   
   The application adds the next video track for the sequence to the Timeline. For example, if the sequence includes only V1, the application adds V2.

3. Move the position indicator to the location where you want the Title effect to begin.

4. Click either the Extract/Splice-in button or the Lift/Overwrite button, depending upon how you want to insert the Title effect.

5. Click the Title Effect Clip icon in the bin, and drag it to the Timeline.
   
   As you drag the Title effect in the Timeline, a white outline of the title clip indicates location in the sequence.

6. Release the mouse button when you have the title positioned where you want it.
   
   The Title effect appears in place in the sequence.
Trimming the Duration of Rolling and Crawling Titles

When you edit the title clip into a marked segment of a sequence, the clip plays back from beginning to end regardless of the duration of the segment. That is, the entire roll shrinks to fit within the duration of the marked segment in the sequence.

Once you have edited the clip into the sequence, you can trim the duration of the segment at any time, and the title adjusts to fit.

Unlike trimming other segments, trimming a rolling or a crawling title does not remove any part of the title contents. As a result, the duration of the title determines how fast it plays. For example, the shorter you trim the title, the faster it rolls.

*Rolling titles might jitter slightly at certain speeds. You can trim the duration slightly to fix the problem.*

**To trim the duration of a rolling title or a crawling title:**

1. Use the Track Selector panel to select the track containing the Title effect and to deselect all other tracks.

2. To enter Trim mode, click the Trim Mode button in the Timeline top toolbar.

3. Select either the head or the tail of the title segment for trimming.

4. Trim the title segment to the duration you want by using standard trim procedures.

   The entire roll or crawl plays back within the new duration.

*If you trim your rolling title very short, it scrolls very fast and cannot display in real time; it must be rendered. The maximum speed for an unrendered rolling title is one screen per second.*
Removing a Title

To remove a title segment:

1. Move the position indicator to the segment containing the Title effect.
2. Use the Track Selector panel to select the track containing the Title effect and to deselect all other tracks.
3. Click the Mark Clip button under the monitor.  
   IN and OUT points appear surrounding the Title effect.
4. In the Timeline bottom toolbar, click the Extract/Splice-in button or the Lift/Overwrite button to remove the segment.

   The Title effect remains in the bin. To remove the Title effect from the bin, select the effect in the bin and press the Delete key.

Replacing a Title

To replace a title in a sequence:

1. In the Timeline bottom toolbar, click the Lift/Overwrite button.
2. Click the title segment currently in the sequence to select it.
3. Click the Mark Clip button below the monitor to mark an IN point at the beginning of the title segment and an OUT point at the end of the segment.
4. Drag the new Title Effect clip from the bin to the marked segment.

   The new title replaces the old title.
Fading a Title

You can use the Fade Effect button to fade a title. A dialog box opens that allows you to enter the number of frames to fade up and fade down without opening the Effect Editor.

Rather than adding Dissolve effects that require rendering, you can use the Fade Effect button to quickly create keyframes in the title with the proper level settings for playback in real time. You can access the keyframes in the Effect Editor. For more information, see “Using the Fade Effect Button” on page 63.

Adjusting Title Effect Parameters

After editing a title into a sequence, you can open the Effect Editor and refine the title with keyframe control over effect parameters.

Adjusting parameters affects the real-time playback capabilities of your titles in various ways, depending upon the particular options available with your Avid application. For more information, see “Restrictions on the Complexity of Titles” on page 454.

To access the effect parameters for a Title effect:

1. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.

   The Effect Editor opens.

2. Click the Title Effect segment in the sequence to select it.

   The Effect Editor displays the parameter controls.
Use the following to work with the Title effect parameters:

- Adjust Title effect parameters by using basic techniques described in “Using the Effect Editor” on page 97.

For information on specific Title effect parameters, see “2D Effects Parameters” in the Help.

- Use multiple keyframes to gradually change keyframeable parameters over time. For more information, see “Using Standard Keyframes” on page 111.

- Save effect templates of Title effect parameter adjustments to a bin for use in other sequences or projects as described in “Using an Effect Template” on page 164.
Revising a Title in a Sequence

If you want to revise a title after you have edited it into a sequence, you must reopen the title in the Title tool directly from the sequence rather than revise the Title Effect clip in the bin.

**To change a title in a sequence:**

1. Click the Title Effect segment in the sequence to select it.
2. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.
3. In the Effect Editor, click the Other Options button.
   A dialog box opens, asking if you want to promote the title to Marquee.

   *Titles promoted to or created in Marquee cannot be edited with the Title tool. For information on Marquee titles and the Marquee Title tool, see the Avid Marquee Title Tool User’s Guide or the Help.*

4. Click No.
   The Title tool opens.
5. Revise the title by using techniques described in Chapter 9.
6. Save the title by using one of the following procedures.

Use this procedure to save the title with the same name (numbered incrementally) and media parameters (bin, drive, resolution, and formats).

**To save the title with the same name and media parameters:**

1. Select File > Save Title.
   A message box opens, asking if you want to save the title and exit the Title tool.
2. Click Save.

   The Title tool closes. The revised Title Effect clip replaces the previous clip in the sequence, the bin, and the Source monitor.

Use this procedure to rename the title or change any of the media parameters (bin, drive, resolution, and formats).

To save the title with a new name or parameters:

1. Select File > Save Title as.
   
   A message box opens, asking if you want to save the title and exit the Title tool.
2. Click Save.

   The Save Title dialog box opens.

   Multiformat check boxes appear in the Title Formats area only on systems that support 24p or 25p projects. See step 4.

3. Rename the title, or select other options from the Bin, Drive, and Resolution pop-up menus.

   You cannot select Fast Save when revising a title in a sequence.

4. (Option) If you are working on a system that supports 24p or 25p projects, select the title formats you want to save.

   For more information, see “Working with Existing Multiformat Titles” on page 469.

5. Click OK to save the title and exit the Title tool.

   The Title tool closes, and the revised Title Effect clip replaces the previous clip in the sequence. The new clip with its new name also appears in the Source monitor and in the bin. The previous Title Effect clip is preserved in the bin.
Working with Existing Multiformat Titles

With 24p or 25p projects, the following restrictions apply when you move multiformat titles between projects or edit them into a sequence.

- You cannot move a title created in one video format into a project in the other video format. For example, you cannot create a title in an NTSC project and then edit it into a PAL project.

- If you need to revise a title that has been edited into a sequence, you must be working in the same aspect ratio in which the project was originally created. You cannot, for example, revise a title at 16:9 if it was created at 4:3. If you are working in an aspect ratio different from the one used to create the title, a message box alerts you to the problem and asks you to change the aspect ratio.

When you revise a title that you have edited into a sequence, the Title tool selects all the formats that already exist in the title as the defaults. If you need to change the formats, select File > Save Title as. You can then create a new title with the formats you need, and the title will replace the previous version in the Timeline.

Replacing Fill Tracks

You can replace the fill track of Title effects with video or graphics. The moving video or graphic effect then appears inside the title itself, keyed over the background.

To replace the fill track:

1. In the Timeline toolbar, click the Step In button to step into the effect.

2. Load the video you would like to use as replacement filler into the Source monitor.

3. Drag the Source Track button in the Track Selector panel to the Record Track button for the fill track to patch the new source video to the title fill track.

4. Using standard editing methods, edit the video from the Source monitor onto the fill track.
Chapter 10  Editing with Titles

Rendering Titles

The following are a few situations in which you might want to render titles:

• If you want to layer rolling titles in a sequence
• If you want to layer multiple effects, particularly more than one layer of titles
• If you want to place other effects over a title
• If you encounter a message box with a message about audio or video underrun when playing a complex layered effect

For more information on rendering Title effects, see “Rendering Effects” on page 176.

Re-creating Title Media

You can use the Re-create Title Media command to:

• Regenerate title media that is offline.
• Generate title media for unrendered (Fast Saved) titles in a bin.
• Change the resolution of a title.
• Generate multiple formats for titles in 24p or 25p projects.

If you have batch captured a sequence at a resolution different from the resolution at which the sequence was originally created, for example, you can use this command to re-create the titles at the new resolution. This procedure is required when conforming an offline sequence with titles for online editing and output at uncompressed resolution.

You can re-create title media that is edited into a sequence in the Timeline, or you can create media for unrendered (Fast Saved) titles in a bin. For more information on Fast Save for titles, see “Using the Fast Save Option” on page 439.
The Re-create Title Media command removes any nested edits made inside a title, replacing the edits with the new title’s graphic and alpha tracks.

Re-creating Title Media from the Timeline

To re-create title media from the Timeline:

1. Load the sequence containing the titles into the Record monitor.
2. Mark IN and OUT points in the sequence surrounding all the titles that you want to re-create.
3. In the Track Selector panel, select the Record Track button for each track that contains titles you want to re-create.
4. Select Clip > Re-create Titles and Mattes.
   The Re-create Titles and Mattes dialog box opens.

   Multiformat check boxes appear in the Title Formats area only on systems that support 24p or 25p projects. See step 7.

5. Select a drive on which to store the re-created titles.
6. Select a resolution for the re-created titles.

   The default drive and resolution are defined in the Titles tab of the Media Creation dialog box. Media Creation is in the Settings scroll list. For more information, see “Preparing to Capture Media” in the Help.

7. (Option) If you are working on a system that supports 24p or 25p projects, select the title formats you want to create.
   For more information, see “Re-creating Title Media on Systems with 24p or 25p Support” on page 473.
8. Click OK.
   The Avid application re-creates the title media file.
Chapter 10  Editing with Titles

Creating Media for Unrendered Titles in a Bin

**To create media for unrendered titles in a bin:**

1. In the bin, select the titles for which you want to generate media. To quickly select all the unrendered titles in the active bin, select Bin > Select Unrendered Titles.

2. Select Clip > Create Unrendered Title Media. The Create Unrendered Title Media dialog box opens.

   - *Multiformat check boxes appear in the Title Formats area only on systems that support 24p or 25p projects. See step 5.*

3. Select a drive on which to store the title media.

4. Select a resolution for the title media that is compatible with the sequence, such as a two-field resolution for a sequence containing two-field media.

   - *The default resolution is the resolution specified at the time the titles were originally saved with the Fast Save option.*

5. (Option) If you are working on a system that supports 24p or 25p projects, select the title formats you want to create.

   For more information, see “Re-creating Title Media on Systems with 24p or 25p Support” on page 473.

6. Click OK.

   The title media file is generated, and the title clip appears in the bin without the (unrendered) label in the name field.
Re-creating Title Media on Systems with 24p or 25p Support

You can use the Re-create Title Media command to re-create title media with different formats just as you can use it to re-create title media at different resolutions. An efficient workflow for multiformat titles involves creating titles and saving them initially in the native format, and then using the Re-create Title Media command to generate any other necessary formats once editing is complete. Re-creating title media for multiformat titles is subject to the same kinds of restrictions as other editing and saving procedures.

• When you mark titles in a sequence and select Clip > Re-create Title Media, the Re-create Title Media dialog box displays the same multiformat check boxes as the Save Title dialog box. You can create all the formats you need (with the same restrictions described in “Saving Titles on Systems with 24p or 25p Support” on page 444).

• You can re-create titles only when the aspect ratio in which you are working is the same as the one used when the title was created.

• When you use Re-create Title Media to create new formats for a 24p title or a 25p title, all formats are re-created. The application cannot add a format to an existing multiformat title file. Even if three of the four formats have been saved previously, the application will re-create all four formats when you add the fourth.

When you first use the Re-create Title Media command to generate media for unrendered titles in a bin, the application selects the native format as the default. Once you select a combination of formats in the Create Unrendered Title Media dialog box, that combination becomes the default when you reopen the Create Unrendered Title Media dialog box while the application is running.

When you first use the Re-create Title Media command to regenerate titles in the Timeline, the application selects all four formats as the default. Once you select a combination of formats in the Re-create Title Media dialog box, that combination becomes the default when you reopen the Re-create Title Media dialog box while the application is running.
Chapter 10  Editing with Titles

Promoting a 2D Title to 3D

You can promote a Title effect to 3D to create additional effects with the title. Title effects promoted to 3D are real-time effects.

For more information, see “Promoting 2D Effects to 3D Effects” on page 350.

Troubleshooting Titles

This section describes errors that might occur when working with Title effects and includes recommendations for resolving the problems.

Title Error Messages

When you edit with titles or graphics, you might experience an underrun error message because the graphic key could not be loaded in time.

Possible causes include the following:

- Insufficient drive speed
- Title rolling too fast
- Several graphics too close together

Possible solutions include the following:

- Render the clip and underlying video.
- Slow down the rolling title.
- Store the clip media on a drive other than the drive containing the underlying media.
- Add filler between sequential clips.
- Use faster drives.
Wrong Title Format

If you see an image in a monitor that says Wrong Format, the resolution of the Title effect is not compatible with the resolution of video clips used in the sequence. You will have to determine the resolution of the video clip. Then, you must regenerate the title at the same resolution as the video clip.

To determine the resolution of the current video clip:

1. Open the bin containing the sequence.
2. Select Bin > Set Bin Display.
3. Select “Show reference clips.”
   The master clips used in the sequence appear in the bin.
4. Check the resolution for any master clips in the Video column when viewing the bin in Text view.

To correct a title’s resolution to match the resolution used in the video clips in the sequence, use the procedure described in “Re-creating Title Media” on page 470.
Chapter 10  Editing with Titles

476
Intraframe editing refers to the ability to perform various paint or animated matte effect operations within an individual frame or series of frames in a clip. Intraframe editing frees you from having to export images from the Avid application, edit them in third-party applications, and import them back into the Avid application. Intraframe editing also allows you to quickly remove scratches and flaws from your video material.

Intraframe editing is done with the Paint Effect and the AniMatte effect, or with the Scratch Removal effect in the specialized case of scratch removal. These effects share many of the same concepts, described in the following sections:

- Understanding the Intraframe Effects
- Rendering Intraframe Effects
- Getting Started with the Paint and AniMatte Effects
- Using the Intraframe Drawing Tools
- Working with Vector-Based Objects
- Previsualization Marker Tool for Film Projects
- Manipulating Intraframe Objects
- Layering, Grouping, and Locking Intraframe Objects
- Exporting a Matte PICT File
- Scratch Removal
- Common Intraframe Editing Techniques
- Working with the Blur Effect and Mosaic Effect
Chapter 11  Intraframe Editing

Understanding the Intraframe Effects

While many of the tools and parameters are the same for all the Intraframe effects, the result of applying each effect is different.

The **Paint Effect** allows you to draw or paint and apply special effects within individual frames or across all the frames in a segment. The Paint Effect includes the following features:

- Customizable paint brushes with preset templates and parameters for adjustable softness and rotation
- Creation of vector-based objects that you can animate and edit
- A variety of paint modes including Blur, Clone, Colorize, Darken, Emboss, Erase, Lighten, Mosaic, Scratch Removal, Unsharp Mask, and more
- Object selection with rescale, lock/unlock, and group/ungroup capabilities
- Z-rotation of painted objects
- Outline feathering with bias control
- Magic Mask™ for quick and easy colorization

The **AniMatte effect** allows you to generate custom matte effects that you can apply to a segment or transition in a sequence. The AniMatte effect includes the following features:

- Modes for keying in and keying out images
- Keyframeable animation of matte effects
- Creation of mattes as vector-based objects that allow you to move, rescale, and reshape the mattes during a segment or transition
- Freehand painting ability to create organic matte wipes
- Magic Mask, brush shapes, Z-rotation, feathering, and more
- Export of mattes to create keys in third-party applications
The **Scratch Removal effect** allows you to remove scratches or other flaws by replacing them with clean material from elsewhere in the same frame or from another nearby frame. The Scratch Removal effect includes the same tools for drawing objects and painting brush strokes found in the Paint Effect, together with specific controls for selecting clean replacement material. For more information, see “Scratch Removal” on page 530.

When you use the Intraframe Editing tools, the application draws vector-based objects on the screen. Vector-based objects are composed of mathematically described lines and Bézier curves. You can edit the lines, curves, and other attributes of vector-based graphics with greater control and efficiency than you can with bitmapped objects, which are drawn on the screen as a pattern of dots, or pixels. For more information, see “Working with Vector-Based Objects” on page 503.

Additionally, any changes you make to an Intraframe effect are not limited to an individual frame. Instead, any object you paint and any changes you make to it appear for the duration of the entire segment or clip. In most cases, you can change the parameters of the effect between keyframes.

You can create multiple paint or matte shapes within a single effect. You can also add keyframes and apply effects separately to each of the shapes.

The **Blur effect** and **Mosaic effect** act as intraframe effects. The Blur parameter category for the Blur effect is the same as the one that appears for the Blur mode of the Paint Effect. The Mosaic parameter category for the Mosaic effect is the same as the one that appears for the Mosaic mode of the Paint Effect. For more information, see “Working with the Blur Effect and Mosaic Effect” on page 564.
Rendering Intraframe Effects

Intraframe effects are not real-time effects. While working in Effect mode, you can see the object as you step through each frame in the segment.

To view the painted object in the Effect Preview monitor:
- Select Special > Render On-The-Fly.

You also can use the Play Preview function to see an off-speed preview of a Paint Effect while you are working in Effect mode. For more information, see “Effect Editor Controls” on page 98.

When you have finished painting or drawing a matte on a segment, you must render the effect to play it in real time. Regardless of how many objects you add to an individual segment, the effect plays back as a single stream of video.

Rendering Paint Effects

Painted objects are rendered to the screen starting with the bottom layer (closest to the video background). Remember this as you use different paint modes in combination and layer painted objects to generate new effects in a sequence. You also can combine the Paint Effect with the AniMatte effect to create custom effects.

Rendering AniMatte Effects

A multitrack AniMatte effect is rendered to the screen starting with the top video track (farthest from the video background and appearing closest to you in three-dimensional space). For example, if the video background is on track V1, and you apply the AniMatte effect to track V2, the effect renders starting with the image on track V2.
However, if you draw multiple mattes in the *same segment*, these mattes are all objects that appear in the same foreground space; they interact with each other much like multiple painted objects do in the same segment. For more information, see “Layering with the Paint Effect” on page 524.

Remember these concepts as you use different key modes in combination and layer them to generate new effects in a sequence. You also can combine the AniMatte effect with the Paint Effect to create custom effects.

**Getting Started with the Paint and AniMatte Effects**

When you apply the Paint effect or the AniMatte effect to a segment and enter Effect mode, the Effect Editor opens. The pointer is an arrow when you select tools and options from the Effect Editor. When you select a paint or editing tool and position the pointer over the Effect Preview monitor, the pointer changes to a crosshair. The crosshair indicates that you can begin to paint or draw a matte on the frame.

*After you use the Rectangle, Oval, Polygon, and Curve tools, the Avid application reverts to the Selection tool, and the pointer changes to an arrow. After you use the Brush tool, it remains the active tool, and the pointer remains a crosshair.*

The painting and editing tools enable you to paint shapes or draw mattes, quick masks, and other vector-based objects on frames in a sequence. When you apply an Intraframe effect to a segment, the object or matte appears for the duration of the entire segment, not just for an individual frame.
Applying the Paint or AniMatte Effect to a Sequence

You can apply an AniMatte effect to segments for multilayered effects or to transitions to create matte key wipes with your own custom shapes. A Paint Effect is a segment effect only; you cannot apply a Paint Effect to a transition in a sequence.

The Paint Effect is located in the Image category in the Effect Palette. The AniMatte effect is in the Key category.

**To apply the Paint Effect or AniMatte effect to a sequence:**

1. Load a sequence into the Record monitor. See “Editing in Source/Record Mode” in the Help.
2. Enter Effect mode by selecting Toolset > Effects Editing.
3. Do one of the following:
   - To apply the Paint Effect:
     a. In the Effect Palette, click the Image category.
     b. Click the Paint Effect icon, drag it to a segment in the sequence, and release the mouse button.
   - To apply the AniMatte Effect:
     a. In the Effect Palette, click the Key category.
     b. Click the AniMatte Effect icon, drag it to a segment in the sequence, and release the mouse button.

The Effect Editor displays the default settings for the effect.
Using the Effect Editor with the Paint Effect

For basic information on working with the Effect Editor, see “Using the Effect Editor” on page 97.

The following illustration identifies the different components of the Effect Editor that appear when you apply a Paint Effect to a segment in a video project and enter Effect mode.
Table 19 briefly describes the components of the Effect Editor for the Paint Effect.

**Table 19  Effect Editor Components for the Paint Effect**

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Effect parameter categories</td>
<td>Enable you to change the parameters of an effect.</td>
</tr>
<tr>
<td>Brush Preview window</td>
<td>Displays the brush head with the parameters you have selected, such as color and shape. You also can use the window to reshape the brush head by dragging its control points.</td>
</tr>
<tr>
<td>Brush Shape buttons</td>
<td>Change the shape of the brush.</td>
</tr>
<tr>
<td>Selection tool</td>
<td>Selects an object so you can change its parameters, move it, or delete it. With the Shift key pressed, selects multiple objects.</td>
</tr>
<tr>
<td>Z-Rotation button</td>
<td>Rotates an object around the Z axis.</td>
</tr>
<tr>
<td>Reshape button</td>
<td>Reshapes objects by manipulating anchor points at locations where new curves begin or straight lines intersect. Inserts additional control points.</td>
</tr>
<tr>
<td>Bring Forward button and Send</td>
<td>Bring a painted object <em>one</em> layer forward on the screen or send an object <em>one</em> layer backward on the screen. With the Alt key (Windows) or Option key (Macintosh) pressed, bring a painted object to the front or send an object to the back.</td>
</tr>
<tr>
<td>Backward button</td>
<td></td>
</tr>
<tr>
<td>Painting tool and Editing tool</td>
<td>Enable you to paint shapes or draw mattes on frames in a sequence with freehand capability or with preset shapes.</td>
</tr>
<tr>
<td>Grid button</td>
<td>Displays the Effect Grid. See “Working with the Effect Grid” on page 88.</td>
</tr>
<tr>
<td>Previsualization Marker tool</td>
<td>Available in film projects. See “Previsualization Marker Tool for Film Projects” on page 516.</td>
</tr>
</tbody>
</table>
Using the Effect Editor with the AniMatte Effect

The following illustration shows the Effect Editor as it appears when you apply an AniMatte effect to a segment in a video project and enter Effect mode.
When you are working with the AniMatte effect, the categories that are available in the Effect Editor are the same as those for the Paint Effect with the following exceptions:

- The Swap Src (swap sources) button in the Foreground parameter category enables you to swap the foreground and background video images for matte keys composed of multiple video tracks. When you are building a single-track wipe, the Swap Src button enables you to swap the incoming and outgoing segments in the sequence.

- With the AniMatte effect, you use the Magic Mask parameter category to select a key color when you create a matte. (With the Paint Effect, you use the Magic Mask parameter category or the Color parameter category to make color selections.)

**Editing with Single-Field Step**

To locate defects on individual fields of a frame for correction with the Paint and AniMatte effects, use the single-field step feature. For information on using single-field step, see “Using Single-Field Step” on page 96.

**Using Effect Templates with the Intraframe Effects**

As you can do with many other effects, you can save a template of a Paint effect or an AniMatte effect and apply it to other video segments in a sequence at a later time. For more information on saving and applying an effect template, see “Using an Effect Template” on page 164.

**Using the Intraframe Drawing Tools**

The Intraframe effects include the following five drawing tools:

- Rectangle tool
- Oval tool
- Polygon tool
Using the Intraframe Drawing Tools

- Curve tool
- Brush tool

You can use these tools for creating preset shapes or for creating freehand, vector-based objects and mattes with editable lines and Bézier curves. Additionally, the Selection tool enables you to select painted objects and mattes to move them, rescale them, and change their parameters.

Understanding Intraframe Modes

The Paint Effect includes a wide variety of *modes* that offer many creative and corrective possibilities. You use the modes to control the nature and appearance of the objects that you create with the drawing tools. Available modes include Solid (for traditional brush strokes), Erase, Clone, Colorize, Emboss, and more.

For example, if you create an oval shape with the Solid mode selected, a solid color oval appears in the frame. (The color is determined by the current selection in the Color parameter category.) If you create the same oval shape and select the Lighten mode, the oval will not be a solid color that masks part of the image beneath. Instead, it will define an area of the image that is lightened by an amount you specify.

The AniMatte effect provides two modes, Key In and Key Out. These modes enable you to key in or key out an image in a sequence.

*For a complete listing of the characteristics of each Paint Effect mode as well as the Key In and Key Out modes in the AniMatte effect, see "Mode for the Paint and AniMatte Effects" in the Help.*

Using an Optional Pen Tool

The Avid application supports the addition of a pen tool and graphics tablet for use with the Intraframe Editing option. For installation and configuration instructions, see the documentation that ships with your pen tool and tablet.
Using the Brush Tool

With the Brush tool, you can use the mouse or a pen tool with a tablet to paint objects or mattes with precision directly on the images in a sequence. You also can change and customize the brush shape, as well as determine the opacity of the paint or matte, adjust the outline feathering and softness values, and, for the Paint Effect, define the color.

When you paint an object in a sequence, you paint on the frame displayed in the Effect Preview monitor. The painted object is superimposed over the video background, appearing closer to you in three-dimensional space. Each object you paint creates a foreground layer that you can work with individually or that you can group with other painted objects in the segment.

Selecting a Color

You can select the color with which you want to paint by using the eyedropper, the parameter sliders, the Windows Color dialog box, or the Macintosh Color Picker. You can select the color before you begin painting or after you have painted an object.

Shortcut for Selecting a Color with the Brush Tool

When you use the Brush tool to paint an object, you can select a color quickly from a video segment.

To select a color from a video segment when using the Brush tool:

1. In the Effect Editor, click the Brush tool to make it the active paint tool.
2. In the Mode category, click the Fast Menu button, and then select Solid.
3. Press and hold the Alt key (Windows) or Option key (Macintosh), and drag the pointer to the Effect Preview monitor.
   The pointer becomes an eyedropper.
4. Position the eyedropper over the color you want to select, and click it.
   The color you picked becomes the new default color shown in the Color Preview window.
Painting with the Brush

To begin painting with the Brush tool:

1. Apply the Paint Effect to a segment in the sequence as described in “Applying the Paint or AniMatte Effect to a Sequence” on page 482.

2. Click the Brush tool in the Effect Editor.

3. Select a paint mode or key mode and parameters in the Effect Editor.

4. In the Brush parameter category of the Effect Editor, click one of the Brush Shape buttons.

   The default shape of the brush head changes to your selection.

5. Position the pointer over the image in the Effect Preview monitor.

   Notice that the pointer becomes a crosshair.

6. Press and hold the mouse button, and drag to paint freehand style on the video background.

7. Release the mouse button when you have finished painting the object.

Creating a Custom Brush Head from a Template

You can change the brush head to a custom shape by modifying the brush head in the Brush Preview window.

To create a custom brush head:

1. Click the Brush tool in the Effect Editor.

2. Click a Brush Shape button to be the basis for your custom brush head.

   The shape appears as the brush head in the Brush Preview window.
3. In the Brush Preview window, click the brush head. Control points appear on the brush head where curves merge or straight lines intersect.

4. Click a control point, and drag it to change the shape of the brush head.
5. Repeat step 4 with other anchor points as needed.

For brush shapes with rounded edges and curves, such as the oval, the ellipse, and the circle, clicking an anchor point creates direction bars and handles that enable you to edit the Bézier curve. For information on working with Bézier curves, see “Working with Vector-Based Objects” on page 503. You can use the direction bars and handles, and you can drag the object’s control points, but you cannot use the modifier key variations.

To rotate the brush head:

1. Click the Brush tool if the brush is not already active.
2. Click the Brush Shape button for the brush head you want to rotate. The shape appears in the Brush Preview window.
3. Do one of the following:
   ▶ Drag the Spin slider to the right (clockwise rotation) or to the left (counterclockwise rotation) to rotate the brush head to the position you want.
   ▶ Click the Spin slider, and use the numeric keypad to type a value from –360 to 360.
Saving a Brush Template

You can save a template of a custom brush to a bin so that you can reuse the parameters of the brush with an Intraframe effect.

**To save a brush template:**

1. In the Brush category, click the Brush Template icon, and then drag it to a bin.

   A brush template appears in the bin, and the name of the template defaults to Brush.

2. Click the name of the template in the bin, type a unique name for the template, and press Enter (Windows) or Return (Macintosh).

**To use a brush template:**

- Click the template in the bin, drag it to the Brush Preview window, and release the mouse button.

  The brush in the Brush Preview window assumes the same parameters as the brush template you saved to the bin.

Using Path to Create a Signature Effect

The Path parameter slider is useful for creating a “signature” effect with the Paint Effect, in which a signature gradually appears on the screen as if written with an invisible pen.
To create the signature effect:

1. Apply the Paint Effect to a segment.
2. In the Effect Editor, click the Brush tool.
3. In the Mode category, click the Fast Menu button, and select Solid.
4. Press and hold the mouse button, and drag the pointer in the Effect Preview monitor to paint a signature or other string of text.
5. Release the mouse button when you are satisfied with the text.
6. Click the first keyframe indicator in the segment to select it.
7. Select the painted object if it is not selected already.
8. Click the Path slider, type 0, and press Enter (Windows) or Return (Macintosh).
9. Click the last keyframe indicator in the segment to select it.
10. Click the Path slider, type 100, and press Enter (Windows) or Return (Macintosh).

Alternatively, you can add keyframes at different locations in the effect’s Timeline and change the percentage of the Path parameter at each keyframe to modify how the effect appears over the course of the segment.

11. Render the Paint Effect to play it back in real time. For more information, see “Rendering Effects” on page 176.

Using the Selection Tool

The Selection tool is one of the most frequently used tools. You use this tool to select a painted object or matte on the screen when you want to make changes to it. After you select an object, you can move it in the frame, rescale it, and change its parameters.

To select an object:

- Click the Selection tool, and click an object.

Selection handles appear around the object.
To select multiple objects, do one of the following:

- Shift+click the additional objects with the Selection tool.
- Press and hold the mouse button, and drag the pointer to draw a lasso around the objects.

When you select multiple objects, one set of selection handles appears around all the objects, which enables you to move, rescale, or otherwise change the parameters of all the selected objects simultaneously.

When a segment contains multiple objects, you can change your selection from one object to another by clicking one of the following buttons: Fast Forward, Rewind, Go to Next, or Go to Previous. The Fast Forward button and the Rewind button are in the Effect Preview Monitor toolbar. To use the Go To Next button and the Go To Previous button in Effect mode, you must map them to your keyboard. For more information on mapping buttons, see the quick reference card, the editing guide, or the Help.

Creating Rectangular Shapes

With the Rectangle tool, you can paint rectangular shapes or mattes on images in a sequence. Using the Rectangle tool, you can access all the paint modes and parameters in the Effect Editor, with the exception of the Brush parameter category.
Chapter 11  Intraframe Editing

To paint with the Rectangle tool:

1. In the Effect Editor, click the Rectangle tool.
2. In the Effect Editor, select a paint mode or key mode and parameters.
3. Position the pointer where you want to begin painting in the frame.
4. Press and hold the mouse button, and drag to create the rectangle.
   As you drag, you describe the diagonal of the rectangle. The rectangle’s anchor point is the point at which you start to drag. For example, if you drag to the right and down, the rectangle is anchored to its upper left corner.

5. Release the mouse button to complete the rectangle.
6. Adjust the object’s parameters if needed.

Creating Oval Shapes

With the Oval tool, you can paint oval shapes or mattes on images in a sequence. Using the Oval tool, you can access all the paint modes and parameters in the Effect Editor, with the exception of the Brush parameter category.

To create oval shapes:

1. In the Effect Editor, click the Oval tool.
2. In the Effect Editor, select a paint mode or key mode and parameters.
3. Position the pointer where you want to begin painting in the frame.

4. Press and hold the mouse button, and drag to create an oval.

   As you drag, you describe the diagonal of the oval. The oval’s anchor point is the point at which you start to drag. For example, if you drag to the right and in a downward fashion, the oval is anchored to its upper left corner.

   If you press the Alt key (Windows) or Option key (Macintosh) and drag, the oval is centered on the point at which you start to drag.

5. Release the mouse button to complete the oval.

6. Adjust the object’s parameters if needed.

**Drawing Polygons**

With the Polygon tool, you can paint a variety of geometric objects and trace images in a frame. Using the Polygon tool, you can access all the modes and parameters in the Effect Editor, with the exception of the Brush parameter category. You can use the Polygon tool to create objects and mattes composed of straight-line segments, curved segments, or a combination of both.

To take full advantage of the power of the Polygon tool, you should be familiar with the concepts behind vector-based graphics. If you are not familiar with these principles, see “Working with Vector-Based Objects” on page 503.
Chapter 11  Intraframe Editing

It might help you to visualize the shape and the position of the polygon within the frame before you begin painting. By visualizing the object first, you gain more control over the object’s attributes when you edit it later.

The general workflow for working with the Polygon tool is:

1. Visualize the object you want to create.
2. Determine a location in the frame to begin painting, and click that location to create the initial control point.
3. Click additional control points as you continue to define the shape of the object.
4. Double-click to create the final control point, or click the initial control point to create the closed polygon.

*Try to create the object with as few control points as possible. Fewer control points will eliminate more work if you need to modify the object later.*

**Creating Polygons with Straight-Line Segments**

**To create a polygon with straight-line segments:**

1. In the Effect Editor, click the Polygon tool.
2. Select a paint mode or key mode and parameters in the Effect Editor.
3. Click in the frame where you want to place the initial control point.

*The control points do not appear as tiny rectangles while you are painting the object.*

4. Click in the frame where you want to place the next control point.

A straight-line segment is drawn between the initial control point and the control point you just created.
Using the Intraframe Drawing Tools

Segments appear as wire frames until you finish painting the object.

5. Click in the frame to create additional control points that further define the shape of the object.

A straight-line segment appears between each pair of adjacent control points.

6. When you are satisfied with the shape of the object, double-click in the frame to create the final control point or click the initial control point. The object becomes a closed polygon.

7. Adjust the parameters of the polygon if needed.
Creating Polygons with Curved Segments

To create a polygon with curved segments:

1. In the Effect Editor, click the Polygon tool.
2. Select a paint mode or key mode and parameters in the Effect Editor.
3. Click in the frame where you want to place the initial control point, and release the mouse button.

The control points do not appear as tiny rectangles while you are painting the object.

4. Drag the pointer to the location where you want to place the next control point.
5. Click and hold the mouse button to begin creating the first curved segment.

Direction bars with handles appear as a tangent to the curved segment. The pointer “leads” the direction handle that you will use to determine the direction and height of the curve.

6. Drag the pointer, which is attached to the direction handle, to adjust the direction and height of the curved segment.
7. Release the mouse button when you are satisfied with the height and angle of the curved segment.
8. Drag the pointer to the next location where you want to create a curved segment.

9. Repeat steps 3 to 8 to create additional curves if needed.

10. When you are satisfied with the shape of the object, double-click in the frame to create the final control point or click the initial control point. The object becomes a closed polygon.

11. Adjust the parameters of the polygon if needed.

**Creating a Straight Line Following a Curve**

**To create a straight line following a curved segment:**

1. Create one or more curved segments as described in “Creating Polygons with Curved Segments” on page 498.

2. Drag the pointer to the location where you want to begin painting the straight line.

3. Click and then release the mouse button to create the control point.

4. Drag the pointer to the location where you want the straight-line segment to end.
5. Click and then release the mouse button to create the control point.

6. Continue to create additional lines and curves.

7. When you are satisfied with the shape of the object, double-click in the frame to create the final control point or click the initial control point. The object becomes a closed polygon.

8. Adjust the parameters of the polygon if needed.
Creating Curved Objects

With the Curve tool, you can trace curved objects with freehand capability. Using the Curve tool, you can access all the paint modes and parameters in the Effect Editor, with the exception of the Brush parameter category.

**To paint with the Curve tool:**

1. In the Effect Editor, click the Curve tool.
2. Select a paint mode or key mode and parameters in the Effect Editor.
3. Position the pointer where you want to begin painting in the frame.
4. Press and hold the mouse button, and drag the pointer as you paint a freehand curved shape on the frame.
5. When you are satisfied with the shape of the object, release the mouse button to complete the curved object.
6. Adjust the object’s parameters if needed.

Changing the Parameters of a Painted Object

You can change the parameters of an object you have already painted. Click the Selection tool, click the object to select it, and perform any of the following procedures.

**To move an object:**

- Click anywhere *within* the object’s outline, and drag the object to a new location.

**To rescale an object, do one of the following:**

- Click one of the selection handles and drag.
- Press and hold the Alt key (Windows) or Option key (Macintosh) while you click one of the selection handles, and drag to rescale the object from its center.
To change the color of an object:

1. Click the triangular opener for the Color parameter category.

<table>
<thead>
<tr>
<th>Color</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Hue</td>
<td>137</td>
</tr>
<tr>
<td>Sat</td>
<td>255</td>
</tr>
<tr>
<td>Lum</td>
<td>255</td>
</tr>
</tbody>
</table>

2. Adjust the Hue, Sat (saturation), and Lum (luminance) sliders.

To add feathering to an object's edges:

1. Click the triangular opener for the Feathering parameter category.

<table>
<thead>
<tr>
<th>Feathering</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Bias</td>
<td>50</td>
</tr>
<tr>
<td>Hor</td>
<td>0</td>
</tr>
<tr>
<td>Vert</td>
<td>0</td>
</tr>
</tbody>
</table>

2. Adjust the Bias, Hor (horizontal), and Vert (vertical) sliders.

To delete an object:

1. Click the Selection tool.

2. Click the object you want to delete.
3. Do one of the following:
   - Press the Delete key.
   - Select Edit > Delete.

To undelete an object:
   - Select Edit > Undo.

**Working with Vector-Based Objects**

Before you begin working with the paint and editing tools included in the Intraframe effects, you must understand the basics of working with vector-based objects and Bézier curves. The vector-based graphics technology of the Intraframe Editing option enables you to create and edit objects and mattes with a precision that you cannot achieve when you work with bitmapped objects. Vector-based objects are not subject to problems such as artifacting when you rescale them.

**The Elements of Vector-Based Objects**

The objects you paint, the matte keys you draw, and the brush templates that appear in the Brush Preview window include a control point at the midpoint of each line or curve, also known as a join. The portion of the line or curve on each side of the control point is called a segment. The control point controls the direction of each segment as it passes through the join.

Control points for a painted object are visible when you select an object with the Selection tool and then click the Reshape tool. Also, when you click a brush template in the Effect Editor, the brush head displays visible control points in the Brush Preview window.
A painted object can include three types of joins that describe its shape:

- Straight-edge join
- Smooth join
- Corner join

A control point associated with a smooth join or a corner join describes a Bézier curve. Clicking a control point makes it the active join. Tangents called direction bars appear on each side of the control point associated with a Bézier curve. At the end of each direction bar is a direction handle. Dragging a direction handle changes the way the segments pass through the control point to define the curve.

When you drag a direction handle, you change the height and angle of the curve. The curve responds as if you were gently tugging it like a piece of string. The segments remain anchored to the control points on either side of the active join.

In contrast, straight-edge joins do not display direction bars and handles when you click them.
To reshape an object composed of one or more straight edges:

- Click the Selection tool, click the object to select it, click the Reshape tool, and then drag one or more control points. For information on control points, see “Moving Control Points Manually” on page 515.
- Convert straight-edge joins to Bézier curves, and manipulate the curves as described in the following sections.

Getting Started with Bézier Curves

If you have never worked with Bézier curves, learning how to work with them requires a willingness to experiment. As you practice working with Bézier curves, you will gain greater control over painted objects and mattes, and the process will become more intuitive. The following sections describe how to paint a rectangular object with the Paint Effect and use the Reshape tool to convert corners into Bézier curves. You then will modify the curves to change the shape of the object.

Transforming a Rectangle into a Circle

**To create a rectangle and transform it into a circle with Bézier curves:**

1. Apply the Paint Effect to a segment in a sequence.

2. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.

3. In the Effect Editor, click the Rectangle tool.

4. In the Mode parameter category, click the Fast Menu button, and then select Solid.

5. Press and hold the mouse button, and drag in the Effect Preview monitor to paint a rectangular object. Do not worry about picking a color or other parameters for this exercise.

6. Click the Selection tool, and click the object you just painted.
7. Click the Reshape tool, or double-click the object.
Notice that each corner of the rectangle displays a control point.

8. Alt+click (Windows) or Option+click (Macintosh) the control point at the top left corner of the rectangle.
Notice that the straight-edge join becomes a smooth join with direction bars and handles.

9. Working in a counterclockwise direction, Alt+click (Windows) or Option+click (Macintosh) each control point until they have all been transformed into smooth joins.
The resulting shape is a circle. The control point at the top right of the circle is the active join and displays direction bars and handles.

**Experimenting with Direction Handles**

To experiment with the direction handles:

1. Click the bottom direction handle, and drag away from the control point to increase the length of the direction bar.

Notice how the curve changes. Also, the direction bar and segment on the opposite side of the control point move in unison with the direction bar you are dragging. The control points adjacent to the active join serve as anchor points for the segments that compose the curve.
2. Drag the direction handle toward the control point to shorten the direction bar.

Notice how the curve changes as you shorten the direction bar.

3. Shift+click the direction handle, and drag it away from the control point.

Notice that the length of the direction bar on the opposite side of the control point does not change; this prevents the height of its associated segment from changing. However, the opposite direction bar does move in unison with the direction handle you are dragging, thereby changing the angle of the segment in unison.

4. Shift+click the direction handle to revert the direction bars to their previous functionality.

5. Click the bottom direction handle, and drag it in a counterclockwise direction.
Notice how the curve changes as you drag the direction bar.

6. When you have finished experimenting, adjust the direction bar so that the object again resembles a circle.

Creating a Corner Join

The painting tools do not create corner joins by default; you can change an existing smooth join into a corner join as described in this section.

*If you want to transform a straight-edge join into a corner join, you must transform the straight-edge join into a smooth join first.*

To transform a smooth join into a corner join:

1. Alt+click (Windows) or Option+click (Macintosh) the bottom direction handle.

   Although you might not notice it immediately, the smooth join is transformed into a corner join.

2. Drag the direction handle away from the control point.
Notice how the active segment behaves as you lengthen the direction bar. The direction bar and segment on the opposite side of the control point do not move in unison with this direction handle. Also, notice that the active segment remains anchored to the adjacent control point.

3. Drag the direction handle in a counterclockwise direction.
Notice how the segment changes as you drag the direction bar.

4. When you are finished experimenting, Alt+click (Windows) or Option+click (Macintosh) the direction handle.
The control point reverts to a smooth join.
Modifying Lines and Curves Summarized

Table 20 summarizes how you can use the mouse and the modifier keys on the keyboard to modify lines and Bézier curves (smooth joins or corner joins).

### Table 20 Methods of Modifying Lines and Curves

<table>
<thead>
<tr>
<th>Illustration</th>
<th>Description</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Direction handle</td>
<td>Smooth join: Drag one direction handle so that the direction bar on the opposite side of the control point moves and changes length in unison.</td>
<td>You do not have to press any of the modifier keys. Click one of the direction handles, and drag it.</td>
</tr>
<tr>
<td>Direction bar</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Active direction handle</td>
<td>Smooth join: Drag one direction handle so that the direction bar on the opposite side of the control point moves in unison but does not change in length.</td>
<td>Shift+click a direction handle. To change it back, Shift+click the direction handle.</td>
</tr>
<tr>
<td>Straight-edge join</td>
<td>Transform a straight-edge join into a smooth join.</td>
<td>Alt+click (Windows) or Option+click (Macintosh) the control point. To change it back to a straight-edge join, Alt+click (Windows) or Option+click (Macintosh) the smooth join.</td>
</tr>
<tr>
<td>Smooth join</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Table 20  Methods of Modifying Lines and Curves (Continued)

<table>
<thead>
<tr>
<th>Illustration</th>
<th>Description</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smooth join</td>
<td>Transform a smooth join into a corner join.</td>
<td>Alt+click (Windows) or Option+click (Macintosh) one of the direction handles. To change it back to a smooth join, Alt+click (Windows) or Option+click (Macintosh) the direction handle.</td>
</tr>
<tr>
<td>Corner join</td>
<td>Corner join: Drag one direction handle so that the direction bar on the opposite side of the control point moves independently of the bar on the opposite side of the control point.</td>
<td>You do not have to press any of the modifier keys. Click one of the direction handles, and drag it.</td>
</tr>
</tbody>
</table>

Painting a New Object with Bézier Curves

When you paint a freehand object to mask, colorize, or otherwise modify an image in a frame, you can achieve extraordinary precision when you know how to control Bézier curves. Being able to visualize curves and where you need to place their associated control points before you begin painting can make the process of tracing shapes easier.

The following tools paint new objects composed of Bézier curves:

- Oval tool
- Polygon tool
- Curve tool
For information on how to use these tools to paint new objects with Bézier curves, see the description for each tool in “Layering with the Paint Effect” on page 524. You are not limited to using these tools to create curved objects because you can transform the straight-edge joins in any painted object into Bézier curves as described in “Modifying Lines and Curves Summarized” on page 511.

**Adding a Control Point**

Placing more control points on an object enables the object to trace more detailed images. For example, if a segment of an object does not follow a curved section on a frame as well as you would like, and adjusting the control points and direction bars does not help, you can add a new control point.

**To add a control point:**

1. Click the Selection tool, and click the object.
2. Do one of the following:
   - Click the Reshape tool.
   - Double-click the object.
3. Click the selected object where you want to add a new control point.

A new control point appears and is calculated so that the original object, as you drew it, does not change dramatically in shape. The new control point appears as part of the object for all keyframes in the segment.

Any changes you make to a control point, such as moving it or changing the angle of the associated curve, affects the keyframes you have selected in the segment. If you change a control point at a selected keyframe or add a keyframe to make changes, the changes are interpolated between the selected keyframe and adjacent keyframes.
Removing a Control Point

Avid recommends that you remove a control point if the object does not need the control point to adequately define its shape. It is better to have fewer control points and to manipulate the direction bars to gain the same effect because fewer control points mean less work if you need to modify an object later.

To remove a control point:

1. Click the control point, and press the Delete key.

You also can Shift+click multiple control points and then delete them.

The Avid application attempts to reconstruct the object so that it does not change. The results you see might vary because of the internal mechanics and geometry of Bézier curve technology. However, adding and then removing the same control point should not dramatically change the curve of that section of an object.

Moving to Adjacent Control Points

You can move from a control point to an adjacent control point without having to click the mouse. You use the Fast Forward button and Rewind button in the Effect Preview Monitor toolbar.

To move to an adjacent control point:

1. Click a control point.
2. Move to an adjacent control point:
   - In the Effect Preview Monitor toolbar, click the Fast Forward button to move in a clockwise fashion to the next control point.
   - In the Effect Preview Monitor toolbar, click the Rewind button to move in a counterclockwise fashion to the next control point.

### Moving Control Points Manually

You can move control points manually by simply clicking them and then dragging. You can move one control point at a time or several control points at once. Before you select control points for moving, first click the Selection tool, and click the object to display the control points.

**To move control points manually:**

- **Single control points**: Drag an individual control point to its new location. The control point’s direction bars do not change orientation.

- **Multiple control points**: Click one control point, and then Shift+click or lasso additional control points that you want to move. Drag one of the selected control points. All other selected control points move in unison. To deselect the group, click any unselected control point.

- **All control points**: Press Ctrl+A (Windows) or ⌘+A (Macintosh) to select all control points. Drag one of the selected control points. All other control points move in unison. To deselect the group, click outside the object to deselect it.

### Moving Control Points and Objects in Small Increments

You can “nudge” selected control points or an entire object in 1-pixel increments using keys on the keyboard.

**The Effect Preview monitor must be the active window for this feature to work. Additionally, if you have remapped the arrow keys on your keyboard, this feature might not function properly.**
To move or “nudge” control points in 1-pixel increments:

1. Click a control point to select it, or Shift+click additional control points to move them as a group.

2. Nudge the control point or points using one of the following techniques:
   - To nudge selected control points to the left, press the Left Arrow key or the Trim Left key.
   - To nudge selected control points to the right, press the Right Arrow key or the Trim Right key.
   - (Windows) To nudge selected control points up, press the Alt key and the Left Arrow key or the Trim Left key.
   - (Macintosh) To nudge selected control points up, press the Option key and the Left Arrow key or the Trim Left key.
   - (Windows) To nudge selected control points down, press the Alt key and the Right Arrow key or the Trim Right key.
   - (Macintosh) To nudge selected control points down, press the Option key and the Right Arrow key or the Trim Right key.

Previsualization Marker Tool for Film Projects

The Previsualization Marker tool enables you to place a marker in a segment to represent an effect that will be processed at an optical facility. This tool is applicable to 24-fps projects only and appears in the Effect Editor only when you are working in a film project with the Paint Effect.

When you create an optical list, each marker, along with its position in the segment on a keyframe-by-keyframe basis, appears as an optical event. The editor at the optical facility can refer to the event as a cue for creating a visual effect, such as a rotoscoped object.

You generate optical lists with Avid FilmScribe. For general information on using Avid FilmScribe, see the Avid FilmScribe User’s Guide.
For example, the optical editor’s assignment is to create an airplane that flies through the scene. The editor can use keyframe information from the optical list to plot the exact path of the effect as it moves through the scene. The marker’s position at each keyframe is described with coordinates derived from the Effect Grid. Position is described in terms of compass coordinates and X, Y coordinates.

Additionally, you can add multiple markers to a single scene to represent different effects, and you can use a unique color for each marker. The resulting optical list will display each marker and its unique color values to enable the optical editor to distinguish each marker.

### Applying a Previsualization Marker Effect

#### To add a Previsualization Marker effect to a sequence:

1. Enable the Effect Grid and set the appropriate parameters for image scan size, aspect ratio, and film format. See “Displaying the Effect Grid in Effect Mode” on page 92 and “Setting the Effect Grid Options” on page 89.

2. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.

3. In the Effect Editor, click the Previsualization Marker tool.

4. Adjust the sliders in the Color parameter category to determine the color of the marker.

5. Move the pointer to the location in the frame where you want to place the marker, and click the mouse.
   
   A marker appears in the frame.

6. Use keyframes to move the marker throughout the segment.

#### To add more markers:

- Repeat steps 2 to 5.

#### To delete a marker:

- Click the marker to highlight it, and then press the Delete key.
Creating a Cut List with Previsualization Marker Information

To include the Previsualization Marker coordinate information in a cut list:

1. Select Output > FilmScribe to start FilmScribe.
2. Select File > New Cut List.
3. In the Lists pane, select Optical.
4. In the Options pane, select Key Frames.

The following illustration shows the presentation of Previsualization Marker information in a cut list.

<table>
<thead>
<tr>
<th>Key Frame Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>KF</td>
</tr>
<tr>
<td>-----</td>
</tr>
<tr>
<td>(1)</td>
</tr>
<tr>
<td>Marker1 (R: 255, G: 0, B: 6)</td>
</tr>
<tr>
<td>(N: 0.0, W: 0.0) (X: 30, Y: 91)</td>
</tr>
<tr>
<td>Marker2 (R: 00, G: 61, B: 20)</td>
</tr>
<tr>
<td>(N: 0.0, W: 0.0) (X: 243, Y: 194)</td>
</tr>
</tbody>
</table>

Manipulating Intraframe Objects

The Intraframe effects include editing tools and additional parameters that enable you to perform the following operations:

- Move objects individually or in groups
- Reshape objects
- Rotate objects
- Scale objects
- Apply keyframed changes over time
Moving Intraframe Objects

The Selection tool also enables you to drag objects or mattes around the screen and in relation to the screen when you zoom out from a frame.

**To move a painted object or matte:**

1. In the Effect Editor, click the Selection tool.
2. Click the object you want to move.
   - The object outline becomes highlighted, and four selection points appear around the object.
3. Click the center of the object, and drag it to a new location.
4. Release the mouse button when the object is positioned in the location you want.

Reshaping Intraframe Objects

The Reshape tool enables you to modify the shape of a painted object or matte on the screen using several different techniques. These procedures require some familiarity with vector-based graphics. For more information, see “Working with Vector-Based Objects” on page 503.

You can use keyframes to change the shape of an intraframe object over time. For more information, see “Changing Intraframe Object Parameters over Time” on page 523.

**To reshape an object:**

1. Click the Selection tool, and click an object or matte.
2. Do one of the following:
   - Click the Reshape tool.
   - Double-click the selected object.
The outline of the object becomes highlighted, and control points appear.

If you want to drag the control points only, Alt+click (Windows) or Option+click (Macintosh) the Reshape tool to hide the direction handles.

3. Edit the shape of the object or matte:
   - Click one or more of the object’s control points and drag. For information on moving control points, see “Moving Control Points Manually” on page 515.
   - Edit the object by manipulating the direction bars at one or more control points. For information on editing straight-line segments and curved segments, see “Modifying Lines and Curves Summarized” on page 511.

Reshaping Objects Created with the Curve Tool

The default behavior of control points in an object or matte created with the Curve tool differs slightly from those created with the Polygon tool. When you drag one of the direction handles, the direction bar on the opposite side of the control point moves in unison but the length does not change in unison. The dimensions of the curved segments on each side of the control point are not equal because the Curve tool creates curves with freehand capability, not with a mathematical formula that describes a Bézier curve in the way that the Polygon tool does.
You can transform the direction bars at a control point so that their lengths change in unison when you drag one of the direction handles. To do so, Shift+click one of the direction handles. For more information, see “Modifying Lines and Curves Summarized” on page 511.

Rotating Intraframe Objects Along the Z Axis

With the Z-Rotation tool, you can select an object or matte and rotate it around the Z axis (clockwise or counterclockwise direction). You also can change the rotation of an object over time by rotating the object on an individual keyframe basis.

You can use keyframes to change the rotation of an intraframe object over time. For more information, see “Changing Intraframe Object Parameters over Time” on page 523.

To rotate an object or matte around the Z axis:

1. In the Effect Editor, click the Z-Rotation tool.
2. Click the object you want to rotate.
   The object outline becomes highlighted, and a rotation handle appears within the object.

    Center of rotation
    Z-Rotation handle

   The X on the rotation handle marks the default center of the Z axis for the object. You can click the X and drag it anywhere on the screen to change the center of the object’s rotation.
3. Click the rotation handle and drag the mouse to rotate the object in either a clockwise or a counterclockwise direction.
Scaling Intraframe Objects

You can rescale any object or matte that you create. Rescaling increases or decreases all dimensions of the object proportionately.

You can use keyframes to change the scale of an intraframe object over time. For more information, see “Changing Intraframe Object Parameters over Time” on page 523.

To rescale an object or matte:

1. In the Effect Editor, click the Selection tool.
2. Click the object you want to rescale.
   The object outline becomes highlighted, and four selection points appear around the object.
3. Rescale the object using one of the following methods:
   - Click any selection point and drag.
     Dragging toward the center of the object decreases the overall size, while dragging away from the center increases the overall size. When you drag a selection point, the object is anchored by the selection point that is diagonal to the one you are dragging.
Manipulating Intraframe Objects

- Alt+click (Windows) or Option+click (Macintosh) any selection point, and drag to rescale the object, using the center of the object as the anchor.

Changing Intraframe Object Parameters over Time

You can animate an intraframe object by changing parameters on an individual keyframe basis. The following parameters are keyframeable:

- Position of an object on screen (see “Moving Intraframe Objects” on page 519)
- Shape of an object (see “Reshaping Intraframe Objects” on page 519)
- Z-axis rotation of an object (see “Rotating Intraframe Objects Along the Z Axis” on page 521)
- Scale or relative size of an object (see “Scaling Intraframe Objects” on page 522)
- Feathering (see “Feathering” in the Help)
- Foreground level (see “Foreground” in the Help)
- Magic Mask (see “Magic Mask” in the Help)

For more information on using keyframes with parameters, see “Using Standard Keyframes” on page 111.
Layering, Grouping, and Locking Intraframe Objects

The Intraframe effects include tools for navigating and adjusting layers of intraframe objects, for grouping objects for performing operations on several objects at once, and for locking objects to prevent further changes.

Layering with the Paint Effect

When you paint on a frame, the paint appears as an object in the foreground, seeming closer to you in three-dimensional space than the video frame. You can change the parameters of each painted object independently, including the object’s orientation in relation to another object. For example, if you have three painted objects, you can stack or cascade them over each other to create three separate layers of objects in the foreground.

All compositing of painted objects takes place in the foreground and is not destructive to the video background. When you composite various Paint Effects on a frame, remember that the application renders the Paint Effects to the screen beginning with the bottom layer.

Layering with the AniMatte Effect

Layering with the AniMatte effect works much as it does with the Paint Effect, but the image that appears in the foreground is the video that you have chosen to key in or key out. Even though the application renders matte keys starting with the highest track in a multilayer matte key, compositing of multiple AniMatte effects in the same segment occurs in the foreground and is not destructive to the video background.

Locating Layered Objects with the Outline/Path Button

You can use the Outline/Path button to locate an object or matte that might be obscured by others on the screen. The Outline/Path button creates a wire-frame representation of each object, which enables you to locate, select, and manipulate the object. Clicking the Outline/Path button switches the Path on or off.
Layering, Grouping, and Locking Intraframe Objects

To locate objects or mattes with the Path function:

1. In the Effect Editor, click the Outline/Path button.
   Each object painted on the frame appears as a wire frame.
2. Select an object, and change its location or parameters.
3. Click the Outline/Path button to return to default viewing mode.

**Bringing Objects and Mattes Forward by One Layer**

You can use the Bring Forward function to bring a single object or matte forward by one layer (appearing closer to you in three-dimensional space).

**To bring an object or matte forward by one layer:**

1. Click the Selection tool, and click an object on the screen.
   If the object is obscured by other objects, use the Outline/Path feature to locate it as described in “Locating Layered Objects with the Outline/Path Button” on page 524.
2. Do one of the following:
   - In the Effect Editor, click the Bring Forward button.
   - Select Object > Bring Forward.
     The object moves one layer forward in the foreground.

**Sending Objects and Mattes Backward by One Layer**

You can use the Send Backward function to send a single object or matte backward by one layer (appearing farther away from you in three-dimensional space).

**To send a painted object or matte backward by one layer:**

1. Click the Selection tool, and click an object on the screen.
   If the object is obscured by other objects, use the Outline/Path feature to locate it as described in “Locating Layered Objects with the Outline/Path Button” on page 524.
Chapter 11  Intraframe Editing

2. Do one of the following:
   - In the Effect Editor, click the Send Backward button.
   - Select Object > Send Backward.
   
   The object moves one layer backward into the layers of objects that appear in the foreground.

**Bringing Objects and Mattes to the Front**

You can use the Bring To Front function to bring a single object or matte to the front of the foreground layers (appearing closest to you in three-dimensional space).

**To bring a painted object or matte to the front:**

1. Click the Selection tool, and click an object on the screen.
   
   If the object is obscured by other objects, use the Outline/Path feature to locate it as described in “Locating Layered Objects with the Outline/Path Button” on page 524.

2. Do one of the following:
   - In the Effect Editor, Alt+click (Windows) or Option+click (Macintosh) the Bring Forward button.
   - Select Object > Bring To Front.
   
   The object becomes the top layer in the foreground.

**Sending Objects or Mattes to the Back**

You can use the Send To Back function to send an object or matte to the bottom layer (appearing farthest away in three-dimensional space).

**To send a painted object or matte to the back:**

1. Click the Selection tool, and click an object on the screen.
   
   If the object is obscured by other objects, use the Outline/Path feature to locate it as described in “Locating Layered Objects with the Outline/Path Button” on page 524.
Layering, Grouping, and Locking Intraframe Objects

2. Do one of the following:
   - In the Effect Editor, Alt+click (Windows) or Option+click (Macintosh) the Send Backward button.
   - Select Object > Send to Back.

   The object becomes the bottom layer in the layers of painted objects that make up the foreground.

Grouping and Ungrouping Intraframe Objects

The Avid application enables you to group objects or mattes so that they behave as a single object. You then can move the new group and change its parameters as if it were a single object. If you want to separate the group and revert to working with the individual objects, you can do so using the Ungroup function.

**To group painted objects or mattes:**

1. Click the Selection tool, and click an object.
   - If the object or matte is obscured by other objects, use the Outline/Path feature to locate it as described in “Locating Layered Objects with the Outline/Path Button” on page 524.
2. Shift+click any additional objects you want to include in the group.
   - The objects become grouped together, and you can manipulate the group as if it were a single object.

**To ungroup painted objects or mattes:**

1. Click the Selection tool, and click an object that is a member of the group.
2. Select Object > UnGroup.
   - The objects become ungrouped.

You can also group together groups of objects. If you then click the new group and select UnGroup, all objects become ungrouped completely.
Chapter 11  Intraframe Editing

Locking and Unlocking Intraframe Objects

Using the lock feature, you can lock an object or a group in place on the screen. When you lock an object, the application prevents you from moving the object accidentally while you add more effects and make additional edits to your sequence.

To lock a painted object, matte, or group:
1. Click the Selection tool, and click an object or group.
   If the object is obscured by other objects, use the Outline/Path feature to locate it as described in “Locating Layered Objects with the Outline/Path Button” on page 524.
2. Select Object > Lock.

To unlock a painted object, matte, or group:
1. Click the Selection tool, and click an object or group.
2. Select Object > Unlock.

Exporting a Matte PICT File

You can create a matte with the AniMatte effect and export it as a high-contrast matte — without having to leave Effect mode. The exported image is a high-contrast 32-bit PICT file that includes an alpha channel.

You can use the exported PICT file in the following ways:

- Import the file back into the Avid application to create a real-time Matte Key clip that you can edit into a sequence. You can use this clip as a garbage matte or promote the clip to 3D.
- Open the file in a third-party graphics application, edit the file, and import the file back into the Avid application.
- Use the file as a graphic in an application other than the Avid application.
When you import the PICT file back into the Avid application, the application creates a Matte Key clip in the bin that you select. You can load the Matte Key clip into the Source monitor and edit it into a sequence as you can with any other imported matte key. The Matte Key clip appears as a high-contrast matte with transparent (black) and opaque (white) components.

For more information on creating matte keys, see “Creating Key Effects” on page 282. For more information on editing a Matte Key clip into a sequence, see “Editing with Imported Matte Key Clips” on page 291.

When you open the high-contrast PICT file in a third-party application that supports alpha channels, select the file’s alpha channel to view the high-contrast components of the matte. However, if you open the PICT file in an application that does not support alpha channels, the image appears completely white.

To export a matte key created with the AniMatte effect:

1. Use the AniMatte effect to create a matte key. For more information, see “Applying the Paint or AniMatte Effect to a Sequence” on page 482.
2. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.
3. In the Timeline, move the position indicator to the frame you want to export.
4. Select File > Export.
   The Export As dialog box opens.
5. Select the location where you want to save the PICT file, and then click Save.
   The application saves the PICT file to the location you selected.
6. If necessary, open the PICT file in a third-party application and make changes to the file.
7. Select the bin into which you will import the PICT file, and select File > Import.
   The Select files to Import dialog box opens.
Chapter 11  Intraframe Editing

8. Click Options.

9. In the Alpha area, click one of the following to select an alpha channel option:
   - Use Existing
   - Invert Existing
   - Ignore

Depending on your needs, you might have to select Invert Existing Alpha; in a high-contrast matte key with an alpha channel, the white regions are opaque, and the black regions are transparent.

For more information on importing a matte key, see “Importing Files” in the Help.

10. When you have finished selecting the options you need, click OK.

11. Continue with the instructions in “Importing Files” in the Help, to complete the import of the file into the bin.

   The PICT file appears as a Matte Key effect clip in the bin you selected.

12. Click the Source/Record Mode button below the Timeline.

13. Load the Matte Key effect clip into the Source monitor.

   The clip appears in the Source monitor as a black-and-white, high-contrast image.

14. Edit the matte key into the sequence as described in “Editing with Imported Matte Key Clips” on page 291.

Scratch Removal

Your Avid editing application includes tools for fixing flaws such as dropout in video frames or defects in film-originated footage. You can replace a flaw with clean material from the same frame or field or from other nearby frames or fields.

When you use Scratch Removal with two-field media, the Avid application can use either frame or field processing to determine the source of the replacement material that covers the flaw.
Understanding Scratch Removal Options

The workflow for removing a flaw involves the following main steps:

1. Isolate the flawed material in a new segment.
2. Apply an Intraframe effect.
3. Use the Intraframe drawing tools and effect parameters to draw a shape that covers the flaw, and fill the shape with clean replacement material.
4. (Option) If the flaw persists over several frames or fields, you might need to use keyframes to adjust the covering shape so it continues to cover the flaw as the footage moves.

Before you correct a flaw, you should make some basic decisions about how you want to make the correction. The following sections provide an overview of the difference between frame and field processing and the differences between correcting within the same frame or field and correcting using nearby frames or fields. They also provide guidance on deciding exactly what material you need to isolate when you make the correction.

Processing by Frame or Field When Using Scratch Removal

When you use Scratch Removal with two-field media, the Avid application can use either frame or field processing to determine the source of the replacement material that covers the flaw. Frame processing copies replacement material from both fields of a selected frame to one or more flawed frames. Field processing copies replacement material from one field to a series of subsequent fields.

To select frame or field processing when using Scratch Removal:

1. Move the position indicator to the effect’s icon in the Timeline.
2. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.

   The Effect Editor opens.
3. Open the Mode parameter category of the Paint Effect or the Scratch parameter category of the Scratch Removal effect, and click the Frame Processing button.

If the Frame Processing button is selected (pink), the Avid application uses frame processing. The Frame/Field parameter slider is labeled Frame and is calibrated in one-frame increments from –5 to +5. For more information on frame processing, see “Understanding Frame Processing” on page 533.

If the Frame Processing button is deselected (gray), the application uses field processing. The Frame/Field parameter slider is labeled Field and is calibrated in one-field increments from –10 to +10. For more information on field processing, see “Understanding Field Processing” on page 534.

When you are working with single-field material, the Frame Processing button does not appear in the Effect Editor.
Understanding Frame Processing

When the Avid application is using frame processing, replacement material is copied from both fields of the clean frame to the corresponding fields in the flawed frame. The application copies replacement material from Field 1 of the clean frame to Field 1 of the flawed frame and from Field 2 of the clean frame to Field 2 of the flawed frame.

The following illustration shows the frame-processing method for a typical two-frame correction created by clicking the Scratch Removal button. The correction uses default parameter settings (Frame: 0; Offset: From Start) that result in material being copied from the first (clean) frame to the second (flawed) frame.

The Scratch Removal button appears by default on the Tool palette. You can also map the Scratch Removal button from the Command palette to the keyboard or to a button. For more information, see “Using the Tool Palette” and “Using the Command Palette” in the Help.

Frame processing is the default processing method. It preserves full video resolution and provides the smoothest correction in most circumstances, particularly when the flaw you are correcting extends over both fields of a frame. Most flaws that originate in film source material (for example, a scratch on a single frame of the film) extend across both fields of the video frame.
Understanding Field Processing

When the Avid application is using field processing, replacement material is copied from only one field.

The following illustration shows the field-processing method for a typical two-frame correction created by clicking the Scratch Removal button. The correction uses default parameter settings (Frame: 0; Offset: From Start) that result in material being copied from the first field of the effect segment to all the subsequent fields.

Field processing results in a better-looking correction under certain circumstances because it allows you to select your replacement material with field accuracy. For example, in the previous illustration, changing the Field parameter value to +1 causes the application to copy material from Field 2 of Frame 1 to both of the fields in Frame 2. A field-based correction might be a good solution when you want to correct a flaw such as video dropout, which does not necessarily occur on both fields of one or more frames. However, field processing always results in at least one instance where material from an odd field is copied to an even field, or vice versa. Depending on the nature of your video material, this might result in a slight jitter on playback.
Removing a Flaw Within a Frame

You can often remove a flaw by replacing it with a clean area from the same frame or field. For example, a flaw on a uniformly colored background such as sky can be replaced by copying another portion of the sky over the flaw.

When you remove a flaw by using material from the same frame that contains the flaw, you can see both the flaw and all the available clean material as you work. This can be helpful for certain kinds of footage, making it easy to select the exact portion of the image that allows for the best replacement.

Removing a Flaw by Using Nearby Frames

Replacing flaws with material from a nearby frame or field allows you to correct flaws in more complex footage. For example, a flaw on an image such as a face might be very difficult to cover using material from the same frame or field — there might be no other area of the face in that image that shows similar tones, textures, and highlights. In this situation, it is better to replace the flaw by copying the same part of the face from an earlier or later frame that does not contain the flaw.

This method also provides an alternative for dealing with uniform areas such as sky since you can replace a flaw with the same area from a nearby clean frame.

When you use material from a nearby frame to replace a flaw, you cannot see the whole of the nearby frame as you work. Instead, you see the replacement area in the shape you draw to cover the flaw, and you use parameter sliders in the Effect Editor to adjust which portion of the nearby frame appears.
Selecting Material to Use When Correcting Flaws

When you isolate a flaw as a new segment to correct it, you must also include enough clean material to make the correction. The Intraframe tools you use for removing flaws cannot reference frames outside the segment that you isolate.

In some cases, you can take all the clean material you need from the same frames that contain the flaw. In other situations, you need to include one or more completely clean frames along with the flawed frames in the segment you isolate.

For example, if a flaw persists across several frames in footage that includes no motion, the simplest way to correct the flaw is to include one clean frame before or after the flawed frames and use replacement material from the clean frame to cover the flaw in all the other frames. For more information on using replacement material from different points in your footage, see “Examples of Scratch Removal Parameter Settings” on page 547.

Isolating a Flaw

If you need to correct a flaw on a single frame, you can use the Scratch Removal button to quickly create a two-frame segment and apply the Scratch Removal effect.

The Scratch Removal button appears by default on the Tool palette. You can also map the Scratch Removal button from the Command palette to the keyboard or to a button. For more information, see “Using the Tool Palette” and “Using the Command Palette” in the Help.

If a flaw persists over several frames, do one of the following:

- Use the Scratch Removal button to create a two-frame segment, and then use standard Trim mode methods to extend the segment.
- Insert add edits, and apply a Scratch Removal effect manually.
You cannot access frames outside the segment you have marked when you are working with the Scratch Removal tools. When you isolate a flaw, you must include in the segment both the flawed frames and sufficient clean material to correct the flaws successfully. For more information on the relationship between flaws and clean material, see “Understanding Scratch Removal Options” on page 531 and “Examples of Scratch Removal Parameter Settings” on page 547.

Isolating a Flaw by Using the Scratch Removal Button

If the flaw you need to fix is on one frame, you can isolate the flaw on a new segment and apply the Scratch Removal effect simply by clicking the Scratch Removal button. The button creates a two-frame segment that isolates the flawed frame and the clean frame immediately before it, which you will use to make the correction.

The Scratch Removal button appears by default on the Tool palette. You can also map the Scratch Removal button from the Command palette to the keyboard or to a button. For more information, see “Using the Tool Palette” and “Using the Command Palette” in the Help.

To isolate a flaw by using the Scratch Removal button:

1. Find the frame containing the flaw:
   - Use the Step Forward button or the Step Backward button (in the toolbar under the monitor) to carefully cue the frame containing the flaw.
   - (Option) Press and hold the Alt key (Windows) or Option key (Macintosh) while clicking the Step Forward or the Step Backward button to step through one field at a time.
2. Move the position indicator to the frame containing the flaw.
3. Make sure that the Record Track button for the track containing the flaw is the highest selected track button in the Track Selector panel.
4. Click the Scratch Removal button.
Chapter 11  Intraframe Editing

The application creates a two-frame segment ending at the frame marked by the position indicator and applies the Scratch Removal effect to that segment. If an effect is already present at that point in the sequence, the application auto-nests the Scratch Removal effect on top of the existing effect.

The Scratch Removal button appears by default on the Tool palette. You can also map the Scratch Removal button from the Command palette to the keyboard or to a button.

Isolating a Flaw by Using Add Edits

If you need to remove a flaw that persists across more than two frames or that requires more than two frames for successful correction, you can use add edits to isolate the flaw manually.

To isolate a flaw by using add edits:

1. Find the series of frames or fields containing the flaw:
   - Use the Step Forward button or the Step Backward button (in the toolbar under the monitor) to carefully cue the frames containing the flaw.
   - (Option) If you are working with two-field media, press and hold the Alt key (Windows) or Option key (Macintosh) while clicking the Step Forward button or the Step Backward button to step through one field at a time if necessary.

2. Isolate the flawed frames, together with sufficient clean material to make your correction, by placing add edits before and after the frames to create a new segment.
3. Apply one of the following Image effects to the segment:
   - Paint Effect
   - Scratch Removal effect

   You can use either the Paint Effect or the Scratch Removal effect. The difference is that the Scratch Removal effect provides only those effect parameters specific to fixing flaws, while the Paint Effect provides Scratch Removal as one of many available Paint modes.

Using Intraframe Tools to Remove a Flaw

Once you have isolated the flaw and have applied an Intraframe effect to it, you can remove the flaw by replacing it with a clean area of video. The best way to do this in most circumstances is to draw a shape that covers the flaw and fill the shape with replacement material. An alternative method is to draw a shape over your selected replacement material and then drag the replacement over the flaw. This works well when you are taking replacement material from the same frame that contains the flaw.

Drawing a Shape over a Flaw

To remove a flaw by drawing a shape over it and filling the shape with replacement material:

1. Isolate the flaw, and apply the Paint Effect or the Scratch Removal effect by using the procedures described in “Isolating a Flaw” on page 536.

2. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.

3. Select the segment if it is not already selected.

4. (Option) If you are working with the Paint Effect, do the following:
   a. Click the triangular opener next to the Mode parameter category.
   b. Click the Fast Menu button, and select Scratch Removal.

5. Click the triangular opener next to the Mode parameter category (Paint Effect) or the Scratch parameter category (Scratch Removal effect).

6. Select a shape tool or a brush in the Effect Editor.
7. Click the image, and drag to create an object that covers the flaw.

*In most circumstances, you should make the object as small as possible while still covering the flaw completely.*

8. Make sure that the Object Visible button is selected (pink) in the Mode parameter category (Paint Effect) or the Scratch parameter category (Scratch Removal effect) of the Effect Editor.

9. (Option) Select frame or field processing. For more information, see “Processing by Frame or Field When Using Scratch Removal” on page 531.

10. Use the Horizontal, Vertical, and Frame/Field sliders in the Effect Editor to select an area of replacement material to fill the object in the image and replace the flaw.

The replacement material appears in the object, replacing the flaw. For more information on using the Horizontal, Vertical, and Frame or Field parameter sliders, see “Using the Scratch Removal Positioning Parameters” on page 545.

11. (Option) Use the Feathering parameters to help blend the replacement material into the surrounding area.

12. Render the effect to play it back in real time. For more information, see “Rendering Intraframe Effects” on page 480.
If necessary, you can animate the shape that contains the replacement material using keyframes to follow movement and changes in the frames of footage. For example, you can resize, reshape, and reposition the shape over time, or you can use the Object Visible button to control when the shape is visible. For more information, see “Animating the AniMatte Effect” on page 560 and “AniMatte and Paint Effect Parameters” in the Help.

A standard Intraframe geometric shape such as an oval or a rectangle renders considerably faster than a series of brush strokes. In most cases of a single small flaw, a brush might be the easiest correction tool. If you need to correct several flaws that are close together, however, you will save rendering time if you can cover them with a single shape rather than use several different brush strokes.

Dragging Replacement Material over a Flaw

To remove a flaw by selecting replacement material and then dragging it over the flaw:

1. Isolate the flaw, and apply the Paint Effect or Scratch Removal effect by using the procedures described in “Isolating a Flaw” on page 536.

2. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.

3. Select the segment if it is not already selected.

4. (Option) If you are working with the Paint Effect, do the following:
   a. Click the triangular opener next to the Mode parameter category.
   b. Click the Fast Menu button, and select Scratch Removal.

5. Click the triangular opener next to the Mode parameter category (Paint Effect) or the Scratch parameter category (Scratch Removal effect).

6. (Option) Select frame or field processing. For more information, see “Processing by Frame or Field When Using Scratch Removal” on page 531.

7. Select a shape tool or a brush in the Effect Editor.
8. Click a clean area of the image, and drag to create a selection that is appropriately sized for covering the flaw.

In most circumstances, you should make the object as small as possible while still covering the flaw completely.

9. Drag the replacement selection over the flaw.

10. (Option) Use the Feathering parameters to help blend the replacement material into the surrounding area.

11. Render the effect to play it back in real time. For more information, see “Rendering Intraframe Effects” on page 480.

If necessary, you can use keyframes to animate the selection so it follows movement and changes in the frames of footage. For example, you can resize, reshape, and reposition the shape over time, or use the Object Visible button to control when the shape is visible. For more information, see “Animating the AniMatte Effect” on page 560 and “AniMatte and Paint Effect Parameters” in the Help.
Using IN and OUT Points with Scratch Removal

You can use IN and OUT points to define multiple frames or fields of video that contain a scratch and then use the Scratch Removal button to quickly create a Scratch Removal effect that covers the scratched frames or fields together with the clean frame or field immediately before them. When you draw a shape to cover the scratch, the application will fill that shape with clean material in every frame or field of the effect.

This method is useful in any situation where a scratch is repeated across several frames or fields. In particular, it allows for quick correction of a scratched frame in film-originated material that has been duplicated by the pulldown process in telecine transfer to video.

To remove a scratch covering more than one frame or field:

1. Mark an IN point at the first scratched frame or field.
2. Mark an OUT point at the last scratched frame or field.
3. Move the position indicator to one of the following locations:
   - Between the marked IN and OUT points
   - On the frame or field immediately before the marked IN point
4. Click the Scratch Removal button.

The Scratch Removal button appears by default on the Tool palette. You can also map the Scratch Removal button from the Command palette to the keyboard or to the Composer window. For more information, see “Using the Tool Palette” and “Using the Command Palette” in the Help.

The application applies a Scratch Removal effect that covers the scratched frames or fields and the clean frame or field immediately before them.
The position indicator must be between the marked IN and OUT points or on the frame or field immediately before the marked IN point. If the position indicator is at any other location, the application creates the Scratch Removal effect at that location and ignores the marked IN and OUT points.

5. (Option) Select frame or field processing. For more information, see “Processing by Frame or Field When Using Scratch Removal” on page 531.

6. In the Effect Editor, select a shape tool or a brush.

7. Click the image, and drag to create a shape that covers the scratch.

The application replaces the material in the shape with material from the clean frame or field. The same clean material covers the scratch on every scratched frame or field within the effect.

The Scratch Removal positioning parameters are set by default to reference the part of the clean frame that corresponds to the shape you draw. In most cases, you do not need to make any adjustments to these parameters to cover the scratch successfully.

8. (Option) Use the Feathering parameters to help blend the replacement material into the surrounding area.

9. Render the effect to play it back in real time. For more information, see “Rendering Intraframe Effects” on page 480.

In some unusual circumstances, you might need to animate the shape that contains the replacement material, using keyframes together with positioning adjustments to follow movement and changes. For example, if the image is changing rapidly from frame to frame and the scratch covers several frames, the clean material might not match the later scratched frames without repositioning.
Using the Scratch Removal Positioning Parameters

The Hor (horizontal), Vert (vertical), and Frame/Field sliders in the Scratch Removal mode of the Paint Effect or in the Scratch parameter category of the Scratch Removal effect allow you to control exactly which material you use from elsewhere in the same frame or in nearby frames to replace flawed material.

The Hor (horizontal) and Vert (vertical) sliders define the position of the replacement material relative to the shape you have drawn on the horizontal and vertical axes of the frame.

The Frame/Field slider defines which nearby frame or field is used as the source of the replacement material. Values represent an offset from the reference point defined in the Offset Fast menu. The following table shows the default settings.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frame/Field</td>
<td>0</td>
</tr>
<tr>
<td>Offset</td>
<td>From Start</td>
</tr>
</tbody>
</table>
These settings correctly reference the clean frame or field whenever you use the Scratch Removal button to apply the Scratch Removal effect. The settings reference the clean frame when you use the Scratch Removal button without marking IN and OUT points to remove a scratch on a single frame or field. They also reference the clean frame when you use the Scratch Removal button with IN and OUT points to remove a scratch or other flaw that repeats across more than one frame or field.

The Frame Processing button lets you select between frame and field processing. If the Frame Processing button is selected (pink), the Avid application uses frame processing. The Frame/Field parameter slider is labeled Frame and is calibrated in one-frame increments from –5 to +5. For more information on frame processing, see “Understanding Frame Processing” on page 533.

If the Frame Processing button is deselected (gray), the application uses field processing. The Frame/Field parameter slider is labeled Field and is calibrated in one-field increments from –10 to +10. For more information on field processing, see “Understanding Field Processing” on page 534.

For more information on these parameters, see “Scratch” in the Help.

- You cannot access frames more than 5 frames (or fields more than 10 fields) from the zero point as defined by the Offset Fast menu, regardless of the length of the segment.

- You cannot access frames or fields outside the segment that contains the effect. If you are positioned six fields from the end of the segment, and you set the Field slider to 10 and the Offset to Relative, you reference the last field of the segment (six fields ahead of your position).

**Using the Scratch Removal Button**

The Scratch Removal button appears by default on the Tool palette. You can also map the Scratch Removal button from the Command palette to the keyboard or to the Composer window. For more information, see “Using the Tool Palette” and “Using the Command Palette” in the Help.
Examples of Scratch Removal Parameter Settings

The following examples illustrate several different settings for the Scratch Removal positioning parameters.

Example 1: Replacement Material in the Same Frame

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical</td>
<td>–250</td>
</tr>
<tr>
<td>Horizontal</td>
<td>+250</td>
</tr>
<tr>
<td>Frame/Field</td>
<td>0</td>
</tr>
<tr>
<td>Offset</td>
<td>Relative</td>
</tr>
</tbody>
</table>

In this example, the effect replaces the area of the rectangle covering the scratch with material from the area of the dotted rectangle in the same frame or field. Each frame or field in the segment will use replacement material from the same relative position in its own frame or field.
Example 2: Replacement Material from a Two-Frame Relative Offset

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical</td>
<td>0</td>
</tr>
<tr>
<td>Horizontal</td>
<td>0</td>
</tr>
<tr>
<td>Frame/Field</td>
<td>+2/+4</td>
</tr>
<tr>
<td>Offset</td>
<td>Relative</td>
</tr>
</tbody>
</table>

In this example, the area of the rectangle covering the scratch is replaced by the same coordinate area of the frame two frames (four fields) ahead. Each frame or field in the segment will use replacement material from two frames (four fields) ahead.
Example 3: Replacement Material from a Single Clean Frame

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical</td>
<td>0</td>
</tr>
<tr>
<td>Horizontal</td>
<td>0</td>
</tr>
<tr>
<td>Frame/Field</td>
<td>0</td>
</tr>
<tr>
<td>Offset</td>
<td>From Start</td>
</tr>
</tbody>
</table>

In every frame, the rectangle covering the scratch is replaced by the material from the dotted rectangle area in Frame 1.

In this example, the area of the rectangle covering the scratch is replaced by the area of the dotted rectangle in the first frame of the segment. If the same parameter settings are used throughout the segment, then every frame in the segment will reference the first frame of the segment.

You can select From Start or From End from the Offset Fast menu in this way to cover a flaw in several frames with clean material from a single frame. In this example, the flaw first appears in frame 2, and it is replaced in every frame in which it appears by clean material from frame 1.
Chapter 11  Intraframe Editing

Common Intraframe Editing Techniques

The following sequence contains examples of basic Intraframe editing techniques — from simple Paint Effects to animated matte keys.

The PDF version of this guide, available on the online library CD-ROM, allows you to double-click the following image to view the entire sequence.

The Timeline for this sequence is shown in the following illustration. The callouts present several Intraframe editing examples and the sections that describe them.

Intraframe Editing examples

- Magic Mask used to colorize a selected region of the image: See “Colorizing with Magic Mask” on page 551.
- Two-layer animated matte effects: See “Creating Animated Matte Key Effects” on page 557.
- Blur effect applied to a traced area of the clip: See “Applying the Paint Effect to Regions of a Clip” on page 555.
Colorizing with Magic Mask

You can use the Magic Mask effect to apply effects across a series of frames, using the chroma and luma values as the criteria for edge detection. Although you can use Magic Mask in conjunction with any of the paint modes to generate custom effects, the primary benefit of this feature is localized colorization, which enables you to create garbage mattes and various chroma effects. For example, this can be used to change the color of a white shirt to another color without having to create a detailed matte.

In this example, the goal is to colorize the window area through which we see the athletes walking to the pool. The odd shapes in the window area would normally make this task extremely time consuming; but because the region is high contrast with a consistent off-white color, Magic Mask makes the job simple.

To colorize the image:

1. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.
2. In the Effect Palette, click the Image category.
3. Click the Paint Effect icon, and drag it to the segment of footage in the sequence.
4. Select the segment if it is not already selected.
   
   The Paint Effect parameters appear in the Effect Editor.

5. For this example, in the Mode parameter category, click the Fast Menu button, and select Solid. In other applications of Magic Mask, you might select another mode such as Lighten, Darken, or Colorize.

6. Click the Rectangle tool (or another shape tool) in the Effect Editor, click in the Effect Preview monitor, and drag to draw a box surrounding the window region.

7. Open the Color category, and, using standard methods, select a color to apply to the window region. For more information on selecting a color, see “Adjusting a Color Parameter” on page 106.

8. (Option) Click the Outline/Path button so you have an unobscured view of the object you want to colorize. Adjust the size and shape of the box as necessary.
9. In the Magic Mask category, click the Enable button.

The application activates the Magic Mask.

The default key color for Magic Mask might not match the color in your selection, so the color is not yet applied to the white area of the window.

10. In the Magic Mask parameter category, click in the Color Preview window, drag the pointer to the off-white area of the window in the image, and then release the mouse button.

The application sets the Magic Mask key color to the color you selected, and applies the effect.

11. Click the Outline/Path button to switch between viewing the image with or without the effect.
12. Adjust the Magic Mask parameters, such as Gain and Soft (softness), to fine-tune the effect.

The application applies the colorization effect to areas where the rectangle shape extends beyond the window area in the image. You can quickly convert the rectangle to a polygon and adjust its shape around the window.

**To reshape the rectangle:**

1. Click the rectangle to select it.
2. Double-click the rectangle to display its control points.
3. Drag the control points at the corners of the rectangle one at a time to surround the window area.
Applying the Paint Effect to Regions of a Clip

The Paint Effect includes a number of modes for applying special effects to traced regions of an image. This example describes using keyframes with the Blur mode to gradually blur a region of the clip. The effect gives the impression that the background is losing focus while the rest of the image is unaffected.

The background behind the woman is traced with the Paint Effect, and the Blur mode is gradually applied during the clip.

To apply the blur:

1. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing. For more information, see “Entering Effect Mode” on page 82.

2. From the Image category, drag the Paint Effect icon to the segment of footage in the sequence.

3. Select the segment if it is not already selected.

   The Paint Effect parameters appear in the Effect Editor.

   The next task is to trace the background region around the woman in the foreground to apply the effect. Because the woman moves during the clip, you must animate the traced shape by using keyframes.
4. Press the Home key to go to the beginning of the clip. Make sure both the first and last keyframes are selected.

5. In the Effect Editor, click the Reduce button to view the image in the Effect Preview monitor at 75 percent. (This makes it easier to include the outer edges of the footage in the traced area.)

6. Click the Curve tool.

7. Click the image, and drag to draw a matte with freehand capability. Trace an outline around the woman and surrounding the background.

8. When you are satisfied with the shape of the matte, release the mouse button.

9. In the Effect Preview monitor, click the last keyframe indicator to select the keyframe. Check the shape of the traced area around the woman, and adjust control points as necessary to make an accurate outline.

10. Before creating new keyframes to further animate the traced outline, apply the blur to the first and last keyframes to ensure a smooth effect across all keyframes:
   a. In the Effect Preview monitor, click the first keyframe indicator to select it.
   b. In the Mode parameter category, click the Fast Menu button, and select Blur.
   c. Drag the Hor (horizontal) and Vert (vertical) sliders all the way to 0.
d. Click the last keyframe indicator to select it.

e. Drag the Hor (horizontal) and Vert (vertical) sliders to 50.

The Blur mode effect is applied.

11. Click elsewhere in the Effect Preview monitor’s position bar to check the traced outline. Make adjustments as necessary.

As you adjust control points, the application automatically creates new keyframes.

12. (Option) To soften the edges of the blurred outline around the woman, adjust the Feathering parameters. For more information, see “Feathering” in the Help.

13. Render the effect to play it back in real time. For more information, see “Rendering Intraframe Effects” on page 480.

Creating Animated Matte Key Effects

When you apply the AniMatte effect and create a matte key, the shape and location of the matte remain fixed over the course of the segment. The parameters of the matte are the same at both the first and last keyframes in the segment.
When you have moving video, you must change the shape and location of the matte in order to follow the changes of the video over the course of the segment.

Applying the Matte Key Effect

To apply a two-layer matte key:

1. For this two-layer effect, edit the image you want to use as the background onto one track and the image you want to use as the foreground onto the track above.
2. Enter Effect mode by selecting Toolset > Effects Editing.
3. In the Effect Palette, click the Key parameter category.
4. Drag the AniMatte Effect icon from the Effect Palette to the upper track in the Timeline.
5. Press the Home key to go to the beginning of the clip. Make sure both the first and last keyframes are selected.

6. In the Effect Editor, click the Reduce button to view the image in the Effect Preview monitor at 75 percent. (This makes it easier to include the outer edges of the footage in the traced area.)

7. Click the Curve tool.

8. In the Mode parameter category, click the Fast Menu button, and select Key In.

9. Click the image, and drag to draw a matte with freehand capability.

10. When you are satisfied with the shape of the matte, release the mouse button.

The area outside the border of the matte reveals the underlying image on the lower track (V1 in the example), and the area inside the border of the matte displays the image on the upper track (V2).

In this example, a series of shapes are drawn to key out all areas of the foreground image.
Chapter 11  Intraframe Editing

11. In the Foreground parameter category, click the Swap Src (swap sources) button to check the traced outline.

![Image]

The foreground and background footage are reversed in the key. This allows you to easily spot areas where the outline encroaches on the foreground image.

12. Click the Swap Src button to restore your effect to a matte that keys in your selection.

**Animating the AniMatte Effect**

**To animate a Matte Key effect:**

1. Under the monitor, click the Step Forward button or the Step Backward button as many times as necessary to park on a frame in which the matte no longer provides a clean key due to the motion of the foreground or background image.

2. If the application is not in Effect mode, enter Effect mode by selecting Toolset > Effects Editing.
3. Adjust the matte outline as follows:
   - Click the Reshape tool, and drag control points to change the shape. You can also Shift+click multiple control points for repositioning as a group. For information, see “Removing a Control Point” on page 514.
   - Edit the object by manipulating the direction bars at one or more control points. For information, see “Modifying Lines and Curves Summarized” on page 511.
   - Click the Swap Src button if necessary to swap the view of the foreground and background images to examine edges.
   - Reposition the matte if necessary by selecting the shape and dragging it with the Selection tool.

   As you adjust control points, the application automatically creates new keyframes.

4. Repeat the procedure as needed to create a matte that keys the images cleanly over the course of the segment.

5. (Option) To soften the edges of matte key, adjust the Feathering parameters. For more information, see “Feathering” in the Help.

6. Render the effect to play it back in real time. For more information, see “Rendering Intraframe Effects” on page 480.

**Creating a Single-Layer Organic Matte Wipe**

You can use the AniMatte effect to create a custom matte wipe. Additionally, you can create soft edges and other useful variations by adjusting the parameters of the AniMatte wipe. Multiple video tracks are not necessary. You apply the AniMatte effect to a transition on a single track of video and then draw the matte wipe as described in this section.
Chapter 11  Intraframe Editing

To create an organic matte wipe:

1. Create a sequence that contains a transition (an incoming and an outgoing segment).

2. Enter Effect mode by selecting Toolset > Effects Editing.

3. Apply the AniMatte effect to a transition as described in “Applying the Paint or AniMatte Effect to a Sequence” on page 482.

4. In the Mode parameter category, click the Fast Menu button, and select Key In.

5. In the Effect Preview Monitor toolbar, click the Reduce button three times to reduce the image to 25 percent of its normal viewing size.

6. Click the first keyframe indicator in the Effect Preview monitor’s position bar.

   The first keyframe indicator is highlighted, and the last keyframe is deselected.

7. Click the Curve tool.

8. Press and hold the mouse button, and drag to draw a custom shape to the right of the image displayed in the Effect Preview monitor.
Draw a matte that is at least as wide as the frame in the Effect Preview monitor.

9. When you are satisfied with the shape of the object, release the mouse button to complete the matte wipe.

10. Click the last keyframe indicator in the Effect Preview monitor’s position bar.
    
    The application highlights the last keyframe indicator, and deselects the first keyframe.

11. Click the matte wipe within its borders and drag it so that it covers the frame in the Record monitor. Make sure to position the leading edge of the wipe so that it is beyond the left border of the frame.
12. In the Effect Preview Monitor toolbar, click the Enlarge button three times to restore the video image to 100 percent.

13. Click in the middle of the Effect Preview monitor’s position bar to view the edge of the wipe.

14. (Option) To soften the edges of the wipe, adjust the Feathering parameters. For more information, see “Feathering” in the Help.

15. Render the effect to play it back in real time. For more information, see “Rendering Intraframe Effects” on page 480.

**Working with the Blur Effect and Mosaic Effect**

The Blur effect and Mosaic effect, found in the Image category, allow you to obscure part of an image by distorting the pixels within a defined area.

The Blur effect and Mosaic effect act as intraframe effects. The Blur parameter category for the Blur effect is the same as the one that appears for the Blur mode of the Paint Effect. The Mosaic parameter category for the Mosaic effect is the same as the one that appears for the Mosaic mode of the Paint Effect.
Other controls that appear in the Blur and Mosaic effects are:

- Feathering parameters
- Z-rotation tool
- Reshape tool
- Bring Forward and Send Backward buttons

*The Blur and Mosaic effects are non-real-time effects. When you have finished creating one of these effects, you must render the effect to play it in real time.*

**Using the Effect Editor with the Blur Effect and Mosaic Effect**

For basic information on working with the Effect Editor, see “Using the Effect Editor” on page 97.

You control the Blur and Mosaic effects by using the following parameters in the Effect Editor:

- Acceleration — Adjusts the effect’s speed from one keyframe to the next when the Blur or Mosaic object moves within a segment.
- Feathering — Adds soft edges to a Blur or Mosaic object. Modifying the outline can make an object stand out from or blend into the background.
- Blur or Mosaic — Controls the overall appearance of the object area, allowing for varying degrees of distortion.
Chapter 11  Intraframe Editing

The following buttons appear on the right side of the Effect Editor for the Blur and Mosaic effects.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection tool</td>
<td>Selects an object so you can change its parameters, move it, or delete it. With the Shift key pressed, selects multiple objects.</td>
</tr>
<tr>
<td>Z-rotation tool</td>
<td>Rotates an object around the Z axis.</td>
</tr>
<tr>
<td>Reshape tool</td>
<td>Allows you to reshape objects by manipulating anchor points at locations where new curves begin or straight lines intersect. Inserts additional control points.</td>
</tr>
<tr>
<td>Bring Forward</td>
<td>Brings an object one layer forward on the screen.</td>
</tr>
<tr>
<td>Send Backward</td>
<td>Sends an object one layer backward on the screen.</td>
</tr>
<tr>
<td>Rectangle tool</td>
<td>Creates a square or rectangle object. The pointer changes to a crosshair when clicked.</td>
</tr>
<tr>
<td>Oval tool</td>
<td>Creates a circle or oval to create an object. The pointer changes to a crosshair when clicked.</td>
</tr>
</tbody>
</table>

Creating Blur and Mosaic Effects

To create a Blur or a Mosaic effect:

1. Select Toolset > Effects Editing.
2. In the Effect Palette, click the Image category.
3. Drag the Blur Effect icon or the Mosaic Effect icon to a segment in the sequence.
4. Click either the Rectangle tool or the Oval tool.
5. Click in the Effect Preview monitor and drag to create an object.
   A wire-frame outline of the object appears, and the default Blur or Mosaic effect appears in the Effect Preview monitor.
The following illustration shows a Mosaic effect in an oval object.

Modifying Blur and Mosaic Objects

To modify the attributes of blur and mosaic objects:

1. Click the Selection tool, and click the object you want to change.

2. Use the Feathering parameter category to adjust the appearance of the outline of the object:
   - Hor (horizontal) adjusts the range of pixels along the X axis to which the effect applies.
   - Vert (vertical) adjusts the range of pixels along the Y axis to which the effect applies.
   - Fixed Aspect locks the horizontal and vertical sliders so that they move in unison. This controls how smoothly the effect blends with the background image.
   - Anti-alias reduces the jaggedness of the edges of the object.

3. Use the sliders in the Blur or Mosaic parameter category to adjust the appearance of the blur or mosaic distortion:
   - Opac (opacity) controls how prominently the blur or mosaic appears against the background image. A value of 0 makes the blur or mosaic transparent; a value of 100 makes it fully opaque.
- Hor (horizontal) and Vert (vertical) change the size of each tile within the effect along the X or Y axis, respectively. They control the coarseness of the blur or mosaic.

- Blur Visible or Mosaic Visible switches the effect on and off in the Effect Preview monitor.

4. Use the Z-rotation and Reshape tools to customize the shape of the blur or mosaic object:

- Z-rotation allows you to rotate the object around a Z axis by manipulating the resize handles.

- Reshape allows you to create an irregular object by moving the resize handles individually.

The following illustration shows the handles on an object in a Mosaic effect.

- Bring Forward and Send Backward apply when objects overlap. You use the buttons to define which object appears closer to the viewer.

5. Drag the center handle of the object to match the movement of the image in the clip. Your application automatically adds a keyframe each time you drag the object to a new position.
Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z

Numerics
14:9 Letterbox effect (2D) described 315
16:9 display in the Title tool 397
16:9 Letterbox effect (2D) described 314
24p or 25p editing projects with multiformat titles 443
24p or 25p titles 443
3D Promote button (Effect Editor) 101, 119
3D titles promoting from 2D 474
3D Warp effect applying 349
3rd-Party plug-in effects 41
4:3 Sidebar effect (2D) described 315
601 Level setting in Avid Pan & Zoom effect 345

Add Keyframe button commands 160
Effect Preview Monitor toolbar 84
Add Page command (Object menu) 418
Adding fades and dissolves 77 pages to a rolling or crawling title 418
Adjusting color parameter 106 Pan and Scan effect 329 shadow softness in titles 427
Advanced keyframes
Add Keyframe button commands 160
Add Keyframe pop-up menu 124 adding or deleting keyframes 122 Align Keyframe command 145 aligning keyframes 146 and nested effects 298 Automatic Start and End Keyframes option 160 Bézier interpolation option 141 copying and pasting keyframe parameters 133 described 111, 115 determining parameter values 150 Effect Editor shortcut menu 157 elastic keyframes 135 Extrapolate command 150 extrapolating parameter values 153 fixed keyframes 136

A
Acceleration parameter 565
Active group defined 127
Add Edit function with Submaster effects 302
Index

Indent Rows command 158
interpolation options for 138
Large Text command 158
Linear interpolation option 139
open graph, defined 130
opening keyframe tracks 117
promoting effects to 116
promotion paths 117
Real Time Update option 159
scaling keyframe graphs 153
Set Position To Keyframe command 159
Shelf interpolation option 139
Show Add Keyframe Mode Menu command 159
Sliders option 158
Slip Keyframes command 145
slipping 148
Spline interpolation option 140
Thumbwheels option 158
toolbar buttons 118
Update Position While Playing command 159
working with 115
Advanced parameter
Avid Pan & Zoom effect 344
Align Keyframe command
brief description 145
Keyframe Graph shortcut menu 146
Align to Frame commands (Alignment menu) 433
Aligning
keyframes 146
Alignment
of keyframes 146
of title text 404
of titles and objects 433
Alpha channel
in 3D Matte Key effect 351
in Matte Key effects 291
title creation with 393
Anchor Frame
See Source Anchor Frame

Animation
editing with imported 290
AniMatte effect (2D)
animating 557
applying 482
described 478
exporting as PICT file 528
matte wipe example 561
modes 487
parameters in Effect Editor 485
position information for 94
rendering 480
using Magic Mask parameters 551
Anti-alias option (Blur and Mosaic effects) 567
Anti-aliased elements in title 393
Applying
Dissolve effects (2D) 64
Pan and Scan effect 318
Submaster effects 302
title styles 450
Arrowheads in titles 411
Aspect ratio
adjusting with Pan and Scan effect 316
in Avid Pan & Zoom effect 337
in Reformat effects 314
selecting within Pan and Scan effect 319
AudioSuite plug-ins
described 41
Auto Size mode (Title tool) 414
Auto Size Mode command (Object menu) 414
Automatic Start and End Keyframes option 160
Avid Hi Qual
Filtering option for Avid Pan & Zoom effect 343
Avid Pan & Zoom effect
Advanced parameter 344
applying 333
aspect ratio 337
Background parameter 343
constant path velocity 340
described 332
Ease In and Ease Out 339
field of view 336
Filtering parameter 342
image file format 332
Path parameter 341
Position parameters 337
Show Action Safe button 335
Source and Target view 335
Source Has Square Pixels 344
Velocity parameter 338
Zoom Factor parameter 336
Avid Pan and Zoom effect
See Avid Pan & Zoom effect
Avid Ultra Qual
Filtering option for Avid Pan & Zoom effect 343
Avid Unity MediaManager 205
Avid Unity workgroup environment 205
Avid Visual Extensions (AVX)
defined 41
AVX (Avid Visual Extensions)
defined 41
AVX plug-ins
assigning multiple tracks in 47
blank icons in Timeline 50
described 41
IllusionFX Pack 41
installing 43
interfaces and parameters for 48
locating AVX_Plug-Ins folder (Macintosh) 44
locating AVX_Plug-Ins folder (Windows) 45
memory usage 42, 51
messages in Console window 50
missing effect categories 51
missing icons 50
Photoshop, compatible plug-ins 42
plug-in icon 41
problems with rendering 50
resetting parameters to default values 357
RGB Keyer effect 282
troubleshooting 49
upgrading 46
vendors 41
Web site for 41
Axes in rotation (3D) 354
Axis parameter (3D)
using for a transition 380

B
Background color, selecting 394
Background parameter
Avid Pan & Zoom effect 343
Bézier command
in Keyframe graph shortcut menu 138
Bézier curves
described 503
keyframe interpolation option 141
manipulating 505
Bézier keyframe interpolation option
asymmetrical adjustment 142
independent adjustment 143
symmetrical adjustment 142
Bins
effect templates in 39, 164
revising titles in 440
titles in 456
viewing fast-saved titles in 440
Blank slider 104
Blend effects (3D)
3D Warp 349, 349
Blended Interpolated rendering option (Timewarp effect) 181, 242
Blended VTR rendering option (Timewarp effect) 181, 243
Blowup effect (2D)
position information for 95
Blue dot 38
Index

Blur effect (2D)
  creating 566
  described 564
  parameters 565
Blur mode, Paint Effect example 555
Bold button
  in Title tool 404
Bold text
  in titles 404
Both Fields rendering option (motion effect) 179
Both Fields rendering option (Timewarp effect) 180, 241
Bring Forward button (Effect Editor) 525, 526
Bring Forward command (Object menu) 431, 525
Bring to Front command (Object menu) 431, 526
Brush tool
  creating a custom shape for 489
  painting with 488
  saving a template 491
B-Spline Catmull
  Filtering option for Avid Pan & Zoom effect 343
Buttons
  3D Promote (Effect Editor) 101, 119
  Add Keyframe (Effect Preview Monitor toolbar) 84
  Bold (Title Tool) 404
  Bring Forward (Effect Editor) 525, 526
  Centered on Cut (Quick Transition dialog box) 76
  Collapse 304
  Crawling Title (Title tool) 391, 416
  Dual Split (Effect Editor) 100
  Dual Split (Effect Preview Monitor toolbar) 84
  Effect Mode 82
  Ending at Cut (Quick Transition dialog box) 76
  Enlarge (Effect Editor) 100
  Enlarge (Effect Preview Monitor toolbar) 85
  Extract/Splice-in 63
  Fade Effect 63, 465
  Fast Forward (Effect Preview Monitor toolbar) 84
  Fit to Fill 225
  Grid 87, 92
  Head Fade 77
  HQ (Effect Editor) 100, 187
  in Effect Preview Monitor toolbar 84
  Italic (Title tool) 404
  Lift/Overwrite 63
  mapping in Effect mode 86
  Match Frame 222
  Motion Effect 223
  Other Options (Effect Editor) 100
  Outline/Path (Effect Editor) 100
  Play (Effect Editor) 100
  Play (Effect Preview Monitor toolbar) 84
  Play (Motion Effect Editor) 239
  Play Loop (Effect Editor) 100
  Play Loop (Effect Preview Monitor toolbar) 84
  Play Loop (Motion Effect Editor) 239
  Play Preview (Effect Preview Monitor toolbar) 84
  Position Graph Display (Timewarp effect) 237
  Quick Transition 66
  Reduce (Effect Editor) 100
  Reduce (Effect Preview Monitor toolbar) 85
  Remove Effect 61
  Render Effect (Effect Editor) 100
  Rewind (Effect Preview Monitor toolbar) 84
  Rolling Title (Title tool) 391, 416
  Scratch Removal 536
  Send Backward (Effect Editor) 526, 527
  Source Anchor Frame (Timewarp effect) 250
  Speed Graph Display (Timewarp effect) 237
  Starting at Cut (Quick Transition dialog box) 76
Step Backward One Field (Effect Preview Monitor toolbar) 84, 96
Step Forward One Field (Effect Preview Monitor toolbar) 84, 96
Step In (Timeline) 295
Step Out (Timeline) 295
Tail Fade 77
Timeline View Name (Timeline) 52
Transition Effect Alignment (Effect Editor) 65, 101
Triangular opener (Effect Editor) 100
Trim Left 1 Frame 113
Trim Left 10 Frames 113
Trim Right 1 Frame 113
Trim Right 10 Frames 113
Video Background (Title tool) 394

Clearing a stamp 379
Client monitor setting up 321
Collapse button 304
Collapsing layers with Submaster effect 304
Color adjusting parameter settings for 106
background 394
blending, in titles 423
for Paint Effect 488
safe limits for titles 394
selecting for titles 421
Color coding for effects 33, 38, 38
Color Effect (2D) preparing high-contrast image with 290
Color levels in Avid Pan & Zoom effect 345
Command palette mapping buttons from 86
Commands See Menu commands
Console window AVX plug-in messages in 50
Constant path velocity with Avid Pan & Zoom effect 340
Constant Velocity option Avid Pan & Zoom effect 340
Control points in Intraframe objects adding 513
deleting 514
described 503
moving 515
removing 514
selecting 514
Controlling real-time effects preview 172
Coordinate system for 3D effects 353
Coordinates displaying position 92
displaying, in monitors 91
Index

Copy command
  for graphic objects 430
  for title elements (Edit menu) 399, 430
keyframes, advanced 133
keyframes, standard 114
Corner pinning an image 375
Crawling Title button (Title tool) 391, 416
Crawling titles
  See also Titles
  adding pages to 418
  copying or moving objects to 419
  creating 413
  defined 413
  deleting pages from 420
  formatting text in 420
  going to a page in 418
  inserting a blank page into 419
Make Crawl command 417
  page count limits for 414
  resizing width of 417
  scrolling through 417
  setting marks in 458
  setting text formatting for 415
  typing text for 416
  workflow options for 415
Creating
  motion effects, Timewarp 233
  motion effects, traditional 213
  multiformat titles 444
  nested effects 296
  stamp 379
  standard keyframes 112
Creating 3D effects
  Corner Pin 375
  cropped foreground 371
  Page Curl transition 362
  Quad Split Page Turn 364
  Stamp 379
  with Axis as a transition 380
Cropped foreground effect
  3D example 371
Cubic
  Filtering option for Avid Pan & Zoom effect 342
Curve tool, for Intraframe editing 501
Custom Start option
  using 65
Cut command
  for title elements (Edit menu) 430
Cut list
  position information in 93
  with Previsualization Marker tool information 518

D

Deleting
  effect media files 205, 209
  motion effect media 209
  pages from rolling or crawling titles 420
Digidesign AudioSuite plug-ins 41
Digital cut
  real-time effects and 33
Dip to Color Blend effect (2D)
  creating with Quick Transition button 66
Display parameter
  Avid Pan & Zoom 335
Display rate
  when processing effects 171
Dissolve effects (2D)
  adding with Head Fade and Tail Fade buttons 77
  applying 64
  creating, with Quick Transition button 66
  duration of 64
Dissolve effects (3D)
  creating splash as 366
Dissolve Icons command (Timeline Fast menu) 52
Dissolves
  See Dissolve effects (2D), Dissolve effects (3D)
Distribute Objects commands (Alignment menu) 434
Distributing titles 434
Draft Quality
  for playback 175
Drawing environment
  preparation in Title tool 392
Drawing tools (Title tool)
  Arrowhead tool 411
  Border Width button 411
  Border Width tool 410
  Box Corner tool 410
  circles and ovals 409
  lines 409
  squares and rectangles 409
Dropped frames
  real-time effects and 33
Dual Split button (Effect Editor) 100
Dual Split button (Effect Preview Monitor toolbar) 84
Duplicate command
  for title elements (Edit menu) 430
Duplicated Field rendering option (motion effect) 179
Duplicated Field rendering option (Timewarp effect) 180, 241

E
Ease In and Ease Out
  with Avid Pan & Zoom effect 338, 339
Ease in and ease out 338
Edit decision list (EDL)
  See EDL (edit decision list)

Editing
  Submaster effects 301, 302
  titles into sequence 457
  with imported matte keys 291
  with titles 454
EDL (edit decision list)
  and fast-saved titles 439
  and Submaster effects 302
  and video mixdown 306
Effect categories (2D)
  listed 36
Effect Editor
  color parameters in 106
  customizing effects with 97
  Dissolve effects in 65
  for adjusting titles 465
  for Intraframe editing 483
  Other Options button in 98
  parameter sliders in 98
  pop-up menu 157
  resetting keyframe graph view 157
  scroll thumbwheel 155
  transition parameters in 65
Effect Grid
  customizing for a single effect 93
  described 88
  displaying in Effect mode 92
  setting options for 89
  using with Pan and Scan effect 323
Effect Icons command (Timeline Fast menu) 52
Effect media files
  deleting 209
  revealing 206
  viewing and deleting 205
Effect mode
  entering 82
  mapping buttons in 86
Effect Mode button 82
Index

Effect Palette
  described 36  
  display of plug-ins in 41  
  displaying 37  
  effect categories in 36  
  resizing 38  
  using 36  

Effect parameters
  accessing, with Other Options button 106  
  adjusting 103  
  blank 104  
  displaying 97  
  extrapolating values with advanced keyframes 153  
  holding values in keyframe graphs 153  
  making slider adjustments 105  

Effect Preview monitor
  described 83  
  displaying safe title/action area in 86  
  grid display in 88  
  moving enlarged image in 102  
  toolbar 84  
  tracking information in 86  
  zooming in 358  

Effect template
  applying 166  
  defined 164  
  displaying in bin 39  
  for 3D effects 357  
  for Intraframe effects 486  
  saving 164  
  viewing 40  

Effects
  See also Effects (2D), Effects (3D)  
  2D, promoting to 3D 350  
  applying Intraframe 482  
  applying one 56  
  applying to multiple segments 59  
  applying to multiple transitions 58, 66  
  applying to multiple transitions using Quick Transition button 70  
  changing position in 96  
  color coding for 38, 38, 39  
  controlling real-time preview 172  
  creation tools for 32  
  deleting a single effect 61  
  deleting multiple effects 62  
  field processing 534  
  frame processing 533  
  Mosaic effects 564  
  processing in real time 171  
  processing when using Scratch Removal 531  
  real-time preview, delaying start 173  
  rendering at position 184  
  rendering between IN and OUT points 185  
  rendering one 183  
  replacing existing 110  
  size of source media 78  
  templates for 40  
  Timewarp 229  
  types of 30  
  upgrading 46  
  using wire frames with 161  
  wire-frame preview of 171  
  working with FluidMotion 266  

Effects (2D)
  Blur effect 564  
  creating with Quick Transition button 66  
  Mosaic effect 564  
  motion, creating 213  
  Pan and Scan 314, 316  
  Reformat category 314  
  Region Stabilize 310  
  Submaster 301  
  troubleshooting Region Stabilize effect 313  
  using Color to prepare high-contrast image 290  

576
Effects (3D)
adjustment handles 358
applying 349
applying 3D Warp 349
compatibility between Avid applications 383
coordinate system for 353
creating a transition using Axis 380
creating Chroma Key 381
creating Corner Pin 375
creating cropped foreground 371
creating Page Curl 362
creating Quad Split Page Turn 364
creating Splash 366, 369
creating Stamp 379
matte key 351
motion path in 359
overview 348
parameter adjustments 355
promoting from 2D 350
resetting parameters to default 357
templates for 357
using Spline parameter 373
Xpress 3D Effect category 383
Effects Quality render setting 182
Effects Quality Render Using
HQ effects 187
Elastic keyframes 135
Enabled group
defined 129
Ending at Cut button (Quick Transition dialog box) 76
Ending at Cut option
using 65
Enlarge button (Effect Editor) 100, 161
Enlarge button (Effect Preview Monitor toolbar) 85
Enlarged image
moving, in Effect Preview monitor 102
Entering
Effect mode 82
Establish Origin parameter (2D)
for Pan and Scan 325
ExpertRender
commands (Clip menu) 193
considerations when using 195
described 192
examples 196
modifying results of 194
rendering with 192
Export Title command (File menu) 451
Exporting
AniMatte effect as a PICT file 528
matte key as PICT file 529
titles as graphics files 451
Extract/Splice-in button 63
Extrapolate command (Keyframe Graph shortcut menu)
advanced keyframes parameter value 150
using 153
Eyedropper
adjusting a color with 421
selecting a color with 488
using 107
F
Fade Effect button
described 63
for fading titles 465
Fade effects (2D)
adding with Fade Effect button 63
adding with Head Fade and Tail Fade buttons 77
Fade from Color Blend effect (2D)
creating with Quick Transition button 66
Fade to Color Blend effect (2D)
creating with Quick Transition button 66
Fades
See Dissolve effects (2D), Dissolve effects (3D), Fade effects (2D)
Fast Forward button (Effect Preview Monitor toolbar) 84
Fast motion effect (2D)
   creating 222
   reversing 224
Fast rolling title playback issues 463
Fast Save option for titles
   described 439
   saving with 439
Fast Save titles
   viewing in bin 440
Feathering
   for Blur and Mosaic effects 565
   for Intraframe effects 502
   using 567
Field processing 534
Film projects
   obtaining position information in 93
Filtering parameter
   Avid Pan & Zoom effect 342
Fit to Fill button 225
Fixed Aspect option
   Blur effect 567
   Mosaic effect 567
Fixed keyframes 136
Flaws 535
FluidMotion Edit
   described 266
   entering 267
FluidMotion rendering option (Timewarp effect) 181, 243, 266
Fonts
   compatibility between systems 392
   installing 392
   selecting 403
   setting point size 403
   substituting 392
Formatting
   rolling or crawling titles 420
   title text 401
Frame processing 533
Free Current Cache
   Avid Pan & Zoom effect 346
Freeze Frame command (Clip menu) 220
Freeze Frame effect (2D)
   creating 220
Freezing a rolling clip 222
Full Quality
   for playback 175
Function keys
   using with title styles 447

G

Gaussian
   Filtering option for Avid Pan & Zoom effect 343
Glow effect on titles 429
Graph
   See Advanced keyframes
Graphic images
   editing with imported 290
Graphical display in Quick Transition dialog box 73
Graphics in titles
   displaying grid for 396
   drawing 408
Green dot 38
Grid
   effect grid 88
   for title alignment 396
   options 90
   parameters in Effect Editor 93
   Safe Action setting 91
   Safe Title setting 91
   snapping to in Title tool 396
Grid button
   for Safe Title/Safe Action 87
   in Effect mode 92
Group, defined 125
Group command (Object menu) 431, 527
Grouping and ungrouping
  Intraframe objects 527
  objects in titles 431

H
Halo effect with titles 429
Handles
  for adjusting 3D effects 358
HDTV aspect ratio
  in the Title tool 397
Head Fade button 77
High-contrast images 290
Highest Quality (HQ) button 100, 187
Hold command (Keyframe Graph shortcut menu)
  advanced keyframe parameter values 150
  using 153
Hollow drag handles, for locked objects 433
Horizontal effects (2D)
  defined 31
HQ button (Effect Editor) 100, 187
HQ rendering 187
  interrupting 188
  Render Settings dialog box 187

I
Icons
  Timeline display of 51
  Title effect 454
IllusionFX Pack 41
Image Resolution
  Avid Pan & Zoom effect 345
Imported master clips
  editing with 293
Indent Rows command 158
Independent keyframes
  See Advanced keyframes
Input Position 253
Installing
  AVX plug-ins 43
Insufficient Source message 78, 361
Interfaces for AVX plug-ins 48
Interpolated Field rendering option
  Timewarp effect 180, 242
  traditional motion effect 180
Interpolation options
  defined 138, 231
Interrupting
  Render On-the-Fly 186
  rendering of effects 190
Intraframe editing
  Brush tool 488
  changing effect parameters 501
  creating polygon shapes 496
  Curve tool 501
  customizing Brush shape 489
  described 478
  drawing tools 486
  examples of 550
  modes described 487
  Oval tool 494
  Polygon tool 495
  Previsualization Marker tool 516
  Rectangle tool 493
  rendering during 480
  saving a brush template 491
  single-field step with 486
  summary of line and curve modification 511
  using control points 513
  using keyframes 523
  using pen tool for 487
  using Selection tool 492
  with Magic Mask 551
Intraframe objects
  grouping and ungrouping 527
  layering 524
  locking and unlocking 528
Index

moving 519
reshaping 519
rotating along Z axis 521
scaling 522
Isolating flaws for removal 536
Italic button
  in Title tool 404
Italic text
  in titles 404

J
Join
  in Intraframe objects 503
Justification of title text 404

K
Kerning of title text 405
Key effects (2D)
  creating Chroma Key effect 284
  creating Luma Key effect 286
  creating Matte Key effect 287
  described 282
  Matte Key effect 291
Key effects (3D)
  3D matte keys 351
Keyboard shortcuts
  saving titles with 438
Keyframe graphs
  See also Advanced keyframes
  aligning keyframes in 146
  copying and pasting keyframes in 133
  extrapolating parameter values 153
  holding parameter values 153
  resetting view 157
  resizing 156
  scale bar 154
  scrolling left to right 155
  scrolling up or down 156
  slipping keyframes 148
  zoom slider 154
  zooming 154
Keyframe interpolation
  defined 231
Keyframe interpolation options
  Bézier 141
  defined 138
  Linear 139
  Shelf 139
  Spline 140
Keyframes
  See also Advanced keyframes
  copying and pasting in keyframe graphs 133
  copying and pasting standard 114
  creating standard 112
  defined 111
  deleting standard 115
  for adjusting titles 466
  moving or changing standard 113
  selecting standard 112
  with Intraframe effects 523

L
Large Text command 158
Layering
  Intraframe objects 524
  titles 431
Layers 281
Leading for title text 407
Letterboxing 314
Level parameter
  Avid Pan & Zoom 345
Lift/Overwrite button 63
Limitations
  playing fast rolling titles 463
  titles 454
Index

Linear command
  in Keyframe graph shortcut menu 138
  keyframe interpolation option 139
Lines
  attribute options 410
  in titles 409
Locating AVX_Plug-Ins folder (Macintosh) 44
Locating AVX_Plug-Ins folder (Windows) 45
Lock command (Object menu) 432, 528
Locked objects
  hollow handles indicating 433
Locking and unlocking
  Intraframe objects 528
  objects in titles 432
Luma Key effect (2D)
  compared to other key effects 282
  creating 286
Matte key
  exporting as PICT file 529
Matte Key effect (2D)
  applying 558
  compared to other key effects 282
  creating 287
  editing with 291
  in nested layers 299
  preparing high-contrast image for 290
  promoting to 3D 351
Matte Key effect (3D)
  using 351
Media files
  deleting 209
  insufficient source material 78
  managing 205
Media Station XL
  rendering effects for 201
MediaManager 205
Memory usage
  AVX plug-ins 42, 51
  in Avid Pan & Zoom effect 345
Menu commands
  Add Page (Object menu) 418
  Align Keyframe (Keyframe Graph shortcut menu) 146
  Align Objects (Alignment menu) 433
  Align to Frame (Alignment menu) 433
  Auto Size Mode (Object menu) 414
  Bézier (Keyframe graph shortcut menu) 138
  Bring Forward (Object menu) 431, 525
  Bring to Front (Object menu) 431
  Bring to Front (Object menu)) 526
  Copy (Edit menu) 430
  Copy to Page (Object menu) 419
  Cut (Edit menu) 430
  Dissolve Icons (Timeline Fast menu) 52
  Distribute Objects (Alignment menu) 434
  Duplicate (Edit menu) 430
  Effect Icons (Timeline Fast menu) 52

M

Macintosh Color Picker 108, 421
Magic Mask parameters (2D)
  colorizing with 551
Magnified image
  moving, in Effect Preview monitor 102
Make Crawl command
  for crawling titles 417
Mark IN and Mark OUT buttons
  using in titles 458
Marquee Title
  Settings dialog box 387
Marquee Title tool
  converting title styles to 448
  described 385
  promoting titles to 467
Match Frame button 222
Matching resolutions with titles 436
Matte
  preparing for key effects 290
Index

ExpertRender (Clip menu) 193
Export Title (File menu) 451
Extrapolate (Keyframe Graph shortcut menu) 153
Freeze Frame (Clip menu) 220
Group (Object menu) 431, 527
Hold (Keyframe Graph shortcut menu) 153
Insert Page (Object menu) 419
Linear (Keyframe graph shortcut menu) 138
Lock (Object menu) 432, 528
Move to Page (Object menu) 419
New Title (Clip menu) 387
Paste (Edit menu) 430
Preview (Object menu) 393
Re-create Titles and Mattes (Clip menu) 471
Remove Page (Object menu) 420
Render On-the-Fly (Special menu) 186
Render Ranges (Timeline Fast menu) 190
Render to Media Station XL (Clip menu) 201
Reset Graph View (Keyframe Graph shortcut menu) 157
Reveal File (File menu) 207
Safe Colors (Object menu) 394
Safe Title Area/Global Grid (Object menu) 394
Send Backward (Object menu) 431, 526
Send to Back (Object menu) 431, 527
Set Bin Display (Bin menu) 206, 456
Shelf (Keyframe graph shortcut menu) 138
Show Alignment Grid (Alignment menu) 396
Slip Keyframes (Keyframe Graph shortcut menu) 148
Snap to Grid (Alignment menu) 396
Soften Shadow (Object menu) 427
Spline (Keyframe graph shortcut menu) 138
UnGroup (Object menu) 432, 527
Unlock (Object menu) 433, 528

Modes
  for Intraframe editing 487

Modifying
  results of ExpertRender 194
  results of Render to Media Station XL 203
  rolling or crawling titles 420

Monitors
  setting up for Pan and Scan effect 321

Mosaic effect
  creating 564
  Mosaic effect (2D)
    creating 564, 566
    described 564
    parameters 565

Motion Effect button 223
Motion Effect Editor
  active graph toolbar 248
  adding or deleting keyframes 122
  components described 237
  keyframe interpolation options 138, 139
  opening 235
  Source Anchor Frame 238
  Speed graph 249
  toolbar 239

Motion Effect media
  deleting 209
  revealing 206

Motion effects (2D)
  brief description 30
  creating 213
  defined 213
  Freeze Frame, creating 220
  freezing a rolling clip 222
  in 24p or 25p projects 219
  rendering existing 216
  rendering requirements for 214
  Strobe Motion, creating 226
  Timewarp 229
  traditional, playback of 215

Modes
  for Intraframe editing 487
type changes, described 218
type changes, displaying information about 219
Variable Speed, creating 222
Motion path
defining in Pan and Scan effect 328
foreground image movement 161
Motion path editor 359
Multiformat titles
creating 444
described 443
ingoing into sequences 469
moving between projects 469
re-creating 473
saving 444
with Pan and Scan effect 317
Multilayer effects
defined 30
deleting 62
described 30
Multilayer effects (2D)
overlapping of 188
Multilayer effects (3D)
3D Matte Key 351
Multiple tracks
and AVX plug-ins 47
Multi-Resolution
Avid Pan & Zoom effect 345

N
Nested effects
changing the order of 298
creating 296
defined 294
expanding in Timeline 296
stepping in and out 295

video layers in 294
with matte key 299
with the Submaster effect 301
Nesting Priority icon 298
New Title command (Clip menu) 387
Non-real-time effects
overlapping with real-time effects 188
rendering 176
NTSC frame and safe title/action guidelines 394

Objects
aligning in the Title tool 433
locking and unlocking 432
Open graph
defined 130
Open group
defined 128
Optical list
position information in 93
with Previsualization Marker tool information 518
Orange dot 33
Origin
setting, in Pan and Scan effect 324
Other Options button (Avid Pan & Zoom) 334
Other Options button (Effect Editor) 100
Outline/Path button (Effect Editor) 100
Output Duration
Timewarp effect 238
Output formats
for Pan and Scan effect 317
Output position 253
Oval tool for Intraframe editing 494
Overlapping effects 188
Index

P

Page count limits
  for rolling and crawling titles 414
Page Curl effect (3D)
  as transition 362
Page number display
  in Title tool 418
Page Turns (3D)
  creating quad split 364
Paint Effect (2D)
  applying 482
  creating signature effect 491
  described 478
  example of Blur mode 555
  modes 487
  painting with Brush tool 489
  parameters for 483
  position information for 94
  rendering 480
  selecting color 488
  using Magic Mask parameters 551
PAL frame and safe title/action guidelines 394
Pan & Zoom
  See Avid Pan & Zoom effect
Panning
  using Avid Pan & Zoom effect 337
Parameters
  See also Parameters (2D), Parameters (3D)
  Blur effect 567
  changes at keyframes (advanced) 139
  for AVX plug-ins 48
  Mosaic effect 567
Parameters (2D)
  Acceleration 565
  AniMatte effect, in Effect Editor 485
  Blur effect 565
  Feathering 565, 567
  Mosaic effect 565
  Paint Effect 483
  Transition 65
Parameters (3D)
  accessing 348
  adjustment handles 358
  resetting to defaults 357
Partial render
  described 188
  example 189
Paste command
  for title elements (Edit menu) 399, 430
  keyframes, advanced 133
  keyframes, standard 114
Path
  in effect motion 359
Path parameter
  Avid Pan & Zoom effect 341
Pen tool 487

setting up monitors for 321
subdividing 326
using Effect Grid with 323
using multiformat titles with 317
viewing media in 322
wire frame display in 327

584
Percent Speed text box
  Timewarp effect 250
Photoshop
  compatible plug-ins 42
Picture-in-Picture effect (2D)
  foreground image movement 161
Pixels
  shape in Avid Pan & Zoom effect 344
Play button (Effect Editor) 100
Play button (Effect Preview Monitor toolbar) 84
Play button (Motion Effect Editor) 239
Play Loop button (Effect Editor) 100
Play Loop button (Effect Preview Monitor toolbar) 84
Play Loop button (Motion Effect Editor) 239
Play Preview button (Effect Preview Monitor toolbar) 84
Playback
  controlling 172
Playback of effects
  basic playback 170
  in a loop 170
  in a wire-frame preview 171
  in Effect mode 170
  real-time capabilities 33
  real-time effect renderings 39
  Video quality for 175
Plug-in effects
  AVX (Avid Visual Extensions) 41
  Digidesign AudioSuite, using 41
Polygon shape creation 496
Polygon tool for Intraframe editing 495
Position
  Timewarp effect 250
Position coordinates
  displaying 92
Position display for two-field media 86
Position graph (Motion Effect Editor)
  adding or deleting keyframes 122
  components 253
  described 230
  displaying 237
  scale bars 245
  toolbar 248
Position Graph display button (Timewarp effect) 244
Position information
  for Blowup effect 95
  for Paint and AniMatte effects 94
  obtaining in a film project 93
Position parameter
  in Avid Pan & Zoom effect 337
Position scale bar 245
Position scale slider 251, 254
Posterization
  constrained by nested Circle Shape Wipe 295
Post-key color correction 286
Preview
  of effects 172
Preview command (Object menu) 393
Previewing
  anti-aliased titles 393
Previsualization Marker tool
  described 516
  using 517
  with cut list 518
Processing
  effects in real time 171
Project window
  managing title styles in 450
Projects
  moving from Macintosh to Windows 392
  moving from Windows to Macintosh 392
Index

Q
Quad Split Page Turn (3D) 364
Quadratic
    Filtering option for Avid Pan & Zoom effect 342
Quick Transition button 66
Quick Transition dialog box
      graphical display in 73
QuickTime
      real-time moving mattes and 288

R
Real Time Update option 159
Real-Time
      Filtering option for Avid Pan & Zoom effect 342
Real-time
      processing of effects 171
Real-time effects
      color coding for 33, 38
      combined with rendered effects 176
      defined 33
      dropped frames and 33
      playback capabilities of 33
      rendering of 176
Real-time moving matte
      editing with 289
      imported as a graphics sequence 289
      imported with QuickTime 288
Real-time streams
      in a Unity environment 174
      limiting to improve playback 174
Recalling
      title styles 449
Re-create Titles and Mattes command (Clip menu) 471
Re-creating
      multiformat titles 473
      titles 470
Rectangle tool for Intraframe editing 493
Rectangular pixels
      in Avid Pan & Zoom effect 344
Reduce button (Effect Editor) 100, 161
Reduce button (Effect Preview Monitor toolbar) 85
Reformat effects (2D)
      aspect ratios and 314
Reformat effects category 314
Region Stabilize effect (2D)
      described 310
      troubleshooting 313
      types of stabilization 311
Remove Effect button 61
Removing
      titles from a sequence 464
Render Effect button (Effect Editor) 100
Render On-the-Fly command
      interrupting 186
      using 186
Render Ranges command (Timeline Fast menu) 190
Render settings
      creating and using 178
      Effects Quality Render Using 182, 187
      HQ rendering 187
Rendered effects
      color coding for 39
      Submaster icon color code 302
      viewing in bins 456
Rendering
      a single effect 183
      AniMatte effects 480
      AVX plug-ins 50
      combining real-time and non-real-time effects 188
defined 33
displaying render ranges 190
during Intraframe editing 480
effects 176
effects at position 184
effects between IN and OUT points 185
ExpertRender examples 196
HQ effects 187
interrupting 190
interrupting, with HQ effects 188
multiple effects with Submaster 302
Paint Effect 480
saving partially completed renders 188
timewarp effect options 231, 238
titles 470
using ExpertRender 192
using Render to Media Station XL 201
Replacing
existing effects 110
title fill tracks 469
titles in a sequence 464
Reset Graph View command (Keyframe Graph shortcut menu) 157
Reset to Origin parameter
for Pan and Scan effect 325
Resetting
keyframe graph view 157
Reshape tool for Intraframe effects 519
Resizing
Effect Palette 38
keyframe graphs 156
rolling or crawling titles 417
Resolution
compatibility in titles 436
Reveal File command (File menu) 207
Revealing
effect media files 206
motion effect media 206
Reversing
fast motion effects 224
slow motion effects 224
Revising
titles in a bin 440
titles in a sequence 467
Rewind button (Effect Preview Monitor toolbar) 84
RGB Keyer effect (AVX Plug-in)
applying 284
described 282, 283
post-key color correction 286
RGB settings
in Avid Pan & Zoom effect 345
Rolling Title button (Title tool) 391, 416
Rolling titles
creating 413
defined 413
deleting pages from 420
formatting text in 420
going to a page in 418
inserting a blank page into 419
page count limits for 414
resizing width of 417
scrolling through 417
setting marks in 458
setting text formatting for 415
trimming 463
typing text for 416
Rotation axes (3D) 354

S

Safe Action area
Avid Pan & Zoom 335
Safe Action option (Grid settings) 91
Safe Colors command (Object menu) 394
Safe Title Area/Global Grid command (Object menu) 394
Index

Safe Title option (Grid settings) 91
Safe title/action area
deleting multiple 62
displaying 86
depending on titles 433
ing Title tool 394
Saturation
deleting one 61
depending on titles 433
Saturation of colors in titles 394
Saving
depending on titles 433
multiformat titles 444
partially completed renders 188
title styles 446
titles 436
titles with a keyboard shortcut 438
titles with Fast Save option 439
titles, overview of 435
Scale bar
depending on titles 433
advanced keyframes 153
keyframe graphs 154
Scaling Intraframe objects 522
Scratch removal
depending on titles 433
frame or field processing 531
isolating flaws 536
parameter setting examples 547
removing flaws 539
selecting clean material 536
using effect parameters 545
using nearby frame or field 535
within single frame or field 535
workflow for 531
Scratch Removal button 536
Scratch Removal effect (2D)
defined 30
described 479
Scroll thumbwheel in Effect Editor 155
Scrolling
depending on titles 433
keyframe graphs, left to right 155
keyframe graphs, up or down 156
through rolling or crawling titles 417
Segment
depending on titles 433
in Intraframe objects 503
Segment effects
defined 30
deleting multiple 62
deleting one 61
defining 30
depending on titles 433
fading 63
Segment effects (2D)
See also Segment effects
Chroma Key editing 282
Luma Key effect 286
Submaster 301
Selecting
standard keyframes 112
Selection tool
defining 431
for grouping objects 431
for ungrouping objects 431
text options for titles 402
viewing attributes with 402
with Intraframe editing 492
Send Backward button (Effect Editor) 526, 527
Send Backward command (Object menu) 431, 526
Send to Back command (Object menu) 431, 527
Sequences
title editing in 457
Set Bin Display command (Bin menu) 206, 456
Set Position To Keyframe command 159
Settings
Grid 90
Render 178
Title Styles 450
Shadow softness
adjusting in titles 427
viewing current setting 429
Shadows for titles 425
Shelf command
depending on titles 433
in Keyframe graph shortcut menu 138
keyframe interpolation option 139
Short clips, using Submaster effect with 304

588
Shortcuts
saving titles with keyboard 438
Show Action Safe parameter
Avid Pan & Zoom 335
Show Add Keyframe Mode Menu command 159
Show Alignment Grid command (Alignment menu) 396
Single-field step 96, 486
Single-layer effects defined 30
Size of effect
foreground image 161
source media 78
Sliders
adjusting effect parameter 105
blank 104
Sliders option 158
Slip Keyframes command
brief description 145
using (Keyframe Graph shortcut menu) 148
Slipping keyframes 148
Slow motion effect (2D)
creating 222
reversing 224
Snap to Grid command (Alignment menu) 396
Soft shadows
adding to titles 427
Soften Shadow command (Object menu) 427
Source Anchor Frame (Motion Effect Editor)
in 238, 250
using 251
Source Anchor Frame (Object menu 427
Source Has Square Pixels
Avid Pan & Zoom effect 344
Speed graph (Motion Effect Editor)
adding or deleting keyframes 122
components 249
described 230
displaying 237
scale bars 245
scale sliders 251
Source Anchor Frame 251
toolbar 248
Speed Graph display button (Timewarp effect) 244
Splashes (3D)
creating dissolve 366
making into flat images 369
Spline command
in Keyframe graph shortcut menu 138
keyframe interpolation option 140
Spline parameters (3D)
using 373
Square pixels
in Avid Pan & Zoom effect 344
Stabilizing an image
See also Region Stabilize effect
using Region Stabilize 310
Stamp (3D)
clearing 379
creating 379
Starting at Cut button (Quick Transition dialog box) 76
Starting at Cut option
using 65
Step Backward One Field button (Effect Preview Monitor toolbar) 84, 96
Step Forward One Field button (Effect Preview Monitor toolbar) 84, 96
Step In button (Timeline) 295
Step Out button (Timeline) 295
Stepping through two-field media 96
Strobe Motion effect (2D)
creating 226
Subdividing
Pan and Scan effect 326
Submaster effects (2D)
applying 302
collapsing layers into 305
Index

editing 301
  using with EDLs 302
  using with short clips 304
Substituting fonts 392

T
  Tail Fade button 77
  Template (effect) 39
  Templates
    for titles 441
  Text for titles
    editing 401
    formatting 401
    justifying 404
    kerning 405
    leading 407
    repositioning 400
    resizing 400
  Text formatting
    setting for rolling and crawling titles 415
  Third-party plug-in effects 41
  Thumbwheels
    adjusting effect parameter 105
    Thumbwheels option 158
  Timeline
    changing nested effect order 298
    color coding of real-time effects 38
    dragging titles into 460
    expanding nested effects in 296
    real-time effects in 302
    real-time effects, color coding 33
    segment deletions in 61
    showing effect icons in 51
  Timeline View Name button (Timeline) 52
  Timewarp effect
    adding or deleting keyframes 122
    creating 233
    described 229
    displaying Position graph 237
    displaying Speed graph 237
    FluidMotion Edit 267
    input position 253
    keyframe interpolation options 138, 139
    keyframe interpolation, defined 231
    Motion Effect Editor 235
    output duration 238
    output position in Position graph 253
    Position graph 253
    promoting traditional effects 233
    rendering options 231, 238
    selecting control graph 238, 239
    Source Anchor Frame 251
    Speed graph 249
  Timewarp Position graph
    described 230
  Timewarp Speed graph
    described 230
  Title effects (2D)
    clips, described 456
    defined 30
    duration of rolls 458
  Title styles
    applying 450
    converting to Marquee 448
    defined 446
    managing in Project window 450
    recalling 449
    saving 446
    using function keys with 447
  Title templates
    creating and using 441
  Title tool
    16:9 display option 397
    adjusting transparency in 424
    as default titling tool 387
    Auto Size mode 414
    background options 394
    blending colors in 423
    blending transparency in 425
Color Picker 421
Crawling Title button 416
described 388
drawing graphics in 408
opening 387
overview 386
pasting text into 399
preparing drawing environment 392
Rolling Title button 416
safe title/action area display in 394
selecting fonts in 403
setting color in 421
setting point size in 403
setting transparency in 421
toolbar overview 389
updating video background in 395
working with shadows in 425
Titles
  adding pages to 418
  adding shadows to 425
  adjusting in Effect Editor 465
  adjusting using keyframes 466
  aligning 433
  applying styles 450
  bold text in 404
  color of background 394
  compatible resolutions with 436
  complexity and playback 454
  copying or moving objects to 419
crawling, defined 413
  creating color background for 396
  creating media for unrendered 472
  creating multiformat 444
  creating rolling or crawling 413
  creating text 398
distributing 434
dragging into Timeline 460
  editing into a sequence 457
  effect clips described 456
  effect icons 454
  exporting as a graphics file 451
  fading 465
  fast saving 439
  fast-saved, and EDLs 439
  formatting rolling or crawling 420
  glow effect with 429
  grouping and ungrouping 431
  inserting a blank page into a rolling or
crawling 419
  italic text in 404
  kerning of text in 405
  layering of 431
  locking and unlocking 432
  managing fonts for 392
  managing styles in Project window 450
  multiformat 443, 469
  on systems with 24p or 25p support 443
  overview of creation 386
  overview of saving 435
  page count limits for rolling or crawling 414
  previewing 393
  promoting to 3D 474
  promoting to Marquee 467
  recalling styles 449
  re-creating 470
  re-creating multiformat 473
  removing from a sequence 464
  rendering 470
  replacing fill tracks 469
  replacing in a sequence 464
  resizing rolling or crawling width of 417
  revising in a sequence 467
  revising in bin 440
  rolling or crawling, deleting pages from 420
  rolling or crawling, going to a page in 418
  rolling, defined 413
  saving 436
  saving multiformat 444
  saving styles 446
  saving with keyboard shortcut 438
scrolling through rolling or crawling 417
setting marks in rolling or crawling 458
setting text formatting for rolling or crawling 415
soft shadows with 427
splicing into a sequence 458
templates for 441
troubleshooting 474
typing rolling or crawling text for 416
unrendered 439
viewing Fast saved in bin 440
viewing Title effects 40
workflow options for crawling 415
Toolbars
Motion Effect Editor, FluidMotion Edit 268
Motion Effect Editor, Position Graph 252
Title tool 389
Tracking information
in Effect Preview monitor 86
Tracks of video
as background in Title tool 395
in nested effects 294
swapping background and foreground (3D) 361
Transition Effect Alignment button 65, 101
Transition Effect Duration box (Effect Editor) 101
Transition effects
adapting with graphical display in Quick Transition dialog box 73
applying to multiple transitions 66
applying with Quick Transition button 66
defined 30
deleting 61
deleting multiple 62
trimming 79
Transition effects (2D)
dissolves 64
with Pan and Scan effect 330
Transition effects (3D)
using Axis for 380
with Page Curl (3D) 362
Transition parameters
using to apply dissolve effects 65
Transparency
adjusting in titles 424
blending in titles 425
setting for titles 421
Triangle
Filtering option for Avid Pan & Zoom effect 342
Triangular opener (Effect Editor) 100
Trim Left 1 Frame button 113
Trim Left 10 Frames button 113
Trim Right 1 Frame button 113
Trim Right 10 Frames button 113
Trimming
rolling titles 463
transitions in Trim mode 79
Troubleshooting
AVX plug-ins 49
Region Stabilize effect 310
titles 474
True Type fonts 393
Two-field media
position display for 86
Typing text for rolling and crawling titles 416

U
UnGroup command (Object menu) 432, 527
Unity
system performance and 174
Unity MediaManager 205
Unity workgroup environment 205
Unlock command (Object menu) 433, 528
Unrendered titles
  creating media for 472
  saving 439
Update Position While Playing command 159
Upgrading AVX plug-ins and effects 46

V
Value scale bar 245
Value scale slider 251, 254
Vector-based objects
  creating 505
  described 503
Velocity In and Velocity Out 338
Velocity parameter
  in Avid Pan & Zoom effect 338
Vertical effects, defined 31
Video
  using as fill for titles and graphics 469
Video background
  updating in Title tool 395
Video Background button (Title tool) 394
Video display buffer
  prefilling 173
Video Display settings
  real-time streams option 174
  video prefill option 173
Video mixdown 306
Video Quality Menu button 175
Video Resolution
  Avid Pan & Zoom effect 345
Viewing
  effect media files 205
VTR-Style rendering option (motion effect) 180
VTR-Style rendering option (Timewarp effect) 180, 242

W
Wide-screen display
  in the Title tool 397
Windows Color dialog box 107, 421
Wire frame
  in Pan and Scan effect 327
  using with effects 161
Workflow
  includes Media Station XL 201
  options for crawling titles 415
Workgroup environment 205

X
X Y Z coordinate system 353
Xpress 3D effect category 383

Z
Zoom Factor parameter
  Avid Pan & Zoom effect 336
Zoom in on an effect 161
Zoom out of an effect 161
Zoom slider
  keyframe graphs 154
Zooming
  in Avid Pan & Zoom 336
  in Effect Preview monitor 358
  keyframe graphs 154
Z-Rotation 568
Z-rotation tool for intraframe effects 521
Index

594